]> git.pld-linux.org Git - packages/perl-IO-Socket-SSL.git/blob - perl-IO-Socket-SSL.spec
a3da57b84989521998da2d7e93ddd34fddbd0276
[packages/perl-IO-Socket-SSL.git] / perl-IO-Socket-SSL.spec
1 #
2 # Conditional build:
3 # _without_tests - do not perform "make test"
4 %include        /usr/lib/rpm/macros.perl
5 %define pdir    IO
6 %define pnam    Socket-SSL
7 Summary:        IO::Socket::SSL -- Nearly transparent SSL encapsulation for IO::Socket::INET
8 Summary(pl):    IO::Socket::SSL -- prawie przezroczysta obudowa SSL dla IO::Socket::INET
9 Name:           perl-IO-Socket-SSL
10 Version:        0.91
11 Release:        1
12 Epoch:          1
13 License:        GPL
14 Group:          Development/Languages/Perl
15 Source0:        ftp://ftp.cpan.org/pub/CPAN/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 BuildRequires:  perl >= 5.6
17 %if %{?_without_tests:0}%{!?_without_tests:1}
18 BuildRequires:  perl-Net-SSLeay
19 %endif
20 BuildRequires:  rpm-perlprov >= 3.0.3-18
21 BuildArch:      noarch
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 This module is a true drop-in replacement for IO::Socket::INET that
26 uses SSL to encrypt data before it is transferred to a remote server
27 or client. IO::Socket::SSL supports all the extra features that one
28 needs to write a full-featured SSL client or server application:
29 multiple SSL contexts, cipher selection, certificate verification, and
30 SSL version selection. As an extra bonus, it works perfectly with
31 mod_perl.
32
33 %description -l pl
34 Ten modu³ jest prawdziwym zamiennikiem dla IO::Socket::INET,
35 u¿ywaj±cym SSL do kodowania danych przed przesy³aniem do zdalnego
36 serwera lub klienta. IO::Socket::SSL wspiera wszystkie dodatkowe
37 rzeczy potrzebne do napisania w pe³ni funkcjonalnego klienta lub
38 serwera SSL: wiele kontekstów SSL, wybór szyfru, weryfikacja
39 certyfikatu, wybór wersji SSL. Ponadto wspaniale dzia³a z mod_perlem.
40
41 %prep
42 %setup -q -n %{pdir}-%{pnam}-%{version}
43
44 %build
45 perl Makefile.PL
46 %{__make}
47
48 %{!?_without_tests:%{__make} test}
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52
53 %{__make} install DESTDIR=$RPM_BUILD_ROOT
54
55 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
56 install example/* util/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
57
58 %clean
59 rm -rf $RPM_BUILD_ROOT
60
61 %files
62 %defattr(644,root,root,755)
63 %doc Change* README docs/*
64 %{perl_sitelib}/IO/Socket/SSL.pm
65 %{_mandir}/man3/*
66 %{_examplesdir}/%{name}-%{version}
This page took 0.06482 seconds and 3 git commands to generate.