]> git.pld-linux.org Git - packages/perl-IO-Socket-SSL.git/blob - perl-IO-Socket-SSL.spec
- BR: perl-devel; do not BR: perl
[packages/perl-IO-Socket-SSL.git] / perl-IO-Socket-SSL.spec
1 #
2 # Conditional build:
3 # _with_tests - perform "make test" - needs network connection
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    IO
7 %define pnam    Socket-SSL
8 Summary:        IO::Socket::SSL -- Nearly transparent SSL encapsulation for IO::Socket::INET
9 Summary(pl):    IO::Socket::SSL -- prawie przezroczysta obudowa SSL dla IO::Socket::INET
10 Name:           perl-IO-Socket-SSL
11 Version:        0.92
12 Release:        2
13 Epoch:          1
14 License:        GPL
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 BuildRequires:  perl-devel >= 5.6
18 BuildRequires:  perl-Net-SSLeay
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 This module is a true drop-in replacement for IO::Socket::INET that
25 uses SSL to encrypt data before it is transferred to a remote server
26 or client. IO::Socket::SSL supports all the extra features that one
27 needs to write a full-featured SSL client or server application:
28 multiple SSL contexts, cipher selection, certificate verification, and
29 SSL version selection. As an extra bonus, it works perfectly with
30 mod_perl.
31
32 %description -l pl
33 Ten modu³ jest prawdziwym zamiennikiem dla IO::Socket::INET,
34 u¿ywaj±cym SSL do kodowania danych przed przesy³aniem do zdalnego
35 serwera lub klienta. IO::Socket::SSL wspiera wszystkie dodatkowe
36 rzeczy potrzebne do napisania w pe³ni funkcjonalnego klienta lub
37 serwera SSL: wiele kontekstów SSL, wybór szyfru, weryfikacja
38 certyfikatu, wybór wersji SSL. Ponadto wspaniale dzia³a z mod_perlem.
39
40 %prep
41 %setup -q -n %{pdir}-%{pnam}-%{version}
42
43 %build
44 %{__perl} Makefile.PL \
45         INSTALLDIRS=vendor 
46 %{__make}
47
48 %{?_with_tests:%{__make} test}
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52
53 %{__make} install DESTDIR=$RPM_BUILD_ROOT
54
55 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
56 install example/* util/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
57
58 %clean
59 rm -rf $RPM_BUILD_ROOT
60
61 %files
62 %defattr(644,root,root,755)
63 %doc Change* README docs/*
64 %{perl_vendorlib}/IO/Socket/SSL.pm
65 %{_mandir}/man3/*
66 %{_examplesdir}/%{name}-%{version}
This page took 0.07457 seconds and 3 git commands to generate.