]> git.pld-linux.org Git - packages/perl-Gtk2.git/blob - perl-Gtk2.spec
- 1.100 (2.12.0)
[packages/perl-Gtk2.git] / perl-Gtk2.spec
1 # TODO:
2 # - perl-Gtk2 shouldn't depend on perl-devel (ExtUtils::MakeMaker). create -devel package?
3 #
4 # Conditional build:
5 %bcond_with     tests   # perform "make test" (requires X server)
6 #
7 %include        /usr/lib/rpm/macros.perl
8 %define         pdir    Gtk2
9 Summary:        Perl interface to the 2.x series of the Gimp Toolkit library
10 Summary(pl):    Interfejs perlowy do wersji 2.x biblioteki Gimp Toolkit
11 Name:           perl-Gtk2
12 Version:        1.100
13 Release:        1
14 License:        LGPL v2.1+
15 Group:          Development/Languages/Perl
16 Source0:        http://heanet.dl.sourceforge.net/gtk2-perl/%{pdir}-%{version}.tar.gz
17 # Source0-md5:  498eb71cedb0fc619654cebf43a41f8e
18 URL:            http://gtk2-perl.sf.net/
19 BuildRequires:  gtk+2-devel >= 1:2.0.0
20 BuildRequires:  perl-ExtUtils-Depends >= 0.201
21 BuildRequires:  perl-ExtUtils-PkgConfig >= 1.06
22 BuildRequires:  perl-Glib >= 1.100
23 BuildRequires:  perl-devel >= 1:5.8.0
24 BuildRequires:  rpm-perlprov >= 4.1-13
25 BuildRequires:  rpmbuild(macros) >= 1.192
26 Requires:       gtk+2 >= 2.0.0
27 Requires:       perl-Glib >= 1.100
28 Obsoletes:      perl-Gnome2-common
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 The Gtk2 module allows a perl developer to use the GTK+ graphical
33 user interface library.
34
35 %description -l pl
36 Modu³ Gtk2 pozwala programistom perlowym na u¿ywanie biblioteki
37 interfejsu graficznego GTK+.
38
39 %prep
40 %setup -q -n %{pdir}-%{version}
41
42 # "use Gtk2 '-init'" requires X display; fortunately Gtk2::Stock->lookup
43 # works without this
44 %{__perl} -pi -e "s/'-init'//" podifystockitems.pl
45
46 %build
47 %{__perl} Makefile.PL \
48         INSTALLDIRS=vendor
49
50 %{__make} \
51         OPTIMIZE="%{rpmcflags}"
52
53 %{?with_tests:%{__make} test}
54
55 %install
56 rm -rf $RPM_BUILD_ROOT
57 install -d $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Gnome2 \
58         $RPM_BUILD_ROOT%{perl_vendorarch}/Gnome2
59
60 %{__make} install \
61         DESTDIR=$RPM_BUILD_ROOT
62
63 rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/%{pdir}/{*,*/*,*/*/*}.pod
64
65 %clean
66 rm -rf $RPM_BUILD_ROOT
67
68 %files
69 %defattr(644,root,root,755)
70 %doc AUTHORS ChangeLog README TODO
71 %{perl_vendorarch}/Gtk2.pm
72 %dir %{perl_vendorarch}/Gtk2
73 %{perl_vendorarch}/Gtk2/*.pm
74 %dir %{perl_vendorarch}/Gtk2/Gdk
75 %{perl_vendorarch}/Gtk2/Gdk/*.pm
76 %{perl_vendorarch}/Gtk2/Install
77 %dir %{perl_vendorarch}/Gnome2
78 %dir %{perl_vendorarch}/auto/Gtk2
79 %{perl_vendorarch}/auto/Gtk2/*.bs
80 %attr(755,root,root) %{perl_vendorarch}/auto/Gtk2/*.so
81 %dir %{perl_vendorarch}/auto/Gnome2
82 %{_mandir}/man3/*
This page took 0.033891 seconds and 4 git commands to generate.