]> git.pld-linux.org Git - packages/perl-Gtk2.git/blob - perl-Gtk2.spec
- 1.121
[packages/perl-Gtk2.git] / perl-Gtk2.spec
1 # TODO:
2 # - perl-Gtk2 shouldn't depend on perl-devel (ExtUtils::MakeMaker). create -devel package?
3 # - review `Unrecognized argument in LIBS ignored: '-pthread'' (from buildlog)
4 #
5 # Conditional build:
6 %bcond_with     tests   # perform "make test" (requires X server)
7 #
8 %include        /usr/lib/rpm/macros.perl
9 %define         pdir    Gtk2
10 Summary:        Perl interface to the 2.x series of the Gimp Toolkit library
11 Summary(pl):    Interfejs perlowy do wersji 2.x biblioteki Gimp Toolkit
12 Name:           perl-Gtk2
13 Version:        1.121
14 Release:        1
15 License:        LGPL v2.1+
16 Group:          Development/Languages/Perl
17 Source0:        http://dl.sourceforge.net/gtk2-perl/%{pdir}-%{version}.tar.gz
18 # Source0-md5:  90bd58334c49a4db9d812537de5b1620
19 URL:            http://gtk2-perl.sf.net/
20 BuildRequires:  gtk+2-devel >= 1:2.0.0
21 BuildRequires:  perl-ExtUtils-Depends >= 0.201
22 BuildRequires:  perl-ExtUtils-PkgConfig >= 1.06
23 BuildRequires:  perl-Glib >= 1.120
24 BuildRequires:  perl-devel >= 1:5.8.0
25 BuildRequires:  rpm-perlprov >= 4.1-13
26 BuildRequires:  rpmbuild(macros) >= 1.192
27 Requires:       gtk+2 >= 2.0.0
28 Requires:       perl-Glib >= 1.120
29 Obsoletes:      perl-Gnome2-common
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 The Gtk2 module allows a perl developer to use the GTK+ graphical user
34 interface library.
35
36 %description -l pl
37 Modu³ Gtk2 pozwala programistom perlowym na u¿ywanie biblioteki
38 interfejsu graficznego GTK+.
39
40 %prep
41 %setup -q -n %{pdir}-%{version}
42
43 # "use Gtk2 '-init'" requires X display; fortunately Gtk2::Stock->lookup
44 # works without this
45 %{__perl} -pi -e "s/'-init'//" podifystockitems.pl
46
47 %build
48 %{__perl} Makefile.PL \
49         INSTALLDIRS=vendor
50
51 %{__make} \
52         OPTIMIZE="%{rpmcflags}"
53
54 %{?with_tests:%{__make} test}
55
56 %install
57 rm -rf $RPM_BUILD_ROOT
58 install -d $RPM_BUILD_ROOT%{perl_vendorarch}/{auto/Gnome2,Gnome2} \
59         $RPM_BUILD_ROOT%{perl_vendorlib}/Gtk2/Ex
60
61 %{__make} install \
62         DESTDIR=$RPM_BUILD_ROOT
63
64 rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/%{pdir}/{*,*/*,*/*/*}.pod
65
66 %clean
67 rm -rf $RPM_BUILD_ROOT
68
69 %files
70 %defattr(644,root,root,755)
71 %doc AUTHORS ChangeLog README TODO
72 %{perl_vendorarch}/Gtk2.pm
73 %dir %{perl_vendorarch}/Gtk2
74 %{perl_vendorarch}/Gtk2/*.pm
75 %dir %{perl_vendorarch}/Gtk2/Gdk
76 %{perl_vendorarch}/Gtk2/Gdk/*.pm
77 %{perl_vendorarch}/Gtk2/Install
78 %dir %{perl_vendorarch}/Gnome2
79 %dir %{perl_vendorarch}/auto/Gtk2
80 %{perl_vendorarch}/auto/Gtk2/*.bs
81 %attr(755,root,root) %{perl_vendorarch}/auto/Gtk2/*.so
82 %dir %{perl_vendorarch}/auto/Gnome2
83 %dir %{perl_vendorlib}/Gtk2
84 %dir %{perl_vendorlib}/Gtk2/Ex
85 %{_mandir}/man3/*
This page took 0.035336 seconds and 4 git commands to generate.