]> git.pld-linux.org Git - packages/perl-Gtk2.git/blob - perl-Gtk2.spec
- tabs in preamble
[packages/perl-Gtk2.git] / perl-Gtk2.spec
1 # TODO:
2 # - review `Unrecognized argument in LIBS ignored: '-pthread'' (from buildlog)
3 #
4 # Conditional build:
5 %bcond_with     tests   # perform "make test" (requires X server)
6 #
7 %include        /usr/lib/rpm/macros.perl
8 %define         pdir    Gtk2
9 Summary:        Perl interface to the 2.x series of the Gimp Toolkit library
10 Summary(pl.UTF-8):      Interfejs perlowy do wersji 2.x biblioteki Gimp Toolkit
11 Name:           perl-Gtk2
12 # note: versions 1.x[13579]y are unstable, if you want them, please use DEVEL branch
13 Version:        1.141
14 Release:        0.1
15 License:        LGPL v2.1+
16 Group:          Development/Languages/Perl
17 Source0:        http://dl.sourceforge.net/gtk2-perl/%{pdir}-%{version}.tar.gz
18 # Source0-md5:  bc7f61c80bef55ae9e0edd4badedddd3
19 URL:            http://gtk2-perl.sourceforge.net/
20 BuildRequires:  gtk+2-devel >= 2:2.10.2
21 BuildRequires:  perl-Cairo >= 1.00
22 BuildRequires:  perl-ExtUtils-Depends >= 0.201
23 BuildRequires:  perl-ExtUtils-PkgConfig >= 1.06
24 BuildRequires:  perl-Glib >= 1.140
25 BuildRequires:  perl-devel >= 1:5.8.0
26 BuildRequires:  rpm-perlprov >= 4.1-13
27 BuildRequires:  rpmbuild(macros) >= 1.192
28 Requires:       gtk+2 >= 2:2.10.2
29 Requires:       perl-Cairo >= 1.00
30 Requires:       perl-Glib >= 1.140
31 Obsoletes:      perl-Gnome2-common
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 The Gtk2 module allows a perl developer to use the GTK+ graphical user
36 interface library.
37
38 %description -l pl.UTF-8
39 Moduł Gtk2 pozwala programistom perlowym na używanie biblioteki
40 interfejsu graficznego GTK+.
41
42 %prep
43 %setup -q -n %{pdir}-%{version}
44
45 %build
46 %{__perl} Makefile.PL \
47         INSTALLDIRS=vendor
48
49 %{__make} \
50         OPTIMIZE="%{rpmcflags}"
51
52 %{?with_tests:%{__make} test}
53
54 %install
55 rm -rf $RPM_BUILD_ROOT
56 install -d $RPM_BUILD_ROOT%{perl_vendorarch}/{auto/Gnome2,Gnome2} \
57         $RPM_BUILD_ROOT%{perl_vendorlib}/Gtk2/Ex
58
59 %{__make} install \
60         DESTDIR=$RPM_BUILD_ROOT
61
62 rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/%{pdir}/{*,*/*,*/*/*}.pod
63 rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/Gtk2.pod
64
65 %clean
66 rm -rf $RPM_BUILD_ROOT
67
68 %files
69 %defattr(644,root,root,755)
70 %doc AUTHORS ChangeLog README TODO
71 %{perl_vendorarch}/Gtk2.pm
72 %dir %{perl_vendorarch}/Gtk2
73 %{perl_vendorarch}/Gtk2/*.pm
74 %dir %{perl_vendorarch}/Gtk2/Gdk
75 %{perl_vendorarch}/Gtk2/Gdk/*.pm
76 %{perl_vendorarch}/Gtk2/Install
77 %dir %{perl_vendorarch}/Gnome2
78 %dir %{perl_vendorarch}/auto/Gtk2
79 %{perl_vendorarch}/auto/Gtk2/*.bs
80 %attr(755,root,root) %{perl_vendorarch}/auto/Gtk2/*.so
81 %dir %{perl_vendorarch}/auto/Gnome2
82 %dir %{perl_vendorlib}/Gtk2
83 %dir %{perl_vendorlib}/Gtk2/Ex
84 %{_mandir}/man3/*
This page took 0.029337 seconds and 4 git commands to generate.