]> git.pld-linux.org Git - packages/perl-Gtk2.git/blob - perl-Gtk2.spec
- release 3
[packages/perl-Gtk2.git] / perl-Gtk2.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # perform "make test" (requires X server)
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Gtk2
7 Summary:        Perl interface to the 2.x series of the Gimp Toolkit library
8 Summary(pl.UTF-8):      Interfejs perlowy do wersji 2.x biblioteki Gimp Toolkit
9 Name:           perl-Gtk2
10 # note: versions 1.x[13579]y are unstable, if you want them, please use DEVEL branch
11 Version:        1.221
12 Release:        3
13 License:        LGPL v2.1+
14 Group:          Development/Languages/Perl
15 Source0:        http://dl.sourceforge.net/gtk2-perl/%{pdir}-%{version}.tar.gz
16 # Source0-md5:  ba412049d10978ed802b98976f6adaa9
17 URL:            http://gtk2-perl.sourceforge.net/
18 BuildRequires:  gtk+2-devel >= 2:2.12.0
19 BuildRequires:  pango-devel >= 1:1.18
20 BuildRequires:  perl-Cairo >= 1.060
21 BuildRequires:  perl-ExtUtils-Depends >= 0.201
22 BuildRequires:  perl-ExtUtils-MakeMaker
23 BuildRequires:  perl-ExtUtils-PkgConfig >= 1.06
24 BuildRequires:  perl-Glib >= 1.183
25 BuildRequires:  perl-Pango >= 1.220
26 BuildRequires:  perl-devel >= 1:5.8.0
27 BuildRequires:  rpm-perlprov >= 4.1-13
28 BuildRequires:  rpmbuild(macros) >= 1.192
29 Requires:       gtk+2 >= 2:2.12.0
30 Requires:       pango >= 1:1.18
31 Requires:       perl-Cairo >= 1.060
32 Requires:       perl-Glib >= 1.183
33 Obsoletes:      perl-Gnome2-common
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 The Gtk2 module allows a perl developer to use the GTK+ graphical user
38 interface library.
39
40 %description -l pl.UTF-8
41 Moduł Gtk2 pozwala programistom perlowym na używanie biblioteki
42 interfejsu graficznego GTK+.
43
44 %prep
45 %setup -q -n %{pdir}-%{version}
46
47 %build
48 %{__perl} Makefile.PL \
49         INSTALLDIRS=vendor
50
51 %{__make} \
52         CC="%{__cc}" \
53         OPTIMIZE="%{rpmcflags}"
54
55 %{?with_tests:%{__make} test}
56
57 %install
58 rm -rf $RPM_BUILD_ROOT
59 install -d $RPM_BUILD_ROOT%{perl_vendorlib}/Gtk2/Ex
60
61 %{__make} pure_install \
62         DESTDIR=$RPM_BUILD_ROOT
63
64 rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/Gtk2/{*,*/*,*/*/*}.pod
65 rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/Gtk2.pod
66
67 %clean
68 rm -rf $RPM_BUILD_ROOT
69
70 %files
71 %defattr(644,root,root,755)
72 %doc AUTHORS NEWS README TODO
73 %{perl_vendorarch}/Gtk2.pm
74 %dir %{perl_vendorarch}/Gtk2
75 %{perl_vendorarch}/Gtk2/*.pm
76 %dir %{perl_vendorarch}/Gtk2/Gdk
77 %{perl_vendorarch}/Gtk2/Gdk/*.pm
78 %{perl_vendorarch}/Gtk2/Install
79 %dir %{perl_vendorarch}/auto/Gtk2
80 %{perl_vendorarch}/auto/Gtk2/*.bs
81 %attr(755,root,root) %{perl_vendorarch}/auto/Gtk2/*.so
82 %dir %{perl_vendorlib}/Gtk2
83 %dir %{perl_vendorlib}/Gtk2/Ex
84 %{_mandir}/man3/Gtk2*.3pm*
This page took 0.032516 seconds and 4 git commands to generate.