]> git.pld-linux.org Git - packages/perl-DateTime.git/blob - perl-DateTime.spec
- fix md5
[packages/perl-DateTime.git] / perl-DateTime.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    DateTime
7 Summary:        DateTime - representation of date/time combinations
8 Summary(pl):    DateTime - reprezentacja kombinacji daty i czasu
9 Name:           perl-DateTime
10 Version:        0.32
11 Release:        1
12 Epoch:          1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{version}.tar.gz
17 # Source0-md5:  6cc7208029b13bc8097ab2b77df070b1
18 URL:            http://datetime.perl.org/
19 %if %{with tests}
20 BuildRequires:  perl-DateTime-Locale >= 0.21
21 BuildRequires:  perl-DateTime-TimeZone >= 1:0.38
22 BuildRequires:  perl-Params-Validate >= 0.76
23 %endif
24 BuildRequires:  perl-devel >= 1:5.8.0
25 BuildRequires:  rpm-perlprov >= 4.1-13
26 Requires:       perl-base >= 1:5.8.7-3
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 DateTime is a class for the representation of date/time combinations,
31 and is part of the Perl DateTime project. For details on this project
32 please see <http://datetime.perl.org/>. The DateTime site has a FAQ
33 which may help answer many "how do I do X?" questions. The FAQ is at
34 <http://datetime.perl.org/faq.html>.
35
36 %description -l pl
37 DateTime to klasa do reprezentowania kombinacji daty i czasu, bêd±ca
38 czê¶ci± perlowego projektu DateTime. Szczegó³y dotycz±ce tego projektu
39 mo¿na znale¼æ pod adresem <http://datetime.perl.org/>. Serwis ten ma
40 swoje FAQ, gdzie mo¿na znale¼æ odpowiedzi na wiele pytañ - dostêpne
41 pod <http://datetime.perl.org/faq.html>.
42
43 %prep
44 %setup -q -n %{pdir}-%{version}
45
46 mv t/20infinite.t{,.broken}
47
48 %build
49 %{__perl} Makefile.PL \
50         INSTALLDIRS=vendor
51
52 %{__make} \
53         OPTIMIZE="%{rpmcflags}"
54
55 %{?with_tests:%{__make} test}
56
57 %install
58 rm -rf $RPM_BUILD_ROOT
59
60 %{__make} install \
61         DESTDIR=$RPM_BUILD_ROOT
62 install -d $RPM_BUILD_ROOT%{perl_vendorlib}/DateTime/Format
63
64 %clean
65 rm -rf $RPM_BUILD_ROOT
66
67 %files
68 %defattr(644,root,root,755)
69 %doc Changes README CREDITS TODO leaptab.txt
70 %{perl_vendorarch}/DateTime*pm
71 %{perl_vendorarch}/DateTime/*.pm
72 %{perl_vendorarch}/auto/DateTime/DateTime.bs
73 %dir %{perl_vendorarch}/auto/DateTime
74 %{perl_vendorlib}/DateTime/*
75 %attr(755,root,root) %{perl_vendorarch}/auto/DateTime/DateTime.so
76 %{_mandir}/man3/*
This page took 0.040278 seconds and 4 git commands to generate.