]> git.pld-linux.org Git - packages/perl-DateTime.git/blob - perl-DateTime.spec
- updated to 0.66
[packages/perl-DateTime.git] / perl-DateTime.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    DateTime
7 Summary:        DateTime - representation of date/time combinations
8 Summary(pl.UTF-8):      DateTime - reprezentacja kombinacji daty i czasu
9 Name:           perl-DateTime
10 Version:        0.66
11 Release:        1
12 Epoch:          2
13 License:        Artistic 2.0
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/DateTime/DROLSKY/%{pdir}-%{version}.tar.gz
16 # Source0-md5:  9399b5b430da65ac0b9056c0182a805b
17 URL:            http://datetime.perl.org/
18 BuildRequires:  perl(Pod::Man) >= 1.14
19 BuildRequires:  perl-ExtUtils-CBuilder
20 BuildRequires:  perl-Module-Build >= 0.3601
21 BuildRequires:  perl-devel >= 1:5.8.0
22 BuildRequires:  rpm-perlprov >= 4.1-13
23 %if %{with tests}
24 BuildRequires:  perl(Time::Local) >= 1.04
25 BuildRequires:  perl-DateTime-Locale >= 0.41
26 BuildRequires:  perl-DateTime-TimeZone >= 1:1.09
27 BuildRequires:  perl-Params-Validate >= 0.76
28 BuildRequires:  perl-Test-Exception
29 BuildRequires:  perl-Test-Exception
30 BuildRequires:  perl-Test-Simple >= 0.88
31 %endif
32 Requires:       perl-base >= 1:5.8.7-3
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 DateTime is a class for the representation of date/time combinations,
37 and is part of the Perl DateTime project. For details on this project
38 please see <http://datetime.perl.org/>. The DateTime site has a FAQ
39 which may help answer many "how do I do X?" questions. The FAQ is at
40 <http://datetime.perl.org/faq.html>.
41
42 %description -l pl.UTF-8
43 DateTime to klasa do reprezentowania kombinacji daty i czasu, będąca
44 częścią perlowego projektu DateTime. Szczegóły dotyczące tego projektu
45 można znaleźć pod adresem <http://datetime.perl.org/>. Serwis ten ma
46 swoje FAQ, gdzie można znaleźć odpowiedzi na wiele pytań - dostępne
47 pod <http://datetime.perl.org/faq.html>.
48
49 %prep
50 %setup -q -n %{pdir}-%{version}
51
52 %build
53 %{__perl} Build.PL \
54         installdirs=vendor \
55         --config cc="%{__cc}" \
56         --config ld="%{__cc}" \
57         --config optimize="%{rpmcflags}"
58
59 ./Build
60
61 %{?with_tests:./Build test}
62
63 %install
64 rm -rf $RPM_BUILD_ROOT
65
66 ./Build install \
67         destdir=$RPM_BUILD_ROOT
68
69 # for noarch DateTime::* modules
70 install -d $RPM_BUILD_ROOT%{perl_vendorlib}/DateTime/{Event,Format}
71
72 %clean
73 rm -rf $RPM_BUILD_ROOT
74
75 %files
76 %defattr(644,root,root,755)
77 %doc Changes README CREDITS TODO leaptab.txt
78 %dir %{perl_vendorlib}/DateTime/Event
79 %dir %{perl_vendorlib}/DateTime/Format
80 %{perl_vendorarch}/DateTime.pm
81 %{perl_vendorarch}/DateTimePP.pm
82 %{perl_vendorarch}/DateTimePPExtra.pm
83 %{perl_vendorarch}/DateTime/*.pm
84 %dir %{perl_vendorarch}/auto/DateTime
85 %{perl_vendorarch}/auto/DateTime/DateTime.bs
86 %attr(755,root,root) %{perl_vendorarch}/auto/DateTime/DateTime.so
87 %{_mandir}/man3/DateTime*.3pm*
This page took 0.069997 seconds and 4 git commands to generate.