]> git.pld-linux.org Git - packages/perl-DateTime.git/blob - perl-DateTime.spec
- updated URLs
[packages/perl-DateTime.git] / perl-DateTime.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # unit tests
4 %bcond_with     tests_i18n      # tests with localization (requires some DateTime::Locale language resources)
5
6 %define         pdir    DateTime
7 Summary:        DateTime - representation of date/time combinations
8 Summary(pl.UTF-8):      DateTime - reprezentacja kombinacji daty i czasu
9 Name:           perl-DateTime
10 Version:        1.59
11 Release:        2
12 Epoch:          2
13 License:        Artistic v2.0
14 Group:          Development/Languages/Perl
15 Source0:        https://www.cpan.org/modules/by-module/DateTime/%{pdir}-%{version}.tar.gz
16 # Source0-md5:  d6d73ba9ff03e00c83610a995fadc481
17 URL:            https://metacpan.org/dist/DateTime
18 BuildRequires:  perl(Pod::Man) >= 1.14
19 BuildRequires:  perl-Dist-CheckConflicts >= 0.02
20 BuildRequires:  perl-devel >= 1:5.8.4
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 BuildRequires:  rpmbuild(macros) >= 1.745
23 %if %{with tests}
24 BuildRequires:  perl-CPAN-Meta-Check >= 0.011
25 BuildRequires:  perl-CPAN-Meta-Requirements
26 BuildRequires:  perl-DateTime-Format-Mail >= 0.402
27 BuildRequires:  perl-DateTime-Format-Strptime >= 1.2000
28 BuildRequires:  perl-DateTime-Locale >= 1.06
29 BuildRequires:  perl-DateTime-TimeZone >= 3:2.44
30 BuildRequires:  perl-JSON-PP >= 2.27300
31 BuildRequires:  perl-Math-Round
32 BuildRequires:  perl-Params-ValidationCompiler >= 0.26
33 BuildRequires:  perl-Scalar-List-Utils
34 BuildRequires:  perl-Specio >= 0.18
35 BuildRequires:  perl-Storable
36 BuildRequires:  perl-Test-Fatal
37 BuildRequires:  perl-Test-Simple >= 0.96
38 BuildRequires:  perl-Test-Warnings >= 0.005
39 BuildRequires:  perl-Test-Without-Module
40 BuildRequires:  perl-Try-Tiny
41 BuildRequires:  perl-namespace-autoclean >= 0.19
42 %endif
43 %if %{with tests_i18n} && "%(ls /usr/share/perl5/vendor_perl/auto/share/dist/DateTime-Locale/{de,en-US-POSIX,fr,it}.pl >/dev/null 2>&1 ; echo $?)" != "0"
44 BuildRequires:  perl-DateTime-Locale(with_locales:de;en-US;fr;it)
45 %endif
46 BuildConflicts: perl-DateTime-Format-Mail <= 0.402
47 Requires:       perl-base >= 1:5.8.7-3
48 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
49
50 %description
51 DateTime is a class for the representation of date/time combinations,
52 and is part of the Perl DateTime project. For details on this project
53 please see <http://datetime.perl.org/>. The DateTime site has a FAQ
54 which may help answer many "how do I do X?" questions. The FAQ is at
55 <http://datetime.perl.org/faq.html>.
56
57 %description -l pl.UTF-8
58 DateTime to klasa do reprezentowania kombinacji daty i czasu, będąca
59 częścią perlowego projektu DateTime. Szczegóły dotyczące tego projektu
60 można znaleźć pod adresem <http://datetime.perl.org/>. Serwis ten ma
61 swoje FAQ, gdzie można znaleźć odpowiedzi na wiele pytań - dostępne
62 pod <http://datetime.perl.org/faq.html>.
63
64 %prep
65 %setup -q -n %{pdir}-%{version}
66
67 %if %{with tests} && %{without tests_i18n}
68 %{__sed} -i -e "/^test_strftime_for_locale( '\(de\|it\)'/d" t/13strftime.t
69 %{__sed} -i -e "/locale.*'de'/ s/'de'/'en-US'/" t/23storable.t
70 %{__rm} t/14locale.t t/41cldr-format.t
71 %endif
72
73 %build
74 %{__perl} Makefile.PL \
75         INSTALLDIRS=vendor
76 %{__make}
77
78 %{?with_tests:%{__make} test}
79
80 %install
81 rm -rf $RPM_BUILD_ROOT
82
83 %{__make} install \
84         DESTDIR=$RPM_BUILD_ROOT
85
86 # for noarch DateTime::* modules
87 install -d $RPM_BUILD_ROOT%{perl_vendorlib}/DateTime/{Event,Format}
88
89 %clean
90 rm -rf $RPM_BUILD_ROOT
91
92 %files
93 %defattr(644,root,root,755)
94 %doc CREDITS Changes TODO leaptab.txt
95 %{perl_vendorarch}/DateTime.pm
96 %{perl_vendorarch}/DateTime/*.pm
97 %dir %{perl_vendorlib}/DateTime/Event
98 %dir %{perl_vendorlib}/DateTime/Format
99 %dir %{perl_vendorarch}/auto/DateTime
100 %attr(755,root,root) %{perl_vendorarch}/auto/DateTime/DateTime.so
101 %{_mandir}/man3/DateTime*.3pm*
This page took 0.068377 seconds and 4 git commands to generate.