]> git.pld-linux.org Git - packages/perl-DateTime.git/blob - perl-DateTime.spec
- pl, License
[packages/perl-DateTime.git] / perl-DateTime.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    DateTime
7 Summary:        DateTime - representation of date/time combinations
8 Summary(pl):    DateTime - reprezentacja kombinacji daty i czasu
9 Name:           perl-DateTime
10 Version:        0.21
11 Release:        1
12 # same as perl
13 License:        GPL or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{version}.tar.gz
16 # Source0-md5:  2f6deb64ffea879ca29832dc08fe428b
17 URL:            http://datetime.perl.org/
18 BuildRequires:  perl-Class-Factory
19 BuildRequires:  perl-DateTime-Locale
20 BuildRequires:  perl-DateTime-TimeZone
21 BuildRequires:  perl-Params-Validate
22 BuildRequires:  perl-devel >= 1:5.8.0
23 BuildRequires:  rpm-perlprov >= 4.1-13
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 DateTime is a class for the representation of date/time combinations,
28 and is part of the Perl DateTime project. For details on this project
29 please see <http://datetime.perl.org/>. The DateTime site has a FAQ
30 which may help answer many "how do I do X?" questions. The FAQ is at
31 <http://datetime.perl.org/faq.html>.
32
33 %description -l pl
34 DateTime to klasa do reprezentowania kombinacji daty i czasu, bêd±ca
35 czê¶ci± perlowego projektu DateTime. Szczegó³y dotycz±ce tego projektu
36 mo¿na znale¼æ pod adresem <http://datetime.perl.org/>. Serwis ten ma
37 swoje FAQ, gdzie mo¿na znale¼æ odpowiedzi na wiele pytañ - dostêpne
38 pod <http://datetime.perl.org/faq.html>.
39
40 %prep
41 %setup -q -n %{pdir}-%{version}
42
43 %build
44 %{__perl} Makefile.PL \
45         INSTALLDIRS=vendor
46
47 %{__make} \
48         OPTIMIZE="%{rpmcflags}"
49
50 %{?with_tests:%{__make} test}
51
52 %install
53 rm -rf $RPM_BUILD_ROOT
54
55 %{__make} install \
56         DESTDIR=$RPM_BUILD_ROOT
57
58 %clean
59 rm -rf $RPM_BUILD_ROOT
60
61 %files
62 %defattr(644,root,root,755)
63 %doc Changes README CREDITS TODO leaptab.txt
64 %{perl_vendorarch}/DateTime*pm
65 %dir %{perl_vendorarch}/DateTime
66 %{perl_vendorarch}/DateTime/*.pm
67 %{perl_vendorarch}/auto/DateTime/DateTime.bs
68 %attr(755,root,root) %{perl_vendorarch}/auto/DateTime/DateTime.so
69 %{_mandir}/man3/*
This page took 0.077091 seconds and 4 git commands to generate.