]> git.pld-linux.org Git - packages/perl-DateTime.git/blob - perl-DateTime.spec
c9cc3bc389a5ff795cad4924f466662f53f44b89
[packages/perl-DateTime.git] / perl-DateTime.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    DateTime
7 Summary:        DateTime - representation of date/time combinations
8 Summary(pl):    DateTime - reprezentacja kombinacji daty i czasu
9 Name:           perl-DateTime
10 Version:        0.22
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{version}.tar.gz
16 # Source0-md5:  b0655fce30830bc413791d260f5185c4
17 URL:            http://datetime.perl.org/
18 %if %{with tests}
19 BuildRequires:  perl-Class-Factory
20 BuildRequires:  perl-DateTime-Locale
21 BuildRequires:  perl-DateTime-TimeZone
22 BuildRequires:  perl-Params-Validate
23 %endif
24 BuildRequires:  perl-devel >= 1:5.8.0
25 BuildRequires:  rpm-perlprov >= 4.1-13
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 DateTime is a class for the representation of date/time combinations,
30 and is part of the Perl DateTime project. For details on this project
31 please see <http://datetime.perl.org/>. The DateTime site has a FAQ
32 which may help answer many "how do I do X?" questions. The FAQ is at
33 <http://datetime.perl.org/faq.html>.
34
35 %description -l pl
36 DateTime to klasa do reprezentowania kombinacji daty i czasu, bêd±ca
37 czê¶ci± perlowego projektu DateTime. Szczegó³y dotycz±ce tego projektu
38 mo¿na znale¼æ pod adresem <http://datetime.perl.org/>. Serwis ten ma
39 swoje FAQ, gdzie mo¿na znale¼æ odpowiedzi na wiele pytañ - dostêpne
40 pod <http://datetime.perl.org/faq.html>.
41
42 %prep
43 %setup -q -n %{pdir}-%{version}
44
45 %build
46 %{__perl} Makefile.PL \
47         INSTALLDIRS=vendor
48
49 %{__make} \
50         OPTIMIZE="%{rpmcflags}"
51
52 %{?with_tests:%{__make} test}
53
54 %install
55 rm -rf $RPM_BUILD_ROOT
56
57 %{__make} install \
58         DESTDIR=$RPM_BUILD_ROOT
59
60 %clean
61 rm -rf $RPM_BUILD_ROOT
62
63 %files
64 %defattr(644,root,root,755)
65 %doc Changes README CREDITS TODO leaptab.txt
66 %{perl_vendorarch}/DateTime*pm
67 %dir %{perl_vendorarch}/DateTime
68 %{perl_vendorarch}/DateTime/*.pm
69 %{perl_vendorarch}/auto/DateTime/DateTime.bs
70 %attr(755,root,root) %{perl_vendorarch}/auto/DateTime/DateTime.so
71 %{_mandir}/man3/*
This page took 0.02493 seconds and 3 git commands to generate.