]> git.pld-linux.org Git - packages/pdns.git/blob - pdns.spec
- spaces -> tabs, other cosmetics
[packages/pdns.git] / pdns.spec
1 Summary:        PowerDNS is a Versatile Database Driven Nameserver
2 Summary(pl):    PowerDNS to wielofunkcyjny serwer nazw korzystaj±cy z relacyjnych baz danych
3 Name:           pdns
4 Version:        2.9.16
5 Release:        1
6 License:        GPL
7 Group:          Networking/Daemons
8 Source0:        http://downloads.powerdns.com/releases/%{name}-%{version}.tar.gz
9 # Source0-md5:  7e9a859a5a21996dbf7b31cd61731dbc
10 Source1:        http://downloads.powerdns.com/documentation/%{name}.pdf
11 # Source1-md5:  72cce8fb180c3a70437187ff0912c2a3
12 Source2:        http://downloads.powerdns.com/documentation/%{name}.txt
13 Source3:        %{name}.init
14 Source4:        %{name}.conf
15 Source5:        %{name}.sysconfig
16 Patch0:         %{name}-configure.patch
17 URL:            http://www.powerdns.com/
18 BuildRequires:  bison
19 BuildRequires:  flex
20 BuildRequires:  libstdc++-devel
21 BuildRequires:  libpq++-devel
22 BuildRequires:  mysql-devel
23 BuildRequires:  zlib-devel
24 BuildRequires:  openldap-devel
25 PreReq:         rc-scripts
26 Requires(pre):  /bin/id
27 Requires(pre):  /usr/sbin/useradd
28 Requires(pre):  /usr/sbin/groupadd
29 Requires(post,preun):   /sbin/chkconfig
30 Requires(postun):       /usr/sbin/userdel
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32 Provides:       nameserver
33 Obsoletes:      powerdns
34
35 %description
36 PowerDNS is a versatile nameserver which supports a large number of
37 different backends ranging from simple zonefiles to relational
38 databases and load balancing/failover algorithms.
39
40 %description -l pl
41 PowerDNS to wielofunkcyjny serwer nazw posiadaj±cy du¿± liczbê wtyczek
42 od prostych stref (a'la BIND) pocz±wszy, a na relacyjnych bazach
43 danych skoñczywszy oraz zawieraj±cy algorytmy zrównowa¿enia obci±¿enia
44 i prze³±czania w wypadku awarii.
45
46 %package backend-pipe
47 Summary:        PowerDNS support for custom pipe backend
48 Summary(pl):    Wsparcie PowerDNS dla w³asnego mechanizmu przechowywania stref
49 Group:          Development/Libraries
50
51 %description backend-pipe
52 This package allows creation of own backend using simple STDIN/STDOUT
53 API. Example backend script in perl is provided in package
54 documentation.
55
56 %description backend-pipe -l pl
57 Ten pakiet pozwala na utworzenie w³asnego mechanizmu przechowywania
58 stref za pomoc¹ prostego interfejsu STDIN/STDOUT. Przyk³adowy skrypt w
59 perlu zosta³ do³±czony do dokumentacji pakietu.
60
61 %package backend-gpgsql
62 Summary:        PowerDNS support for PostgreSQL
63 Summary(pl):    Wsparcie PowerDNS dla baz PostgresQL
64 Group:          Development/Libraries
65 Requires:       postgresql
66
67 %description backend-gpgsql
68 This package allows zone storage in PostgreSQL relational db tables.
69
70 %description backend-gpgsql -l pl
71 Ten pakiet pozwala na przechowywanie danych o strefach w tabelach
72 relacyjnej bazy danych PostgreSQL.
73
74 %package backend-gmysql
75 Summary:        PowerDNS support for MySQL
76 Summary(pl):    Wsparcie PowerDNS dla baz MySQL
77 Group:          Development/Libraries
78 Requires:       mysql
79
80 %description backend-gmysql
81 This package allows zone storage in MySQL relational db tables.
82
83 %description backend-gmysql -l pl
84 Ten pakiet pozwala na przechowywanie danych o strefach w tabelach
85 relacyjnej bazy danych MySQL.
86
87 %package backend-ldap
88 Summary:        PowerDNS support for LDAP
89 Summary(pl):    Wsparcie PowerDNS dla baz LDAP
90 Group:          Development/Libraries
91 Requires:       openldap
92
93 %description backend-ldap
94 This package allows zone storage in LDAP directory.
95
96 %description backend-ldap -l pl
97 Ten pakiet pozwala na przechowywanie danych o strefach w katalogu LDAP.
98
99 %prep
100 %setup -q
101 %patch0 -p1
102 cp %{SOURCE1} .
103 cp %{SOURCE2} .
104
105 %build
106 CPPFLAGS="-DHAVE_NAMESPACE_STD -DHAVE_CXX_STRING_HEADER -DDLLIMPORT=\"\""
107 %configure \
108         --libdir=%{_libdir}/%{name} \
109         --sysconfdir=%{_sysconfdir}/%{name} \
110         --with-socketdir=/var/run \
111         --with-dynmodules="gmysql gpgsql pipe ldap" \
112         --with-modules="" \
113         --enable-mysql \
114         --enable-pgsql \
115         --with-pgsql-lib=/usr/lib \
116         --with-pgsql-includes=%{_includedir} \
117         --enable-ldap \
118         --disable-static
119
120 %{__make}
121
122 %install
123 rm -rf $RPM_BUILD_ROOT
124 install -d $RPM_BUILD_ROOT{%{_initrddir},%{_sysconfdir}/%{name},/etc/sysconfig}
125
126 %{__make} install \
127         DESTDIR=$RPM_BUILD_ROOT
128
129 install %{SOURCE3} $RPM_BUILD_ROOT%{_initrddir}/%{name}
130 install %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/%{name}.conf
131 install %{SOURCE5} $RPM_BUILD_ROOT/etc/sysconfig/pdns
132
133 # useless - modules are dlopened by *.so
134 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/*.la
135
136 %clean
137 rm -rf $RPM_BUILD_ROOT
138
139 %pre
140 if [ -n "`getgid djbdns`" ]; then
141         if [ "`getgid djbdns`" != "32" ]; then
142                 echo "Error: group djbdns doesn't have gid=32. Correct this before installing pdns." 1>&2
143                 exit 1
144         fi
145 else
146         /usr/sbin/groupadd -g 32 -r -f djbdns
147 fi
148 if [ -n "`id -u pdns 2>/dev/null`" ]; then
149         if [ "`id -u pdns`" != "30" ]; then
150                 echo "Error: user pdns doesn't have uid=30. Correct this before installing pdns." 1>&2
151                 exit 1
152         fi
153 else
154         /usr/sbin/useradd -u 30 -r -d /var/lib/pdns -s /bin/false -c "pdns User" -g djbdns pdns 1>&2
155 fi
156
157 %post
158 # dirty hack so the config file is processed correctly, and server does not respawn
159 TMP=`mktemp /tmp/pdns.install-tmp.XXXXXX`
160 sed 's/^ *//g' /etc/pdns/pdns.conf > $TMP
161 cp /etc/pdns/pdns.conf /etc/pdns/pdns.conf.rpmsave
162 mv $TMP /etc/pdns/pdns.conf
163
164 /sbin/chkconfig --add pdns
165 if [ -f /var/lock/subsys/pdns ]; then
166         /etc/rc.d/init.d/pdns restart >&2
167 else
168         echo "Run \"/etc/rc.d/init.d/pdns start\" to start pdns." >&2
169 fi
170
171 %preun
172 if [ "$1" = "0" ]; then
173         if [ -f /var/lock/subsys/pdns ]; then
174                 /etc/rc.d/init.d/pdns stop
175         fi
176         /sbin/chkconfig --del pdns
177 fi
178
179 %postun
180 if [ "$1" = "0" ]; then
181         /usr/sbin/userdel pdns
182 fi
183
184 %files
185 %defattr(644,root,root,755)
186 %doc ChangeLog HACKING INSTALL README TODO WARNING pdns.pdf pdns.txt
187 %config(noreplace) %attr(0600,root,root) %{_sysconfdir}/%{name}/%{name}.conf
188 %config(noreplace) %attr(0754,root,root) %{_initrddir}/%{name}
189 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/sysconfig/pdns
190 %dir %{_sysconfdir}/%{name}
191 %attr(755,root,root) %{_sbindir}/*
192 %attr(755,root,root) %{_bindir}/*
193 %{_mandir}/man8/*
194
195 %files backend-gmysql
196 %defattr(644,root,root,755)
197 %attr(755,root,root) %{_libdir}/%{name}/*mysql*.so*
198
199 %files backend-gpgsql
200 %defattr(644,root,root,755)
201 %attr(755,root,root) %{_libdir}/%{name}/*pgsql*.so*
202
203 %files backend-pipe
204 %defattr(644,root,root,755)
205 %attr(755,root,root) %{_libdir}/%{name}/*pipe*.so*
206
207 %files backend-ldap
208 %defattr(644,root,root,755)
209 %attr(755,root,root) %{_libdir}/%{name}/*ldap*.so*
This page took 0.064032 seconds and 3 git commands to generate.