]> git.pld-linux.org Git - packages/pcsc-lite.git/blob - pcsc-lite.spec
- added init script
[packages/pcsc-lite.git] / pcsc-lite.spec
1 Summary:        Muscle PCSC Framework for Linux
2 Summary(pl):    ¦rodowisko PCSC dla Linuksa
3 Name:           pcsc-lite
4 Version:        1.1.1
5 Release:        2
6 License:        BSD
7 Group:          Daemons
8 Source0:        http://linuxnet.com/middleware/file/%{name}-%{version}.tar.gz
9 Source1:        %{name}-pcscd.init
10 Source2:        %{name}-pcscd.sysconfig
11 Patch0:         %{name}-fhs.patch
12 URL:            http://www.linuxnet.com/middle.html
13 PreReq:         rc-scripts
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %description
17 pcscd is the daemon program for PC/SC Lite. It is a resource manager
18 that coorinates communications with Smart Card readers and Smart Cards
19 that are connected to the system. The purpose of PCSC Lite is to
20 provide a Windows(R) SCard interface in a very small form factor for
21 communicating to smartcards and readers. PCSC Lite uses the same
22 winscard api as used under Windows(R).
23
24 %description -l pl
25 pcscd jest demonem dla PC/SC Lite. Jest to zarz±dca zasobów,
26 koordynuj±cy komunikacjê z czytnikami kart procesorowych pod³±czonymi
27 do systemu. Celem PCSC Lite jest udostêpnienie interfejsu zgodnego z
28 Windows(R) SCard s³u¿±cego do komunikacji z czytnikami kart chipowych.
29 U¿ywa tego samego API winscard, które jest u¿ywane pod Microsoft(TM)
30 Windows(R).
31
32 %package libs
33 Summary:        PC/SC Lite libraries
34 Summary(pl):    Biblioteki PC/SC Lite
35 Group:          Libraries
36
37 %description libs
38 PC/SC Lite libraries.
39
40 %description libs -l pl
41 Biblioteki PC/SC Lite.
42
43 %package devel
44 Summary:        PC/SC Lite development files
45 Summary(pl):    Pliki dla programistów u¿ywaj±cych PC/SC Lite
46 Group:          Development/Tools
47 Requires:       %{name}-libs = %{version}
48
49 %description devel
50 PC/SC Lite development files.
51
52 %description devel -l pl
53 Pliki dla programistów u¿ywaj±cych PC/SC Lite.
54
55 %package static
56 Summary:        Static PC/SC Lite libraries
57 Summary(pl):    Biblioteki statyczne PC/SC Lite
58 Group:          Development/Tools
59 Requires:       %{name}-devel = %{version}
60
61 %description static
62 Static PC/SC Lite libraries.
63
64 %description static -l pl
65 Statyczne biblioteki PC/SC Lite.
66
67 %prep
68 %setup -q
69 %patch -p1
70
71 %build
72 %configure2_13
73
74 %{__make}
75
76 %install
77 rm -rf $RPM_BUILD_ROOT
78 install -d $RPM_BUILD_ROOT%{_libdir}/pcsc/{drivers,services} \
79         $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig}
80
81 %{__make} install \
82         DESTDIR=$RPM_BUILD_ROOT
83
84 # useful for drivers development
85 install src/ifdhandler.h $RPM_BUILD_ROOT%{_includedir}
86
87 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/pcscd
88 install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/pcscd
89
90 %clean
91 rm -rf $RPM_BUILD_ROOT
92
93 %post
94 /sbin/chkconfig --add pcscd
95 if [ -f /var/lock/subsys/pcscd ]; then
96         /etc/rc.d/init.d/pcscd restart >&2
97 else
98         echo "Run \"/etc/rc.d/init.d/pcscd start\" to start pcscd daemon."
99 fi
100
101 %preun
102 if [ "$1" = "0" ]; then
103         if [ -f /var/lock/subsys/pcscd ]; then
104                 /etc/rc.d/init.d/pcscd stop >&2
105         fi
106         /sbin/chkconfig --del pcscd
107 fi
108
109 %post   libs -p /sbin/ldconfig
110 %postun libs -p /sbin/ldconfig
111
112 %files
113 %defattr(644,root,root,755)
114 %doc AUTHORS COPYING DRIVERS NEWS HELP README SECURITY doc/{README.DAEMON,*.pdf,pcscd.startup}
115 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/reader.conf
116 %attr(754,root,root) /etc/rc.d/init.d/pcscd
117 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/sysconfig/pcscd
118 %attr(755,root,root) %{_sbindir}/pcscd
119 %attr(755,root,root) %{_bindir}/bundleTool
120 %attr(755,root,root) %{_bindir}/formaticc
121 %attr(755,root,root) %{_bindir}/installifd
122 %{_libdir}/pcsc
123 %{_mandir}/man1/bundleTool.1*
124 %{_mandir}/man8/pcscd.8*
125
126 %files libs
127 %defattr(644,root,root,755)
128 %attr(755,root,root) %{_libdir}/lib*.so.*.*
129
130 %files devel
131 %defattr(644,root,root,755)
132 %attr(755,root,root) %{_libdir}/lib*.so
133 %{_libdir}/libpcsc*.la
134 %{_includedir}/*.h
135
136 %files static
137 %defattr(644,root,root,755)
138 %{_libdir}/lib*.a
This page took 0.06365 seconds and 4 git commands to generate.