]> git.pld-linux.org Git - packages/pcsc-lite.git/blob - pcsc-lite.spec
- check-files cleanup
[packages/pcsc-lite.git] / pcsc-lite.spec
1 Summary:        Muscle PCSC Framework for Linux
2 Summary(pl):    ¦rodowisko PCSC dla Linuksa
3 Name:           pcsc-lite
4 Version:        1.3.1
5 Release:        1
6 License:        BSD
7 Group:          Daemons
8 #Source0Download: http://alioth.debian.org/project/showfiles.php?group_id=30105
9 Source0:        http://alioth.debian.org/download.php/1565/%{name}-%{version}.tar.gz
10 # Source0-md5:  90fa7e9cdfdfe88fdf6644ca8b60a681
11 Source1:        %{name}-pcscd.init
12 Source2:        %{name}-pcscd.sysconfig
13 Patch0:         %{name}-fhs.patch
14 Patch1:         %{name}-any.patch
15 URL:            http://www.linuxnet.com/middle.html
16 BuildRequires:  autoconf >= 2.52
17 BuildRequires:  automake
18 BuildRequires:  flex
19 BuildRequires:  libtool >= 1.4.2-9
20 BuildRequires:  libusb-devel
21 BuildRequires:  rpmbuild(macros) >= 1.268
22 Requires(post,preun):   /sbin/chkconfig
23 Requires(pre):  fileutils
24 Requires:       rc-scripts
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %define         usbdropdir      /usr/%{_lib}/pcsc/drivers
28 %define         muscledropdir   /usr/%{_lib}/pcsc/services
29
30 %description
31 pcscd is the daemon program for PC/SC Lite. It is a resource manager
32 that coorinates communications with Smart Card readers and Smart Cards
33 that are connected to the system. The purpose of PCSC Lite is to
34 provide a Windows(R) SCard interface in a very small form factor for
35 communicating to smartcards and readers. PCSC Lite uses the same
36 winscard api as used under Windows(R).
37
38 %description -l pl
39 pcscd jest demonem dla PC/SC Lite. Jest to zarz±dca zasobów,
40 koordynuj±cy komunikacjê z czytnikami kart procesorowych pod³±czonymi
41 do systemu. Celem PCSC Lite jest udostêpnienie interfejsu zgodnego z
42 Windows(R) SCard s³u¿±cego do komunikacji z czytnikami kart chipowych.
43 U¿ywa tego samego API winscard, które jest u¿ywane pod Microsoft(TM)
44 Windows(R).
45
46 %package libs
47 Summary:        PC/SC Lite libraries
48 Summary(pl):    Biblioteki PC/SC Lite
49 Group:          Libraries
50
51 %description libs
52 PC/SC Lite libraries.
53
54 %description libs -l pl
55 Biblioteki PC/SC Lite.
56
57 %package devel
58 Summary:        PC/SC Lite development files
59 Summary(pl):    Pliki dla programistów u¿ywaj±cych PC/SC Lite
60 Group:          Development/Libraries
61 Requires:       %{name}-libs = %{version}-%{release}
62
63 %description devel
64 PC/SC Lite development files.
65
66 %description devel -l pl
67 Pliki dla programistów u¿ywaj±cych PC/SC Lite.
68
69 %package static
70 Summary:        Static PC/SC Lite libraries
71 Summary(pl):    Biblioteki statyczne PC/SC Lite
72 Group:          Development/Libraries
73 Requires:       %{name}-devel = %{version}-%{release}
74
75 %description static
76 Static PC/SC Lite libraries.
77
78 %description static -l pl
79 Statyczne biblioteki PC/SC Lite.
80
81 %prep
82 %setup -q
83 %patch0 -p1
84 %patch1 -p1
85
86 %build
87 %{__libtoolize}
88 %{__aclocal} -I m4
89 %{__autoconf}
90 %{__autoheader}
91 %{__automake}
92 %configure \
93         --enable-muscledropdir=%{muscledropdir} \
94         --enable-runpid=/var/run/pcscd.pid \
95         --enable-usbdropdir=%{usbdropdir}
96
97 %{__make}
98
99 %install
100 rm -rf $RPM_BUILD_ROOT
101 install -d $RPM_BUILD_ROOT{%{usbdropdir},%{muscledropdir}} \
102         $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig} \
103         $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
104
105 %{__make} install \
106         DESTDIR=$RPM_BUILD_ROOT
107
108 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/pcscd
109 install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/pcscd
110
111 install doc/example/*.c $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
112
113 :> $RPM_BUILD_ROOT%{_sysconfdir}/reader.conf
114 rm -rf $RPM_BUILD_ROOT%{_prefix}/doc
115
116 %clean
117 rm -rf $RPM_BUILD_ROOT
118
119 %pre
120 # upgrade from pcsc-lite < 1.2.9-0.beta7
121 if [ -f /etc/reader.conf -a ! -f /etc/reader.conf.d/reader.conf ]; then
122         install -d -m755 /etc/reader.conf.d
123         cp -af /etc/reader.conf /etc/reader.conf.d/reader.conf
124 fi
125
126 %post
127 /sbin/chkconfig --add pcscd
128 %service pcscd restart "pcscd daemon"
129
130 %preun
131 if [ "$1" = "0" ]; then
132         %service pcscd stop
133         /sbin/chkconfig --del pcscd
134 fi
135
136 %post   libs -p /sbin/ldconfig
137 %postun libs -p /sbin/ldconfig
138
139 %files
140 %defattr(644,root,root,755)
141 %doc AUTHORS COPYING ChangeLog* DRIVERS HELP NEWS README SECURITY doc/README.DAEMON
142 %attr(755,root,root) %{_bindir}/formaticc
143 %attr(755,root,root) %{_sbindir}/installifd
144 %attr(755,root,root) %{_sbindir}/pcscd
145 %attr(755,root,root) %{_sbindir}/update-reader.conf
146 %{_libdir}/pcsc
147 %dir %{_sysconfdir}/reader.conf.d
148 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/reader.conf.d/reader.conf
149 %ghost %{_sysconfdir}/reader.conf
150 %attr(754,root,root) /etc/rc.d/init.d/pcscd
151 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/pcscd
152 %{_mandir}/man1/formaticc.1*
153 %{_mandir}/man5/reader.conf.5*
154 %{_mandir}/man8/pcscd.8*
155
156 %files libs
157 %defattr(644,root,root,755)
158 %attr(755,root,root) %{_libdir}/libpcsclite.so.*.*.*
159
160 %files devel
161 %defattr(644,root,root,755)
162 %doc doc/*.pdf
163 %attr(755,root,root) %{_libdir}/libpcsclite.so
164 %{_libdir}/libpcsclite.la
165 %{_includedir}/PCSC
166 %{_pkgconfigdir}/libpcsclite.pc
167 %{_examplesdir}/%{name}-%{version}
168
169 %files static
170 %defattr(644,root,root,755)
171 %{_libdir}/libpcsclite.a
This page took 0.07387 seconds and 4 git commands to generate.