]> git.pld-linux.org Git - packages/pcsc-lite.git/blob - pcsc-lite.spec
- adapterized (sorted %verify flags)
[packages/pcsc-lite.git] / pcsc-lite.spec
1 Summary:        Muscle PCSC Framework for Linux
2 Summary(pl):    ¦rodowisko PCSC dla Linuksa
3 Name:           pcsc-lite
4 Version:        1.2.0
5 Release:        2
6 License:        BSD
7 Group:          Daemons
8 #Source0Download: http://alioth.debian.org/project/showfiles.php?group_id=30105
9 Source0:        http://alioth.debian.org/download.php/419/%{name}-%{version}.tar.gz
10 # Source0-md5:  98456d274b2f4bfe74c5ab59070f8d50
11 Source1:        %{name}-pcscd.init
12 Source2:        %{name}-pcscd.sysconfig
13 Patch0:         %{name}-fhs.patch
14 URL:            http://www.linuxnet.com/middle.html
15 BuildRequires:  autoconf >= 2.52
16 BuildRequires:  automake
17 BuildRequires:  flex
18 BuildRequires:  libtool >= 1.4.2-9
19 BuildRequires:  libusb-devel
20 Requires(post,preun):   /sbin/chkconfig
21 Requires:       rc-scripts
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %define         muscledropdir   /usr/%{_lib}/pcsc/services
25 %define         usbdropdir      /usr/%{_lib}/pcsc/drivers
26
27 %description
28 pcscd is the daemon program for PC/SC Lite. It is a resource manager
29 that coorinates communications with Smart Card readers and Smart Cards
30 that are connected to the system. The purpose of PCSC Lite is to
31 provide a Windows(R) SCard interface in a very small form factor for
32 communicating to smartcards and readers. PCSC Lite uses the same
33 winscard api as used under Windows(R).
34
35 %description -l pl
36 pcscd jest demonem dla PC/SC Lite. Jest to zarz±dca zasobów,
37 koordynuj±cy komunikacjê z czytnikami kart procesorowych pod³±czonymi
38 do systemu. Celem PCSC Lite jest udostêpnienie interfejsu zgodnego z
39 Windows(R) SCard s³u¿±cego do komunikacji z czytnikami kart chipowych.
40 U¿ywa tego samego API winscard, które jest u¿ywane pod Microsoft(TM)
41 Windows(R).
42
43 %package libs
44 Summary:        PC/SC Lite libraries
45 Summary(pl):    Biblioteki PC/SC Lite
46 Group:          Libraries
47
48 %description libs
49 PC/SC Lite libraries.
50
51 %description libs -l pl
52 Biblioteki PC/SC Lite.
53
54 %package devel
55 Summary:        PC/SC Lite development files
56 Summary(pl):    Pliki dla programistów u¿ywaj±cych PC/SC Lite
57 Group:          Development/Tools
58 Requires:       %{name}-libs = %{version}-%{release}
59
60 %description devel
61 PC/SC Lite development files.
62
63 %description devel -l pl
64 Pliki dla programistów u¿ywaj±cych PC/SC Lite.
65
66 %package static
67 Summary:        Static PC/SC Lite libraries
68 Summary(pl):    Biblioteki statyczne PC/SC Lite
69 Group:          Development/Tools
70 Requires:       %{name}-devel = %{version}-%{release}
71
72 %description static
73 Static PC/SC Lite libraries.
74
75 %description static -l pl
76 Statyczne biblioteki PC/SC Lite.
77
78 %prep
79 %setup -q
80 %patch0 -p1
81
82 %build
83 %{__libtoolize}
84 %{__aclocal} -I aclocal
85 %{__autoconf}
86 %{__autoheader}
87 %{__automake}
88 %configure \
89         --enable-muscledropdir=%{muscledropdir} \
90         --enable-runpid=/var/run/pcscd.pid \
91         --enable-usbdropdir=%{usbdropdir}
92
93 %{__make}
94
95 %install
96 rm -rf $RPM_BUILD_ROOT
97 install -d $RPM_BUILD_ROOT{%{muscledropdir},%{usbdropdir}} \
98         $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig} \
99         $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
100
101 %{__make} install \
102         DESTDIR=$RPM_BUILD_ROOT
103
104 # useful for drivers development
105 install src/ifdhandler.h $RPM_BUILD_ROOT%{_includedir}
106
107 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/pcscd
108 install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/pcscd
109
110 install doc/example/*.c $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
111
112 %clean
113 rm -rf $RPM_BUILD_ROOT
114
115 %post
116 /sbin/chkconfig --add pcscd
117 if [ -f /var/lock/subsys/pcscd ]; then
118         /etc/rc.d/init.d/pcscd restart >&2
119 else
120         echo "Run \"/etc/rc.d/init.d/pcscd start\" to start pcscd daemon."
121 fi
122
123 %preun
124 if [ "$1" = "0" ]; then
125         if [ -f /var/lock/subsys/pcscd ]; then
126                 /etc/rc.d/init.d/pcscd stop >&2
127         fi
128         /sbin/chkconfig --del pcscd
129 fi
130
131 %post   libs -p /sbin/ldconfig
132 %postun libs -p /sbin/ldconfig
133
134 %files
135 %defattr(644,root,root,755)
136 %doc AUTHORS COPYING ChangeLog* DRIVERS HELP NEWS README SECURITY doc/README.DAEMON
137 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/reader.conf
138 %attr(754,root,root) /etc/rc.d/init.d/pcscd
139 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/pcscd
140 %attr(755,root,root) %{_sbindir}/pcscd
141 %attr(755,root,root) %{_bindir}/bundleTool
142 %attr(755,root,root) %{_bindir}/formaticc
143 %attr(755,root,root) %{_bindir}/installifd
144 %{_libdir}/pcsc
145 %{_mandir}/man1/formaticc.1*
146 %{_mandir}/man8/bundleTool.8*
147 %{_mandir}/man8/pcscd.8*
148
149 %files libs
150 %defattr(644,root,root,755)
151 %attr(755,root,root) %{_libdir}/lib*.so.*.*
152
153 %files devel
154 %defattr(644,root,root,755)
155 %doc doc/*.pdf
156 %attr(755,root,root) %{_libdir}/lib*.so
157 %{_libdir}/lib*.la
158 %{_includedir}/*.h
159 %{_pkgconfigdir}/*.pc
160 %{_examplesdir}/%{name}-%{version}
161
162 %files static
163 %defattr(644,root,root,755)
164 %{_libdir}/lib*.a
This page took 0.082975 seconds and 4 git commands to generate.