]> git.pld-linux.org Git - packages/pcsc-lite.git/blob - pcsc-lite.spec
- distfiles don't support https, changed Source0 to http
[packages/pcsc-lite.git] / pcsc-lite.spec
1 Summary:        Muscle PCSC Framework for Linux
2 Summary(pl):    ¦rodowisko PCSC dla Linuksa
3 Name:           pcsc-lite
4 Version:        1.2.0
5 Release:        1
6 License:        BSD
7 Group:          Daemons
8 #Source0Download: http://alioth.debian.org/project/showfiles.php?group_id=1225
9 Source0:        http://alioth.debian.org/download.php/419/%{name}-%{version}.tar.gz
10 # Source0-md5:  98456d274b2f4bfe74c5ab59070f8d50
11 Source1:        %{name}-pcscd.init
12 Source2:        %{name}-pcscd.sysconfig
13 Patch0:         %{name}-fhs.patch
14 Patch1:         %{name}-link.patch
15 Patch2:         %{name}-amfix.patch
16 URL:            http://www.linuxnet.com/middle.html
17 BuildRequires:  autoconf >= 2.52
18 BuildRequires:  automake
19 BuildRequires:  flex
20 BuildRequires:  libtool >= 1.4.2-9
21 BuildRequires:  libusb-devel
22 PreReq:         rc-scripts
23 Requires(post,preun):   /sbin/chkconfig
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %define         muscledropdir   /usr/lib/pcsc/services
27 %define         usbdropdir      /usr/lib/pcsc/drivers
28
29 %description
30 pcscd is the daemon program for PC/SC Lite. It is a resource manager
31 that coorinates communications with Smart Card readers and Smart Cards
32 that are connected to the system. The purpose of PCSC Lite is to
33 provide a Windows(R) SCard interface in a very small form factor for
34 communicating to smartcards and readers. PCSC Lite uses the same
35 winscard api as used under Windows(R).
36
37 %description -l pl
38 pcscd jest demonem dla PC/SC Lite. Jest to zarz±dca zasobów,
39 koordynuj±cy komunikacjê z czytnikami kart procesorowych pod³±czonymi
40 do systemu. Celem PCSC Lite jest udostêpnienie interfejsu zgodnego z
41 Windows(R) SCard s³u¿±cego do komunikacji z czytnikami kart chipowych.
42 U¿ywa tego samego API winscard, które jest u¿ywane pod Microsoft(TM)
43 Windows(R).
44
45 %package libs
46 Summary:        PC/SC Lite libraries
47 Summary(pl):    Biblioteki PC/SC Lite
48 Group:          Libraries
49
50 %description libs
51 PC/SC Lite libraries.
52
53 %description libs -l pl
54 Biblioteki PC/SC Lite.
55
56 %package devel
57 Summary:        PC/SC Lite development files
58 Summary(pl):    Pliki dla programistów u¿ywaj±cych PC/SC Lite
59 Group:          Development/Tools
60 Requires:       %{name}-libs = %{version}-%{release}
61
62 %description devel
63 PC/SC Lite development files.
64
65 %description devel -l pl
66 Pliki dla programistów u¿ywaj±cych PC/SC Lite.
67
68 %package static
69 Summary:        Static PC/SC Lite libraries
70 Summary(pl):    Biblioteki statyczne PC/SC Lite
71 Group:          Development/Tools
72 Requires:       %{name}-devel = %{version}-%{release}
73
74 %description static
75 Static PC/SC Lite libraries.
76
77 %description static -l pl
78 Statyczne biblioteki PC/SC Lite.
79
80 %prep
81 %setup -q
82 %patch0 -p1
83
84 %build
85 %{__libtoolize}
86 %{__aclocal} -I aclocal
87 %{__autoconf}
88 %{__autoheader}
89 %{__automake}
90 %configure \
91         --enable-muscledropdir=%{muscledropdir} \
92         --enable-runpid=/var/run/pcscd.pid \
93         --enable-usbdropdir=%{usbdropdir}
94
95 %{__make}
96
97 %install
98 rm -rf $RPM_BUILD_ROOT
99 install -d $RPM_BUILD_ROOT{%{muscledropdir},%{usbdropdir}} \
100         $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig} \
101         $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
102
103 %{__make} install \
104         DESTDIR=$RPM_BUILD_ROOT
105
106 # useful for drivers development
107 install src/ifdhandler.h $RPM_BUILD_ROOT%{_includedir}
108
109 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/pcscd
110 install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/pcscd
111
112 install doc/example/*.c $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
113
114 %clean
115 rm -rf $RPM_BUILD_ROOT
116
117 %post
118 /sbin/chkconfig --add pcscd
119 if [ -f /var/lock/subsys/pcscd ]; then
120         /etc/rc.d/init.d/pcscd restart >&2
121 else
122         echo "Run \"/etc/rc.d/init.d/pcscd start\" to start pcscd daemon."
123 fi
124
125 %preun
126 if [ "$1" = "0" ]; then
127         if [ -f /var/lock/subsys/pcscd ]; then
128                 /etc/rc.d/init.d/pcscd stop >&2
129         fi
130         /sbin/chkconfig --del pcscd
131 fi
132
133 %post   libs -p /sbin/ldconfig
134 %postun libs -p /sbin/ldconfig
135
136 %files
137 %defattr(644,root,root,755)
138 %doc AUTHORS COPYING ChangeLog* DRIVERS HELP NEWS README SECURITY doc/README.DAEMON
139 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/reader.conf
140 %attr(754,root,root) /etc/rc.d/init.d/pcscd
141 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/sysconfig/pcscd
142 %attr(755,root,root) %{_sbindir}/pcscd
143 %attr(755,root,root) %{_bindir}/bundleTool
144 %attr(755,root,root) %{_bindir}/formaticc
145 %attr(755,root,root) %{_bindir}/installifd
146 %{_libdir}/pcsc
147 %{_mandir}/man1/formaticc.1*
148 %{_mandir}/man8/bundleTool.8*
149 %{_mandir}/man8/pcscd.8*
150
151 %files libs
152 %defattr(644,root,root,755)
153 %attr(755,root,root) %{_libdir}/lib*.so.*.*
154
155 %files devel
156 %defattr(644,root,root,755)
157 %doc doc/*.pdf
158 %attr(755,root,root) %{_libdir}/lib*.so
159 %{_libdir}/lib*.la
160 %{_includedir}/*.h
161 %{_pkgconfigdir}/*.pc
162 %{_examplesdir}/%{name}-%{version}
163
164 %files static
165 %defattr(644,root,root,755)
166 %{_libdir}/lib*.a
This page took 0.101726 seconds and 3 git commands to generate.