]> git.pld-linux.org Git - packages/pcsc-lite.git/blob - pcsc-lite.spec
- converted to UTF-8
[packages/pcsc-lite.git] / pcsc-lite.spec
1 Summary:        Muscle PCSC Framework for Linux
2 Summary(pl.UTF-8):   Środowisko PCSC dla Linuksa
3 Name:           pcsc-lite
4 Version:        1.3.3
5 Release:        1
6 License:        BSD
7 Group:          Daemons
8 #Source0Download: http://alioth.debian.org/project/showfiles.php?group_id=30105
9 Source0:        http://alioth.debian.org/frs/download.php/1869/%{name}-%{version}.tar.gz
10 # Source0-md5:  851b090aa0efedd0196f6afd9c0c61bb
11 Source1:        %{name}-pcscd.init
12 Source2:        %{name}-pcscd.sysconfig
13 Patch0:         %{name}-fhs.patch
14 Patch1:         %{name}-any.patch
15 URL:            http://www.linuxnet.com/middle.html
16 BuildRequires:  autoconf >= 2.58
17 BuildRequires:  automake >= 1:1.8
18 BuildRequires:  flex
19 BuildRequires:  libtool >= 1.4.2-9
20 BuildRequires:  libusb-devel >= 0.1.7
21 BuildRequires:  pkgconfig
22 BuildRequires:  rpmbuild(macros) >= 1.268
23 Requires(post,preun):   /sbin/chkconfig
24 Requires(pre):  fileutils
25 Requires:       rc-scripts
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %define         usbdropdir      /usr/%{_lib}/pcsc/drivers
29 %define         muscledropdir   /usr/%{_lib}/pcsc/services
30
31 %description
32 pcscd is the daemon program for PC/SC Lite. It is a resource manager
33 that coorinates communications with Smart Card readers and Smart Cards
34 that are connected to the system. The purpose of PCSC Lite is to
35 provide a Windows(R) SCard interface in a very small form factor for
36 communicating to smartcards and readers. PCSC Lite uses the same
37 winscard api as used under Windows(R).
38
39 %description -l pl.UTF-8
40 pcscd jest demonem dla PC/SC Lite. Jest to zarządca zasobów,
41 koordynujący komunikację z czytnikami kart procesorowych podłączonymi
42 do systemu. Celem PCSC Lite jest udostępnienie interfejsu zgodnego z
43 Windows(R) SCard służącego do komunikacji z czytnikami kart chipowych.
44 Używa tego samego API winscard, które jest używane pod Microsoft(TM)
45 Windows(R).
46
47 %package libs
48 Summary:        PC/SC Lite libraries
49 Summary(pl.UTF-8):   Biblioteki PC/SC Lite
50 Group:          Libraries
51
52 %description libs
53 PC/SC Lite libraries.
54
55 %description libs -l pl.UTF-8
56 Biblioteki PC/SC Lite.
57
58 %package devel
59 Summary:        PC/SC Lite development files
60 Summary(pl.UTF-8):   Pliki dla programistów używających PC/SC Lite
61 Group:          Development/Libraries
62 Requires:       %{name}-libs = %{version}-%{release}
63
64 %description devel
65 PC/SC Lite development files.
66
67 %description devel -l pl.UTF-8
68 Pliki dla programistów używających PC/SC Lite.
69
70 %package static
71 Summary:        Static PC/SC Lite libraries
72 Summary(pl.UTF-8):   Biblioteki statyczne PC/SC Lite
73 Group:          Development/Libraries
74 Requires:       %{name}-devel = %{version}-%{release}
75
76 %description static
77 Static PC/SC Lite libraries.
78
79 %description static -l pl.UTF-8
80 Statyczne biblioteki PC/SC Lite.
81
82 %prep
83 %setup -q
84 %patch0 -p1
85 %patch1 -p1
86
87 %build
88 %{__libtoolize}
89 %{__aclocal} -I m4
90 %{__autoconf}
91 %{__autoheader}
92 %{__automake}
93 %configure \
94         --enable-muscledropdir=%{muscledropdir} \
95         --enable-runpid=/var/run/pcscd.pid \
96         --enable-usbdropdir=%{usbdropdir}
97
98 %{__make}
99
100 %install
101 rm -rf $RPM_BUILD_ROOT
102 install -d $RPM_BUILD_ROOT{%{usbdropdir},%{muscledropdir}} \
103         $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig} \
104         $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
105
106 %{__make} install \
107         DESTDIR=$RPM_BUILD_ROOT
108
109 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/pcscd
110 install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/pcscd
111
112 install doc/example/*.c $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
113
114 :> $RPM_BUILD_ROOT%{_sysconfdir}/reader.conf
115 rm -rf $RPM_BUILD_ROOT%{_prefix}/doc
116
117 %clean
118 rm -rf $RPM_BUILD_ROOT
119
120 %pre
121 # upgrade from pcsc-lite < 1.2.9-0.beta7
122 if [ -f /etc/reader.conf -a ! -f /etc/reader.conf.d/reader.conf ]; then
123         install -d -m755 /etc/reader.conf.d
124         cp -af /etc/reader.conf /etc/reader.conf.d/reader.conf
125 fi
126
127 %post
128 /sbin/chkconfig --add pcscd
129 %service pcscd restart "pcscd daemon"
130
131 %preun
132 if [ "$1" = "0" ]; then
133         %service pcscd stop
134         /sbin/chkconfig --del pcscd
135 fi
136
137 %post   libs -p /sbin/ldconfig
138 %postun libs -p /sbin/ldconfig
139
140 %files
141 %defattr(644,root,root,755)
142 %doc AUTHORS COPYING ChangeLog* DRIVERS HELP NEWS README SECURITY TODO doc/README.DAEMON
143 %attr(755,root,root) %{_sbindir}/pcscd
144 %attr(755,root,root) %{_sbindir}/update-reader.conf
145 %{_libdir}/pcsc
146 %dir %{_sysconfdir}/reader.conf.d
147 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/reader.conf.d/reader.conf
148 %ghost %{_sysconfdir}/reader.conf
149 %attr(754,root,root) /etc/rc.d/init.d/pcscd
150 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/pcscd
151 %{_mandir}/man1/formaticc.1*
152 %{_mandir}/man5/reader.conf.5*
153 %{_mandir}/man8/pcscd.8*
154 %{_mandir}/man8/update-reader.conf.8*
155
156 %files libs
157 %defattr(644,root,root,755)
158 %attr(755,root,root) %{_libdir}/libpcsclite.so.*.*.*
159
160 %files devel
161 %defattr(644,root,root,755)
162 %doc doc/*.pdf
163 %attr(755,root,root) %{_libdir}/libpcsclite.so
164 %{_libdir}/libpcsclite.la
165 %{_includedir}/PCSC
166 %{_pkgconfigdir}/libpcsclite.pc
167 %{_examplesdir}/%{name}-%{version}
168
169 %files static
170 %defattr(644,root,root,755)
171 %{_libdir}/libpcsclite.a
This page took 0.061581 seconds and 3 git commands to generate.