]> git.pld-linux.org Git - packages/pango.git/blob - pango.spec
afcf0726a29d1f9cc68e822754c0fe4f670701fb
[packages/pango.git] / pango.spec
1 #
2 # Conditional build:
3 %bcond_with     xlibs   # use pkgconfig to find libX11 CFLAGS
4 #
5 Summary:        System for layout and rendering of internationalized text
6 Summary(pl):    System renderowania miêdzynarodowego tekstu
7 Summary(pt_BR): Sistema para layout e renderização de texto internacionalizado
8 Name:           pango
9 Version:        1.4.0
10 Release:        1
11 License:        LGPL
12 Group:          X11/Libraries
13 Source0:        http://ftp.gnome.org/pub/gnome/sources/%{name}/1.4/%{name}-%{version}.tar.bz2
14 # Source0-md5:  9b5d9a5dcce5b3899d401f9c2cd6873f
15 Patch0:         %{name}-xfonts.patch
16 Patch1:         %{name}-xlibs.patch
17 URL:            http://www.pango.org/
18 BuildRequires:  %{?with_xlibs:libX11-devel}%{!?with_xlibs:XFree86-devel}
19 BuildRequires:  autoconf >= 2.54
20 BuildRequires:  automake >= 1.7
21 BuildRequires:  docbook-dtd412-xml
22 BuildRequires:  docbook-style-xsl
23 BuildRequires:  freetype-devel >= 2.1.7
24 BuildRequires:  glib2-devel >= 1:2.4.0
25 BuildRequires:  gtk-doc >= 1.0
26 BuildRequires:  libtool >= 1:1.4.2-9
27 BuildRequires:  perl-base
28 BuildRequires:  pkgconfig
29 BuildRequires:  rpm-build >= 4.1-8.2
30 BuildRequires:  xft-devel >= 2.1.2
31 Requires(post): /sbin/ldconfig
32 Requires:       freetype >= 2.1.7
33 Requires:       glib2 >= 1:2.4.0
34 Obsoletes:      libpango24
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %description
38 System for layout and rendering of internationalized text.
39
40 %description -l pl
41 System obs³ugi i renderowania miêdzynarodowego tekstu.
42
43 %description -l pt_BR
44 Pango é um sistema para layout e renderização de texto
45 internacionalizado.
46
47 %package devel
48 Summary:        System for layout and rendering of internationalized text
49 Summary(pl):    System obs³ugi i renderowania miêdzynarodowego tekstu
50 Summary(pt_BR): Sistema para layout e renderização de texto internacionalizado
51 Group:          X11/Development/Libraries
52 Requires:       %{name} = %{version}-%{release}
53 Requires:       %{?with_xlibs:libX11-devel}%{!?with_xlibs:XFree86-devel}
54 Requires:       freetype-devel >= 2.1.7
55 Requires:       glib2-devel >= 1:2.4.0
56 Requires:       gtk-doc-common
57 Requires:       xft-devel >= 2.1.2
58 Obsoletes:      libpango24-devel
59
60 %description devel
61 Developer files for pango.
62
63 %description devel -l pl
64 Pliki developerskie pango.
65
66 %description devel -l pt_BR
67 Pango é um sistema para layout e renderização de texto
68 internacionalizado.
69
70 %package static
71 Summary:        Static %{name} libraries
72 Summary(pl):    Biblioteki statyczne %{name}
73 Summary(pt_BR): Sistema para layout e renderização de texto internacionalizado
74 Group:          X11/Development/Libraries
75 Requires:       %{name}-devel = %{version}-%{release}
76
77 %description static
78 Static %{name} libraries.
79
80 %description static -l pl
81 Biblioteki statyczne %{name}.
82
83 %description static -l pt_BR
84 Pango é um sistema para layout e renderização de texto
85 internacionalizado.
86
87 %package modules
88 Summary:        System for layout and rendering of internationalized text
89 Summary(pl):    System obs³ugi i renderowania miêdzynarodowego tekstu
90 Summary(pt_BR): Sistema para layout e renderização de texto internacionalizado
91 Group:          X11/Development/Libraries
92 Requires(post,postun):  %{name} = %{version}-%{release}
93 Requires:       %{name} = %{version}-%{release}
94
95 %description modules
96 System for layout and rendering of internationalized text.
97
98 This package contains pango modules for: arabic, bengali, devanagari,
99 gujarati, gurmukhi, hangul, hebrew, indic, myanmar, tamil, thai.
100
101 %description modules -l pl
102 System obs³ugi i renderowania miêdzynarodowego tekstu.
103
104 Pakiet zawiera modu³y pango dla jêzyków: arabic, bengali, devanagari,
105 gujarati, gurmukhi, hangul, hebrew, indic, myanmar, tamil, thai.
106
107 %description modules -l pt_BR
108 Pango é um sistema para layout e renderização de texto
109 internacionalizado.
110
111 %prep
112 %setup -q
113 %patch0 -p1
114 %{?with_xlibs:%patch1 -p1}
115
116 %build
117 gtkdocize --copy
118 %{__libtoolize}
119 %{__aclocal}
120 %{__autoheader}
121 %{__autoconf}
122 %{__automake}
123 %configure \
124         --with-fribidi \
125         --enable-gtk-doc \
126         --with-html-dir=%{_gtkdocdir} \
127         --enable-static \
128         --enable-debug=%{?debug:yes}%{!?debug:minimum} \
129         --enable-man
130 %{__make}
131
132 %install
133 rm -rf $RPM_BUILD_ROOT
134
135 %{__make} install \
136         DESTDIR=$RPM_BUILD_ROOT \
137         pkgconfigdir=%{_pkgconfigdir}
138
139 > $RPM_BUILD_ROOT%{_sysconfdir}/pango/pango.modules
140
141 # useless (modules loaded through libgmodule)
142 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/1.4.0/modules/*.{la,a}
143
144 %clean
145 rm -rf $RPM_BUILD_ROOT
146
147 %post
148 /sbin/ldconfig
149 umask 022
150 %{_bindir}/pango-querymodules > %{_sysconfdir}/pango/pango.modules
151 exit 0
152
153 %postun -p /sbin/ldconfig
154
155 %post modules
156 umask 022
157 %{_bindir}/pango-querymodules > %{_sysconfdir}/pango/pango.modules
158 exit 0
159
160 %postun modules
161 umask 022
162 %{_bindir}/pango-querymodules > %{_sysconfdir}/pango/pango.modules
163 exit 0
164
165 %files
166 %defattr(644,root,root,755)
167 %doc AUTHORS NEWS README examples/HELLO.utf8
168 %attr(755,root,root) %{_bindir}/pango-querymodules
169 %attr(755,root,root) %{_libdir}/lib*.so.*.*
170 %dir %{_libdir}/pango
171 %dir %{_libdir}/pango/1.4.0
172 %dir %{_libdir}/pango/1.4.0/modules
173 %attr(755,root,root) %{_libdir}/pango/1.4.0/modules/*basic*.so
174 %dir %{_sysconfdir}/pango
175 %config(noreplace) %verify(not size md5 mtime) %{_sysconfdir}/pango/pangox.aliases
176 %ghost %{_sysconfdir}/pango/pango.modules
177 %{_mandir}/man1/*
178
179 %files devel
180 %defattr(644,root,root,755)
181 %doc ChangeLog TODO
182 %attr(755,root,root) %{_libdir}/libpango*.so
183 %{_libdir}/libpango*.la
184 %{_pkgconfigdir}/*
185 %{_includedir}/*
186 %{_gtkdocdir}/pango
187
188 %files static
189 %defattr(644,root,root,755)
190 %{_libdir}/libpango*.a
191
192 %files modules
193 %defattr(644,root,root,755)
194 %attr(755,root,root) %{_libdir}/pango/1.4.0/modules/*.so
195 %exclude %{_libdir}/pango/1.4.0/modules/*basic*.so
This page took 0.038748 seconds and 2 git commands to generate.