]> git.pld-linux.org Git - packages/pam-pam_mount.git/blob - pam-pam_mount.spec
- up to 1.18, verbose files (again), or manuals not installed for programs
[packages/pam-pam_mount.git] / pam-pam_mount.spec
1 %define         modulename pam_mount
2 Summary:        A PAM module that can mount remote volumes for a user session
3 Summary(pl.UTF-8):      Moduł PAM, pozwalający montować zdalne zasoby na czas sesji użytkownika
4 Name:           pam-%{modulename}
5 Version:        1.18
6 Release:        1
7 Epoch:          0
8 License:        LGPL
9 Group:          Base
10 Source0:        http://dl.sourceforge.net/pam-mount/%{modulename}-%{version}.tar.bz2
11 # Source0-md5:  209a0e73d1b71e4fc724f2f3be695119
12 URL:            http://pam-mount.sourceforge.net/
13 BuildRequires:  autoconf
14 BuildRequires:  automake
15 BuildRequires:  glib2-devel
16 BuildRequires:  libHX-devel
17 BuildRequires:  libtool
18 BuildRequires:  libxml2-devel
19 BuildRequires:  openssl-devel >= 0.9.7d
20 BuildRequires:  pam-devel
21 BuildRequires:  pkgconfig
22 BuildRequires:  zlib-devel
23 Obsoletes:      pam_mount
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 This module is aimed to environments with SMB (Samba or Windows NT)
28 and/or NCP (Netware or Mars-NWE) servers that Unix users want or need
29 to access, and some users have / every user has private volumes in
30 that servers. The module also supports mounting home directories using
31 loopback encrypted filesystems (see also
32 http://www.tldp.org/HOWTO/Loopback-Encrypted-Filesystem-HOWTO.html).
33  - Every user can access his/her own volumes
34  - The user needs to type the password just once (at login) (*)
35  - The mouting process is transparent to the users
36  - There is no need to keep the login passwords in any additional file
37  - The volumes are unmount upon logout, so it saves system resources,
38    avoiding the need of listing every every possibly useful remote volume
39    in /etc/fstab or in an automount/supermount config file. This is also
40    necessary for securing encrypted filesystems.
41
42 (*) Obviously, the user password in the Unix system and in the remote
43 servers must be the same ;)
44
45 Pam_mount "understands" SMB, NCP, and encrypted loopback volumes, but
46 this can be extended very easily.
47
48 %description -l pl.UTF-8
49 Przeznaczeniem tego modułu są środowiska z protokołem SMB (Samba lub
50 Windows NT) i/lub NCP (Netware lub Mars-NWE), w których użytkownicy
51 chcą lub potrzebują indywidualnych zasobów. Moduł ten wspiera także
52 montowanie katalogów domowych z zaszyfrowanych systemów plików przy
53 użyciu loopbacka (zobacz także:
54 http://www.tldp.org/HOWTO/Loopback-Encrypted-Filesystem-HOWTO.html).
55  - każdy użytkownik ma dostęp do swoich zasobów
56  - użytkownik musi wpisać swoje hasło tylko raz (przy logowaniu) (*)
57  - proces montowania jest niewidzialny dla użytkownika
58  - nie ma potrzeby trzymania hasła i loginu w żadnym dodatkowym pliku
59  - katalogi są odmontowywane podczas wylogowania, co oszczędza zasoby
60    systemowe, zabezpiecza przed koniecznością umieszczenia każdego
61    potrzebnego zdalnego zasobu w /etc/fstab lub w konfiguracji
62    automounta/supermounta. Jest to także konieczne do zabezpieczenia
63    zaszyfrowanych systemów plików.
64
65 (*) Oczywiście hasło na lokalnym i zdalnym systemie musi być
66 identyczne ;)
67
68 pam_mount "rozumie" SMB, NCP oraz zaszyfrowane systemy plików po
69 loopbacku, ale może być rozszerzony w prosty sposób.
70
71 %prep
72 %setup -q -n %{modulename}-%{version}
73
74 %build
75 %{__libtoolize}
76 %{__aclocal}
77 %{__autoconf}
78 %{__autoheader}
79 %{__automake}
80 %configure \
81         --disable-static
82 %{__make}
83
84 %install
85 rm -rf $RPM_BUILD_ROOT
86 install -d $RPM_BUILD_ROOT{/etc/security,/sbin}
87
88 %{__make} install \
89         moduledir=/%{_lib}/security \
90         DESTDIR=$RPM_BUILD_ROOT
91
92 install config/pam_mount.conf.xml $RPM_BUILD_ROOT/etc/security
93 ln -sf /sbin/mount.crypt $RPM_BUILD_ROOT%{_bindir}/mount.crypt
94
95 rm -f $RPM_BUILD_ROOT/%{_lib}/security/pam_mount.la
96
97 # void code on non-OpenBSD, besides broken
98 rm -f $RPM_BUILD_ROOT{%{_bindir}/mount_ehd,%{_mandir}/man8/mount_ehd.8}
99
100 %clean
101 rm -rf $RPM_BUILD_ROOT
102
103 %files
104 %defattr(644,root,root,755)
105 %attr(755,root,root) /%{_lib}/security/pam_mount.so
106 %config(noreplace) %verify(not md5 mtime size) /etc/security/pam_mount.conf.xml
107 %attr(755,root,root) /sbin/mount.crypt
108 %attr(755,root,root) /sbin/mount.crypt_LUKS
109 %attr(755,root,root) /sbin/mount.crypto_LUKS
110 %attr(755,root,root) /sbin/mount.encfs13
111 %attr(755,root,root) /sbin/umount.crypt
112 %attr(755,root,root) /sbin/umount.crypt_LUKS
113 %attr(755,root,root) /sbin/umount.crypto_LUKS
114 %attr(755,root,root) %{_bindir}/mount.crypt
115 %attr(755,root,root) %{_bindir}/pmt-fd0ssh
116 %attr(755,root,root) %{_bindir}/pmt-ofl
117 %attr(755,root,root) %{_sbindir}/pmt-ehd
118 %attr(755,root,root) %{_sbindir}/pmvarrun
119 %{_mandir}/man1/pmt-fd0ssh.1*
120 %{_mandir}/man5/pam_mount.conf.5*
121 %{_mandir}/man8/mount.crypt.8*
122 %{_mandir}/man8/mount.crypt_LUKS.8
123 %{_mandir}/man8/mount.crypto_LUKS.8
124 %{_mandir}/man8/pam_mount.8*
125 %{_mandir}/man8/pmt-ehd.8*
126 %{_mandir}/man8/pmvarrun.8*
127 %{_mandir}/man8/umount.crypt.8*
128 %{_mandir}/man8/umount.crypt_LUKS.8
129 %{_mandir}/man8/umount.crypto_LUKS.8
This page took 0.077021 seconds and 4 git commands to generate.