]> git.pld-linux.org Git - packages/opera.git/blob - opera.spec
- SECURITY note
[packages/opera.git] / opera.spec
1 # TODO:
2 # - move translations into a separate, noarch package
3 # - SECURITY: http://securitytracker.com/alerts/2004/Aug/1010966.html
4 #
5 %bcond_without  shared          # static or shared version
6 %bcond_without  distributable   # distributable or not
7 %bcond_without  incall          # include all tarballs into src.rpm (but splitted into shared/static)
8 %bcond_with     snap            # snap version
9
10 %define ver             7.54
11 %define shver           %(echo %{ver} | tr -d .)
12 %define dirrel          20040803
13 # type of release, usually final or beta or Preview-4 for snaps
14 %define reltype         final
15 %define x86_shared_rel          %{dirrel}.5
16 %define x86_static_rel          %{dirrel}.1
17 %define sparc_shared_rel        %{dirrel}.2
18 %define sparc_static_rel        %{dirrel}.1
19 %define ppc_shared_rel          %{dirrel}.2
20 %define ppc_static_rel          %{dirrel}.1
21 %if %{with shared}
22 %define type            shared
23 # We should be able to build src.rpm also on not supported archs
24 %define rel             %{x86_shared_rel}
25 %ifarch sparc64 sparc
26 %define rel             %{sparc_shared_rel}
27 %endif
28 %ifarch ppc
29 %define rel             %{ppc_shared_rel}
30 %endif
31 %else
32 %define type            static
33 %define rel             %{x86_static_rel}
34 %ifarch sparc sparc64
35 %define rel             %{sparc_static_rel}
36 %endif
37 %ifarch ppc
38 %define rel             %{ppc_static_rel}
39 %endif
40 %endif
41
42 Summary:        World fastest web browser
43 Summary(pl):    Najszybsza przegl±darka WWW na ¶wiecie
44 Name:           opera
45 Version:        %{ver}.%{rel}
46 Release:        2
47 License:        Distributable for PLD until 31 Dec 2006 - http://distribute.opera.com/ (otherwise restricted, see file LICENSE)
48 Group:          X11/Applications/Networking
49 %if %{without shared}
50 %{!?with_incall:%ifarch %{ix86}}
51 %if ! %{with snap}
52 Source0:        ftp://ftp.opera.com/pub/opera/linux/%{shver}/%{reltype}/en/i386/static/%{name}-%{ver}-%{x86_static_rel}-static-qt.i386-en.tar.bz2
53 # Source0-md5:  0a7e933ef593d4b7a897041c9f87bba2
54 %else
55 Source100:      http://snapshot.opera.com/unix/%{ver}-%{reltype}/intel-linux/en/%{name}-%{ver}-%{x86_static_rel}-static-qt.i386-en.tar.bz2
56 %endif
57 %{!?with_distributable:NoSource:        0}
58 %if ! %{with incall}
59 %endif
60 %ifarch sparc sparc64
61 %endif
62 %if ! %{with snap}
63 Source1:        ftp://ftp.opera.com/pub/opera/linux/%{shver}/%{reltype}/en/sparc/static/%{name}-%{ver}-%{sparc_static_rel}-static-qt.sparc-en.tar.bz2
64 # Source1-md5:  04976a6ace7a4345ce5e4cf763159939
65 %else
66 Source101:      http://snapshot.opera.com/unix/%{ver}-%{reltype}/sparc-linux/en/%{name}-%{ver}-%{sparc_static_rel}-static-qt.sparc-en.tar.bz2
67 %endif
68 %{!?with_distributable:NoSource:        1}
69 %if ! %{with incall}
70 %endif
71 %ifarch ppc
72 %endif
73 %if ! %{with snap}
74 Source2:        ftp://ftp.opera.com/pub/opera/linux/%{shver}/%{reltype}/en/ppc/static/%{name}-%{ver}-%{ppc_static_rel}-static-qt.ppc-en.tar.bz2
75 # Source2-md5:  c11a4c78d18bdaa4bd338b4c0dc27f38
76 %else
77 Source102:      http://snapshot.opera.com/unix/%{ver}-%{reltype}/ppc-linux/en/%{name}-%{ver}-%{ppc_static_rel}-static-qt.ppc-en.tar.bz2
78 %endif
79 %{!?with_distributable:NoSource:        2}
80 %{!?with_incall:%endif}
81 %else
82 %{!?with_incall:%ifarch %{ix86}}
83 %if ! %{with snap}
84 Source20:       ftp://ftp.opera.com/pub/opera/linux/%{shver}/%{reltype}/en/i386/shared/%{name}-%{ver}-%{x86_shared_rel}-shared-qt.i386-en.tar.bz2
85 # Source20-md5: 0e407a050f3aa4559011a3cea707cd20
86 %else
87 Source1020:     http://snapshot.opera.com/unix/%{ver}-%{reltype}/intel-linux/en/%{name}-%{ver}-%{x86_shared_rel}-shared-qt.i386-en.tar.bz2
88 %endif
89 %{!?with_distributable:NoSource:        20}
90 %if ! %{with incall}
91 %endif
92 %ifarch sparc sparc64
93 %endif
94 %if ! %{with snap}
95 Source21:       ftp://ftp.opera.com/pub/opera/linux/%{shver}/%{reltype}/en/sparc/shared/gcc-2.95/%{name}-%{ver}-%{sparc_shared_rel}-shared-qt.sparc-en.tar.bz2
96 # Source21-md5: d8635013dac0c98c680997fcc9dd66c4
97 %else
98 Source1021:     http://snapshot.opera.com/unix/%{ver}-%{reltype}/sparc-linux/en/%{name}-%{ver}-%{sparc_shared_rel}-shared-qt.sparc-en.tar.bz2
99 %endif
100 %{!?with_distributable:NoSource:        21}
101 %if ! %{with incall}
102 %endif
103 %ifarch ppc
104 %endif
105 %if ! %{with snap}
106 Source22:       ftp://ftp.opera.com/pub/opera/linux/%{shver}/%{reltype}/en/ppc/shared/gcc-2.95/%{name}-%{ver}-%{ppc_shared_rel}-shared-qt.ppc-en.tar.bz2
107 # Source22-md5: 516992e68c5a710d795a1ecc791c7f4d
108 %else
109 Source1022:     http://snapshot.opera.com/unix/%{ver}-%{reltype}/ppc-linux/en/%{name}-%{ver}-%{ppc_shared_rel}-shared-qt.ppc-en.tar.bz2
110 %endif
111 %{!?with_distributable:NoSource:        22}
112 %endif
113 %{!?with_incall:%endif}
114 Source201:      ftp://ftp.opera.com/pub/opera/unix/lng/721/bg/ou721_480bg.lng
115 Source202:      ftp://ftp.opera.com/pub/opera/unix/lng/721/ca/ou721_480ca.lng
116 Source203:      ftp://ftp.opera.com/pub/opera/unix/lng/721/zh-cn/ou721_480zh-cn.lng
117 Source204:      ftp://ftp.opera.com/pub/opera/unix/lng/721/da/ou721_480da.lng
118 Source205:      ftp://ftp.opera.com/pub/opera/unix/lng/721/nl/ou721_480nl.lng
119 Source206:      ftp://ftp.opera.com/pub/opera/unix/lng/721/es-LA/ou721_480es-LA.lng
120 Source207:      ftp://ftp.opera.com/pub/opera/unix/lng/721/ja/ou721_480ja.lng
121 Source208:      ftp://ftp.opera.com/pub/opera/unix/lng/752/fi/ou752_727fi.lng
122 Source209:      ftp://ftp.opera.com/pub/opera/unix/lng/752/fr/ou752_727fr.lng
123 Source210:      ftp://ftp.opera.com/pub/opera/unix/lng/752/it/ou752_727it.lng
124 Source211:      ftp://ftp.opera.com/pub/opera/unix/lng/754/de/ou754_751de.lng
125 Source212:      ftp://ftp.opera.com/pub/opera/unix/lng/754/ko/ou754_751ko.lng
126 Source213:      ftp://ftp.opera.com/pub/opera/unix/lng/754/nb/ou754_751nb.lng
127 Source214:      ftp://ftp.opera.com/pub/opera/unix/lng/754/pl/ou754_751pl.lng
128 Source215:      ftp://ftp.opera.com/pub/opera/unix/lng/754/es-ES/ou754_751es-ES.lng
129 Source216:      ftp://ftp.opera.com/pub/opera/unix/lng/754/sv/ou754_751sv.lng
130 Source217:      ftp://ftp.opera.com/pub/opera/linux/lng/711/el/ou711_406el.lng
131 Source218:      http://www.opera.com/download/lng/linux-freebsd/ou711_406zh-tw.lng
132 Source219:      http://www.opera.com/download/lng/linux-freebsd/ou711_406en-GB.lng
133 Source220:      http://www.opera.com/download/lng/linux-freebsd/ou711_406nn.lng
134 Source221:      http://www.opera.com/download/lng/linux-freebsd/ou711_406pt-BR.lng
135 Source222:      http://www.opera.com/download/lng/linux-freebsd/ou711_406ru.lng
136 Source223:      http://www.opera.com/download/lng/linux-freebsd/ou711_406tr.lng
137 Source4:        %{name}.desktop
138 URL:            http://www.opera.com/
139 ExclusiveArch:  %{ix86} ppc sparc sparc64
140 Requires:       freetype >= 2
141
142 Requires:       openmotif >= 2
143 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
144
145 %define         _plugindir      %{_libdir}/opera/plugins
146 %define         _operadocdir    %{_docdir}/%{name}-%{ver}.%{rel}
147 %define         configfile      %{_datadir}/opera/config/opera6rc
148
149 %description
150 Opera is world fastest web browser. It supports most of nowaday
151 extensions of HTML. And it is quite stable. Only disadvantage are
152 advertisements on the top of its window. Version static linked with
153 qt.
154
155 %description -l pl
156 Opera jest najszybsz± przegl±dark± WWW na ¶wiecie. Obs³uguje wiêkszo¶æ
157 dzisiejszych rozszerzeñ HTMLa. Dodatkowo jest w miarê stabilna. Jedyn±
158 niedogodno¶ci± s± reklamy ukazuj±ce siê w górze okna. Wersja
159 statycznie skonsolidowana z qt.
160
161 %prep
162 %ifarch %{ix86}
163 %setup -q %{?with_shared:-T -b %{?with_snap:10}20} -n %{name}-%{ver}-%{rel}-%{type}-qt.i386-en
164 %endif
165 %ifarch sparc sparc64
166 %setup -q -T -b %{?with_snap:10}%{?with_shared:2}1 -n %{name}-%{ver}-%{rel}-%{type}-qt.sparc-en
167 %endif
168 %ifarch ppc
169 %setup -q -T -b %{?with_snap:10}%{?with_shared:2}2 -n %{name}-%{ver}-%{rel}-%{type}-qt.ppc-en
170 %endif
171
172 %install
173 rm -rf $RPM_BUILD_ROOT
174
175 install -d $RPM_BUILD_ROOT{/etc,%{_mandir}/man1,%{_pixmapsdir},%{_desktopdir}}
176
177 cat install.sh | sed 's|/etc|$RPM_BUILD_ROOT%{_sysconfdir}|' > install2.sh
178 mv install2.sh install.sh
179
180 echo y |\
181 sh install.sh \
182   --prefix=$RPM_BUILD_ROOT%{_prefix} \
183   --wrapperdir=$RPM_BUILD_ROOT%{_bindir} \
184   --docdir=$RPM_BUILD_ROOT%{_operadocdir} \
185   --sharedir=$RPM_BUILD_ROOT%{_datadir}/opera \
186   --exec_prefix=$RPM_BUILD_ROOT%{_datadir}/opera/bin \
187   --plugindir=$RPM_BUILD_ROOT%{_plugindir}
188
189 # Polish locale
190 install %{SOURCE201} $RPM_BUILD_ROOT%{_datadir}/opera/locale/bulgarian.lng
191 install %{SOURCE202} $RPM_BUILD_ROOT%{_datadir}/opera/locale/catalan.lng
192 install %{SOURCE203} $RPM_BUILD_ROOT%{_datadir}/opera/locale/chinese-simplified.lng
193 install %{SOURCE204} $RPM_BUILD_ROOT%{_datadir}/opera/locale/danish.lng
194 install %{SOURCE205} $RPM_BUILD_ROOT%{_datadir}/opera/locale/dutch.lng
195 install %{SOURCE206} $RPM_BUILD_ROOT%{_datadir}/opera/locale/spanish-latin-american.lng
196 install %{SOURCE207} $RPM_BUILD_ROOT%{_datadir}/opera/locale/japanese.lng
197 install %{SOURCE208} $RPM_BUILD_ROOT%{_datadir}/opera/locale/finish.lng
198 install %{SOURCE209} $RPM_BUILD_ROOT%{_datadir}/opera/locale/french.lng
199 install %{SOURCE210} $RPM_BUILD_ROOT%{_datadir}/opera/locale/italian.lng
200 install %{SOURCE211} $RPM_BUILD_ROOT%{_datadir}/opera/locale/germen.lng
201 install %{SOURCE212} $RPM_BUILD_ROOT%{_datadir}/opera/locale/korean.lng
202 install %{SOURCE213} $RPM_BUILD_ROOT%{_datadir}/opera/locale/norwegian-bokmal.lng
203 install %{SOURCE214} $RPM_BUILD_ROOT%{_datadir}/opera/locale/polish.lng
204 install %{SOURCE215} $RPM_BUILD_ROOT%{_datadir}/opera/locale/spanish.lng
205 install %{SOURCE216} $RPM_BUILD_ROOT%{_datadir}/opera/locale/swedish.lng
206 install %{SOURCE217} $RPM_BUILD_ROOT%{_datadir}/opera/locale/greek.lng
207 install %{SOURCE218} $RPM_BUILD_ROOT%{_datadir}/opera/locale/chinese-traditional.lng
208 install %{SOURCE219} $RPM_BUILD_ROOT%{_datadir}/opera/locale/english-british.lng
209 install %{SOURCE220} $RPM_BUILD_ROOT%{_datadir}/opera/locale/norwegian-nynorsk.lng
210 install %{SOURCE221} $RPM_BUILD_ROOT%{_datadir}/opera/locale/portuguese-brazilian.lng
211 install %{SOURCE222} $RPM_BUILD_ROOT%{_datadir}/opera/locale/russian.lng
212 install %{SOURCE223} $RPM_BUILD_ROOT%{_datadir}/opera/locale/turkish.lng
213
214 # man install
215 install man/opera.1 $RPM_BUILD_ROOT%{_mandir}/man1
216
217 # wrapper correction
218 sed s#$RPM_BUILD_ROOT## > $RPM_BUILD_ROOT%{_bindir}/opera2 $RPM_BUILD_ROOT%{_bindir}/opera
219 mv $RPM_BUILD_ROOT%{_bindir}/opera2 $RPM_BUILD_ROOT%{_bindir}/opera
220
221 # install in kde etc.
222 install images/opera.xpm $RPM_BUILD_ROOT%{_pixmapsdir}
223
224 install %{SOURCE4} $RPM_BUILD_ROOT%{_desktopdir}
225
226 # symlink który niweluje burkanie siê opery :>
227 #ln -sf %{_datadir}/opera/ $RPM_BUILD_ROOT/usr/share/
228 #ln -sf %{_libdir}/opera $RPM_BUILD_ROOT/usr/lib/
229
230 sed -i -e "s#$RPM_BUILD_ROOT##g" $RPM_BUILD_ROOT%{_datadir}/opera/java/*.policy
231
232 # always use wrapper linked with libXm.so.3
233 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/plugins/operamotifwrapper
234 ln -sf operamotifwrapper-3 $RPM_BUILD_ROOT%{_libdir}/%{name}/plugins/operamotifwrapper-2
235 ln -sf operamotifwrapper-3 $RPM_BUILD_ROOT%{_libdir}/%{name}/plugins/operamotifwrapper-1
236
237 # %{_libdir} is not the best place for it but opera doesn't search for it in better
238 # places :/
239 install lib/spellcheck.so $RPM_BUILD_ROOT%{_libdir}
240
241 %clean
242 rm -rf $RPM_BUILD_ROOT
243
244 %files
245 %defattr(644,root,root,755)
246 %doc LICENSE bugreport help
247 %attr(755,root,root) %{_bindir}/*
248 %dir %{_datadir}/opera
249 %dir %{_datadir}/opera/bin
250 %attr(755,root,root) %{_datadir}/opera/bin/*
251 %{_datadir}/opera/config
252 %{_datadir}/opera/help
253 %{_datadir}/opera/images
254 %{_datadir}/opera/java
255 %dir %{_datadir}/opera/locale
256 %lang(bg) %{_datadir}/opera/locale/bulgarian.lng
257 %lang(ca) %{_datadir}/opera/locale/catalan.lng
258 %lang(da) %{_datadir}/opera/locale/danish.lng
259 %lang(de) %{_datadir}/opera/locale/german.lng
260 %lang(el) %{_datadir}/opera/locale/greek.lng
261 %lang(en_GB) %{_datadir}/opera/locale/english-british.lng
262 %lang(es) %{_datadir}/opera/locale/spanish.lng
263 %lang(es) %{_datadir}/opera/locale/spanish-latin-american.lng
264 %lang(fi) %{_datadir}/opera/locale/finish.lng
265 %lang(fr) %{_datadir}/opera/locale/french.lng
266 %lang(it) %{_datadir}/opera/locale/italian.lng
267 %lang(ja) %{_datadir}/opera/locale/japanese.lng
268 %lang(ko) %{_datadir}/opera/locale/korean.lng
269 %lang(nb) %{_datadir}/opera/locale/norwegian-bokmal.lng
270 %lang(nl) %{_datadir}/opera/locale/dutch.lng
271 %lang(nn) %{_datadir}/opera/locale/norwegian-nynorsk.lng
272 %lang(pl) %{_datadir}/opera/locale/polish.lng
273 %lang(pt_BR) %{_datadir}/opera/locale/portuguese-brazilian.lng
274 %lang(ru) %{_datadir}/opera/locale/russian.lng
275 %lang(sv) %{_datadir}/opera/locale/swedish.lng
276 %lang(tr) %{_datadir}/opera/locale/turkish.lng
277 %lang(zh_CN) %{_datadir}/opera/locale/chinese-simplified.lng
278 %lang(zh_TW) %{_datadir}/opera/locale/chinese-traditional.lng
279 %{_datadir}/opera/skin
280 %{_datadir}/opera/styles
281 %{_datadir}/opera/ini
282 %{_datadir}/opera/search.ini
283 %{_datadir}/opera/*.html
284 %{_datadir}/opera/*.ssr
285 %{_datadir}/opera/*.txt
286 %ifarch %{ix86}
287 %attr(755,root,root) %{_datadir}/opera/chartables.bin
288 %endif
289 %ifarch ppc
290 %attr(755,root,root) %{_datadir}/opera/chartables-be.bin
291 %endif
292 %attr(755,root,root) %{_datadir}/opera/opera6.adr
293 %attr(755,root,root) %{_libdir}/*.so
294 %dir %{_libdir}/opera
295 %dir %{_plugindir}
296 %attr(755,root,root) %{_plugindir}/*
297
298 %{_pixmapsdir}/opera.xpm
299 %{_desktopdir}/*.desktop
300
301 %{_mandir}/man1/opera.1*
This page took 0.252038 seconds and 4 git commands to generate.