]> git.pld-linux.org Git - packages/opera.git/blob - opera.spec
- cleanup bconds, disable debug package, check-files cleanup
[packages/opera.git] / opera.spec
1 # BRANCHES:
2 # - HEAD - stable version
3 # - DEVEL - development version
4 # - WEEKLY - weekly development version (sometimes it's on DEVEL)
5 %bcond_without  distributable   # distributable or not
6
7 %define         ver                     10.50
8 %define         reltype         snapshot
9 %define         magicstr        6219
10
11 %define         _rel    1
12 Summary:        World fastest web browser
13 Summary(pl.UTF-8):      Najszybsza przeglądarka WWW na świecie
14 Name:           opera
15 Version:        %{ver}
16 Release:        0.%{?magicstr:%{magicstr}.}%{_rel}.%{reltype}
17 Epoch:          2
18 License:        Distributable
19 Group:          X11/Applications/Networking
20
21 Source0:        http://snapshot.opera.com/unix/snapshot-%{magicstr}/%{name}-%{ver}-%{magicstr}.i386.linux.tar.bz2
22 # Source0-md5:  351a4eb5da64ac601f9f420f266b9ca4
23 %{!?with_distributable:NoSource:        0}
24
25 Source1:        http://snapshot.opera.com/unix/snapshot-%{magicstr}/%{name}-%{ver}-%{magicstr}.x86_64.linux.tar.bz2
26 # Source1-md5:  adfe0766c762eb01a4cd18a3c87edcbf
27 %{!?with_distributable:NoSource:        1}
28
29 Source4:        %{name}.desktop
30 Patch0:         %{name}-wrapper.patch
31 URL:            http://www.opera.com/
32 BuildRequires:  rpmbuild(macros) >= 1.356
33 BuildRequires:  sed >= 4.0
34 Requires:       browser-plugins >= 2.0
35 Requires:       freetype >= 2
36 Suggests:       gstreamer-theora
37 Suggests:       gstreamer-vorbis
38 Provides:       wwwbrowser
39 Obsoletes:      opera-i18n
40 ExclusiveArch:  %{ix86} %{x8664}
41 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43 %define         _enable_debug_packages  0
44
45 %define         _plugindir              %{_libdir}/opera/plugins
46 %define         _operadocdir    %{_docdir}/%{name}-%{ver}
47
48 %description
49 Opera is world fastest web browser. It supports most of nowaday
50 extensions of HTML. And it is quite stable.
51
52 %description -l pl.UTF-8
53 Opera jest najszybszą przeglądarką WWW na świecie. Obsługuje większość
54 dzisiejszych rozszerzeń HTML-a. Dodatkowo jest w miarę stabilna.
55
56 %package plugin32
57 Summary:        Opera 32-bit plugins support
58 Summary(pl.UTF-8):      Obsługa 32-bitowych wtyczek Opery
59 Group:          X11/Applications/Networking
60 Requires:       %{name} = %{epoch}:%{version}-%{release}
61
62 %description plugin32
63 Opera 32-bit plugins support.
64
65 %description plugin32 -l pl.UTF-8
66 Obsługa 32-bitowych wtyczek Opery.
67
68 %prep
69 %ifarch %{ix86}
70 %setup -q -T -b0 -n %{name}-%{ver}-%{magicstr}.i386.linux
71 %endif
72
73 %ifarch %{x8664}
74 %setup -q -T -b1 -n %{name}-%{ver}-%{magicstr}.x86_64.linux
75 %endif
76
77 %patch0 -p0
78
79 %install
80 rm -rf $RPM_BUILD_ROOT
81 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir},%{_datadir},%{_pixmapsdir},%{_desktopdir},%{_sysconfdir}}
82
83 %browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins -b <<'EOF'
84 # opera does not use for .xpt files
85 *.xpt
86
87 # use mplayerplug-in-opera instead
88 mplayerplug-in*
89 EOF
90
91 install opera $RPM_BUILD_ROOT%{_bindir}
92 cp -a usr/lib/opera $RPM_BUILD_ROOT%{_libdir}
93 cp -a usr/share/* $RPM_BUILD_ROOT%{_datadir}
94 cp -a etc/*.ini $RPM_BUILD_ROOT%{_sysconfdir}
95
96 rm $RPM_BUILD_ROOT/usr/share/doc/opera/{LGPL-2,LGPL-3,LICENSE}
97 # opera packaging tools we don't need runtime
98 rm -rf $RPM_BUILD_ROOT%{_datadir}/opera/package
99
100 # add desktop file
101 cp -a %{SOURCE4} $RPM_BUILD_ROOT%{_desktopdir}
102
103 sed -i -e 's#^OPERA_BINARYDIR=.*#OPERA_BINARYDIR=%{_libdir}/opera#g' $RPM_BUILD_ROOT%{_bindir}/opera
104
105 %clean
106 rm -rf $RPM_BUILD_ROOT
107
108 %post
109 %update_browser_plugins
110
111 %postun
112 if [ "$1" = 0 ]; then
113         %update_browser_plugins
114 fi
115
116 %files
117 %defattr(644,root,root,755)
118 %doc LICENSE
119 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/opera*ini
120
121 # browser plugins v2
122 %{_browserpluginsconfdir}/browsers.d/%{name}.*
123 %config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
124
125 %attr(755,root,root) %{_bindir}/*
126 %dir %{_libdir}/opera
127 #%ifarch %{x8664}
128 #%exclude %{_libdir}/opera/*-ia32-*
129 #%endif
130 %attr(755,root,root) %{_libdir}/opera/*.so
131 %attr(755,root,root) %{_libdir}/opera/opera*
132 %attr(755,root,root) %{_libdir}/opera/works
133 %dir %{_plugindir}
134 %dir %{_datadir}/opera
135 %{_datadir}/opera/*.*
136 %{_datadir}/opera/defaults
137 %{_datadir}/opera/extra
138 %{_datadir}/opera/skin
139 #%{_datadir}/opera/scripts
140 %{_datadir}/opera/styles
141 %{_datadir}/opera/ui
142 %{_datadir}/opera/unite
143 %dir %{_datadir}/opera/locale
144 %{_datadir}/opera/locale/en
145 %lang(be) %{_datadir}/opera/locale/be
146 %lang(bg) %{_datadir}/opera/locale/bg
147 %lang(cs) %{_datadir}/opera/locale/cs
148 %lang(da) %{_datadir}/opera/locale/da
149 %lang(de) %{_datadir}/opera/locale/de
150 %lang(el) %{_datadir}/opera/locale/el
151 %lang(en_GB) %{_datadir}/opera/locale/en-GB
152 %lang(es_ES) %{_datadir}/opera/locale/es-ES
153 %lang(es_LA) %{_datadir}/opera/locale/es-LA
154 %lang(et) %{_datadir}/opera/locale/et
155 %lang(fi) %{_datadir}/opera/locale/fi
156 %lang(fr) %{_datadir}/opera/locale/fr
157 %lang(fr_CA) %{_datadir}/opera/locale/fr-CA
158 %lang(fy) %{_datadir}/opera/locale/fy
159 %lang(hi) %{_datadir}/opera/locale/hi
160 %lang(hr) %{_datadir}/opera/locale/hr
161 %lang(hu) %{_datadir}/opera/locale/hu
162 %lang(id) %{_datadir}/opera/locale/id
163 %lang(it) %{_datadir}/opera/locale/it
164 %lang(ja) %{_datadir}/opera/locale/ja
165 %lang(ka) %{_datadir}/opera/locale/ka
166 %lang(ko) %{_datadir}/opera/locale/ko
167 %lang(lt) %{_datadir}/opera/locale/lt
168 %lang(mk) %{_datadir}/opera/locale/mk
169 %lang(nb) %{_datadir}/opera/locale/nb
170 %lang(nl) %{_datadir}/opera/locale/nl
171 %lang(nn) %{_datadir}/opera/locale/nn
172 %lang(pl) %{_datadir}/opera/locale/pl
173 %lang(pt) %{_datadir}/opera/locale/pt
174 %lang(pt_BR) %{_datadir}/opera/locale/pt-BR
175 %lang(ro) %{_datadir}/opera/locale/ro
176 %lang(ru) %{_datadir}/opera/locale/ru
177 %lang(sk) %{_datadir}/opera/locale/sk
178 %lang(sr) %{_datadir}/opera/locale/sr
179 %lang(sv) %{_datadir}/opera/locale/sv
180 %lang(ta) %{_datadir}/opera/locale/ta
181 %lang(te) %{_datadir}/opera/locale/te
182 %lang(tr) %{_datadir}/opera/locale/tr
183 %lang(uk) %{_datadir}/opera/locale/uk
184 %lang(zh_CN) %{_datadir}/opera/locale/zh-cn
185 %lang(zh_HK) %{_datadir}/opera/locale/zh-hk
186 %lang(zh_TW) %{_datadir}/opera/locale/zh-tw
187 %{_desktopdir}/*.desktop
188 %{_mandir}/man1/opera.1*
189 %{_pixmapsdir}/opera.xpm
190 %{_iconsdir}/hicolor/*/*/*.*
191
192 #%ifarch %{x8664}
193 #files plugin32
194 #%defattr(644,root,root,755)
195 #%attr(755,root,root) %{_libdir}/opera/*-ia32-*
196 #%endif
This page took 0.040036 seconds and 4 git commands to generate.