]> git.pld-linux.org Git - packages/opera.git/blob - opera.spec
- corrected %*rel*
[packages/opera.git] / opera.spec
1 #
2 # There're some problems with "shared" version
3 #
4 %bcond_with     shared
5
6 %define ver             7.50
7 %define dirrel          20040218
8 %define shared_rel      %{dirrel}.5
9 %define static_rel      %{dirrel}.1
10 %if %{with shared}
11 %define rel             %{shared_rel}
12 %define type            shared
13 %else
14 %define rel             %{static_rel}
15 %define type            static
16 %endif
17 Summary:        World fastest web browser
18 Summary(pl):    Najszybsza przegl±darka WWW na ¶wiecie
19 Name:           opera
20 Version:        %{ver}.%{rel}
21 Release:        0.1
22 License:        Restricted, see file LICENSE
23 Group:          X11/Applications/Networking
24 # Source0:      ftp://ftp.opera.com/pub/opera/linux/723/final/en/i386/static/%{name}-%{ver}-%{static_rel}-static-qt.i386-en.tar.bz2
25 Source0:        http://snapshot.opera.com/unix/7.50-Preview-2/intel-linux/en/%{name}-%{ver}-%{static_rel}-static-qt.i386-en.tar.bz2
26 # Source1:      ftp://ftp.opera.com/pub/opera/linux/723/final/en/sparc/static/%{name}-%{ver}-%{static_rel}-static-qt.sparc-en.tar.bz2
27 Source1:        http://snapshot.opera.com/unix/7.50-Preview-2/sparc-linux/en/%{name}-%{ver}-%{static_rel}-static-qt.sparc-en.tar.bz2
28 # Source2:      ftp://ftp.opera.com/pub/opera/linux/723/final/en/ppc/static/%{name}-%{ver}-%{static_rel}-static-qt.ppc-en.tar.bz2
29 Source2:        http://snapshot.opera.com/unix/7.50-Preview-2/ppc-linux/en/%{name}-%{ver}-%{static_rel}-static-qt.ppc-en.tar.bz2
30 # polish language file (taken from where?)
31 Source3:        %{name}-2887.lng
32 Source4:        %{name}.desktop
33 # Source20:     ftp://ftp.opera.com/pub/opera/linux/723/final/en/i386/shared/%{name}-%{ver}-%{shared_rel}-shared-qt.i386-en.tar.bz2
34 Source20:       http://snapshot.opera.com/unix/7.50-Preview-2/intel-linux/en/%{name}-%{ver}-%{shared_rel}-shared-qt.i386-en.tar.bz2
35 # Source21:     ftp://ftp.opera.com/pub/opera/linux/723/final/en/sparc/shared/gcc-2.95/%{name}-%{ver}-%{dirrel}.2-shared-qt.sparc-en.tar.bz2
36 Source21:       http://snapshot.opera.com/unix/7.50-Preview-2/sparc-linux/en/%{name}-%{ver}-%{dirrel}.2-shared-qt.sparc-en.tar.bz2
37 # Source22:     ftp://ftp.opera.com/pub/opera/linux/723/final/en/ppc/shared/gcc-2.95/%{name}-%{ver}-%{dirrel}.2-shared-qt.ppc-en.tar.bz2
38 Source22:       http://snapshot.opera.com/unix/7.50-Preview-2/ppc-linux/en/%{name}-%{ver}-%{dirrel}.2-shared-qt.ppc-en.tar.bz2
39 NoSource:       0
40 NoSource:       1
41 NoSource:       2
42 NoSource:       20
43 NoSource:       21
44 NoSource:       22
45 URL:            http://www.opera.com/
46 ExclusiveArch:  %{ix86} ppc sparc sparc64
47 Requires:       freetype >= 2
48 Requires:       openmotif >= 2
49 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
50
51 %define         _plugindir      %{_libdir}/opera/plugins
52 %define         _operadocdir    %{_docdir}/%{name}-%{ver}.%{rel}
53 %define         configfile      %{_datadir}/opera/config/opera6rc
54
55 %description
56 Opera is world fastest web browser. It supports most of nowaday
57 extensions of HTML. And it is quite stable. Only disadvantage are
58 advertisements on the top of its window. Version static linked with
59 qt.
60
61 %description -l pl
62 Opera jest najszybsz± przegl±dark± WWW na ¶wiecie. Obs³uguje wiêkszo¶æ
63 dzisiejszych rozszerzeñ HTMLa. Dodatkowo jest w miarê stabilna. Jedyn±
64 niedogodno¶ci± s± reklamy ukazuj±ce siê w górze okna. Wersja
65 statycznie skonsolidowana z qt.
66
67 %prep
68 %ifarch %{ix86}
69 %setup -q %{?_with_shared:-T -b 20} -n %{name}-%{ver}-%{rel}-%{type}-qt.i386-en
70 %endif
71 %ifarch sparc sparc64
72 %setup -q -T -b %{?_with_shared:2}1 -n %{name}-%{ver}-%{rel}-%{type}-qt.sparc-en
73 %endif
74 %ifarch ppc
75 %setup -q -T -b %{?_with_shared:2}2 -n %{name}-%{ver}-%{rel}-%{type}-qt.ppc-en
76 %endif
77
78 %install
79 rm -rf $RPM_BUILD_ROOT
80
81 install -d $RPM_BUILD_ROOT{/etc,%{_mandir}/man1,%{_pixmapsdir},%{_desktopdir}}
82
83 cat install.sh | sed 's|/etc|$RPM_BUILD_ROOT%{_sysconfdir}|' > install2.sh
84 mv install2.sh install.sh
85
86 echo y |\
87 sh install.sh \
88   --prefix=$RPM_BUILD_ROOT%{_prefix} \
89   --wrapperdir=$RPM_BUILD_ROOT%{_bindir} \
90   --docdir=$RPM_BUILD_ROOT%{_operadocdir} \
91   --sharedir=$RPM_BUILD_ROOT%{_datadir}/opera \
92   --exec_prefix=$RPM_BUILD_ROOT%{_datadir}/opera/bin \
93   --plugindir=$RPM_BUILD_ROOT%{_plugindir}
94
95 # Polish locale
96 install %{SOURCE3} $RPM_BUILD_ROOT%{_datadir}/opera/locale/
97
98 # man install
99 install man/opera.1 $RPM_BUILD_ROOT%{_mandir}/man1
100
101 # wrapper correction
102 sed s#$RPM_BUILD_ROOT## > $RPM_BUILD_ROOT%{_bindir}/opera2 $RPM_BUILD_ROOT%{_bindir}/opera
103 mv $RPM_BUILD_ROOT%{_bindir}/opera2 $RPM_BUILD_ROOT%{_bindir}/opera
104
105 # install in kde etc.
106 install images/opera.xpm $RPM_BUILD_ROOT%{_pixmapsdir}
107
108 install %{SOURCE4} $RPM_BUILD_ROOT%{_desktopdir}
109
110 # symlink który niweluje burkanie siê opery :>
111 #ln -sf %{_datadir}/opera/ $RPM_BUILD_ROOT/usr/share/
112 #ln -sf %{_libdir}/opera $RPM_BUILD_ROOT/usr/lib/
113
114 sed -i -e "s#$RPM_BUILD_ROOT##g" $RPM_BUILD_ROOT%{_datadir}/opera/java/*.policy
115
116 # always use wrapper linked with libXm.so.3
117 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/plugins/operamotifwrapper-3
118 ln -sf operamotifwrapper $RPM_BUILD_ROOT%{_libdir}/%{name}/plugins/operamotifwrapper
119
120 %clean
121 rm -rf $RPM_BUILD_ROOT
122
123 %files
124 %defattr(644,root,root,755)
125 %doc LICENSE bugreport help
126 %attr(755,root,root) %{_bindir}/*
127 %dir %{_datadir}/opera
128 %dir %{_datadir}/opera/bin
129 %attr(755,root,root) %{_datadir}/opera/bin/*
130 %{_datadir}/opera/config
131 %{_datadir}/opera/help
132 %{_datadir}/opera/images
133 %{_datadir}/opera/java
134 %{_datadir}/opera/locale
135 %{_datadir}/opera/skin
136 %{_datadir}/opera/styles
137 %{_datadir}/opera/ini
138 %{_datadir}/opera/search.ini
139 %{_datadir}/opera/*.html
140 %{_datadir}/opera/*.ssr
141 %{_datadir}/opera/*.txt
142 %ifarch %{ix86}
143 %attr(755,root,root) %{_datadir}/opera/chartables.bin
144 %endif
145 %ifarch ppc
146 %attr(755,root,root) %{_datadir}/opera/chartables-be.bin
147 %endif
148 %attr(755,root,root) %{_datadir}/opera/opera6.adr
149 %dir %{_libdir}/opera
150 %dir %{_plugindir}
151 %attr(755,root,root) %{_plugindir}/*
152
153 %{_pixmapsdir}/opera.xpm
154 %{_desktopdir}/*.desktop
155
156 %{_mandir}/man1/opera.1*
This page took 0.038923 seconds and 4 git commands to generate.