]> git.pld-linux.org Git - packages/opera.git/blob - opera.spec
- move english.lng to opera.spec
[packages/opera.git] / opera.spec
1 # TODO:
2 # - move translations into a separate, noarch package
3 #
4 %bcond_without  shared          # static or shared version
5 %bcond_without  distributable   # distributable or not
6 %bcond_without  incall          # include all tarballs into src.rpm (but splitted into shared/static)
7 %bcond_with     snap            # snap version
8
9 %if %{with snap}
10 %define ver             7.60
11 %define dirrel          20040824
12 %define reltype         Preview-1
13 %else
14 %define ver             7.54
15 %define dirrel          20040803
16 %define reltype         final
17 %endif
18
19 %define shver           %(echo %{ver} | tr -d .)
20 %define x86_shared_rel          %{dirrel}.5
21 %define x86_static_rel          %{dirrel}.1
22 %define sparc_shared_rel        %{dirrel}.2
23 %define sparc_static_rel        %{dirrel}.1
24 %define ppc_shared_rel          %{dirrel}.2
25 %define ppc_static_rel          %{dirrel}.1
26 %if %{with shared}
27 %define type            shared
28 # We should be able to build src.rpm also on not supported archs
29 %define rel             %{x86_shared_rel}
30 %ifarch sparc64 sparc
31 %define rel             %{sparc_shared_rel}
32 %endif
33 %ifarch ppc
34 %define rel             %{ppc_shared_rel}
35 %endif
36 %else
37 %define type            static
38 %define rel             %{x86_static_rel}
39 %ifarch sparc sparc64
40 %define rel             %{sparc_static_rel}
41 %endif
42 %ifarch ppc
43 %define rel             %{ppc_static_rel}
44 %endif
45 %endif
46
47 Summary:        World fastest web browser
48 Summary(pl):    Najszybsza przegl±darka WWW na ¶wiecie
49 Name:           opera
50 Version:        %{ver}.%{rel}
51 Release:        3
52 License:        Distributable for PLD until 31 Dec 2006 - http://distribute.opera.com/ (otherwise restricted, see file LICENSE)
53 Group:          X11/Applications/Networking
54 %if %{without shared}
55 %{!?with_incall:%ifarch %{ix86}}
56 %if ! %{with snap}
57 Source0:        ftp://ftp.opera.com/pub/opera/linux/%{shver}/%{reltype}/en/i386/static/%{name}-%{ver}-%{x86_static_rel}-static-qt.i386-en.tar.bz2
58 # Source0-md5:  0a7e933ef593d4b7a897041c9f87bba2
59 %else
60 Source100:      http://snapshot.opera.com/unix/%{ver}-%{reltype}/intel-linux/en/%{name}-%{ver}-%{x86_static_rel}-static-qt.i386-en.tar.bz2
61 %endif
62 %{!?with_distributable:NoSource:        0}
63 %if ! %{with incall}
64 %endif
65 %ifarch sparc sparc64
66 %endif
67 %if ! %{with snap}
68 Source1:        ftp://ftp.opera.com/pub/opera/linux/%{shver}/%{reltype}/en/sparc/static/%{name}-%{ver}-%{sparc_static_rel}-static-qt.sparc-en.tar.bz2
69 # Source1-md5:  04976a6ace7a4345ce5e4cf763159939
70 %else
71 #Source101:     http://snapshot.opera.com/unix/%{ver}-%{reltype}/sparc-linux/en/%{name}-%{ver}-%{sparc_static_rel}-static-qt.sparc-en.tar.bz2
72 %endif
73 %{!?with_distributable:NoSource:        1}
74 %if ! %{with incall}
75 %endif
76 %ifarch ppc
77 %endif
78 %if ! %{with snap}
79 Source2:        ftp://ftp.opera.com/pub/opera/linux/%{shver}/%{reltype}/en/ppc/static/%{name}-%{ver}-%{ppc_static_rel}-static-qt.ppc-en.tar.bz2
80 # Source2-md5:  c11a4c78d18bdaa4bd338b4c0dc27f38
81 %else
82 Source102:      http://snapshot.opera.com/unix/%{ver}-%{reltype}/ppc-linux/en/%{name}-%{ver}-%{ppc_static_rel}-static-qt.ppc-en.tar.bz2
83 %endif
84 %{!?with_distributable:NoSource:        2}
85 %{!?with_incall:%endif}
86 %else
87 %{!?with_incall:%ifarch %{ix86}}
88 %if ! %{with snap}
89 Source20:       ftp://ftp.opera.com/pub/opera/linux/%{shver}/%{reltype}/en/i386/shared/%{name}-%{ver}-%{x86_shared_rel}-shared-qt.i386-en.tar.bz2
90 # Source20-md5: 0e407a050f3aa4559011a3cea707cd20
91 %else
92 Source1020:     http://snapshot.opera.com/unix/%{ver}-%{reltype}/intel-linux/en/%{name}-%{ver}-%{x86_shared_rel}-shared-qt.i386-en.tar.bz2
93 # Source1020-md5:       da4df3c5d65057eac4e063b4359fafa6
94 %endif
95 %{!?with_distributable:NoSource:        20}
96 %if ! %{with incall}
97 %endif
98 %ifarch sparc sparc64
99 %endif
100 %if ! %{with snap}
101 Source21:       ftp://ftp.opera.com/pub/opera/linux/%{shver}/%{reltype}/en/sparc/shared/gcc-2.95/%{name}-%{ver}-%{sparc_shared_rel}-shared-qt.sparc-en.tar.bz2
102 # Source21-md5: d8635013dac0c98c680997fcc9dd66c4
103 %else
104 #Source1021:    http://snapshot.opera.com/unix/%{ver}-%{reltype}/sparc-linux/en/%{name}-%{ver}-%{sparc_shared_rel}-shared-qt.sparc-en.tar.bz2
105 %endif
106 %{!?with_distributable:NoSource:        21}
107 %if ! %{with incall}
108 %endif
109 %ifarch ppc
110 %endif
111 %if ! %{with snap}
112 Source22:       ftp://ftp.opera.com/pub/opera/linux/%{shver}/%{reltype}/en/ppc/shared/gcc-2.95/%{name}-%{ver}-%{ppc_shared_rel}-shared-qt.ppc-en.tar.bz2
113 # Source22-md5: 516992e68c5a710d795a1ecc791c7f4d
114 %else
115 Source1022:     http://snapshot.opera.com/unix/%{ver}-%{reltype}/ppc-linux/en/%{name}-%{ver}-%{ppc_shared_rel}-shared-qt.ppc-en.tar.bz2
116 # Source1022-md5:      6496d9871a2ca7337377ed3ecc298559
117 %endif
118 %{!?with_distributable:NoSource:        22}
119 %endif
120 %{!?with_incall:%endif}
121 Source4:        %{name}.desktop
122 URL:            http://www.opera.com/
123 ExclusiveArch:  %{ix86} ppc sparc sparc64
124 Requires:       freetype >= 2
125
126 Requires:       openmotif >= 2
127 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
128
129 %define         _plugindir      %{_libdir}/opera/plugins
130 %define         _operadocdir    %{_docdir}/%{name}-%{ver}.%{rel}
131 %define         configfile      %{_datadir}/opera/config/opera6rc
132
133 %description
134 Opera is world fastest web browser. It supports most of nowaday
135 extensions of HTML. And it is quite stable. Only disadvantage are
136 advertisements on the top of its window. Version static linked with
137 qt.
138
139 %description -l pl
140 Opera jest najszybsz± przegl±dark± WWW na ¶wiecie. Obs³uguje wiêkszo¶æ
141 dzisiejszych rozszerzeñ HTMLa. Dodatkowo jest w miarê stabilna. Jedyn±
142 niedogodno¶ci± s± reklamy ukazuj±ce siê w górze okna. Wersja
143 statycznie skonsolidowana z qt.
144
145 %prep
146 %ifarch %{ix86}
147 %setup -q %{?with_shared:-T -b %{?with_snap:10}20} -n %{name}-%{ver}-%{rel}-%{type}-qt.i386-en
148 %endif
149 %ifarch sparc sparc64
150 %setup -q -T -b %{?with_snap:10}%{?with_shared:2}1 -n %{name}-%{ver}-%{rel}-%{type}-qt.sparc-en
151 %endif
152 %ifarch ppc
153 %setup -q -T -b %{?with_snap:10}%{?with_shared:2}2 -n %{name}-%{ver}-%{rel}-%{type}-qt.ppc-en
154 %endif
155
156 %install
157 rm -rf $RPM_BUILD_ROOT
158
159 install -d $RPM_BUILD_ROOT{/etc,%{_mandir}/man1,%{_pixmapsdir},%{_desktopdir}}
160
161 cat install.sh | sed 's|/etc|$RPM_BUILD_ROOT%{_sysconfdir}|' > install2.sh
162 mv install2.sh install.sh
163
164 echo y |\
165 sh install.sh \
166   --prefix=$RPM_BUILD_ROOT%{_prefix} \
167   --wrapperdir=$RPM_BUILD_ROOT%{_bindir} \
168   --docdir=$RPM_BUILD_ROOT%{_operadocdir} \
169   --sharedir=$RPM_BUILD_ROOT%{_datadir}/opera \
170   --exec_prefix=$RPM_BUILD_ROOT%{_datadir}/opera/bin \
171   --plugindir=$RPM_BUILD_ROOT%{_plugindir}
172
173 # man install
174 install man/opera.1 $RPM_BUILD_ROOT%{_mandir}/man1
175
176 # wrapper correction
177 sed s#$RPM_BUILD_ROOT## > $RPM_BUILD_ROOT%{_bindir}/opera2 $RPM_BUILD_ROOT%{_bindir}/opera
178 mv $RPM_BUILD_ROOT%{_bindir}/opera2 $RPM_BUILD_ROOT%{_bindir}/opera
179
180 # install in kde etc.
181 install images/opera.xpm $RPM_BUILD_ROOT%{_pixmapsdir}
182
183 install %{SOURCE4} $RPM_BUILD_ROOT%{_desktopdir}
184
185 # symlink który niweluje burkanie siê opery :>
186 #ln -sf %{_datadir}/opera/ $RPM_BUILD_ROOT/usr/share/
187 #ln -sf %{_libdir}/opera $RPM_BUILD_ROOT/usr/lib/
188
189 sed -i -e "s#$RPM_BUILD_ROOT##g" $RPM_BUILD_ROOT%{_datadir}/opera/java/*.policy
190
191 # always use wrapper linked with libXm.so.3
192 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/plugins/operamotifwrapper
193 ln -sf operamotifwrapper-3 $RPM_BUILD_ROOT%{_libdir}/%{name}/plugins/operamotifwrapper-2
194 ln -sf operamotifwrapper-3 $RPM_BUILD_ROOT%{_libdir}/%{name}/plugins/operamotifwrapper-1
195
196 # %{_libdir} is not the best place for it but opera doesn't search for it in better
197 # places :/
198 install lib/spellcheck.so $RPM_BUILD_ROOT%{_libdir}
199
200 %clean
201 rm -rf $RPM_BUILD_ROOT
202
203 %files
204 %defattr(644,root,root,755)
205 %doc LICENSE bugreport help
206 %attr(755,root,root) %{_bindir}/*
207 %dir %{_datadir}/opera
208 %dir %{_datadir}/opera/bin
209 %attr(755,root,root) %{_datadir}/opera/bin/*
210 %{_datadir}/opera/config
211 %{_datadir}/opera/help
212 %{_datadir}/opera/images
213 %{_datadir}/opera/java
214 %{_datadir}/opera/skin
215 %{_datadir}/opera/styles
216 %{_datadir}/opera/ini
217 %{_datadir}/opera/search.ini
218 %{_datadir}/opera/*.html
219 %{_datadir}/opera/*.ssr
220 %{_datadir}/opera/*.txt
221 %ifarch %{ix86}
222 %attr(755,root,root) %{_datadir}/opera/chartables.bin
223 %endif
224 %ifarch ppc
225 %attr(755,root,root) %{_datadir}/opera/chartables-be.bin
226 %endif
227 %attr(755,root,root) %{_datadir}/opera/opera6.adr
228 %attr(755,root,root) %{_libdir}/*.so
229 %dir %{_libdir}/opera
230 %dir %{_plugindir}
231 %attr(755,root,root) %{_plugindir}/*
232
233 %dir %{_datadir}/opera/locale
234 %{_datadir}/opera/locale/en
235 %{_datadir}/opera/locale/english.lng
236
237 %{_pixmapsdir}/opera.xpm
238 %{_desktopdir}/*.desktop
239
240 %{_mandir}/man1/opera.1*
This page took 0.079286 seconds and 4 git commands to generate.