]> git.pld-linux.org Git - packages/opera.git/blob - opera.spec
- S: gstreamer-{vorbis,theora}
[packages/opera.git] / opera.spec
1 # BRANCHES:
2 # - HEAD - stable version
3 # - DEVEL - development version
4 # - WEEKLY - weekly development version (sometimes it's on DEVEL)
5
6 %bcond_without  shared          # static or shared version
7 %bcond_without  distributable   # distributable or not
8 %bcond_with     snap            # snap version
9 %bcond_with     weekly          # weekly snapshot version
10
11 %define ver             10.50
12 %define reltype         snapshot
13 %define magicstr        6177
14
15 %define         _rel    1
16 Summary:        World fastest web browser
17 Summary(pl.UTF-8):      Najszybsza przeglądarka WWW na świecie
18 Name:           opera
19 Version:        %{ver}
20 Release:        0.%{?magicstr:%{magicstr}.}%{_rel}.%{reltype}
21 Epoch:          2
22 License:        Distributable
23 Group:          X11/Applications/Networking
24
25 Source0:        http://snapshot.opera.com/unix/labs-6177/%{name}-%{ver}-%{magicstr}.linux.i386.tar.bz2
26 # Source0-md5:  a40752ad9829dfac54bb15e16817c29a
27 %{!?with_distributable:NoSource:        0}
28
29 Source1:        http://snapshot.opera.com/unix/labs-6177/%{name}-%{ver}-%{magicstr}.linux.x86_64.tar.bz2
30 # Source1-md5:  76dc5d8bf40e9a25a1c62881758d1f16
31 %{!?with_distributable:NoSource:        1}
32
33 Source4:        %{name}.desktop
34 Patch0:         %{name}-wrapper.patch
35 URL:            http://www.opera.com/
36 BuildRequires:  rpmbuild(macros) >= 1.356
37 BuildRequires:  sed >= 4.0
38 Requires:       browser-plugins >= 2.0
39 Requires:       freetype >= 2
40 Suggests:       gstreamer-vorbis
41 Suggests:       gstreamer-theora
42 Provides:       wwwbrowser
43 Obsoletes:      opera-i18n
44 ExclusiveArch:  %{ix86} %{x8664}
45 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
46
47 %define         _plugindir      %{_libdir}/opera/plugins
48 %define         _operadocdir    %{_docdir}/%{name}-%{ver}
49
50 %description
51 Opera is world fastest web browser. It supports most of nowaday
52 extensions of HTML. And it is quite stable.
53
54 %description -l pl.UTF-8
55 Opera jest najszybszą przeglądarką WWW na świecie. Obsługuje większość
56 dzisiejszych rozszerzeń HTML-a. Dodatkowo jest w miarę stabilna.
57
58 %package plugin32
59 Summary:        Opera 32-bit plugins support
60 Summary(pl.UTF-8):      Obsługa 32-bitowych wtyczek Opery
61 Group:          X11/Applications/Networking
62 Requires:       %{name} = %{epoch}:%{version}-%{release}
63
64 %description plugin32
65 Opera 32-bit plugins support.
66
67 %description plugin32 -l pl.UTF-8
68 Obsługa 32-bitowych wtyczek Opery.
69
70 %prep
71 %ifarch %{ix86}
72 %setup -q -T -b0 -n %{name}-%{ver}-%{magicstr}.linux.i386
73 %endif
74
75 %ifarch %{x8664}
76 %setup -q -T -b1 -n %{name}-%{ver}-%{magicstr}.linux.x86_64
77 %endif
78
79 %patch0 -p0
80
81 %install
82 rm -rf $RPM_BUILD_ROOT
83 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir},%{_datadir},%{_pixmapsdir},%{_desktopdir},%{_sysconfdir}}
84
85 %browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins -b <<'EOF'
86 # opera does not use for .xpt files
87 *.xpt
88
89 # use mplayerplug-in-opera instead
90 mplayerplug-in*
91
92 # opera uses libjava.so to run java
93 libjavaplugin_oji.so
94 EOF
95
96 install opera $RPM_BUILD_ROOT%{_bindir}
97 cp -a usr/lib/opera $RPM_BUILD_ROOT%{_libdir}
98 cp -a usr/share/* $RPM_BUILD_ROOT%{_datadir}
99 install etc/*.ini $RPM_BUILD_ROOT%{_sysconfdir}
100
101 # install in kde etc.
102 install %{SOURCE4} $RPM_BUILD_ROOT%{_desktopdir}
103
104 %clean
105 rm -rf $RPM_BUILD_ROOT
106
107 %post
108 %update_browser_plugins
109
110 %postun
111 if [ "$1" = 0 ]; then
112         %update_browser_plugins
113 fi
114
115 %files
116 %defattr(644,root,root,755)
117 %doc LICENSE
118 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/opera*ini
119
120 # browser plugins v2
121 %{_browserpluginsconfdir}/browsers.d/%{name}.*
122 %config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
123
124 %attr(755,root,root) %{_bindir}/*
125 %dir %{_libdir}/opera
126 %ifarch %{x8664}
127 %exclude %{_libdir}/opera/*-ia32-*
128 %endif
129 %attr(755,root,root) %{_libdir}/opera/*.so
130 %attr(755,root,root) %{_libdir}/opera/opera*
131 %attr(755,root,root) %{_libdir}/opera/works
132 %dir %{_plugindir}
133 %dir %{_datadir}/opera
134 %{_datadir}/opera/*.*
135 %{_datadir}/opera/defaults
136 %{_datadir}/opera/extra
137 %{_datadir}/opera/java
138 %{_datadir}/opera/skin
139 %{_datadir}/opera/scripts
140 %{_datadir}/opera/styles
141 %{_datadir}/opera/ui
142 %{_datadir}/opera/unite
143 %dir %{_datadir}/opera/locale
144 %{_datadir}/opera/locale/en
145 #%lang(be) %{_datadir}/opera/locale/be
146 #%lang(bg) %{_datadir}/opera/locale/bg
147 #%lang(cs) %{_datadir}/opera/locale/cs
148 #%lang(da) %{_datadir}/opera/locale/da
149 #%lang(de) %{_datadir}/opera/locale/de
150 #%lang(el) %{_datadir}/opera/locale/el
151 #%lang(en_GB) %{_datadir}/opera/locale/en-GB
152 #%lang(es_ES) %{_datadir}/opera/locale/es-ES
153 #%lang(es_LA) %{_datadir}/opera/locale/es-LA
154 #%lang(et) %{_datadir}/opera/locale/et
155 #%lang(fi) %{_datadir}/opera/locale/fi
156 #%lang(fr) %{_datadir}/opera/locale/fr
157 #%lang(fr_CA) %{_datadir}/opera/locale/fr-CA
158 #%lang(fy) %{_datadir}/opera/locale/fy
159 #%lang(hi) %{_datadir}/opera/locale/hi
160 #%lang(hr) %{_datadir}/opera/locale/hr
161 #%lang(hu) %{_datadir}/opera/locale/hu
162 #%lang(id) %{_datadir}/opera/locale/id
163 #%lang(it) %{_datadir}/opera/locale/it
164 #%lang(ja) %{_datadir}/opera/locale/ja
165 #%lang(ka) %{_datadir}/opera/locale/ka
166 #%lang(ko) %{_datadir}/opera/locale/ko
167 #%lang(lt) %{_datadir}/opera/locale/lt
168 #%lang(mk) %{_datadir}/opera/locale/mk
169 #%lang(nb) %{_datadir}/opera/locale/nb
170 #%lang(nl) %{_datadir}/opera/locale/nl
171 #%lang(nn) %{_datadir}/opera/locale/nn
172 #%lang(pl) %{_datadir}/opera/locale/pl
173 #%lang(pt) %{_datadir}/opera/locale/pt
174 #%lang(pt_BR) %{_datadir}/opera/locale/pt-BR
175 #%lang(ro) %{_datadir}/opera/locale/ro
176 #%lang(ru) %{_datadir}/opera/locale/ru
177 #%lang(sk) %{_datadir}/opera/locale/sk
178 #%lang(sr) %{_datadir}/opera/locale/sr
179 #%lang(sv) %{_datadir}/opera/locale/sv
180 #%lang(ta) %{_datadir}/opera/locale/ta
181 #%lang(te) %{_datadir}/opera/locale/te
182 #%lang(tr) %{_datadir}/opera/locale/tr
183 #%lang(uk) %{_datadir}/opera/locale/uk
184 %lang(zh_CN) %{_datadir}/opera/locale/zh-cn
185 %lang(zh_HK) %{_datadir}/opera/locale/zh-hk
186 %lang(zh_TW) %{_datadir}/opera/locale/zh-tw
187 %{_desktopdir}/*.desktop
188 %{_mandir}/man1/opera.1*
189 %{_pixmapsdir}/opera.xpm
190 %{_iconsdir}/hicolor/*/*/*.*
191
192 %ifarch %{x8664}
193 %files plugin32
194 %defattr(644,root,root,755)
195 %attr(755,root,root) %{_libdir}/opera/*-ia32-*
196 %endif
This page took 0.111224 seconds and 4 git commands to generate.