]> git.pld-linux.org Git - packages/opera.git/blob - opera.spec
- up to 10.50 snapshot (no longer uses qt)
[packages/opera.git] / opera.spec
1 # BRANCHES:
2 # - HEAD - stable version
3 # - DEVEL - development version
4 # - WEEKLY - weekly development version (sometimes it's on DEVEL)
5
6 %bcond_without  shared          # static or shared version
7 %bcond_without  distributable   # distributable or not
8 %bcond_with     snap            # snap version
9 %bcond_with     weekly          # weekly snapshot version
10
11 %define ver             10.50
12 %define reltype         snapshot
13 %define magicstr        6177
14
15 %define         _rel    1
16 Summary:        World fastest web browser
17 Summary(pl.UTF-8):      Najszybsza przeglądarka WWW na świecie
18 Name:           opera
19 Version:        %{ver}
20 Release:        0.%{?magicstr:%{magicstr}.}%{rel}.%{_rel}.%{sreltype}
21 Epoch:          2
22 License:        Distributable
23 Group:          X11/Applications/Networking
24
25 Source0:        http://snapshot.opera.com/unix/labs-6177/%{name}-%{ver}-%{magicstr}.linux.i386.tar.bz2
26 # Source0-md5:  a40752ad9829dfac54bb15e16817c29a
27 %{!?with_distributable:NoSource:        0}
28
29 Source1:        http://snapshot.opera.com/unix/labs-6177/%{name}-%{ver}-%{magicstr}.linux.x86_64.tar.bz2
30 # Source1-md5:  76dc5d8bf40e9a25a1c62881758d1f16
31 %{!?with_distributable:NoSource:        1}
32
33 Source4:        %{name}.desktop
34 Patch0:         %{name}-wrapper.patch
35 URL:            http://www.opera.com/
36 BuildRequires:  rpmbuild(macros) >= 1.356
37 BuildRequires:  sed >= 4.0
38 Requires:       browser-plugins >= 2.0
39 Requires:       freetype >= 2
40 Provides:       wwwbrowser
41 Obsoletes:      opera-i18n
42 ExclusiveArch:  %{ix86} %{x8664}
43 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
44
45 %define         _plugindir      %{_libdir}/opera/plugins
46 %define         _operadocdir    %{_docdir}/%{name}-%{ver}
47
48 %description
49 Opera is world fastest web browser. It supports most of nowaday
50 extensions of HTML. And it is quite stable.
51
52 %description -l pl.UTF-8
53 Opera jest najszybszą przeglądarką WWW na świecie. Obsługuje większość
54 dzisiejszych rozszerzeń HTML-a. Dodatkowo jest w miarę stabilna.
55
56 %package plugin32
57 Summary:        Opera 32-bit plugins support
58 Summary(pl.UTF-8):      Obsługa 32-bitowych wtyczek Opery
59 Group:          X11/Applications/Networking
60 Requires:       %{name} = %{epoch}:%{version}-%{release}
61
62 %description plugin32
63 Opera 32-bit plugins support.
64
65 %description plugin32 -l pl.UTF-8
66 Obsługa 32-bitowych wtyczek Opery.
67
68 %prep
69 %ifarch %{ix86}
70 %setup -q -T -b0 -n %{name}-%{ver}-%{magicstr}.linux.i386
71 %endif
72
73 %ifarch %{x8664}
74 %setup -q -T -b1 -n %{name}-%{ver}-%{magicstr}.linux.x86_64
75 %endif
76
77 %patch0 -p0
78
79 %install
80 rm -rf $RPM_BUILD_ROOT
81 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir},%{_datadir},%{_pixmapsdir},%{_desktopdir},%{_sysconfdir}}
82
83 %browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins -b <<'EOF'
84 # opera does not use for .xpt files
85 *.xpt
86
87 # use mplayerplug-in-opera instead
88 mplayerplug-in*
89
90 # opera uses libjava.so to run java
91 libjavaplugin_oji.so
92 EOF
93
94 install opera $RPM_BUILD_ROOT%{_bindir}
95 cp -a usr/lib/opera $RPM_BUILD_ROOT%{_libdir}
96 cp -a usr/share/* $RPM_BUILD_ROOT%{_datadir}
97 install etc/*.ini $RPM_BUILD_ROOT%{_sysconfdir}
98
99 # install in kde etc.
100 install %{SOURCE4} $RPM_BUILD_ROOT%{_desktopdir}
101
102 %clean
103 rm -rf $RPM_BUILD_ROOT
104
105 %post
106 %update_browser_plugins
107
108 %postun
109 if [ "$1" = 0 ]; then
110         %update_browser_plugins
111 fi
112
113 %files
114 %defattr(644,root,root,755)
115 %doc LICENSE
116 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/opera*ini
117
118 # browser plugins v2
119 %{_browserpluginsconfdir}/browsers.d/%{name}.*
120 %config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
121
122 %attr(755,root,root) %{_bindir}/*
123 %dir %{_libdir}/opera
124 %ifarch %{x8664}
125 %exclude %{_libdir}/opera/*-ia32-*
126 %endif
127 %attr(755,root,root) %{_libdir}/opera/*.so
128 %attr(755,root,root) %{_libdir}/opera/opera*
129 %attr(755,root,root) %{_libdir}/opera/works
130 %dir %{_plugindir}
131 %dir %{_datadir}/opera
132 %{_datadir}/opera/*.*
133 %{_datadir}/opera/defaults
134 %{_datadir}/opera/extra
135 %{_datadir}/opera/java
136 %{_datadir}/opera/skin
137 %{_datadir}/opera/scripts
138 %{_datadir}/opera/styles
139 %{_datadir}/opera/ui
140 %{_datadir}/opera/unite
141 %dir %{_datadir}/opera/locale
142 %{_datadir}/opera/locale/en
143 #%lang(be) %{_datadir}/opera/locale/be
144 #%lang(bg) %{_datadir}/opera/locale/bg
145 #%lang(cs) %{_datadir}/opera/locale/cs
146 #%lang(da) %{_datadir}/opera/locale/da
147 #%lang(de) %{_datadir}/opera/locale/de
148 #%lang(el) %{_datadir}/opera/locale/el
149 #%lang(en_GB) %{_datadir}/opera/locale/en-GB
150 #%lang(es_ES) %{_datadir}/opera/locale/es-ES
151 #%lang(es_LA) %{_datadir}/opera/locale/es-LA
152 #%lang(et) %{_datadir}/opera/locale/et
153 #%lang(fi) %{_datadir}/opera/locale/fi
154 #%lang(fr) %{_datadir}/opera/locale/fr
155 #%lang(fr_CA) %{_datadir}/opera/locale/fr-CA
156 #%lang(fy) %{_datadir}/opera/locale/fy
157 #%lang(hi) %{_datadir}/opera/locale/hi
158 #%lang(hr) %{_datadir}/opera/locale/hr
159 #%lang(hu) %{_datadir}/opera/locale/hu
160 #%lang(id) %{_datadir}/opera/locale/id
161 #%lang(it) %{_datadir}/opera/locale/it
162 #%lang(ja) %{_datadir}/opera/locale/ja
163 #%lang(ka) %{_datadir}/opera/locale/ka
164 #%lang(ko) %{_datadir}/opera/locale/ko
165 #%lang(lt) %{_datadir}/opera/locale/lt
166 #%lang(mk) %{_datadir}/opera/locale/mk
167 #%lang(nb) %{_datadir}/opera/locale/nb
168 #%lang(nl) %{_datadir}/opera/locale/nl
169 #%lang(nn) %{_datadir}/opera/locale/nn
170 #%lang(pl) %{_datadir}/opera/locale/pl
171 #%lang(pt) %{_datadir}/opera/locale/pt
172 #%lang(pt_BR) %{_datadir}/opera/locale/pt-BR
173 #%lang(ro) %{_datadir}/opera/locale/ro
174 #%lang(ru) %{_datadir}/opera/locale/ru
175 #%lang(sk) %{_datadir}/opera/locale/sk
176 #%lang(sr) %{_datadir}/opera/locale/sr
177 #%lang(sv) %{_datadir}/opera/locale/sv
178 #%lang(ta) %{_datadir}/opera/locale/ta
179 #%lang(te) %{_datadir}/opera/locale/te
180 #%lang(tr) %{_datadir}/opera/locale/tr
181 #%lang(uk) %{_datadir}/opera/locale/uk
182 %lang(zh_CN) %{_datadir}/opera/locale/zh-cn
183 %lang(zh_HK) %{_datadir}/opera/locale/zh-hk
184 %lang(zh_TW) %{_datadir}/opera/locale/zh-tw
185 %{_desktopdir}/*.desktop
186 %{_mandir}/man1/opera.1*
187 %{_pixmapsdir}/opera.xpm
188 %{_iconsdir}/hicolor/*/*/*.*
189
190 %ifarch %{x8664}
191 %files plugin32
192 %defattr(644,root,root,755)
193 %attr(755,root,root) %{_libdir}/opera/*-ia32-*
194 %endif
This page took 0.480517 seconds and 4 git commands to generate.