]> git.pld-linux.org Git - packages/opera.git/blob - opera.spec
- bcond for shared version - works ok. Default mode perhaps?
[packages/opera.git] / opera.spec
1 #
2 # There're some problems with "shared" version
3 #
4 %define ver     7.23
5 %define dirrel  20031119
6 %{!?_with_shared:%define        rel     %{dirrel}.1}
7 %{?_with_shared:%define rel     %{dirrel}.5}
8 %{!?_with_shared:%define type   static}
9 %{?_with_shared:%define type    shared}
10 Summary:        World fastest web browser
11 Summary(pl):    Najszybsza przegl±darka WWW na ¶wiecie
12 Name:           opera
13 Version:        %{ver}.%{rel}
14 Release:        1
15 License:        Restricted, see file LICENSE
16 Group:          X11/Applications/Networking
17 Source0:        ftp://ftp.opera.com/pub/opera/linux/723/final/en/i386/%{type}/%{name}-%{ver}-%{rel}-%{type}-qt.i386-en.tar.bz2
18 Source1:        ftp://ftp.opera.com/pub/opera/linux/723/final/en/sparc/%{type}/%{name}-%{ver}-%{rel}-%{type}-qt.sparc-en.tar.bz2
19 Source2:        ftp://ftp.opera.com/pub/opera/linux/723/final/en/ppc/%{type}/%{name}-%{ver}-%{rel}-%{type}-qt.ppc-en.tar.bz2
20 # polish language file (taken from where?)
21 Source3:        %{name}-2887.lng
22 Source4:        %{name}.desktop
23 NoSource:       0
24 URL:            http://www.opera.com/
25 ExclusiveArch:  %{ix86} ppc sparc sparc64
26 Requires:       freetype >= 2
27 Requires:       openmotif >= 2
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %define         _plugindir      %{_libdir}/opera/plugins
31 %define         _operadocdir    %{_docdir}/%{name}-%{ver}.%{rel}
32 %define         configfile      %{_datadir}/opera/config/opera6rc
33
34 %description
35 Opera is world fastest web browser. It supports most of nowaday
36 extensions of HTML. And it is quite stable. Only disadvantage are
37 advertisements on the top of its window. Version static linked with
38 qt.
39
40 %description -l pl
41 Opera jest najszybsz± przegl±dark± WWW na ¶wiecie. Obs³uguje wiêkszo¶æ
42 dzisiejszych rozszerzeñ HTMLa. Dodatkowo jest w miarê stabilna. Jedyn±
43 niedogodno¶ci± s± reklamy ukazuj±ce siê w górze okna. Wersja
44 statycznie skonsolidowana z qt.
45
46 %prep
47 %ifarch %{ix86}
48 %setup -q  -n %{name}-%{ver}-%{rel}-%{type}-qt.i386-en
49 %endif
50 %ifarch sparc sparc64
51 %setup -q -T -b 1 -n %{name}-%{ver}-%{rel}-%{type}-qt.sparc-en
52 %endif
53 %ifarch ppc
54 %setup -q -T -b 2 -n %{name}-%{ver}-%{rel}-%{type}-qt.ppc-en
55 %endif
56
57 %install
58 rm -rf $RPM_BUILD_ROOT
59
60 cat install.sh | sed 's|/etc|$RPM_BUILD_ROOT%{_sysconfdir}|' > install2.sh
61 mv install2.sh install.sh
62
63 echo y |\
64 sh install.sh \
65   --prefix=$RPM_BUILD_ROOT%{_prefix} \
66   --wrapperdir=$RPM_BUILD_ROOT%{_bindir} \
67   --docdir=$RPM_BUILD_ROOT%{_operadocdir} \
68   --sharedir=$RPM_BUILD_ROOT%{_datadir}/opera \
69   --exec_prefix=$RPM_BUILD_ROOT%{_datadir}/opera/bin \
70   --plugindir=$RPM_BUILD_ROOT%{_plugindir}
71
72 # Polish locale
73 install %{SOURCE3} $RPM_BUILD_ROOT%{_datadir}/opera/locale/
74
75 # man install
76 install -d $RPM_BUILD_ROOT%{_mandir}/man1
77 install man/opera.1 $RPM_BUILD_ROOT%{_mandir}/man1
78
79 # wrapper correction
80 sed s#$RPM_BUILD_ROOT## > $RPM_BUILD_ROOT%{_bindir}/opera2 $RPM_BUILD_ROOT%{_bindir}/opera
81 mv $RPM_BUILD_ROOT%{_bindir}/opera2 $RPM_BUILD_ROOT%{_bindir}/opera
82
83 # install in kde etc.
84 install -d $RPM_BUILD_ROOT%{_pixmapsdir}
85 install images/opera.xpm $RPM_BUILD_ROOT%{_pixmapsdir}
86
87 install -d $RPM_BUILD_ROOT%{_desktopdir}
88 install %{SOURCE4} $RPM_BUILD_ROOT%{_desktopdir}
89
90 # symlink który niweluje burkanie siê opery :>
91 #ln -sf %{_datadir}/opera/ $RPM_BUILD_ROOT/usr/share/
92 #ln -sf %{_libdir}/opera $RPM_BUILD_ROOT/usr/lib/
93
94 sed -i -e "s#$RPM_BUILD_ROOT##g" $RPM_BUILD_ROOT%{_datadir}/opera/java/*.policy
95
96 %clean
97 rm -rf $RPM_BUILD_ROOT
98
99 %files
100 %defattr(644,root,root,755)
101 %doc LICENSE bugreport help
102 %attr(755,root,root) %{_bindir}/*
103 %dir %{_datadir}/opera
104 %dir %{_datadir}/opera/bin
105 %attr(755,root,root) %{_datadir}/opera/bin/*
106 %{_datadir}/opera/config
107 %{_datadir}/opera/help
108 %{_datadir}/opera/images
109 %{_datadir}/opera/java
110 %{_datadir}/opera/locale
111 %{_datadir}/opera/skin
112 %{_datadir}/opera/styles
113 %{_datadir}/opera/ini
114 %{_datadir}/opera/search.ini
115 %{_datadir}/opera/*.html
116 %{_datadir}/opera/*.ssr
117 %{_datadir}/opera/*.txt
118 %ifarch %{ix86}
119 %attr(755,root,root) %{_datadir}/opera/chartables.bin
120 %endif
121 %ifarch ppc
122 %attr(755,root,root) %{_datadir}/opera/chartables-be.bin
123 %endif
124 %attr(755,root,root) %{_datadir}/opera/opera6.adr
125 %dir %{_libdir}/opera
126 %dir %{_plugindir}
127 %attr(755,root,root) %{_plugindir}/*
128
129 %{_pixmapsdir}/opera.xpm
130 %{_desktopdir}/*.desktop
131
132 %{_mandir}/man1/opera.1*
This page took 0.038954 seconds and 4 git commands to generate.