]> git.pld-linux.org Git - packages/openssh.git/blob - openssh.spec
- updated to pre17
[packages/openssh.git] / openssh.spec
1 Summary:        OpenSSH free Secure Shell (SSH) implementation
2 Name:           openssh
3 Version:        1.2pre17
4 Release:        1
5 Source0:        http://violet.ibs.com.au/openssh/files/%{name}-%{version}.tar.gz
6 Source1:        opensshd.conf
7 Source2:        openssh.conf
8 Source3:        opensshd.init
9 Source4:        opensshd.pamd
10 Source5:        openssh.sysconfig
11 Source6:        passwd.pamd
12 Patch0:         openssh-ssl.patch
13 Patch1:         openssh-DESTDIR.patch
14 Patch2:         openssh-PAM_NEW_AUTHTOK.patch
15 Patch3:         http://www.misiek.eu.org/ipv6/openssh-1.2pre17-ipv6-untested-12121999.patch.gz
16 License:        BSD
17 Group:          Applications/Networking
18 Group(pl):      Aplikacje/Sieciowe
19 BuildRequires:  openssl-devel
20 BuildRequires:  zlib-devel
21 BuildRequires:  pam-devel
22 BuildRequires:  XFree86-devel
23 BuildRequires:  gnome-libs-devel
24 BuildRoot:      /tmp/%{name}-%{version}-root
25 Obsoletes:      ssh
26
27 %define         _sysconfdir     /etc/ssh
28
29 %description
30 Ssh (Secure Shell) a program for logging into a remote machine and for
31 executing commands in a remote machine.  It is intended to replace
32 rlogin and rsh, and provide secure encrypted communications between
33 two untrusted hosts over an insecure network.  X11 connections and
34 arbitrary TCP/IP ports can also be forwarded over the secure channel.
35
36 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing it
37 up to date in terms of security and features, as well as removing all 
38 patented algorithms to seperate libraries (OpenSSL).
39
40 This package includes the core files necessary for both the OpenSSH
41 client and server.  To make this package useful, you should also
42 install openssh-clients, openssh-server, or both.
43
44 %package clients
45 Summary:        OpenSSH Secure Shell protocol clients
46 Requires:       openssh
47 Group:          Applications/Networking
48 Group(pl):      Aplikacje/Sieciowe
49 Obsoletes:      ssh-clients
50 Requires:       %{name} = %{version}
51
52 %description clients
53 Ssh (Secure Shell) a program for logging into a remote machine and for
54 executing commands in a remote machine.  It is intended to replace
55 rlogin and rsh, and provide secure encrypted communications between
56 two untrusted hosts over an insecure network.  X11 connections and
57 arbitrary TCP/IP ports can also be forwarded over the secure channel.
58
59 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing it
60 up to date in terms of security and features, as well as removing all 
61 patented algorithms to seperate libraries (OpenSSL).
62
63 This package includes the clients necessary to make encrypted connections
64 to SSH servers.
65
66 %package server
67 Summary:        OpenSSH Secure Shell protocol server (sshd)
68 Requires:       openssh chkconfig >= 0.9
69 Group:          Networking/Daemons
70 Group(pl):      Sieciowe/Serwery
71 Obsoletes:      ssh-server
72 Requires:       rc-scripts
73 Prereq:         %{name} = %{version}
74
75 %description server
76 Ssh (Secure Shell) a program for logging into a remote machine and for
77 executing commands in a remote machine.  It is intended to replace
78 rlogin and rsh, and provide secure encrypted communications between
79 two untrusted hosts over an insecure network.  X11 connections and
80 arbitrary TCP/IP ports can also be forwarded over the secure channel.
81
82 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing it
83 up to date in terms of security and features, as well as removing all 
84 patented algorithms to seperate libraries (OpenSSL).
85
86 This package contains the secure shell daemon. The sshd is the server 
87 part of the secure shell protocol and allows ssh clients to connect to 
88 your host.
89
90 %package askpass
91 Summary:        OpenSSH GNOME passphrase dialog
92 Group:          Applications/Networking
93 Group(pl):      Aplikacje/Sieciowe
94 Requires:       %{name} = %{version}
95 Obsoletes:      ssh-extras
96 Obsoletes:      ssh-askpass
97
98 %description askpass
99 Ssh (Secure Shell) a program for logging into a remote machine and for
100 executing commands in a remote machine.  It is intended to replace
101 rlogin and rsh, and provide secure encrypted communications between
102 two untrusted hosts over an insecure network.  X11 connections and
103 arbitrary TCP/IP ports can also be forwarded over the secure channel.
104
105 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing it
106 up to date in terms of security and features, as well as removing all 
107 patented algorithms to seperate libraries (OpenSSL).
108
109 This package contains the GNOME passphrase dialog.
110
111
112 %prep
113 %setup  -q
114 %patch0 -p1
115 %patch1 -p1 
116 %patch2 -p1
117 %patch3 -p1
118
119 %build
120 autoconf
121 %configure \
122         --with-gnome-askpass \
123         --with-tcp-wrappers \
124         --with-md5-passwords \
125         --enable-ipv6 \
126         --enable-log-auth 
127         
128 #       --without-kerberos4 \
129 #       --without-afs \
130 #       --without-skey 
131
132 echo '#define LOGIN_PROGRAM           "/bin/login"' >>config.h
133
134 make
135
136 %install
137 rm -rf $RPM_BUILD_ROOT
138
139 install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/{pam.d,rc.d/init.d,sysconfig}}
140
141 make install \
142         DESTDIR="$RPM_BUILD_ROOT"
143
144 install %{SOURCE4} $RPM_BUILD_ROOT/etc/pam.d/sshd
145 install %{SOURCE6} $RPM_BUILD_ROOT/etc/pam.d/passwdssh
146 install %{SOURCE5} $RPM_BUILD_ROOT/etc/sysconfig/sshd
147 install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
148 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/ssh_config
149 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/sshd_config
150
151 gzip -9fn ChangeLog OVERVIEW COPYING.Ylonen README README.Ylonen UPGRADING \
152         $RPM_BUILD_ROOT/%{_mandir}/man*/*
153         
154 %clean
155 rm -rf $RPM_BUILD_ROOT
156
157 %post server
158 /sbin/chkconfig --add sshd
159 if [ ! -f /etc/ssh/ssh_host_key -o ! -s /etc/ssh/ssh_host_key ]; then
160         /usr/bin/ssh-keygen -b 1024 -f /etc/ssh/ssh_host_key -N '' >&2
161 fi
162 if test -r /var/run/sshd.pid
163 then
164         /etc/rc.d/init.d/sshd restart >&2
165 fi
166 if ! grep ssh /etc/security/passwd.conf >/dev/null 2>&1 ; then
167         echo "ssh" >> /etc/security/passwd.conf
168 fi
169
170 %preun server
171 if [ "$1" = 0 ]
172 then
173         /etc/rc.d/init.d/sshd stop >&2
174         /sbin/chkconfig --del sshd
175 fi
176
177 %files
178 %defattr(644,root,root,755)
179 %doc {ChangeLog,OVERVIEW,COPYING.Ylonen,README,README.Ylonen,UPGRADING}.gz
180 %attr(755,root,root) %{_bindir}/ssh-keygen
181 %{_mandir}/man1/ssh-keygen.1*
182 %dir %{_sysconfdir}
183
184 %files clients
185 %defattr(644,root,root,755)
186 # suid root ?
187 #%attr(4755,root,root) %{_bindir}/ssh
188 %attr(0755,root,root) %{_bindir}/ssh
189 %attr(0755,root,root) %{_bindir}/ssh-agent
190 %attr(0755,root,root) %{_bindir}/ssh-add
191 #%attr(0755,root,root) %{_bindir}/slogin
192 %attr(755,root,root) %{_bindir}/scp
193 %{_mandir}/man1/scp.1*
194 %{_mandir}/man1/ssh.1*
195 %{_mandir}/man1/ssh-agent.1*
196 %{_mandir}/man1/ssh-add.1*
197 #%{_mandir}/man1/slogin.1
198 %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/ssh_config
199
200 %files server
201 %defattr(644,root,root,755)
202 %attr(755,root,root) %{_sbindir}/sshd
203 %{_mandir}/man8/sshd.8*
204 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/sshd_config
205 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/pam.d/sshd
206 %attr(754,root,root) /etc/rc.d/init.d/sshd
207 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/sysconfig/sshd
208
209 %files askpass
210 %defattr(644,root,root,755)
211 %dir %{_libexecdir}/ssh
212 %attr(755,root,root) %{_libexecdir}/ssh/ssh-askpass
This page took 0.149011 seconds and 4 git commands to generate.