]> git.pld-linux.org Git - packages/openssh.git/blob - openssh.spec
- added forced password change patch
[packages/openssh.git] / openssh.spec
1 Summary:        OpenSSH free Secure Shell (SSH) implementation
2 Name:           openssh
3 Version:        1.2pre15
4 Release:        2
5 Source0:        http://violet.ibs.com.au/openssh/files/%{name}-%{version}.tar.gz
6 Source1:        opensshd.conf
7 Source2:        openssh.conf
8 Source3:        opensshd.init
9 Source4:        opensshd.pamd
10 Source5:        openssh.sysconfig
11 Source6:        passwd.pamd
12 Patch0:         openssh-ssl.patch
13 Patch1:         openssh-DESTDIR.patch
14 Patch2:         openssh-PAM_NEW_AUTHTOK.patch
15 License:        BSD
16 Group:          Applications/Networking
17 Group(pl):      Aplikacje/Sieciowe
18 BuildRequires:  openssl-devel
19 BuildRequires:  zlib-devel
20 BuildRequires:  pam-devel
21 BuildRequires:  XFree86-devel
22 BuildRequires:  gnome-libs-devel
23 BuildRoot:      /tmp/%{name}-%{version}-root
24 Obsoletes:      ssh
25
26 %define         _sysconfdir     /etc/ssh
27
28 %description
29 Ssh (Secure Shell) a program for logging into a remote machine and for
30 executing commands in a remote machine.  It is intended to replace
31 rlogin and rsh, and provide secure encrypted communications between
32 two untrusted hosts over an insecure network.  X11 connections and
33 arbitrary TCP/IP ports can also be forwarded over the secure channel.
34
35 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing it
36 up to date in terms of security and features, as well as removing all 
37 patented algorithms to seperate libraries (OpenSSL).
38
39 This package includes the core files necessary for both the OpenSSH
40 client and server.  To make this package useful, you should also
41 install openssh-clients, openssh-server, or both.
42
43 %package clients
44 Summary:        OpenSSH Secure Shell protocol clients
45 Requires:       openssh
46 Group:          Applications/Networking
47 Group(pl):      Aplikacje/Sieciowe
48 Obsoletes:      ssh-clients
49 Requires:       %{name} = %{version}
50
51 %description clients
52 Ssh (Secure Shell) a program for logging into a remote machine and for
53 executing commands in a remote machine.  It is intended to replace
54 rlogin and rsh, and provide secure encrypted communications between
55 two untrusted hosts over an insecure network.  X11 connections and
56 arbitrary TCP/IP ports can also be forwarded over the secure channel.
57
58 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing it
59 up to date in terms of security and features, as well as removing all 
60 patented algorithms to seperate libraries (OpenSSL).
61
62 This package includes the clients necessary to make encrypted connections
63 to SSH servers.
64
65 %package server
66 Summary:        OpenSSH Secure Shell protocol server (sshd)
67 Requires:       openssh chkconfig >= 0.9
68 Group:          Networking/Daemons
69 Group(pl):      Sieciowe/Serwery
70 Obsoletes:      ssh-server
71 Requires:       rc-scripts
72 Prereq:         %{name} = %{version}
73
74 %description server
75 Ssh (Secure Shell) a program for logging into a remote machine and for
76 executing commands in a remote machine.  It is intended to replace
77 rlogin and rsh, and provide secure encrypted communications between
78 two untrusted hosts over an insecure network.  X11 connections and
79 arbitrary TCP/IP ports can also be forwarded over the secure channel.
80
81 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing it
82 up to date in terms of security and features, as well as removing all 
83 patented algorithms to seperate libraries (OpenSSL).
84
85 This package contains the secure shell daemon. The sshd is the server 
86 part of the secure shell protocol and allows ssh clients to connect to 
87 your host.
88
89 %package askpass
90 Summary:        OpenSSH GNOME passphrase dialog
91 Group:          Applications/Networking
92 Group(pl):      Aplikacje/Sieciowe
93 Requires:       %{name} = %{version}
94 Obsoletes:      ssh-extras
95 Obsoletes:      ssh-askpass
96
97 %description askpass
98 Ssh (Secure Shell) a program for logging into a remote machine and for
99 executing commands in a remote machine.  It is intended to replace
100 rlogin and rsh, and provide secure encrypted communications between
101 two untrusted hosts over an insecure network.  X11 connections and
102 arbitrary TCP/IP ports can also be forwarded over the secure channel.
103
104 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing it
105 up to date in terms of security and features, as well as removing all 
106 patented algorithms to seperate libraries (OpenSSL).
107
108 This package contains the GNOME passphrase dialog.
109
110
111 %prep
112 %setup  -q
113 %patch0 -p1
114 %patch1 -p1
115 %patch2 -p1
116
117 %build
118 autoconf
119 %configure \
120         --with-gnome-askpass
121 make
122
123 %install
124 rm -rf $RPM_BUILD_ROOT
125
126 install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/{pam.d,rc.d/init.d,sysconfig}}
127
128 make install \
129         DESTDIR="$RPM_BUILD_ROOT"
130
131 install %{SOURCE4} $RPM_BUILD_ROOT/etc/pam.d/sshd
132 install %{SOURCE6} $RPM_BUILD_ROOT/etc/pam.d/passwdssh
133 install %{SOURCE5} $RPM_BUILD_ROOT/etc/sysconfig/sshd
134 install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
135 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/ssh_config
136 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/sshd_config
137
138 gzip -9fn ChangeLog OVERVIEW COPYING.Ylonen README README.Ylonen UPGRADING \
139         $RPM_BUILD_ROOT/%{_mandir}/man*/*
140         
141 %clean
142 rm -rf $RPM_BUILD_ROOT
143
144 %post server
145 /sbin/chkconfig --add sshd
146 if [ ! -f /etc/ssh/ssh_host_key -o ! -s /etc/ssh/ssh_host_key ]; then
147         /usr/bin/ssh-keygen -b 1024 -f /etc/ssh/ssh_host_key -N '' >&2
148 fi
149 if test -r /var/run/sshd.pid
150 then
151         /etc/rc.d/init.d/sshd restart >&2
152 fi
153 if ! grep ssh /etc/security/passwd.conf >/dev/null 2>&1 ; then
154         echo "ssh" >> /etc/security/passwd.conf
155 fi
156
157 %preun server
158 if [ "$1" = 0 ]
159 then
160         /etc/rc.d/init.d/sshd stop >&2
161         /sbin/chkconfig --del sshd
162 fi
163
164 %files
165 %defattr(644,root,root,755)
166 %doc {ChangeLog,OVERVIEW,COPYING.Ylonen,README,README.Ylonen,UPGRADING}.gz
167 %attr(755,root,root) %{_bindir}/ssh-keygen
168 %{_mandir}/man1/ssh-keygen.1*
169 %dir %{_sysconfdir}
170
171 %files clients
172 %defattr(644,root,root,755)
173 # suid root ?
174 #%attr(4755,root,root) %{_bindir}/ssh
175 %attr(0755,root,root) %{_bindir}/ssh
176 %attr(0755,root,root) %{_bindir}/ssh-agent
177 %attr(0755,root,root) %{_bindir}/ssh-add
178 #%attr(0755,root,root) %{_bindir}/slogin
179 %attr(755,root,root) %{_bindir}/scp
180 %{_mandir}/man1/scp.1*
181 %{_mandir}/man1/ssh.1*
182 %{_mandir}/man1/ssh-agent.1*
183 %{_mandir}/man1/ssh-add.1*
184 #%{_mandir}/man1/slogin.1
185 %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/ssh_config
186
187 %files server
188 %defattr(644,root,root,755)
189 %attr(755,root,root) %{_sbindir}/sshd
190 %{_mandir}/man8/sshd.8*
191 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/sshd_config
192 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/pam.d/sshd
193 %attr(754,root,root) /etc/rc.d/init.d/sshd
194 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/sysconfig/sshd
195
196 %files askpass
197 %defattr(644,root,root,755)
198 %dir %{_libexecdir}/ssh
199 %attr(755,root,root) %{_libexecdir}/ssh/ssh-askpass
This page took 0.040424 seconds and 4 git commands to generate.