]> git.pld-linux.org Git - packages/openssh.git/blob - openssh.spec
- make rel to stand out from macros
[packages/openssh.git] / openssh.spec
1 #
2 # Conditional build:
3 %bcond_without  chroot          # without chrooted user environment support
4 %bcond_with     gnome           # with gnome-askpass (GNOME 1.x) utility
5 %bcond_without  gtk             # without GTK+ (2.x)
6 %bcond_with     ldap            # with ldap support
7 %bcond_without  libedit         # without libedit (editline/history support in sftp client)
8 %bcond_without  kerberos5       # without kerberos5 support
9 %bcond_without  selinux         # build without SELinux support
10 %bcond_with     hpn             # with High Performance SSH/SCP - HPN-SSH (see patch comment)
11 %bcond_with     hpn_none        # with hpn (above) and '-z' none cipher option
12 #
13 %if %{with hpn_none}
14 %undefine       with_hpn
15 %endif
16 # gtk2-based gnome-askpass means no gnome1-based
17 %{?with_gtk:%undefine with_gnome}
18 #
19 %define         _rel    5
20 #
21 Summary:        OpenSSH free Secure Shell (SSH) implementation
22 Summary(de.UTF-8):      OpenSSH - freie Implementation der Secure Shell (SSH)
23 Summary(es.UTF-8):      Implementación libre de SSH
24 Summary(fr.UTF-8):      Implémentation libre du shell sécurisé OpenSSH (SSH)
25 Summary(it.UTF-8):      Implementazione gratuita OpenSSH della Secure Shell
26 Summary(pl.UTF-8):      Publicznie dostępna implementacja bezpiecznego shella (SSH)
27 Summary(pt.UTF-8):      Implementação livre OpenSSH do protocolo 'Secure Shell' (SSH)
28 Summary(pt_BR.UTF-8):   Implementação livre do SSH
29 Summary(ru.UTF-8):      OpenSSH - свободная реализация протокола Secure Shell (SSH)
30 Summary(uk.UTF-8):      OpenSSH - вільна реалізація протоколу Secure Shell (SSH)
31 Name:           openssh
32 Version:        4.6p1
33 Release:        %{_rel}%{?with_hpn:hpn}%{?with_hpn_none:hpn_none}
34 Epoch:          2
35 License:        BSD
36 Group:          Applications/Networking
37 Source0:        ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/%{name}-%{version}.tar.gz
38 # Source0-md5:  6a7fa99f44d9e1b5b04d15256e1405bb
39 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
40 # Source1-md5:  66943d481cc422512b537bcc2c7400d1
41 Source2:        %{name}d.init
42 Source3:        %{name}d.pamd
43 Source4:        %{name}.sysconfig
44 Source5:        ssh-agent.sh
45 Source6:        ssh-agent.conf
46 Patch0:         %{name}-no_libnsl.patch
47 Patch1:         %{name}-sshv1-openssl.patch
48 Patch2:         %{name}-linux-ipv6.patch
49 Patch3:         %{name}-pam_misc.patch
50 Patch4:         %{name}-sigpipe.patch
51 # http://www.opendarwin.org/projects/openssh-lpk/
52 Patch5:         %{name}-lpk-4.3p1-0.3.7.patch
53 Patch6:         %{name}-config.patch
54 Patch7:         %{name}-pam-conv.patch
55 # http://chrootssh.sourceforge.net/download/osshChroot-3.7.1p2.diff
56 Patch8:         %{name}-chroot.patch
57 Patch9:         %{name}-selinux.patch
58 # HPN patches rediffed due sigpipe patch.
59 # High Performance SSH/SCP - HPN-SSH - http://www.psc.edu/networking/projects/hpn-ssh/
60 # http://www.psc.edu/networking/projects/hpn-ssh/openssh-4.2p1-hpn11.diff
61 Patch10:        %{name}-4.3p1-hpn11.patch
62 # Adds HPN (see p11) and an undocumented -z none cipher flag
63 # http://www.psc.edu/networking/projects/hpn-ssh/openssh-4.2p1-hpn11-none.diff
64 Patch11:        %{name}-4.3p1-hpn11-none.patch
65 Patch12:        %{name}-include.patch
66 URL:            http://www.openssh.com/
67 BuildRequires:  %{__perl}
68 BuildRequires:  autoconf
69 BuildRequires:  automake
70 %{?with_gnome:BuildRequires:    gnome-libs-devel}
71 %{?with_gtk:BuildRequires:      gtk+2-devel}
72 %{?with_kerberos5:BuildRequires:        krb5-devel}
73 %{?with_libedit:BuildRequires:  libedit-devel}
74 %{?with_selinux:BuildRequires:  libselinux-devel}
75 BuildRequires:  libwrap-devel
76 %{?with_ldap:BuildRequires:     openldap-devel}
77 BuildRequires:  openssl-devel >= 0.9.7d
78 BuildRequires:  pam-devel
79 %{?with_gtk:BuildRequires:      pkgconfig}
80 BuildRequires:  rpmbuild(macros) >= 1.318
81 BuildRequires:  zlib-devel
82 Requires:       filesystem >= 3.0-11
83 Requires:       pam >= 0.99.7.1
84 Obsoletes:      ssh
85 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
86
87 %define         _sysconfdir     /etc/ssh
88 %define         _libexecdir     %{_libdir}/%{name}
89 %define         _privsepdir     /usr/share/empty
90
91 %description
92 Ssh (Secure Shell) a program for logging into a remote machine and for
93 executing commands in a remote machine. It is intended to replace
94 rlogin and rsh, and provide secure encrypted communications between
95 two untrusted hosts over an insecure network. X11 connections and
96 arbitrary TCP/IP ports can also be forwarded over the secure channel.
97
98 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
99 it up to date in terms of security and features, as well as removing
100 all patented algorithms to seperate libraries (OpenSSL).
101
102 This package includes the core files necessary for both the OpenSSH
103 client and server. To make this package useful, you should also
104 install openssh-clients, openssh-server, or both.
105 %if %{with hpn} || %{with hpn_none}
106 This release includes High Performance SSH/SCP patches from
107 http://www.psc.edu/networking/projects/hpn-ssh/ which are supposed
108 to increase throughput on fast connections with high RTT (20-150 msec).
109 See the website for '-w' values for your connection and /proc/sys TCP
110 values. BTW. in a LAN you have got generally RTT < 1 msec.
111 %endif
112 %if %{with hpn_none}
113 It also includes an undocumented '-z' option which switches
114 the cipher to none after authentication is completed. Data is
115 still secured from tampering and corruption in transit through
116 the use of the Message Authentication Code (MAC).
117 This option will significantly reduce the number of cpu cycles used
118 by the SSH/SCP process. This may allow some users to see significant
119 improvement in (sniffable) data tranfer rates.
120 %endif
121
122 %description -l de.UTF-8
123 OpenSSH (Secure Shell) stellt den Zugang zu anderen Rechnern her. Es
124 ersetzt telnet, rlogin, rexec und rsh und stellt eine sichere,
125 verschlüsselte Verbindung zwischen zwei nicht vertrauenswürdigen Hosts
126 über eine unsicheres Netzwerk her. X11 Verbindungen und beliebige
127 andere TCP/IP Ports können ebenso über den sicheren Channel
128 weitergeleitet werden.
129
130 %description -l es.UTF-8
131 SSH es un programa para accesar y ejecutar órdenes en computadores
132 remotos. Sustituye rlogin y rsh, y suministra un canal de comunicación
133 seguro entre dos servidores en una red insegura. Conexiones X11 y
134 puertas TCP/IP arbitrárias también pueden ser usadas por el canal
135 seguro.
136
137 OpenSSH es el resultado del trabajo del equipo de OpenBSD para
138 continuar la última versión gratuita de SSH, actualizándolo en
139 términos de seguridad y recursos,así también eliminando todos los
140 algoritmos patentados y colocándolos en bibliotecas separadas
141 (OpenSSL).
142
143 Este paquete contiene "port" para Linux de OpenSSH. Se debe instalar
144 también el paquete openssh-clients u openssh-server o ambos.
145
146 %description -l fr.UTF-8
147 OpenSSH (Secure Shell) fournit un accès à un système distant. Il
148 remplace telnet, rlogin, rexec et rsh, tout en assurant des
149 communications cryptées securisées entre deux hôtes non fiabilisés sur
150 un réseau non sécurisé. Des connexions X11 et des ports TCP/IP
151 arbitraires peuvent également être transmis sur le canal sécurisé.
152
153 %description -l it.UTF-8
154 OpenSSH (Secure Shell) fornisce l'accesso ad un sistema remoto.
155 Sostituisce telnet, rlogin, rexec, e rsh, e fornisce comunicazioni
156 sicure e crittate tra due host non fidati su una rete non sicura. Le
157 connessioni X11 ad una porta TCP/IP arbitraria possono essere
158 inoltrate attraverso un canale sicuro.
159
160 %description -l pl.UTF-8
161 Ssh (Secure Shell) to program służący do logowania się na zdalną
162 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
163 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
164 pomiędzy dwoma hostami.
165
166 Ten pakiet zawiera podstawowe pliki potrzebne zarówno po stronie
167 klienta jak i serwera OpenSSH. Aby był użyteczny, trzeba zainstalować
168 co najmniej jeden z pakietów: openssh-clients lub openssh-server.
169 %if %{with hpn} || %{with hpn_none}
170 Ta wersja zawiera łaty z projektu High Performance SSH/SCP
171 http://www.psc.edu/networking/projects/hpn-ssh/, które mają na celu
172 zwiększenie przepustowości transmisji dla szybkich połączeń
173 z dużym RTT (20-150 msec). Na stronie projektu znaleźć można
174 odpowednie dla danego połączenia wartości parametru '-w' oraz
175 opcje /proc/sys dla TCP. Nawiasem mówiąc w sieciach LAN RTT < 1 msec.
176 %endif
177 %if %{with hpn_none}
178 Obsługiwana jest również nieudokumentowana opcja '-z' odpowiedzialna
179 za wyłączenie szyfrowania danych po zakończeniu procesu uwierzytelniania.
180 Dane są zabezpieczone przed modyfikacją lub uszkodzeniem przez
181 stosowanie Message Authentication Code (MAC).
182 Opcja ta znacznie redukuje liczbę cykli procesora zużywanych przez
183 procesy SSH/SCP. W wybranych zastosowaniach może ona wpłynąć
184 na wyraźne przyspieszenie (podsłuchiwalnej) transmisji danych.
185 %endif
186
187 %description -l pt.UTF-8
188 OpenSSH (Secure Shell) fornece acesso a um sistema remoto. Substitui o
189 telnet, rlogin, rexec, e o rsh e fornece comunicações seguras e
190 cifradas entre duas máquinas sem confiança mútua sobre uma rede
191 insegura. Ligações X11 e portos TCP/IP arbitrários também poder ser
192 reenviados pelo canal seguro.
193
194 %description -l pt_BR.UTF-8
195 SSH é um programa para acessar e executar comandos em máquinas
196 remotas. Ele substitui rlogin e rsh, e provem um canal de comunicação
197 seguro entre dois hosts em uma rede insegura. Conexões X11 e portas
198 TCP/IP arbitrárias também podem ser usadas pelo canal seguro.
199
200 OpenSSH é o resultado do trabalho da equipe do OpenBSD em continuar a
201 última versão gratuita do SSH, atualizando-o em termos de segurança e
202 recursos, assim como removendo todos os algoritmos patenteados e
203 colocando-os em bibliotecas separadas (OpenSSL).
204
205 Esse pacote contém o "port" pra Linux do OpenSSH. Você deve instalar
206 também ou o pacote openssh-clients, ou o openssh-server, ou ambos.
207
208 %description -l ru.UTF-8
209 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
210 машину и для выполнения команд на удаленной машине. Она предназначена
211 для замены rlogin и rsh и обеспечивает безопасную шифрованную
212 коммуникацию между двумя хостами в сети, являющейся небезопасной.
213 Соединения X11 и любые порты TCP/IP могут также быть проведены через
214 безопасный канал.
215
216 OpenSSH - это переделка командой разработчиков OpenBSD последней
217 свободной версии SSH, доведенная до современного состояния в терминах
218 уровня безопасности и поддерживаемых возможностей. Все патентованные
219 алгоритмы вынесены в отдельные библиотеки (OpenSSL).
220
221 Этот пакет содержит файлы, необходимые как для клиента, так и для
222 сервера OpenSSH. Вам нужно будет установить еще openssh-clients,
223 openssh-server, или оба пакета.
224
225 %description -l uk.UTF-8
226 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
227 машини та для виконання команд на віддаленій машині. Вона призначена
228 для заміни rlogin та rsh і забезпечує безпечну шифровану комунікацію
229 між двома хостами в мережі, яка не є безпечною. З'єднання X11 та
230 довільні порти TCP/IP можуть також бути проведені через безпечний
231 канал.
232
233 OpenSSH - це переробка командою розробників OpenBSD останньої вільної
234 версії SSH, доведена до сучасного стану в термінах рівня безпеки та
235 підтримуваних можливостей. Всі патентовані алгоритми винесені до
236 окремих бібліотек (OpenSSL).
237
238 Цей пакет містить файли, необхідні як для клієнта, так і для сервера
239 OpenSSH. Вам потрібно буде ще встановити openssh-clients,
240 openssh-server, чи обидва пакети.
241
242 %package clients
243 Summary:        OpenSSH Secure Shell protocol clients
244 Summary(es.UTF-8):      Clientes de OpenSSH
245 Summary(pl.UTF-8):      Klienci protokołu Secure Shell
246 Summary(pt_BR.UTF-8):   Clientes do OpenSSH
247 Summary(ru.UTF-8):      OpenSSH - клиенты протокола Secure Shell
248 Summary(uk.UTF-8):      OpenSSH - клієнти протоколу Secure Shell
249 Group:          Applications/Networking
250 Requires:       %{name} = %{epoch}:%{version}-%{release}
251 Provides:       ssh-clients
252 Obsoletes:      ssh-clients
253
254 %description clients
255 Ssh (Secure Shell) a program for logging into a remote machine and for
256 executing commands in a remote machine. It is intended to replace
257 rlogin and rsh, and provide secure encrypted communications between
258 two untrusted hosts over an insecure network. X11 connections and
259 arbitrary TCP/IP ports can also be forwarded over the secure channel.
260
261 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
262 it up to date in terms of security and features, as well as removing
263 all patented algorithms to seperate libraries (OpenSSL).
264
265 This package includes the clients necessary to make encrypted
266 connections to SSH servers.
267
268 %description clients -l es.UTF-8
269 Este paquete incluye los clientes que se necesitan para hacer
270 conexiones codificadas con servidores SSH.
271
272 %description clients -l pl.UTF-8
273 Ssh (Secure Shell) to program służący do logowania się na zdalną
274 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
275 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
276 pomiędzy dwoma hostami.
277
278 Ten pakiet zawiera klientów służących do łączenia się z serwerami SSH.
279
280 %description clients -l pt_BR.UTF-8
281 Esse pacote inclui os clientes necessários para fazer conexões
282 encriptadas com servidores SSH.
283
284 %description clients -l ru.UTF-8
285 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
286 машину и для выполнения команд на удаленной машине.
287
288 Этот пакет содержит программы-клиенты, необходимые для установления
289 зашифрованных соединений с серверами SSH.
290
291 %description clients -l uk.UTF-8
292 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
293 машини та для виконання команд на віддаленій машині.
294
295 Цей пакет містить програми-клієнти, необхідні для встановлення
296 зашифрованих з'єднань з серверами SSH.
297
298 %package clients-agent-profile_d
299 Summary:        OpenSSH Secure Shell agent init script
300 Summary(pl.UTF-8):      Skrypt startowy agenta OpenSSH
301 Group:          Applications/Networking
302 Requires:       %{name}-clients = %{epoch}:%{version}-%{release}
303
304 %description clients-agent-profile_d
305 profile.d scripts for starting SSH agent.
306
307 %description clients-agent-profile_d -l pl.UTF-8
308 Skrypty profile.d do uruchamiania agenta SSH.
309
310 %package clients-agent-xinitrc
311 Summary:        OpenSSH Secure Shell agent init script
312 Summary(pl.UTF-8):      Skrypt inicjujący agenta ssh przez xinitrc
313 Group:          Applications/Networking
314 Requires:       %{name}-clients-agent-profile_d = %{epoch}:%{version}-%{release}
315 Requires:       xinitrc
316
317 %description clients-agent-xinitrc
318 xinitrc scripts for starting SSH agent.
319
320 %description clients-agent-xinitrc -l pl.UTF-8
321 Skrypty xinitrc do uruchamiania agenta SSH.
322
323 %package server
324 Summary:        OpenSSH Secure Shell protocol server (sshd)
325 Summary(de.UTF-8):      OpenSSH Secure Shell Protocol-Server (sshd)
326 Summary(es.UTF-8):      Servidor OpenSSH para comunicaciones codificadas
327 Summary(fr.UTF-8):      Serveur de protocole du shell sécurisé OpenSSH (sshd)
328 Summary(it.UTF-8):      Server OpenSSH per il protocollo Secure Shell (sshd)
329 Summary(pl.UTF-8):      Serwer protokołu Secure Shell (sshd)
330 Summary(pt.UTF-8):      Servidor do protocolo 'Secure Shell' OpenSSH (sshd)
331 Summary(pt_BR.UTF-8):   Servidor OpenSSH para comunicações encriptadas
332 Summary(ru.UTF-8):      OpenSSH - сервер протокола Secure Shell (sshd)
333 Summary(uk.UTF-8):      OpenSSH - сервер протоколу Secure Shell (sshd)
334 Group:          Networking/Daemons
335 Requires(post): chkconfig >= 0.9
336 Requires(post): grep
337 Requires(post,preun):   /sbin/chkconfig
338 Requires(postun):       /usr/sbin/userdel
339 Requires(pre):  /bin/id
340 Requires(pre):  /usr/sbin/useradd
341 Requires:       %{name} = %{epoch}:%{version}-%{release}
342 Requires:       /bin/login
343 Requires:       pam >= 0.99.7.1
344 Requires:       rc-scripts >= 0.4.0.18
345 Requires:       util-linux
346 Provides:       ssh-server
347 Provides:       user(sshd)
348
349 %description server
350 Ssh (Secure Shell) a program for logging into a remote machine and for
351 executing commands in a remote machine. It is intended to replace
352 rlogin and rsh, and provide secure encrypted communications between
353 two untrusted hosts over an insecure network. X11 connections and
354 arbitrary TCP/IP ports can also be forwarded over the secure channel.
355
356 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
357 it up to date in terms of security and features, as well as removing
358 all patented algorithms to seperate libraries (OpenSSL).
359
360 This package contains the secure shell daemon. The sshd is the server
361 part of the secure shell protocol and allows ssh clients to connect to
362 your host.
363
364 %description server -l de.UTF-8
365 Dieses Paket installiert den sshd, den Server-Teil der OpenSSH.
366
367 %description server -l es.UTF-8
368 Este paquete contiene el servidor SSH. sshd es la parte servidor del
369 protocolo secure shell y permite que clientes ssh se conecten a su
370 servidor.
371
372 %description server -l fr.UTF-8
373 Ce paquetage installe le 'sshd', partie serveur de OpenSSH.
374
375 %description server -l it.UTF-8
376 Questo pacchetto installa sshd, il server di OpenSSH.
377
378 %description server -l pl.UTF-8
379 Ssh (Secure Shell) to program służący do logowania się na zdalną
380 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
381 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
382 pomiędzy dwoma hostami.
383
384 Ten pakiet zawiera serwer sshd (do którego mogą łączyć się klienci
385 ssh).
386
387 %description server -l pt.UTF-8
388 Este pacote intala o sshd, o servidor do OpenSSH.
389
390 %description server -l pt_BR.UTF-8
391 Esse pacote contém o servidor SSH. O sshd é a parte servidor do
392 protocolo secure shell e permite que clientes ssh se conectem ao seu
393 host.
394
395 %description server -l ru.UTF-8
396 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
397 машину и для выполнения команд на удаленной машине.
398
399 Этот пакет содержит sshd - "демон" Secure Shell. sshd - это серверная
400 часть протокола Secure Shell, позволяющая клиентам ssh соединяться с
401 вашим хостом.
402
403 %description server -l uk.UTF-8
404 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
405 машини та для виконання команд на віддаленій машині.
406
407 Цей пакет містить sshd - "демон" Secure Shell. sshd - це серверна
408 частина протоколу Secure Shell, яка дозволяє клієнтам ssh зв'язуватись
409 з вашим хостом.
410
411 %package gnome-askpass
412 Summary:        OpenSSH GNOME passphrase dialog
413 Summary(de.UTF-8):      OpenSSH GNOME Passwort-Dialog
414 Summary(es.UTF-8):      Diálogo para introducción de passphrase para GNOME
415 Summary(fr.UTF-8):      Dialogue pass-phrase GNOME d'OpenSSH
416 Summary(it.UTF-8):      Finestra di dialogo GNOME per la frase segreta di OpenSSH
417 Summary(pl.UTF-8):      Odpytywacz hasła OpenSSH dla GNOME
418 Summary(pt.UTF-8):      Diálogo de pedido de senha para GNOME do OpenSSH
419 Summary(pt_BR.UTF-8):   Diálogo para entrada de passphrase para GNOME
420 Summary(ru.UTF-8):      OpenSSH - диалог ввода ключевой фразы (passphrase) для GNOME
421 Summary(uk.UTF-8):      OpenSSH - діалог вводу ключової фрази (passphrase) для GNOME
422 Group:          Applications/Networking
423 Requires:       %{name} = %{epoch}:%{version}-%{release}
424 Obsoletes:      openssh-askpass
425 Obsoletes:      ssh-askpass
426 Obsoletes:      ssh-extras
427
428 %description gnome-askpass
429 Ssh (Secure Shell) a program for logging into a remote machine and for
430 executing commands in a remote machine. It is intended to replace
431 rlogin and rsh, and provide secure encrypted communications between
432 two untrusted hosts over an insecure network. X11 connections and
433 arbitrary TCP/IP ports can also be forwarded over the secure channel.
434
435 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
436 it up to date in terms of security and features, as well as removing
437 all patented algorithms to seperate libraries (OpenSSL).
438
439 This package contains the GNOME passphrase dialog.
440
441 %description gnome-askpass -l es.UTF-8
442 Este paquete contiene un programa que abre una caja de diálogo para
443 entrada de passphrase en GNOME.
444
445 %description gnome-askpass -l pl.UTF-8
446 Ssh (Secure Shell) to program służący do logowania się na zdalną
447 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
448 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
449 pomiędzy dwoma hostami.
450
451 Ten pakiet zawiera ,,odpytywacz hasła'' dla GNOME.
452
453 %description gnome-askpass -l pt_BR.UTF-8
454 Esse pacote contém um programa que abre uma caixa de diálogo para
455 entrada de passphrase no GNOME.
456
457 %description gnome-askpass -l ru.UTF-8
458 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
459 машину и для выполнения команд на удаленной машине.
460
461 Этот пакет содержит диалог ввода ключевой фразы для использования под
462 GNOME.
463
464 %description gnome-askpass -l uk.UTF-8
465 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
466 машини та для виконання команд на віддаленій машині.
467
468 Цей пакет містить діалог вводу ключової фрази для використання під
469 GNOME.
470
471 %prep
472 %setup -q
473 %patch0 -p1
474 %patch1 -p1
475 %patch2 -p1
476 %patch3 -p1
477 %patch4 -p1
478 %{?with_ldap:%patch5 -p1}
479 %patch6 -p1
480 #%patch7 -p1
481 %patch8 -p1
482 %patch9 -p1
483 %{?with_hpn:%patch10 -p1}
484 %{?with_hpn_none:%patch11 -p1}
485 %patch12 -p1
486
487 %build
488 cp /usr/share/automake/config.sub .
489 %{__aclocal}
490 %{__autoconf}
491 %{?with_chroot:CPPFLAGS="-DCHROOT"}
492 %configure \
493         PERL=%{__perl} \
494         --with-dns \
495         --with-pam \
496         --with-mantype=man \
497         --with-md5-passwords \
498         --with-ipaddr-display \
499         %{?with_libedit:--with-libedit} \
500         --with-4in6 \
501         --disable-suid-ssh \
502         --with-tcp-wrappers \
503         %{?with_ldap:--with-libs="-lldap -llber"} \
504         %{?with_ldap:--with-cppflags="-DWITH_LDAP_PUBKEY"} \
505         %{?with_kerberos5:--with-kerberos5=/usr} \
506         --with-privsep-path=%{_privsepdir} \
507         --with-pid-dir=%{_localstatedir}/run \
508         --with-xauth=/usr/bin/xauth \
509         --enable-utmpx \
510         --enable-wtmpx
511
512 echo '#define LOGIN_PROGRAM                "/bin/login"' >>config.h
513
514 %{__make}
515
516 cd contrib
517 %if %{with gnome}
518 %{__make} gnome-ssh-askpass1 \
519         CC="%{__cc} %{rpmldflags} %{rpmcflags}"
520 %endif
521 %if %{with gtk}
522 %{__make} gnome-ssh-askpass2 \
523         CC="%{__cc} %{rpmldflags} %{rpmcflags}"
524 %endif
525
526 %install
527 rm -rf $RPM_BUILD_ROOT
528 install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/{pam.d,rc.d/init.d,sysconfig,security,env.d}} \
529         $RPM_BUILD_ROOT%{_libexecdir}/ssh
530 install -d $RPM_BUILD_ROOT/etc/{profile.d,X11/xinit/xinitrc.d}
531
532 %{__make} install \
533         DESTDIR=$RPM_BUILD_ROOT
534
535 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
536
537 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
538 install %{SOURCE3} $RPM_BUILD_ROOT/etc/pam.d/sshd
539 install %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/sshd
540 install %{SOURCE5} $RPM_BUILD_ROOT/etc/profile.d
541 ln -sf  /etc/profile.d/ssh-agent.sh $RPM_BUILD_ROOT/etc/X11/xinit/xinitrc.d/ssh-agent.sh
542 install %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}
543
544 %if %{with gnome}
545 install contrib/gnome-ssh-askpass1 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
546 %endif
547 %if %{with gtk}
548 install contrib/gnome-ssh-askpass2 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
549 %endif
550 %if %{with gnome} || %{with gtk}
551 cat << EOF >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_SERVER
552 #GNOME_SSH_ASKPASS_GRAB_SERVER="true"
553 EOF
554 cat << EOF >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_POINTER
555 #GNOME_SSH_ASKPASS_GRAB_POINTER="true"
556 EOF
557 ln -s %{_libexecdir}/ssh/ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/ssh-askpass
558 %endif
559
560 rm -f   $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
561 echo ".so ssh.1" > $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
562
563 touch $RPM_BUILD_ROOT/etc/security/blacklist.sshd
564
565 %if "%{_lib}" != "lib"
566 find $RPM_BUILD_ROOT%{_sysconfdir} -type f -print0 | xargs -0 sed -i -e 's#%{_prefix}/lib#%{_libdir}#'
567 %endif
568
569 cat << 'EOF' > $RPM_BUILD_ROOT/etc/env.d/SSH_ASKPASS
570 #SSH_ASKPASS="%{_libexecdir}/ssh-askpass"
571 EOF
572
573 %clean
574 rm -rf $RPM_BUILD_ROOT
575
576 %post clients
577 %env_update
578
579 %postun clients
580 %env_update
581
582 %post gnome-askpass
583 %env_update
584
585 %postun gnome-askpass
586 %env_update
587
588 %pre server
589 %useradd -P %{name}-server -u 40 -d %{_privsepdir} -s /bin/false -c "OpenSSH PrivSep User" -g nobody sshd
590
591 %post server
592 /sbin/chkconfig --add sshd
593 %service sshd reload "openssh daemon"
594 if ! grep -qs ssh /etc/security/passwd.conf ; then
595         umask 022
596         echo "ssh" >> /etc/security/passwd.conf
597 fi
598
599 %preun server
600 if [ "$1" = "0" ]; then
601         %service sshd stop
602         /sbin/chkconfig --del sshd
603 fi
604
605 %postun server
606 if [ "$1" = "0" ]; then
607         %userremove sshd
608 fi
609
610 %files
611 %defattr(644,root,root,755)
612 %doc *.RNG TODO README OVERVIEW CREDITS Change*
613 %attr(755,root,root) %{_bindir}/ssh-key*
614 %{_mandir}/man1/ssh-key*.1*
615 %dir %{_sysconfdir}
616 %dir %{_libexecdir}
617
618 %files clients
619 %defattr(644,root,root,755)
620 %attr(755,root,root) %{_bindir}/ssh
621 %attr(755,root,root) %{_bindir}/slogin
622 %attr(755,root,root) %{_bindir}/sftp
623 %attr(755,root,root) %{_bindir}/ssh-agent
624 %attr(755,root,root) %{_bindir}/ssh-add
625 %attr(755,root,root) %{_bindir}/scp
626 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh_config
627 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/SSH_ASKPASS
628 %{_mandir}/man1/scp.1*
629 %{_mandir}/man1/ssh.1*
630 %{_mandir}/man1/slogin.1*
631 %{_mandir}/man1/sftp.1*
632 %{_mandir}/man1/ssh-agent.1*
633 %{_mandir}/man1/ssh-add.1*
634 %{_mandir}/man5/ssh_config.5*
635 %lang(it) %{_mandir}/it/man1/ssh.1*
636 %lang(it) %{_mandir}/it/man5/ssh_config.5*
637 %lang(pl) %{_mandir}/pl/man1/scp.1*
638 %lang(zh_CN) %{_mandir}/zh_CN/man1/scp.1*
639
640 # for host-based auth (suid required for accessing private host key)
641 #%attr(4755,root,root) %{_libexecdir}/ssh-keysign
642 #%{_mandir}/man8/ssh-keysign.8*
643
644 %files clients-agent-profile_d
645 %defattr(644,root,root,755)
646 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh-agent.conf
647 %attr(755,root,root) /etc/profile.d/ssh-agent.sh
648
649 %files clients-agent-xinitrc
650 %defattr(644,root,root,755)
651 %attr(755,root,root) /etc/X11/xinit/xinitrc.d/ssh-agent.sh
652
653 %files server
654 %defattr(644,root,root,755)
655 %attr(755,root,root) %{_sbindir}/sshd
656 %attr(755,root,root) %{_libexecdir}/sftp-server
657 %attr(755,root,root) %{_libexecdir}/ssh-keysign
658 %{_mandir}/man8/sshd.8*
659 %{_mandir}/man8/sftp-server.8*
660 %{_mandir}/man8/ssh-keysign.8*
661 %{_mandir}/man5/sshd_config.5*
662 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sshd_config
663 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/sshd
664 %attr(640,root,root) %{_sysconfdir}/moduli
665 %attr(754,root,root) /etc/rc.d/init.d/sshd
666 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/sshd
667 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.sshd
668
669 %if %{with gnome} || %{with gtk}
670 %files gnome-askpass
671 %defattr(644,root,root,755)
672 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/GNOME_SSH_ASKPASS*
673 %dir %{_libexecdir}/ssh
674 %attr(755,root,root) %{_libexecdir}/ssh/ssh-askpass
675 %attr(755,root,root) %{_libexecdir}/ssh-askpass
676 %endif
This page took 0.079297 seconds and 4 git commands to generate.