]> git.pld-linux.org Git - packages/openssh.git/blob - openssh.spec
- Prereq: openssl
[packages/openssh.git] / openssh.spec
1 Summary:        OpenSSH free Secure Shell (SSH) implementation
2 Name:           openssh
3 Version:        1.2.3
4 Release:        3
5 License:        BSD
6 Group:          Applications/Networking
7 Group(pl):      Aplikacje/Sieciowe
8 Source0:        ftp://ftp.franken.de/pub/Linux/openssh/files/%{name}-%{version}.tar.gz
9 Source1:        opensshd.conf
10 Source2:        openssh.conf
11 Source3:        opensshd.init
12 Source4:        opensshd.pamd
13 Source5:        openssh.sysconfig
14 Source6:        passwd.pamd
15 Patch0:         openssh-PAM_NEW_AUTHTOK.patch
16 Patch1:         openssh-libwrap.patch
17 BuildRequires:  openssl-devel >= 0.9.4-2
18 BuildRequires:  rpm >= 3.0.4
19 BuildRequires:  zlib-devel
20 BuildRequires:  pam-devel
21 BuildRequires:  XFree86-devel
22 BuildRequires:  gnome-libs-devel
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24 Prereq:         openssl >= 0.9.4-2
25 Obsoletes:      ssh < %{version}, ssh > %{version}
26
27 %define         _sysconfdir     /etc/ssh
28
29 %description
30 Ssh (Secure Shell) a program for logging into a remote machine and for
31 executing commands in a remote machine. It is intended to replace rlogin and
32 rsh, and provide secure encrypted communications between two untrusted hosts
33 over an insecure network. X11 connections and arbitrary TCP/IP ports can
34 also be forwarded over the secure channel.
35
36 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing it up
37 to date in terms of security and features, as well as removing all patented
38 algorithms to seperate libraries (OpenSSL).
39
40 This package includes the core files necessary for both the OpenSSH
41 client and server. To make this package useful, you should also
42 install openssh-clients, openssh-server, or both.
43
44 %package clients
45 Summary:        OpenSSH Secure Shell protocol clients
46 Requires:       openssh
47 Group:          Applications/Networking
48 Group(pl):      Aplikacje/Sieciowe
49 Obsoletes:      ssh-clients < %{version}, ssh-clients > %{version}
50 Requires:       %{name} = %{version}
51
52 %description clients
53 Ssh (Secure Shell) a program for logging into a remote machine and for
54 executing commands in a remote machine. It is intended to replace rlogin and
55 rsh, and provide secure encrypted communications between two untrusted hosts
56 over an insecure network. X11 connections and arbitrary TCP/IP ports can
57 also be forwarded over the secure channel.
58
59 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing it up
60 to date in terms of security and features, as well as removing all patented
61 algorithms to seperate libraries (OpenSSL).
62
63 This package includes the clients necessary to make encrypted connections to
64 SSH servers.
65
66 %package server
67 Summary:        OpenSSH Secure Shell protocol server (sshd)
68 Requires:       openssh chkconfig >= 0.9
69 Group:          Networking/Daemons
70 Group(pl):      Sieciowe/Serwery
71 Obsoletes:      ssh-server < %{version}, ssh-server > %{version}
72 Requires:       rc-scripts
73 Requires:       /bin/login
74 Requires:       util-linux
75 Prereq:         %{name} = %{version}
76
77 %description server
78 Ssh (Secure Shell) a program for logging into a remote machine and for
79 executing commands in a remote machine. It is intended to replace rlogin and
80 rsh, and provide secure encrypted communications between two untrusted hosts
81 over an insecure network. X11 connections and arbitrary TCP/IP ports can
82 also be forwarded over the secure channel.
83
84 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing it up
85 to date in terms of security and features, as well as removing all patented
86 algorithms to seperate libraries (OpenSSL).
87
88 This package contains the secure shell daemon. The sshd is the server part
89 of the secure shell protocol and allows ssh clients to connect to your host.
90
91 %package gnome-askpass
92 Summary:        OpenSSH GNOME passphrase dialog
93 Group:          Applications/Networking
94 Group(pl):      Aplikacje/Sieciowe
95 Requires:       %{name} = %{version}
96 Obsoletes:      ssh-extras < %{version}, ssh-extras > %{version}
97 Obsoletes:      ssh-askpass < %{version}, ssh-askpass > %{version}
98 Obsoletes:      openssh-askpass < %{version}, openssh-askpass > %{version}
99
100 %description gnome-askpass
101 Ssh (Secure Shell) a program for logging into a remote machine and for
102 executing commands in a remote machine. It is intended to replace rlogin
103 and rsh, and provide secure encrypted communications between two untrusted
104 hosts over an insecure network. X11 connections and arbitrary TCP/IP ports
105 can also be forwarded over the secure channel.
106
107 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing it up
108 to date in terms of security and features, as well as removing all patented
109 algorithms to seperate libraries (OpenSSL).
110
111 This package contains the GNOME passphrase dialog.
112
113 %prep
114 %setup  -q
115 %patch0 -p1
116 %patch1 -p1
117
118 %build
119 autoconf
120 %configure \
121         --with-gnome-askpass \
122         --with-tcp-wrappers \
123         --with-md5-passwords \
124         --with-ipaddr-display \
125         --enable-ipv6 \
126         --enable-log-auth 
127
128 # with ipv4-default sshd can't listen on IPv6 and IPv4 sockets
129 #       --with-ipv4-default \
130 # broken options
131 #       --without-kerberos4 \
132 #       --without-afs \
133 #       --without-skey 
134
135 echo '#define LOGIN_PROGRAM           "/bin/login"' >>config.h
136
137 make
138
139 %install
140 rm -rf $RPM_BUILD_ROOT
141
142 install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/{pam.d,rc.d/init.d,sysconfig,security}}
143
144 make install DESTDIR="$RPM_BUILD_ROOT"
145
146 install %{SOURCE4} $RPM_BUILD_ROOT/etc/pam.d/sshd
147 install %{SOURCE6} $RPM_BUILD_ROOT/etc/pam.d/passwdssh
148 install %{SOURCE5} $RPM_BUILD_ROOT/etc/sysconfig/sshd
149 install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
150 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/ssh_config
151 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/sshd_config
152 install -d $RPM_BUILD_ROOT%{_libexecdir}/ssh
153 install ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
154
155 gzip -9fn ChangeLog OVERVIEW COPYING.Ylonen README README.Ylonen UPGRADING \
156         $RPM_BUILD_ROOT/%{_mandir}/man*/*
157
158 touch $RPM_BUILD_ROOT/etc/security/blacklist.sshd
159         
160 %clean
161 rm -rf $RPM_BUILD_ROOT
162
163 %post server
164 /sbin/chkconfig --add sshd
165 if [ ! -f /etc/ssh/ssh_host_key -o ! -s /etc/ssh/ssh_host_key ]; then
166         /usr/bin/ssh-keygen -b 1024 -f /etc/ssh/ssh_host_key -N '' 1>&2
167 fi
168 if [ -f /var/lock/subsys/sshd ]; then
169         /etc/rc.d/init.d/sshd restart 1>&2
170 else
171         echo "Run \"/etc/rc.d/init.d/sshd start\" to start openssh daemon."
172 fi
173 if ! grep ssh /etc/security/passwd.conf >/dev/null 2>&1 ; then
174         echo "ssh" >> /etc/security/passwd.conf
175 fi
176
177 %preun server
178 if [ "$1" = 0 ]; then
179         if [ -f /var/lock/subsys/sshd ]; then
180                 /etc/rc.d/init.d/sshd stop 1>&2
181         fi
182         /sbin/chkconfig --del sshd
183 fi
184
185 %files
186 %defattr(644,root,root,755)
187 %doc {ChangeLog,OVERVIEW,COPYING.Ylonen,README,README.Ylonen,UPGRADING}.gz
188 %attr(755,root,root) %{_bindir}/ssh-keygen
189 %{_mandir}/man1/ssh-keygen.1*
190 %dir %{_sysconfdir}
191
192 %files clients
193 %defattr(644,root,root,755)
194 # suid root ?
195 #%attr(4755,root,root) %{_bindir}/ssh
196 %attr(0755,root,root) %{_bindir}/ssh
197 %attr(0755,root,root) %{_bindir}/ssh-agent
198 %attr(0755,root,root) %{_bindir}/ssh-add
199 #%attr(0755,root,root) %{_bindir}/slogin
200 %attr(755,root,root) %{_bindir}/scp
201 %{_mandir}/man1/scp.1*
202 %{_mandir}/man1/ssh.1*
203 %{_mandir}/man1/ssh-agent.1*
204 %{_mandir}/man1/ssh-add.1*
205 #%{_mandir}/man1/slogin.1
206 %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/ssh_config
207
208 %files server
209 %defattr(644,root,root,755)
210 %attr(755,root,root) %{_sbindir}/sshd
211 %{_mandir}/man8/sshd.8*
212 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/sshd_config
213 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/pam.d/sshd
214 %attr(754,root,root) /etc/rc.d/init.d/sshd
215 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/sysconfig/sshd
216 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/security/blacklist.sshd
217
218 %files gnome-askpass
219 %defattr(644,root,root,755)
220 %dir %{_libexecdir}/ssh
221 %attr(755,root,root) %{_libexecdir}/ssh/ssh-askpass
This page took 0.336648 seconds and 4 git commands to generate.