]> git.pld-linux.org Git - packages/openssh.git/blob - openssh.spec
- update hpn to 13v2; rel 2
[packages/openssh.git] / openssh.spec
1 #
2 # Conditional build:
3 %bcond_with     gnome           # with gnome-askpass (GNOME 1.x) utility
4 %bcond_without  gtk             # without GTK+ (2.x)
5 %bcond_with     ldap            # with ldap support
6 %bcond_without  libedit         # without libedit (editline/history support in sftp client)
7 %bcond_without  kerberos5       # without kerberos5 support
8 %bcond_without  selinux         # build without SELinux support
9 %bcond_without  hpn             # High Performance SSH/SCP - HPN-SSH including Cipher NONE
10
11 # gtk2-based gnome-askpass means no gnome1-based
12 %{?with_gtk:%undefine with_gnome}
13 #
14 Summary:        OpenSSH free Secure Shell (SSH) implementation
15 Summary(de.UTF-8):      OpenSSH - freie Implementation der Secure Shell (SSH)
16 Summary(es.UTF-8):      Implementación libre de SSH
17 Summary(fr.UTF-8):      Implémentation libre du shell sécurisé OpenSSH (SSH)
18 Summary(it.UTF-8):      Implementazione gratuita OpenSSH della Secure Shell
19 Summary(pl.UTF-8):      Publicznie dostępna implementacja bezpiecznego shella (SSH)
20 Summary(pt.UTF-8):      Implementação livre OpenSSH do protocolo 'Secure Shell' (SSH)
21 Summary(pt_BR.UTF-8):   Implementação livre do SSH
22 Summary(ru.UTF-8):      OpenSSH - свободная реализация протокола Secure Shell (SSH)
23 Summary(uk.UTF-8):      OpenSSH - вільна реалізація протоколу Secure Shell (SSH)
24 Name:           openssh
25 Version:        5.0p1
26 Release:        2
27 Epoch:          2
28 License:        BSD
29 Group:          Applications/Networking
30 Source0:        ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/%{name}-%{version}.tar.gz
31 # Source0-md5:  1f1dfaa775f33dd3328169de9bdc292a
32 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
33 # Source1-md5:  66943d481cc422512b537bcc2c7400d1
34 Source2:        %{name}d.init
35 Source3:        %{name}d.pamd
36 Source4:        %{name}.sysconfig
37 Source5:        ssh-agent.sh
38 Source6:        ssh-agent.conf
39 Patch0:         %{name}-no_libnsl.patch
40 Patch1:         %{name}-linux-ipv6.patch
41 Patch2:         %{name}-pam_misc.patch
42 Patch3:         %{name}-sigpipe.patch
43 # http://www.opendarwin.org/projects/openssh-lpk/
44 Patch4:         %{name}-lpk-4.3p1-0.3.7.patch
45 Patch5:         %{name}-config.patch
46 Patch7:         %{name}-selinux.patch
47 # High Performance SSH/SCP - HPN-SSH - http://www.psc.edu/networking/projects/hpn-ssh/
48 # http://www.psc.edu/networking/projects/hpn-ssh/openssh-4.9p1-hpn13v2.diff.gz
49 Patch9:         %{name}-4.9p1-hpn13v2.diff
50 Patch10:        %{name}-include.patch
51 URL:            http://www.openssh.com/
52 BuildRequires:  %{__perl}
53 BuildRequires:  autoconf
54 BuildRequires:  automake
55 %{?with_gnome:BuildRequires:    gnome-libs-devel}
56 %{?with_gtk:BuildRequires:      gtk+2-devel}
57 %{?with_kerberos5:BuildRequires:        krb5-devel}
58 %{?with_libedit:BuildRequires:  libedit-devel}
59 %{?with_selinux:BuildRequires:  libselinux-devel}
60 BuildRequires:  libwrap-devel
61 %{?with_ldap:BuildRequires:     openldap-devel >= 2.4.6}
62 BuildRequires:  openssl-devel >= 0.9.7d
63 BuildRequires:  pam-devel
64 %{?with_gtk:BuildRequires:      pkgconfig}
65 BuildRequires:  rpmbuild(macros) >= 1.318
66 BuildRequires:  zlib-devel
67 Requires:       filesystem >= 3.0-11
68 Requires:       pam >= 0.99.7.1
69 Obsoletes:      ssh
70 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
71
72 %define         _sysconfdir     /etc/ssh
73 %define         _libexecdir     %{_libdir}/%{name}
74 %define         _privsepdir     /usr/share/empty
75
76 %description
77 Ssh (Secure Shell) a program for logging into a remote machine and for
78 executing commands in a remote machine. It is intended to replace
79 rlogin and rsh, and provide secure encrypted communications between
80 two untrusted hosts over an insecure network. X11 connections and
81 arbitrary TCP/IP ports can also be forwarded over the secure channel.
82
83 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
84 it up to date in terms of security and features, as well as removing
85 all patented algorithms to seperate libraries (OpenSSL).
86
87 This package includes the core files necessary for both the OpenSSH
88 client and server. To make this package useful, you should also
89 install openssh-clients, openssh-server, or both.
90 %if %{with hpn} || %{with hpn_none}
91 This release includes High Performance SSH/SCP patches from
92 http://www.psc.edu/networking/projects/hpn-ssh/ which are supposed
93 to increase throughput on fast connections with high RTT (20-150 msec).
94 See the website for '-w' values for your connection and /proc/sys TCP
95 values. BTW. in a LAN you have got generally RTT < 1 msec.
96 %endif
97 %if %{with hpn_none}
98 It also includes an undocumented '-z' option which switches
99 the cipher to none after authentication is completed. Data is
100 still secured from tampering and corruption in transit through
101 the use of the Message Authentication Code (MAC).
102 This option will significantly reduce the number of cpu cycles used
103 by the SSH/SCP process. This may allow some users to see significant
104 improvement in (sniffable) data tranfer rates.
105 %endif
106
107 %description -l de.UTF-8
108 OpenSSH (Secure Shell) stellt den Zugang zu anderen Rechnern her. Es
109 ersetzt telnet, rlogin, rexec und rsh und stellt eine sichere,
110 verschlüsselte Verbindung zwischen zwei nicht vertrauenswürdigen Hosts
111 über eine unsicheres Netzwerk her. X11 Verbindungen und beliebige
112 andere TCP/IP Ports können ebenso über den sicheren Channel
113 weitergeleitet werden.
114
115 %description -l es.UTF-8
116 SSH es un programa para accesar y ejecutar órdenes en computadores
117 remotos. Sustituye rlogin y rsh, y suministra un canal de comunicación
118 seguro entre dos servidores en una red insegura. Conexiones X11 y
119 puertas TCP/IP arbitrárias también pueden ser usadas por el canal
120 seguro.
121
122 OpenSSH es el resultado del trabajo del equipo de OpenBSD para
123 continuar la última versión gratuita de SSH, actualizándolo en
124 términos de seguridad y recursos,así también eliminando todos los
125 algoritmos patentados y colocándolos en bibliotecas separadas
126 (OpenSSL).
127
128 Este paquete contiene "port" para Linux de OpenSSH. Se debe instalar
129 también el paquete openssh-clients u openssh-server o ambos.
130
131 %description -l fr.UTF-8
132 OpenSSH (Secure Shell) fournit un accès à un système distant. Il
133 remplace telnet, rlogin, rexec et rsh, tout en assurant des
134 communications cryptées securisées entre deux hôtes non fiabilisés sur
135 un réseau non sécurisé. Des connexions X11 et des ports TCP/IP
136 arbitraires peuvent également être transmis sur le canal sécurisé.
137
138 %description -l it.UTF-8
139 OpenSSH (Secure Shell) fornisce l'accesso ad un sistema remoto.
140 Sostituisce telnet, rlogin, rexec, e rsh, e fornisce comunicazioni
141 sicure e crittate tra due host non fidati su una rete non sicura. Le
142 connessioni X11 ad una porta TCP/IP arbitraria possono essere
143 inoltrate attraverso un canale sicuro.
144
145 %description -l pl.UTF-8
146 Ssh (Secure Shell) to program służący do logowania się na zdalną
147 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
148 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
149 pomiędzy dwoma hostami.
150
151 Ten pakiet zawiera podstawowe pliki potrzebne zarówno po stronie
152 klienta jak i serwera OpenSSH. Aby był użyteczny, trzeba zainstalować
153 co najmniej jeden z pakietów: openssh-clients lub openssh-server.
154 %if %{with hpn} || %{with hpn_none}
155 Ta wersja zawiera łaty z projektu High Performance SSH/SCP
156 http://www.psc.edu/networking/projects/hpn-ssh/, które mają na celu
157 zwiększenie przepustowości transmisji dla szybkich połączeń
158 z dużym RTT (20-150 msec). Na stronie projektu znaleźć można
159 odpowednie dla danego połączenia wartości parametru '-w' oraz
160 opcje /proc/sys dla TCP. Nawiasem mówiąc w sieciach LAN RTT < 1 msec.
161 %endif
162 %if %{with hpn_none}
163 Obsługiwana jest również nieudokumentowana opcja '-z' odpowiedzialna
164 za wyłączenie szyfrowania danych po zakończeniu procesu uwierzytelniania.
165 Dane są zabezpieczone przed modyfikacją lub uszkodzeniem przez
166 stosowanie Message Authentication Code (MAC).
167 Opcja ta znacznie redukuje liczbę cykli procesora zużywanych przez
168 procesy SSH/SCP. W wybranych zastosowaniach może ona wpłynąć
169 na wyraźne przyspieszenie (podsłuchiwalnej) transmisji danych.
170 %endif
171
172 %description -l pt.UTF-8
173 OpenSSH (Secure Shell) fornece acesso a um sistema remoto. Substitui o
174 telnet, rlogin, rexec, e o rsh e fornece comunicações seguras e
175 cifradas entre duas máquinas sem confiança mútua sobre uma rede
176 insegura. Ligações X11 e portos TCP/IP arbitrários também poder ser
177 reenviados pelo canal seguro.
178
179 %description -l pt_BR.UTF-8
180 SSH é um programa para acessar e executar comandos em máquinas
181 remotas. Ele substitui rlogin e rsh, e provem um canal de comunicação
182 seguro entre dois hosts em uma rede insegura. Conexões X11 e portas
183 TCP/IP arbitrárias também podem ser usadas pelo canal seguro.
184
185 OpenSSH é o resultado do trabalho da equipe do OpenBSD em continuar a
186 última versão gratuita do SSH, atualizando-o em termos de segurança e
187 recursos, assim como removendo todos os algoritmos patenteados e
188 colocando-os em bibliotecas separadas (OpenSSL).
189
190 Esse pacote contém o "port" pra Linux do OpenSSH. Você deve instalar
191 também ou o pacote openssh-clients, ou o openssh-server, ou ambos.
192
193 %description -l ru.UTF-8
194 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
195 машину и для выполнения команд на удаленной машине. Она предназначена
196 для замены rlogin и rsh и обеспечивает безопасную шифрованную
197 коммуникацию между двумя хостами в сети, являющейся небезопасной.
198 Соединения X11 и любые порты TCP/IP могут также быть проведены через
199 безопасный канал.
200
201 OpenSSH - это переделка командой разработчиков OpenBSD последней
202 свободной версии SSH, доведенная до современного состояния в терминах
203 уровня безопасности и поддерживаемых возможностей. Все патентованные
204 алгоритмы вынесены в отдельные библиотеки (OpenSSL).
205
206 Этот пакет содержит файлы, необходимые как для клиента, так и для
207 сервера OpenSSH. Вам нужно будет установить еще openssh-clients,
208 openssh-server, или оба пакета.
209
210 %description -l uk.UTF-8
211 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
212 машини та для виконання команд на віддаленій машині. Вона призначена
213 для заміни rlogin та rsh і забезпечує безпечну шифровану комунікацію
214 між двома хостами в мережі, яка не є безпечною. З'єднання X11 та
215 довільні порти TCP/IP можуть також бути проведені через безпечний
216 канал.
217
218 OpenSSH - це переробка командою розробників OpenBSD останньої вільної
219 версії SSH, доведена до сучасного стану в термінах рівня безпеки та
220 підтримуваних можливостей. Всі патентовані алгоритми винесені до
221 окремих бібліотек (OpenSSL).
222
223 Цей пакет містить файли, необхідні як для клієнта, так і для сервера
224 OpenSSH. Вам потрібно буде ще встановити openssh-clients,
225 openssh-server, чи обидва пакети.
226
227 %package clients
228 Summary:        OpenSSH Secure Shell protocol clients
229 Summary(es.UTF-8):      Clientes de OpenSSH
230 Summary(pl.UTF-8):      Klienci protokołu Secure Shell
231 Summary(pt_BR.UTF-8):   Clientes do OpenSSH
232 Summary(ru.UTF-8):      OpenSSH - клиенты протокола Secure Shell
233 Summary(uk.UTF-8):      OpenSSH - клієнти протоколу Secure Shell
234 Group:          Applications/Networking
235 Requires:       %{name} = %{epoch}:%{version}-%{release}
236 Provides:       ssh-clients
237 Obsoletes:      ssh-clients
238
239 %description clients
240 Ssh (Secure Shell) a program for logging into a remote machine and for
241 executing commands in a remote machine. It is intended to replace
242 rlogin and rsh, and provide secure encrypted communications between
243 two untrusted hosts over an insecure network. X11 connections and
244 arbitrary TCP/IP ports can also be forwarded over the secure channel.
245
246 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
247 it up to date in terms of security and features, as well as removing
248 all patented algorithms to seperate libraries (OpenSSL).
249
250 This package includes the clients necessary to make encrypted
251 connections to SSH servers.
252
253 %description clients -l es.UTF-8
254 Este paquete incluye los clientes que se necesitan para hacer
255 conexiones codificadas con servidores SSH.
256
257 %description clients -l pl.UTF-8
258 Ssh (Secure Shell) to program służący do logowania się na zdalną
259 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
260 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
261 pomiędzy dwoma hostami.
262
263 Ten pakiet zawiera klientów służących do łączenia się z serwerami SSH.
264
265 %description clients -l pt_BR.UTF-8
266 Esse pacote inclui os clientes necessários para fazer conexões
267 encriptadas com servidores SSH.
268
269 %description clients -l ru.UTF-8
270 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
271 машину и для выполнения команд на удаленной машине.
272
273 Этот пакет содержит программы-клиенты, необходимые для установления
274 зашифрованных соединений с серверами SSH.
275
276 %description clients -l uk.UTF-8
277 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
278 машини та для виконання команд на віддаленій машині.
279
280 Цей пакет містить програми-клієнти, необхідні для встановлення
281 зашифрованих з'єднань з серверами SSH.
282
283 %package clients-agent-profile_d
284 Summary:        OpenSSH Secure Shell agent init script
285 Summary(pl.UTF-8):      Skrypt startowy agenta OpenSSH
286 Group:          Applications/Networking
287 Requires:       %{name}-clients = %{epoch}:%{version}-%{release}
288
289 %description clients-agent-profile_d
290 profile.d scripts for starting SSH agent.
291
292 %description clients-agent-profile_d -l pl.UTF-8
293 Skrypty profile.d do uruchamiania agenta SSH.
294
295 %package clients-agent-xinitrc
296 Summary:        OpenSSH Secure Shell agent init script
297 Summary(pl.UTF-8):      Skrypt inicjujący agenta ssh przez xinitrc
298 Group:          Applications/Networking
299 Requires:       %{name}-clients-agent-profile_d = %{epoch}:%{version}-%{release}
300 Requires:       xinitrc
301
302 %description clients-agent-xinitrc
303 xinitrc scripts for starting SSH agent.
304
305 %description clients-agent-xinitrc -l pl.UTF-8
306 Skrypty xinitrc do uruchamiania agenta SSH.
307
308 %package server
309 Summary:        OpenSSH Secure Shell protocol server (sshd)
310 Summary(de.UTF-8):      OpenSSH Secure Shell Protocol-Server (sshd)
311 Summary(es.UTF-8):      Servidor OpenSSH para comunicaciones codificadas
312 Summary(fr.UTF-8):      Serveur de protocole du shell sécurisé OpenSSH (sshd)
313 Summary(it.UTF-8):      Server OpenSSH per il protocollo Secure Shell (sshd)
314 Summary(pl.UTF-8):      Serwer protokołu Secure Shell (sshd)
315 Summary(pt.UTF-8):      Servidor do protocolo 'Secure Shell' OpenSSH (sshd)
316 Summary(pt_BR.UTF-8):   Servidor OpenSSH para comunicações encriptadas
317 Summary(ru.UTF-8):      OpenSSH - сервер протокола Secure Shell (sshd)
318 Summary(uk.UTF-8):      OpenSSH - сервер протоколу Secure Shell (sshd)
319 Group:          Networking/Daemons
320 Requires(post): chkconfig >= 0.9
321 Requires(post): grep
322 Requires(post,preun):   /sbin/chkconfig
323 Requires(postun):       /usr/sbin/userdel
324 Requires(pre):  /bin/id
325 Requires(pre):  /usr/sbin/useradd
326 Requires:       %{name} = %{epoch}:%{version}-%{release}
327 Requires:       /bin/login
328 Requires:       pam >= 0.99.7.1
329 Requires:       rc-scripts >= 0.4.0.18
330 Requires:       util-linux
331 Provides:       ssh-server
332 Provides:       user(sshd)
333
334 %description server
335 Ssh (Secure Shell) a program for logging into a remote machine and for
336 executing commands in a remote machine. It is intended to replace
337 rlogin and rsh, and provide secure encrypted communications between
338 two untrusted hosts over an insecure network. X11 connections and
339 arbitrary TCP/IP ports can also be forwarded over the secure channel.
340
341 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
342 it up to date in terms of security and features, as well as removing
343 all patented algorithms to seperate libraries (OpenSSL).
344
345 This package contains the secure shell daemon. The sshd is the server
346 part of the secure shell protocol and allows ssh clients to connect to
347 your host.
348
349 %description server -l de.UTF-8
350 Dieses Paket installiert den sshd, den Server-Teil der OpenSSH.
351
352 %description server -l es.UTF-8
353 Este paquete contiene el servidor SSH. sshd es la parte servidor del
354 protocolo secure shell y permite que clientes ssh se conecten a su
355 servidor.
356
357 %description server -l fr.UTF-8
358 Ce paquetage installe le 'sshd', partie serveur de OpenSSH.
359
360 %description server -l it.UTF-8
361 Questo pacchetto installa sshd, il server di OpenSSH.
362
363 %description server -l pl.UTF-8
364 Ssh (Secure Shell) to program służący do logowania się na zdalną
365 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
366 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
367 pomiędzy dwoma hostami.
368
369 Ten pakiet zawiera serwer sshd (do którego mogą łączyć się klienci
370 ssh).
371
372 %description server -l pt.UTF-8
373 Este pacote intala o sshd, o servidor do OpenSSH.
374
375 %description server -l pt_BR.UTF-8
376 Esse pacote contém o servidor SSH. O sshd é a parte servidor do
377 protocolo secure shell e permite que clientes ssh se conectem ao seu
378 host.
379
380 %description server -l ru.UTF-8
381 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
382 машину и для выполнения команд на удаленной машине.
383
384 Этот пакет содержит sshd - "демон" Secure Shell. sshd - это серверная
385 часть протокола Secure Shell, позволяющая клиентам ssh соединяться с
386 вашим хостом.
387
388 %description server -l uk.UTF-8
389 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
390 машини та для виконання команд на віддаленій машині.
391
392 Цей пакет містить sshd - "демон" Secure Shell. sshd - це серверна
393 частина протоколу Secure Shell, яка дозволяє клієнтам ssh зв'язуватись
394 з вашим хостом.
395
396 %package gnome-askpass
397 Summary:        OpenSSH GNOME passphrase dialog
398 Summary(de.UTF-8):      OpenSSH GNOME Passwort-Dialog
399 Summary(es.UTF-8):      Diálogo para introducción de passphrase para GNOME
400 Summary(fr.UTF-8):      Dialogue pass-phrase GNOME d'OpenSSH
401 Summary(it.UTF-8):      Finestra di dialogo GNOME per la frase segreta di OpenSSH
402 Summary(pl.UTF-8):      Odpytywacz hasła OpenSSH dla GNOME
403 Summary(pt.UTF-8):      Diálogo de pedido de senha para GNOME do OpenSSH
404 Summary(pt_BR.UTF-8):   Diálogo para entrada de passphrase para GNOME
405 Summary(ru.UTF-8):      OpenSSH - диалог ввода ключевой фразы (passphrase) для GNOME
406 Summary(uk.UTF-8):      OpenSSH - діалог вводу ключової фрази (passphrase) для GNOME
407 Group:          Applications/Networking
408 Requires:       %{name} = %{epoch}:%{version}-%{release}
409 Obsoletes:      openssh-askpass
410 Obsoletes:      ssh-askpass
411 Obsoletes:      ssh-extras
412
413 %description gnome-askpass
414 Ssh (Secure Shell) a program for logging into a remote machine and for
415 executing commands in a remote machine. It is intended to replace
416 rlogin and rsh, and provide secure encrypted communications between
417 two untrusted hosts over an insecure network. X11 connections and
418 arbitrary TCP/IP ports can also be forwarded over the secure channel.
419
420 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
421 it up to date in terms of security and features, as well as removing
422 all patented algorithms to seperate libraries (OpenSSL).
423
424 This package contains the GNOME passphrase dialog.
425
426 %description gnome-askpass -l es.UTF-8
427 Este paquete contiene un programa que abre una caja de diálogo para
428 entrada de passphrase en GNOME.
429
430 %description gnome-askpass -l pl.UTF-8
431 Ssh (Secure Shell) to program służący do logowania się na zdalną
432 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
433 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
434 pomiędzy dwoma hostami.
435
436 Ten pakiet zawiera ,,odpytywacz hasła'' dla GNOME.
437
438 %description gnome-askpass -l pt_BR.UTF-8
439 Esse pacote contém um programa que abre uma caixa de diálogo para
440 entrada de passphrase no GNOME.
441
442 %description gnome-askpass -l ru.UTF-8
443 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
444 машину и для выполнения команд на удаленной машине.
445
446 Этот пакет содержит диалог ввода ключевой фразы для использования под
447 GNOME.
448
449 %description gnome-askpass -l uk.UTF-8
450 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
451 машини та для виконання команд на віддаленій машині.
452
453 Цей пакет містить діалог вводу ключової фрази для використання під
454 GNOME.
455
456 %prep
457 %setup -q
458 %patch0 -p1
459 %patch1 -p1
460 %patch2 -p1
461 %patch3 -p1
462 %{?with_ldap:%patch4 -p1}
463 %patch5 -p1
464 %patch7 -p1
465 %{?with_hpn:%patch9 -p1}
466 %patch10 -p1
467
468 %build
469 cp /usr/share/automake/config.sub .
470 %{__aclocal}
471 %{__autoconf}
472 %configure \
473         PERL=%{__perl} \
474         --with-dns \
475         --with-pam \
476         --with-mantype=man \
477         --with-md5-passwords \
478         --with-ipaddr-display \
479         %{?with_libedit:--with-libedit} \
480         --with-4in6 \
481         --disable-suid-ssh \
482         --with-tcp-wrappers \
483         %{?with_ldap:--with-libs="-lldap -llber"} \
484         %{?with_ldap:--with-cppflags="-DWITH_LDAP_PUBKEY"} \
485         %{?with_kerberos5:--with-kerberos5=/usr} \
486         --with-privsep-path=%{_privsepdir} \
487         --with-pid-dir=%{_localstatedir}/run \
488         --with-xauth=/usr/bin/xauth \
489         --enable-utmpx \
490         --enable-wtmpx
491
492 echo '#define LOGIN_PROGRAM                "/bin/login"' >>config.h
493
494 %{__make}
495
496 cd contrib
497 %if %{with gnome}
498 %{__make} gnome-ssh-askpass1 \
499         CC="%{__cc} %{rpmldflags} %{rpmcflags}"
500 %endif
501 %if %{with gtk}
502 %{__make} gnome-ssh-askpass2 \
503         CC="%{__cc} %{rpmldflags} %{rpmcflags}"
504 %endif
505
506 %install
507 rm -rf $RPM_BUILD_ROOT
508 install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/{pam.d,rc.d/init.d,sysconfig,security,env.d}} \
509         $RPM_BUILD_ROOT%{_libexecdir}/ssh
510 install -d $RPM_BUILD_ROOT/etc/{profile.d,X11/xinit/xinitrc.d}
511
512 %{__make} install \
513         DESTDIR=$RPM_BUILD_ROOT
514
515 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
516
517 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
518 install %{SOURCE3} $RPM_BUILD_ROOT/etc/pam.d/sshd
519 install %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/sshd
520 install %{SOURCE5} $RPM_BUILD_ROOT/etc/profile.d
521 ln -sf  /etc/profile.d/ssh-agent.sh $RPM_BUILD_ROOT/etc/X11/xinit/xinitrc.d/ssh-agent.sh
522 install %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}
523
524 %if %{with gnome}
525 install contrib/gnome-ssh-askpass1 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
526 %endif
527 %if %{with gtk}
528 install contrib/gnome-ssh-askpass2 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
529 %endif
530 %if %{with gnome} || %{with gtk}
531 cat << 'EOF' >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_SERVER
532 #GNOME_SSH_ASKPASS_GRAB_SERVER="true"
533 EOF
534 cat << 'EOF' >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_POINTER
535 #GNOME_SSH_ASKPASS_GRAB_POINTER="true"
536 EOF
537 ln -s %{_libexecdir}/ssh/ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/ssh-askpass
538 %endif
539
540 rm -f   $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
541 echo ".so ssh.1" > $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
542
543 touch $RPM_BUILD_ROOT/etc/security/blacklist.sshd
544
545 cat << 'EOF' > $RPM_BUILD_ROOT/etc/env.d/SSH_ASKPASS
546 #SSH_ASKPASS="%{_libexecdir}/ssh-askpass"
547 EOF
548
549 rm -f $RPM_BUILD_ROOT%{_datadir}/Ssh.bin # ???
550 rm -f $RPM_BUILD_ROOT%{_mandir}/README.openssh-non-english-man-pages
551
552 %clean
553 rm -rf $RPM_BUILD_ROOT
554
555 %post clients
556 %env_update
557
558 %postun clients
559 %env_update
560
561 %post gnome-askpass
562 %env_update
563
564 %postun gnome-askpass
565 %env_update
566
567 %pre server
568 %useradd -P %{name}-server -u 40 -d %{_privsepdir} -s /bin/false -c "OpenSSH PrivSep User" -g nobody sshd
569
570 %post server
571 /sbin/chkconfig --add sshd
572 %service sshd reload "openssh daemon"
573 if ! grep -qs ssh /etc/security/passwd.conf ; then
574         umask 022
575         echo "ssh" >> /etc/security/passwd.conf
576 fi
577
578 %preun server
579 if [ "$1" = "0" ]; then
580         %service sshd stop
581         /sbin/chkconfig --del sshd
582 fi
583
584 %postun server
585 if [ "$1" = "0" ]; then
586         %userremove sshd
587 fi
588
589 %files
590 %defattr(644,root,root,755)
591 %doc *.RNG TODO README OVERVIEW CREDITS Change*
592 %attr(755,root,root) %{_bindir}/ssh-key*
593 %{_mandir}/man1/ssh-key*.1*
594 %dir %{_sysconfdir}
595 %dir %{_libexecdir}
596
597 %files clients
598 %defattr(644,root,root,755)
599 %attr(755,root,root) %{_bindir}/ssh
600 %attr(755,root,root) %{_bindir}/slogin
601 %attr(755,root,root) %{_bindir}/sftp
602 %attr(755,root,root) %{_bindir}/ssh-agent
603 %attr(755,root,root) %{_bindir}/ssh-add
604 %attr(755,root,root) %{_bindir}/scp
605 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh_config
606 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/SSH_ASKPASS
607 %{_mandir}/man1/scp.1*
608 %{_mandir}/man1/ssh.1*
609 %{_mandir}/man1/slogin.1*
610 %{_mandir}/man1/sftp.1*
611 %{_mandir}/man1/ssh-agent.1*
612 %{_mandir}/man1/ssh-add.1*
613 %{_mandir}/man5/ssh_config.5*
614 %lang(it) %{_mandir}/it/man1/ssh.1*
615 %lang(it) %{_mandir}/it/man5/ssh_config.5*
616 %lang(pl) %{_mandir}/pl/man1/scp.1*
617 %lang(zh_CN) %{_mandir}/zh_CN/man1/scp.1*
618
619 # for host-based auth (suid required for accessing private host key)
620 #%attr(4755,root,root) %{_libexecdir}/ssh-keysign
621 #%{_mandir}/man8/ssh-keysign.8*
622
623 %files clients-agent-profile_d
624 %defattr(644,root,root,755)
625 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh-agent.conf
626 %attr(755,root,root) /etc/profile.d/ssh-agent.sh
627
628 %files clients-agent-xinitrc
629 %defattr(644,root,root,755)
630 %attr(755,root,root) /etc/X11/xinit/xinitrc.d/ssh-agent.sh
631
632 %files server
633 %defattr(644,root,root,755)
634 %attr(755,root,root) %{_sbindir}/sshd
635 %attr(755,root,root) %{_libexecdir}/sftp-server
636 %attr(755,root,root) %{_libexecdir}/ssh-keysign
637 %{_mandir}/man8/sshd.8*
638 %{_mandir}/man8/sftp-server.8*
639 %{_mandir}/man8/ssh-keysign.8*
640 %{_mandir}/man5/sshd_config.5*
641 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sshd_config
642 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/sshd
643 %attr(640,root,root) %{_sysconfdir}/moduli
644 %attr(754,root,root) /etc/rc.d/init.d/sshd
645 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/sshd
646 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.sshd
647
648 %if %{with gnome} || %{with gtk}
649 %files gnome-askpass
650 %defattr(644,root,root,755)
651 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/GNOME_SSH_ASKPASS*
652 %dir %{_libexecdir}/ssh
653 %attr(755,root,root) %{_libexecdir}/ssh/ssh-askpass
654 %attr(755,root,root) %{_libexecdir}/ssh-askpass
655 %endif
This page took 0.081375 seconds and 4 git commands to generate.