]> git.pld-linux.org Git - packages/openssh.git/blob - openssh.spec
- connect moved to separate package (connect); release 2
[packages/openssh.git] / openssh.spec
1 #
2 # Conditional build:
3 %bcond_without  chroot          # without chrooted user environment support
4 %bcond_with     gnome           # with gnome-askpass (GNOME 1.x) utility
5 %bcond_without  gtk             # without GTK+ (2.x)
6 %bcond_with     ldap            # with ldap support
7 %bcond_without  libedit         # without libedit (editline/history support in sftp client)
8 %bcond_without  kerberos5       # without kerberos5 support
9 %bcond_without  selinux         # build without SELinux support
10 %bcond_with     sshagentsh      # with system-wide script for starting ssh-agent
11 %bcond_with     hpn             # with High Performance SSH/SCP - HPN-SSH (see patch comment)
12 %bcond_with     hpn_none        # with hpn (above) and '-z' none cipher option
13 #
14 %if %{with hpn_none}
15 %undefine       with_hpn
16 %endif
17 # gtk2-based gnome-askpass means no gnome1-based
18 %{?with_gtk:%undefine with_gnome}
19 Summary:        OpenSSH free Secure Shell (SSH) implementation
20 Summary(de):    OpenSSH - freie Implementation der Secure Shell (SSH)
21 Summary(es):    Implementación libre de SSH
22 Summary(fr):    Implémentation libre du shell sécurisé OpenSSH (SSH)
23 Summary(it):    Implementazione gratuita OpenSSH della Secure Shell
24 Summary(pl):    Publicznie dostêpna implementacja bezpiecznego shella (SSH)
25 Summary(pt):    Implementação livre OpenSSH do protocolo 'Secure Shell' (SSH)
26 Summary(pt_BR): Implementação livre do SSH
27 Summary(ru):    OpenSSH - Ó×ÏÂÏÄÎÁÑ ÒÅÁÌÉÚÁÃÉÑ ÐÒÏÔÏËÏÌÁ Secure Shell (SSH)
28 Summary(uk):    OpenSSH - ×¦ÌØÎÁ ÒÅÁ̦ÚÁæѠÐÒÏÔÏËÏÌÕ Secure Shell (SSH)
29 Name:           openssh
30 Version:        4.5p1
31 Release:        2%{?with_hpn:hpn}%{?with_hpn_none:hpn_none}
32 Epoch:          2
33 License:        BSD
34 Group:          Applications/Networking
35 Source0:        ftp://ftp.ca.openbsd.org/pub/OpenBSD/OpenSSH/portable/%{name}-%{version}.tar.gz
36 # Source0-md5:  6468c339886f78e8a149b88f695839dd
37 Source1:        %{name}d.conf
38 Source2:        %{name}.conf
39 Source3:        %{name}d.init
40 Source4:        %{name}d.pamd
41 Source5:        %{name}.sysconfig
42 Source6:        passwd.pamd
43 Source7:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
44 # Source7-md5:  66943d481cc422512b537bcc2c7400d1
45 Source11:       ssh-agent.sh
46 Source12:       ssh-agent.conf
47 Patch0:         %{name}-no_libnsl.patch
48 Patch2:         %{name}-linux-ipv6.patch
49 Patch3:         %{name}-pam_misc.patch
50 Patch4:         %{name}-sigpipe.patch
51 # http://www.opendarwin.org/projects/openssh-lpk/
52 Patch5:         %{name}-lpk-4.3p1-0.3.7.patch
53 Patch6:         %{name}-heimdal.patch
54 Patch7:         %{name}-pam-conv.patch
55 # http://chrootssh.sourceforge.net/download/osshChroot-3.7.1p2.diff
56 Patch8:         %{name}-chroot.patch
57 Patch9:         %{name}-selinux.patch
58 # HPN patches rediffed due sigpipe patch.
59 # High Performance SSH/SCP - HPN-SSH - http://www.psc.edu/networking/projects/hpn-ssh/
60 # http://www.psc.edu/networking/projects/hpn-ssh/openssh-4.2p1-hpn11.diff
61 Patch10:        %{name}-4.3p1-hpn11.patch
62 # Adds HPN (see p11) and an undocumented -z none cipher flag
63 # http://www.psc.edu/networking/projects/hpn-ssh/openssh-4.2p1-hpn11-none.diff
64 Patch11:        %{name}-4.3p1-hpn11-none.patch
65 Patch12:        %{name}-include.patch
66 URL:            http://www.openssh.com/
67 BuildRequires:  %{__perl}
68 BuildRequires:  autoconf
69 BuildRequires:  automake
70 %{?with_gnome:BuildRequires:    gnome-libs-devel}
71 %{?with_gtk:BuildRequires:      gtk+2-devel}
72 %{?with_kerberos5:BuildRequires:        heimdal-devel >= 0.7}
73 %{?with_libedit:BuildRequires:  libedit-devel}
74 %{?with_selinux:BuildRequires:  libselinux-devel}
75 BuildRequires:  libwrap-devel
76 %{?with_ldap:BuildRequires:     openldap-devel}
77 BuildRequires:  openssl-devel >= 0.9.7d
78 BuildRequires:  pam-devel
79 %{?with_gtk:BuildRequires:      pkgconfig}
80 BuildRequires:  rpmbuild(macros) >= 1.318
81 BuildRequires:  zlib-devel
82 Requires:       filesystem >= 3.0-11
83 Requires:       pam >= 0.79.0
84 Obsoletes:      ssh
85 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
86
87 %define         _sysconfdir     /etc/ssh
88 %define         _libexecdir     %{_libdir}/%{name}
89 %define         _privsepdir     /usr/share/empty
90
91 %description
92 Ssh (Secure Shell) a program for logging into a remote machine and for
93 executing commands in a remote machine. It is intended to replace
94 rlogin and rsh, and provide secure encrypted communications between
95 two untrusted hosts over an insecure network. X11 connections and
96 arbitrary TCP/IP ports can also be forwarded over the secure channel.
97
98 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
99 it up to date in terms of security and features, as well as removing
100 all patented algorithms to seperate libraries (OpenSSL).
101
102 This package includes the core files necessary for both the OpenSSH
103 client and server. To make this package useful, you should also
104 install openssh-clients, openssh-server, or both.
105 %if %{with hpn} || %{with hpn_none}
106 This release includes High Performance SSH/SCP patches from
107 http://www.psc.edu/networking/projects/hpn-ssh/ which are supposed
108 to increase throughput on fast connections with high RTT (20-150 msec).
109 See the website for '-w' values for your connection and /proc/sys TCP
110 values. BTW. in a LAN you have got generally RTT < 1 msec.
111 %endif
112 %if %{with hpn_none}
113 It also includes an undocumented '-z' option which switches
114 the cipher to none after authentication is completed. Data is
115 still secured from tampering and corruption in transit through
116 the use of the Message Authentication Code (MAC).
117 This option will significantly reduce the number of cpu cycles used
118 by the SSH/SCP process. This may allow some users to see significant
119 improvement in (sniffable) data tranfer rates.
120 %endif
121
122 %description -l de
123 OpenSSH (Secure Shell) stellt den Zugang zu anderen Rechnern her. Es
124 ersetzt telnet, rlogin, rexec und rsh und stellt eine sichere,
125 verschlüsselte Verbindung zwischen zwei nicht vertrauenswürdigen Hosts
126 über eine unsicheres Netzwerk her. X11 Verbindungen und beliebige
127 andere TCP/IP Ports können ebenso über den sicheren Channel
128 weitergeleitet werden.
129
130 %description -l es
131 SSH es un programa para accesar y ejecutar órdenes en computadores
132 remotos. Sustituye rlogin y rsh, y suministra un canal de comunicación
133 seguro entre dos servidores en una red insegura. Conexiones X11 y
134 puertas TCP/IP arbitrárias también pueden ser usadas por el canal
135 seguro.
136
137 OpenSSH es el resultado del trabajo del equipo de OpenBSD para
138 continuar la última versión gratuita de SSH, actualizándolo en
139 términos de seguridad y recursos,así también eliminando todos los
140 algoritmos patentados y colocándolos en bibliotecas separadas
141 (OpenSSL).
142
143 Este paquete contiene "port" para Linux de OpenSSH. Se debe instalar
144 también el paquete openssh-clients u openssh-server o ambos.
145
146 %description -l fr
147 OpenSSH (Secure Shell) fournit un accès à un système distant. Il
148 remplace telnet, rlogin, rexec et rsh, tout en assurant des
149 communications cryptées securisées entre deux hôtes non fiabilisés sur
150 un réseau non sécurisé. Des connexions X11 et des ports TCP/IP
151 arbitraires peuvent également être transmis sur le canal sécurisé.
152
153 %description -l it
154 OpenSSH (Secure Shell) fornisce l'accesso ad un sistema remoto.
155 Sostituisce telnet, rlogin, rexec, e rsh, e fornisce comunicazioni
156 sicure e crittate tra due host non fidati su una rete non sicura. Le
157 connessioni X11 ad una porta TCP/IP arbitraria possono essere
158 inoltrate attraverso un canale sicuro.
159
160 %description -l pl
161 Ssh (Secure Shell) to program s³u¿±cy do logowania siê na zdaln±
162 maszynê i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
163 zast±piæ rlogin, rsh i dostarczyæ bezpieczne, szyfrowane po³±czenie
164 pomiêdzy dwoma hostami.
165
166 Ten pakiet zawiera podstawowe pliki potrzebne zarówno po stronie
167 klienta jak i serwera OpenSSH. Aby by³ u¿yteczny, trzeba zainstalowaæ
168 co najmniej jeden z pakietów: openssh-clients lub openssh-server.
169 %if %{with hpn} || %{with hpn_none}
170 Ta wersja zawiera ³aty z projektu High Performance SSH/SCP
171 http://www.psc.edu/networking/projects/hpn-ssh/, które maj± na celu
172 zwiêkszenie przepustowo¶ci transmisji dla szybkich po³±czeñ
173 z du¿ym RTT (20-150 msec). Na stronie projektu znale¼æ mo¿na
174 odpowednie dla danego po³±czenia warto¶ci parametru '-w' oraz
175 opcje /proc/sys dla TCP. Nawiasem mówi±c w sieciach LAN RTT < 1 msec.
176 %endif
177 %if %{with hpn_none}
178 Obs³ugiwana jest równie¿ nieudokumentowana opcja '-z' odpowiedzialna
179 za wy³±czenie szyfrowania danych po zakoñczeniu procesu uwierzytelniania.
180 Dane s± zabezpieczone przed modyfikacj± lub uszkodzeniem przez
181 stosowanie Message Authentication Code (MAC).
182 Opcja ta znacznie redukuje liczbê cykli procesora zu¿ywanych przez
183 procesy SSH/SCP. W wybranych zastosowaniach mo¿e ona wp³yn±æ
184 na wyra¼ne przyspieszenie (pods³uchiwalnej) transmisji danych.
185 %endif
186
187 %description -l pt
188 OpenSSH (Secure Shell) fornece acesso a um sistema remoto. Substitui o
189 telnet, rlogin, rexec, e o rsh e fornece comunicações seguras e
190 cifradas entre duas máquinas sem confiança mútua sobre uma rede
191 insegura. Ligações X11 e portos TCP/IP arbitrários também poder ser
192 reenviados pelo canal seguro.
193
194 %description -l pt_BR
195 SSH é um programa para acessar e executar comandos em máquinas
196 remotas. Ele substitui rlogin e rsh, e provem um canal de comunicação
197 seguro entre dois hosts em uma rede insegura. Conexões X11 e portas
198 TCP/IP arbitrárias também podem ser usadas pelo canal seguro.
199
200 OpenSSH é o resultado do trabalho da equipe do OpenBSD em continuar a
201 última versão gratuita do SSH, atualizando-o em termos de segurança e
202 recursos, assim como removendo todos os algoritmos patenteados e
203 colocando-os em bibliotecas separadas (OpenSSL).
204
205 Esse pacote contém o "port" pra Linux do OpenSSH. Você deve instalar
206 também ou o pacote openssh-clients, ou o openssh-server, ou ambos.
207
208 %description -l ru
209 Ssh (Secure Shell) - ÜÔÏ ÐÒÏÇÒÁÍÍÁ ÄÌÑ "ÚÁÈÏÄÁ" (login) ÎÁ ÕÄÁÌÅÎÎÕÀ
210 ÍÁÛÉÎÕ É ÄÌÑ ×ÙÐÏÌÎÅÎÉÑ ËÏÍÁÎÄ ÎÁ ÕÄÁÌÅÎÎÏÊ ÍÁÛÉÎÅ. ïÎÁ ÐÒÅÄÎÁÚÎÁÞÅÎÁ
211 ÄÌÑ ÚÁÍÅÎÙ rlogin É rsh É ÏÂÅÓÐÅÞÉ×ÁÅÔ ÂÅÚÏÐÁÓÎÕÀ ÛÉÆÒÏ×ÁÎÎÕÀ
212 ËÏÍÍÕÎÉËÁÃÉÀ ÍÅÖÄÕ Ä×ÕÍÑ ÈÏÓÔÁÍÉ × ÓÅÔÉ, Ñ×ÌÑÀÝÅÊÓÑ ÎÅÂÅÚÏÐÁÓÎÏÊ.
213 óÏÅÄÉÎÅÎÉÑ X11 É ÌÀÂÙÅ ÐÏÒÔÙ TCP/IP ÍÏÇÕÔ ÔÁËÖÅ ÂÙÔØ ÐÒÏ×ÅÄÅÎÙ ÞÅÒÅÚ
214 ÂÅÚÏÐÁÓÎÙÊ ËÁÎÁÌ.
215
216 OpenSSH - ÜÔÏ ÐÅÒÅÄÅÌËÁ ËÏÍÁÎÄÏÊ ÒÁÚÒÁÂÏÔÞÉËÏ× OpenBSD ÐÏÓÌÅÄÎÅÊ
217 Ó×ÏÂÏÄÎÏÊ ×ÅÒÓÉÉ SSH, ÄÏ×ÅÄÅÎÎÁÑ ÄÏ ÓÏ×ÒÅÍÅÎÎÏÇÏ ÓÏÓÔÏÑÎÉÑ × ÔÅÒÍÉÎÁÈ
218 ÕÒÏ×ÎÑ ÂÅÚÏÐÁÓÎÏÓÔÉ É ÐÏÄÄÅÒÖÉ×ÁÅÍÙÈ ×ÏÚÍÏÖÎÏÓÔÅÊ. ÷ÓÅ ÐÁÔÅÎÔÏ×ÁÎÎÙÅ
219 ÁÌÇÏÒÉÔÍÙ ×ÙÎÅÓÅÎÙ × ÏÔÄÅÌØÎÙÅ ÂÉÂÌÉÏÔÅËÉ (OpenSSL).
220
221 üÔÏÔ ÐÁËÅÔ ÓÏÄÅÒÖÉÔ ÆÁÊÌÙ, ÎÅÏÂÈÏÄÉÍÙÅ ËÁË ÄÌÑ ËÌÉÅÎÔÁ, ÔÁË É ÄÌÑ
222 ÓÅÒ×ÅÒÁ OpenSSH. ÷ÁÍ ÎÕÖÎÏ ÂÕÄÅÔ ÕÓÔÁÎÏ×ÉÔØ ÅÝÅ openssh-clients,
223 openssh-server, ÉÌÉ ÏÂÁ ÐÁËÅÔÁ.
224
225 %description -l uk
226 Ssh (Secure Shell) - ÃÅ ÐÒÏÇÒÁÍÁ ÄÌÑ "ÚÁÈÏÄÕ" (login) ÄϠצÄÄÁÌÅÎϧ
227 ÍÁÛÉÎÉ ÔÁ ÄÌÑ ×ÉËÏÎÁÎÎÑ ËÏÍÁÎÄ ÎÁ ×¦ÄÄÁÌÅΦʠÍÁÛÉΦ. ÷ÏÎÁ ÐÒÉÚÎÁÞÅÎÁ
228 ÄÌÑ ÚÁͦÎÉ rlogin ÔÁ rsh ¦ ÚÁÂÅÚÐÅÞÕ¤ ÂÅÚÐÅÞÎÕ ÛÉÆÒÏ×ÁÎÕ ËÏÍÕΦËÁæÀ
229 ͦ֠Ä×ÏÍÁ ÈÏÓÔÁÍÉ × ÍÅÒÅÖ¦, ÑËÁ ÎÅ ¤ ÂÅÚÐÅÞÎÏÀ. ú'¤ÄÎÁÎÎÑ X11 ÔÁ
230 ÄÏצÌØΦ ÐÏÒÔÉ TCP/IP ÍÏÖÕÔØ ÔÁËÏÖ ÂÕÔÉ ÐÒÏ×ÅÄÅΦ ÞÅÒÅÚ ÂÅÚÐÅÞÎÉÊ
231 ËÁÎÁÌ.
232
233 OpenSSH - ÃÅ ÐÅÒÅÒÏÂËÁ ËÏÍÁÎÄÏÀ ÒÏÚÒÏÂÎÉ˦נOpenBSD ÏÓÔÁÎÎØϧ ×¦ÌØÎϧ
234 ×ÅÒÓ¦§ SSH, ÄÏ×ÅÄÅÎÁ ÄÏ ÓÕÞÁÓÎÏÇÏ ÓÔÁÎÕ × ÔÅÒͦÎÁÈ Ò¦×ÎÑ ÂÅÚÐÅËÉ ÔÁ
235 ЦÄÔÒÉÍÕ×ÁÎÉÈ ÍÏÖÌÉ×ÏÓÔÅÊ. ÷Ó¦ ÐÁÔÅÎÔÏ×ÁΦ ÁÌÇÏÒÉÔÍÉ ×ÉÎÅÓÅΦ ÄÏ
236 ÏËÒÅÍÉȠ¦Â̦ÏÔÅË (OpenSSL).
237
238 ãÅÊ ÐÁËÅԠͦÓÔÉÔØ ÆÁÊÌÉ, ÎÅÏÂȦÄΦ ÑË ÄÌÑ Ë̦¤ÎÔÁ, ÔÁË ¦ ÄÌÑ ÓÅÒ×ÅÒÁ
239 OpenSSH. ÷ÁÍ ÐÏÔÒ¦ÂÎÏ ÂÕÄÅ ÝÅ ×ÓÔÁÎÏ×ÉÔÉ openssh-clients,
240 openssh-server, ÞÉ ÏÂÉÄ×Á ÐÁËÅÔÉ.
241
242 %package clients
243 Summary:        OpenSSH Secure Shell protocol clients
244 Summary(es):    Clientes de OpenSSH
245 Summary(pl):    Klienci protoko³u Secure Shell
246 Summary(pt_BR): Clientes do OpenSSH
247 Summary(ru):    OpenSSH - ËÌÉÅÎÔÙ ÐÒÏÔÏËÏÌÁ Secure Shell
248 Summary(uk):    OpenSSH - Ë̦¤ÎÔÉ ÐÒÏÔÏËÏÌÕ Secure Shell
249 Group:          Applications/Networking
250 Requires:       %{name} = %{epoch}:%{version}-%{release}
251 %{?with_sshagentsh:Requires:    xinitrc}
252 Provides:       ssh-clients
253 Obsoletes:      ssh-clients
254
255 %description clients
256 Ssh (Secure Shell) a program for logging into a remote machine and for
257 executing commands in a remote machine. It is intended to replace
258 rlogin and rsh, and provide secure encrypted communications between
259 two untrusted hosts over an insecure network. X11 connections and
260 arbitrary TCP/IP ports can also be forwarded over the secure channel.
261
262 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
263 it up to date in terms of security and features, as well as removing
264 all patented algorithms to seperate libraries (OpenSSL).
265
266 This package includes the clients necessary to make encrypted
267 connections to SSH servers.
268
269 %description clients -l es
270 Este paquete incluye los clientes que se necesitan para hacer
271 conexiones codificadas con servidores SSH.
272
273 %description clients -l pl
274 Ssh (Secure Shell) to program s³u¿±cy do logowania siê na zdaln±
275 maszynê i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
276 zast±piæ rlogin, rsh i dostarczyæ bezpieczne, szyfrowane po³±czenie
277 pomiêdzy dwoma hostami.
278
279 Ten pakiet zawiera klientów s³u¿±cych do ³±czenia siê z serwerami SSH.
280
281 %description clients -l pt_BR
282 Esse pacote inclui os clientes necessários para fazer conexões
283 encriptadas com servidores SSH.
284
285 %description clients -l ru
286 Ssh (Secure Shell) - ÜÔÏ ÐÒÏÇÒÁÍÍÁ ÄÌÑ "ÚÁÈÏÄÁ" (login) ÎÁ ÕÄÁÌÅÎÎÕÀ
287 ÍÁÛÉÎÕ É ÄÌÑ ×ÙÐÏÌÎÅÎÉÑ ËÏÍÁÎÄ ÎÁ ÕÄÁÌÅÎÎÏÊ ÍÁÛÉÎÅ.
288
289 üÔÏÔ ÐÁËÅÔ ÓÏÄÅÒÖÉÔ ÐÒÏÇÒÁÍÍÙ-ËÌÉÅÎÔÙ, ÎÅÏÂÈÏÄÉÍÙÅ ÄÌÑ ÕÓÔÁÎÏ×ÌÅÎÉÑ
290 ÚÁÛÉÆÒÏ×ÁÎÎÙÈ ÓÏÅÄÉÎÅÎÉÊ Ó ÓÅÒ×ÅÒÁÍÉ SSH.
291
292 %description clients -l uk
293 Ssh (Secure Shell) - ÃÅ ÐÒÏÇÒÁÍÁ ÄÌÑ "ÚÁÈÏÄÕ" (login) ÄϠצÄÄÁÌÅÎϧ
294 ÍÁÛÉÎÉ ÔÁ ÄÌÑ ×ÉËÏÎÁÎÎÑ ËÏÍÁÎÄ ÎÁ ×¦ÄÄÁÌÅΦʠÍÁÛÉΦ.
295
296 ãÅÊ ÐÁËÅԠͦÓÔÉÔØ ÐÒÏÇÒÁÍÉ-Ë̦¤ÎÔÉ, ÎÅÏÂȦÄΦ ÄÌÑ ×ÓÔÁÎÏ×ÌÅÎÎÑ
297 ÚÁÛÉÆÒÏ×ÁÎÉÈ Ú'¤ÄÎÁÎØ Ú ÓÅÒ×ÅÒÁÍÉ SSH.
298
299 %package server
300 Summary:        OpenSSH Secure Shell protocol server (sshd)
301 Summary(de):    OpenSSH Secure Shell Protocol-Server (sshd)
302 Summary(es):    Servidor OpenSSH para comunicaciones codificadas
303 Summary(fr):    Serveur de protocole du shell sécurisé OpenSSH (sshd)
304 Summary(it):    Server OpenSSH per il protocollo Secure Shell (sshd)
305 Summary(pl):    Serwer protoko³u Secure Shell (sshd)
306 Summary(pt):    Servidor do protocolo 'Secure Shell' OpenSSH (sshd)
307 Summary(pt_BR): Servidor OpenSSH para comunicações encriptadas
308 Summary(ru):    OpenSSH - ÓÅÒ×ÅÒ ÐÒÏÔÏËÏÌÁ Secure Shell (sshd)
309 Summary(uk):    OpenSSH - ÓÅÒ×ÅÒ ÐÒÏÔÏËÏÌÕ Secure Shell (sshd)
310 Group:          Networking/Daemons
311 Requires(post): chkconfig >= 0.9
312 Requires(post): grep
313 Requires(post,preun):   /sbin/chkconfig
314 Requires(postun):       /usr/sbin/userdel
315 Requires(pre):  /bin/id
316 Requires(pre):  /usr/sbin/useradd
317 Requires:       %{name} = %{epoch}:%{version}-%{release}
318 Requires:       /bin/login
319 Requires:       pam >= 0.77.3
320 Requires:       rc-scripts >= 0.4.0.18
321 Requires:       util-linux
322 Provides:       ssh-server
323 Provides:       user(sshd)
324
325 %description server
326 Ssh (Secure Shell) a program for logging into a remote machine and for
327 executing commands in a remote machine. It is intended to replace
328 rlogin and rsh, and provide secure encrypted communications between
329 two untrusted hosts over an insecure network. X11 connections and
330 arbitrary TCP/IP ports can also be forwarded over the secure channel.
331
332 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
333 it up to date in terms of security and features, as well as removing
334 all patented algorithms to seperate libraries (OpenSSL).
335
336 This package contains the secure shell daemon. The sshd is the server
337 part of the secure shell protocol and allows ssh clients to connect to
338 your host.
339
340 %description server -l de
341 Dieses Paket installiert den sshd, den Server-Teil der OpenSSH.
342
343 %description server -l es
344 Este paquete contiene el servidor SSH. sshd es la parte servidor del
345 protocolo secure shell y permite que clientes ssh se conecten a su
346 servidor.
347
348 %description server -l fr
349 Ce paquetage installe le 'sshd', partie serveur de OpenSSH.
350
351 %description server -l it
352 Questo pacchetto installa sshd, il server di OpenSSH.
353
354 %description server -l pl
355 Ssh (Secure Shell) to program s³u¿±cy do logowania siê na zdaln±
356 maszynê i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
357 zast±piæ rlogin, rsh i dostarczyæ bezpieczne, szyfrowane po³±czenie
358 pomiêdzy dwoma hostami.
359
360 Ten pakiet zawiera serwer sshd (do którego mog± ³±czyæ siê klienci
361 ssh).
362
363 %description server -l pt
364 Este pacote intala o sshd, o servidor do OpenSSH.
365
366 %description server -l pt_BR
367 Esse pacote contém o servidor SSH. O sshd é a parte servidor do
368 protocolo secure shell e permite que clientes ssh se conectem ao seu
369 host.
370
371 %description server -l ru
372 Ssh (Secure Shell) - ÜÔÏ ÐÒÏÇÒÁÍÍÁ ÄÌÑ "ÚÁÈÏÄÁ" (login) ÎÁ ÕÄÁÌÅÎÎÕÀ
373 ÍÁÛÉÎÕ É ÄÌÑ ×ÙÐÏÌÎÅÎÉÑ ËÏÍÁÎÄ ÎÁ ÕÄÁÌÅÎÎÏÊ ÍÁÛÉÎÅ.
374
375 üÔÏÔ ÐÁËÅÔ ÓÏÄÅÒÖÉÔ sshd - "ÄÅÍÏÎ" Secure Shell. sshd - ÜÔÏ ÓÅÒ×ÅÒÎÁÑ
376 ÞÁÓÔØ ÐÒÏÔÏËÏÌÁ Secure Shell, ÐÏÚ×ÏÌÑÀÝÁÑ ËÌÉÅÎÔÁÍ ssh ÓÏÅÄÉÎÑÔØÓÑ Ó
377 ×ÁÛÉÍ ÈÏÓÔÏÍ.
378
379 %description server -l uk
380 Ssh (Secure Shell) - ÃÅ ÐÒÏÇÒÁÍÁ ÄÌÑ "ÚÁÈÏÄÕ" (login) ÄϠצÄÄÁÌÅÎϧ
381 ÍÁÛÉÎÉ ÔÁ ÄÌÑ ×ÉËÏÎÁÎÎÑ ËÏÍÁÎÄ ÎÁ ×¦ÄÄÁÌÅΦʠÍÁÛÉΦ.
382
383 ãÅÊ ÐÁËÅԠͦÓÔÉÔØ sshd - "ÄÅÍÏÎ" Secure Shell. sshd - ÃÅ ÓÅÒ×ÅÒÎÁ
384 ÞÁÓÔÉÎÁ ÐÒÏÔÏËÏÌÕ Secure Shell, ÑËÁ ÄÏÚ×ÏÌѤ Ë̦¤ÎÔÁÍ ssh Ú×'ÑÚÕ×ÁÔÉÓØ
385 Ú ×ÁÛÉÍ ÈÏÓÔÏÍ.
386
387 %package gnome-askpass
388 Summary:        OpenSSH GNOME passphrase dialog
389 Summary(de):    OpenSSH GNOME Passwort-Dialog
390 Summary(es):    Diálogo para introducción de passphrase para GNOME
391 Summary(fr):    Dialogue pass-phrase GNOME d'OpenSSH
392 Summary(it):    Finestra di dialogo GNOME per la frase segreta di OpenSSH
393 Summary(pl):    Odpytywacz has³a OpenSSH dla GNOME
394 Summary(pt):    Diálogo de pedido de senha para GNOME do OpenSSH
395 Summary(pt_BR): Diálogo para entrada de passphrase para GNOME
396 Summary(ru):    OpenSSH - ÄÉÁÌÏÇ ××ÏÄÁ ËÌÀÞÅ×ÏÊ ÆÒÁÚÙ (passphrase) ÄÌÑ GNOME
397 Summary(uk):    OpenSSH - Ä¦ÁÌÏÇ ××ÏÄÕ ËÌÀÞÏ×ϧ ÆÒÁÚÉ (passphrase) ÄÌÑ GNOME
398 Group:          Applications/Networking
399 Requires:       %{name} = %{epoch}:%{version}-%{release}
400 Obsoletes:      openssh-askpass
401 Obsoletes:      ssh-askpass
402 Obsoletes:      ssh-extras
403
404 %description gnome-askpass
405 Ssh (Secure Shell) a program for logging into a remote machine and for
406 executing commands in a remote machine. It is intended to replace
407 rlogin and rsh, and provide secure encrypted communications between
408 two untrusted hosts over an insecure network. X11 connections and
409 arbitrary TCP/IP ports can also be forwarded over the secure channel.
410
411 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
412 it up to date in terms of security and features, as well as removing
413 all patented algorithms to seperate libraries (OpenSSL).
414
415 This package contains the GNOME passphrase dialog.
416
417 %description gnome-askpass -l es
418 Este paquete contiene un programa que abre una caja de diálogo para
419 entrada de passphrase en GNOME.
420
421 %description gnome-askpass -l pl
422 Ssh (Secure Shell) to program s³u¿±cy do logowania siê na zdaln±
423 maszynê i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
424 zast±piæ rlogin, rsh i dostarczyæ bezpieczne, szyfrowane po³±czenie
425 pomiêdzy dwoma hostami.
426
427 Ten pakiet zawiera ,,odpytywacz has³a'' dla GNOME.
428
429 %description gnome-askpass -l pt_BR
430 Esse pacote contém um programa que abre uma caixa de diálogo para
431 entrada de passphrase no GNOME.
432
433 %description gnome-askpass -l ru
434 Ssh (Secure Shell) - ÜÔÏ ÐÒÏÇÒÁÍÍÁ ÄÌÑ "ÚÁÈÏÄÁ" (login) ÎÁ ÕÄÁÌÅÎÎÕÀ
435 ÍÁÛÉÎÕ É ÄÌÑ ×ÙÐÏÌÎÅÎÉÑ ËÏÍÁÎÄ ÎÁ ÕÄÁÌÅÎÎÏÊ ÍÁÛÉÎÅ.
436
437 üÔÏÔ ÐÁËÅÔ ÓÏÄÅÒÖÉÔ ÄÉÁÌÏÇ ××ÏÄÁ ËÌÀÞÅ×ÏÊ ÆÒÁÚÙ ÄÌÑ ÉÓÐÏÌØÚÏ×ÁÎÉÑ ÐÏÄ
438 GNOME.
439
440 %description gnome-askpass -l uk
441 Ssh (Secure Shell) - ÃÅ ÐÒÏÇÒÁÍÁ ÄÌÑ "ÚÁÈÏÄÕ" (login) ÄϠצÄÄÁÌÅÎϧ
442 ÍÁÛÉÎÉ ÔÁ ÄÌÑ ×ÉËÏÎÁÎÎÑ ËÏÍÁÎÄ ÎÁ ×¦ÄÄÁÌÅΦʠÍÁÛÉΦ.
443
444 ãÅÊ ÐÁËÅԠͦÓÔÉÔؠĦÁÌÏÇ ××ÏÄÕ ËÌÀÞÏ×ϧ ÆÒÁÚÉ ÄÌÑ ×ÉËÏÒÉÓÔÁÎÎѠЦÄ
445 GNOME.
446
447 %prep
448 %setup -q
449 %patch0 -p1
450 %patch2 -p1
451 %patch3 -p1
452 %patch4 -p1
453 %{?with_ldap:%patch5 -p1}
454 %{?with_kerberos5:%patch6 -p1}
455 #%patch7 -p1
456 %patch8 -p1
457 %patch9 -p1
458 %{?with_hpn:%patch10 -p1}
459 %{?with_hpn_none:%patch11 -p1}
460 %patch12 -p1
461
462 %build
463 cp /usr/share/automake/config.sub .
464 %{__aclocal}
465 %{__autoconf}
466 %{?with_chroot:CPPFLAGS="-DCHROOT"}
467 %configure \
468         PERL=%{__perl} \
469         --with-dns \
470         --with-pam \
471         --with-mantype=man \
472         --with-md5-passwords \
473         --with-ipaddr-display \
474         %{?with_libedit:--with-libedit} \
475         --with-4in6 \
476         --disable-suid-ssh \
477         --with-tcp-wrappers \
478         %{?with_ldap:--with-libs="-lldap -llber"} \
479         %{?with_ldap:--with-cppflags="-DWITH_LDAP_PUBKEY"} \
480         %{?with_kerberos5:--with-kerberos5} \
481         --with-privsep-path=%{_privsepdir} \
482         --with-pid-dir=%{_localstatedir}/run \
483         --with-xauth=/usr/bin/xauth \
484         --enable-utmpx \
485         --enable-wtmpx
486
487 echo '#define LOGIN_PROGRAM                "/bin/login"' >>config.h
488
489 %{__make}
490
491 cd contrib
492 %if %{with gnome}
493 %{__make} gnome-ssh-askpass1 \
494         CC="%{__cc} %{rpmldflags} %{rpmcflags}"
495 %endif
496 %if %{with gtk}
497 %{__make} gnome-ssh-askpass2 \
498         CC="%{__cc} %{rpmldflags} %{rpmcflags}"
499 %endif
500
501 %install
502 rm -rf $RPM_BUILD_ROOT
503 install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/{pam.d,rc.d/init.d,sysconfig,security,env.d}} \
504         $RPM_BUILD_ROOT%{_libexecdir}/ssh
505 %{?with_sshagentsh:install -d $RPM_BUILD_ROOT/etc/{profile.d,X11/xinit/xinitrc.d}}
506
507 %{__make} install \
508         DESTDIR=$RPM_BUILD_ROOT
509
510 install %{SOURCE4} $RPM_BUILD_ROOT/etc/pam.d/sshd
511 install %{SOURCE6} $RPM_BUILD_ROOT/etc/pam.d/passwdssh
512 install %{SOURCE5} $RPM_BUILD_ROOT/etc/sysconfig/sshd
513 install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
514 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/ssh_config
515 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/sshd_config
516 %if %{with sshagentsh}
517 install %{SOURCE11} $RPM_BUILD_ROOT/etc/profile.d
518 ln -sf  /etc/profile.d/ssh-agent.sh $RPM_BUILD_ROOT/etc/X11/xinit/xinitrc.d/ssh-agent.sh
519 install %{SOURCE12} $RPM_BUILD_ROOT%{_sysconfdir}
520 %endif
521
522 bzip2 -dc %{SOURCE7} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
523
524 %if %{with gnome}
525 install contrib/gnome-ssh-askpass1 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
526 %endif
527 %if %{with gtk}
528 install contrib/gnome-ssh-askpass2 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
529 %endif
530 %if %{with gnome} || %{with gtk}
531 cat << EOF >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_SERVER
532 #GNOME_SSH_ASKPASS_GRAB_SERVER="true"
533 EOF
534 cat << EOF >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_POINTER
535 #GNOME_SSH_ASKPASS_GRAB_POINTER="true"
536 EOF
537 ln -s %{_libexecdir}/ssh/ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/ssh-askpass
538 %endif
539
540 rm -f   $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
541 echo ".so ssh.1" > $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
542
543 touch $RPM_BUILD_ROOT/etc/security/blacklist.sshd
544
545 %if "%{_lib}" != "lib"
546 find $RPM_BUILD_ROOT%{_sysconfdir} -type f -print0 | xargs -0 sed -i -e 's#%{_prefix}/lib#%{_libdir}#'
547 %endif
548
549 cat << 'EOF' > $RPM_BUILD_ROOT/etc/env.d/SSH_ASKPASS
550 #SSH_ASKPASS="%{_libexecdir}/ssh-askpass"
551 EOF
552
553 %clean
554 rm -rf $RPM_BUILD_ROOT
555
556 %post clients
557 %env_update
558
559 %postun clients
560 %env_update
561
562 %post gnome-askpass
563 %env_update
564
565 %postun gnome-askpass
566 %env_update
567
568 %pre server
569 %useradd -P %{name}-server -u 40 -d %{_privsepdir} -s /bin/false -c "OpenSSH PrivSep User" -g nobody sshd
570
571 %post server
572 /sbin/chkconfig --add sshd
573 %service sshd reload "openssh daemon"
574 if ! grep -qs ssh /etc/security/passwd.conf ; then
575         umask 022
576         echo "ssh" >> /etc/security/passwd.conf
577 fi
578
579 %preun server
580 if [ "$1" = "0" ]; then
581         %service sshd stop
582         /sbin/chkconfig --del sshd
583 fi
584
585 %postun server
586 if [ "$1" = "0" ]; then
587         %userremove sshd
588 fi
589
590 %files
591 %defattr(644,root,root,755)
592 %doc *.RNG TODO README OVERVIEW CREDITS Change*
593 %attr(755,root,root) %{_bindir}/ssh-key*
594 %{_mandir}/man1/ssh-key*.1*
595 %dir %{_sysconfdir}
596 %dir %{_libexecdir}
597
598 %files clients
599 %defattr(644,root,root,755)
600 %attr(755,root,root) %{_bindir}/ssh
601 %attr(755,root,root) %{_bindir}/slogin
602 %attr(755,root,root) %{_bindir}/sftp
603 %attr(755,root,root) %{_bindir}/ssh-agent
604 %attr(755,root,root) %{_bindir}/ssh-add
605 %attr(755,root,root) %{_bindir}/scp
606 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh_config
607 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/SSH_ASKPASS
608 %if %{with sshagentsh}
609 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh-agent.conf
610 %attr(755,root,root) /etc/profile.d/ssh-agent.sh
611 %attr(755,root,root) /etc/X11/xinit/xinitrc.d/ssh-agent.sh
612 %endif
613 %{_mandir}/man1/scp.1*
614 %{_mandir}/man1/ssh.1*
615 %{_mandir}/man1/slogin.1*
616 %{_mandir}/man1/sftp.1*
617 %{_mandir}/man1/ssh-agent.1*
618 %{_mandir}/man1/ssh-add.1*
619 %{_mandir}/man5/ssh_config.5*
620 %lang(it) %{_mandir}/it/man1/ssh.1*
621 %lang(it) %{_mandir}/it/man5/ssh_config.5*
622 %lang(pl) %{_mandir}/pl/man1/scp.1*
623 %lang(zh_CN) %{_mandir}/zh_CN/man1/scp.1*
624
625 # for host-based auth (suid required for accessing private host key)
626 #%attr(4755,root,root) %{_libexecdir}/ssh-keysign
627 #%{_mandir}/man8/ssh-keysign.8*
628
629 %files server
630 %defattr(644,root,root,755)
631 %attr(755,root,root) %{_sbindir}/sshd
632 %attr(755,root,root) %{_libexecdir}/sftp-server
633 %attr(755,root,root) %{_libexecdir}/ssh-keysign
634 %{_mandir}/man8/sshd.8*
635 %{_mandir}/man8/sftp-server.8*
636 %{_mandir}/man8/ssh-keysign.8*
637 %{_mandir}/man5/sshd_config.5*
638 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sshd_config
639 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/sshd
640 %attr(640,root,root) %{_sysconfdir}/moduli
641 %attr(754,root,root) /etc/rc.d/init.d/sshd
642 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/sshd
643 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.sshd
644
645 %if %{with gnome} || %{with gtk}
646 %files gnome-askpass
647 %defattr(644,root,root,755)
648 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/GNOME_SSH_ASKPASS*
649 %dir %{_libexecdir}/ssh
650 %attr(755,root,root) %{_libexecdir}/ssh/ssh-askpass
651 %attr(755,root,root) %{_libexecdir}/ssh-askpass
652 %endif
This page took 0.137256 seconds and 4 git commands to generate.