]> git.pld-linux.org Git - packages/openssh.git/blob - openssh.spec
- up to 5.2
[packages/openssh.git] / openssh.spec
1 #
2 # TODO:
3 # - check this:
4 #   http://securitytracker.com/alerts/2008/Nov/1021235.html (CVE-2008-5161)
5 #
6 # Conditional build:
7 %bcond_with     gnome           # with gnome-askpass (GNOME 1.x) utility
8 %bcond_without  gtk             # without GTK+ (2.x)
9 %bcond_with     ldap            # with ldap support
10 %bcond_without  libedit         # without libedit (editline/history support in sftp client)
11 %bcond_without  kerberos5       # without kerberos5 support
12 %bcond_without  selinux         # build without SELinux support
13 %bcond_with     hpn             # High Performance SSH/SCP - HPN-SSH including Cipher NONE (broken too often)
14
15 # gtk2-based gnome-askpass means no gnome1-based
16 %{?with_gtk:%undefine with_gnome}
17 #
18 Summary:        OpenSSH free Secure Shell (SSH) implementation
19 Summary(de.UTF-8):      OpenSSH - freie Implementation der Secure Shell (SSH)
20 Summary(es.UTF-8):      Implementación libre de SSH
21 Summary(fr.UTF-8):      Implémentation libre du shell sécurisé OpenSSH (SSH)
22 Summary(it.UTF-8):      Implementazione gratuita OpenSSH della Secure Shell
23 Summary(pl.UTF-8):      Publicznie dostępna implementacja bezpiecznego shella (SSH)
24 Summary(pt.UTF-8):      Implementação livre OpenSSH do protocolo 'Secure Shell' (SSH)
25 Summary(pt_BR.UTF-8):   Implementação livre do SSH
26 Summary(ru.UTF-8):      OpenSSH - свободная реализация протокола Secure Shell (SSH)
27 Summary(uk.UTF-8):      OpenSSH - вільна реалізація протоколу Secure Shell (SSH)
28 Name:           openssh
29 Version:        5.2p1
30 Release:        1
31 Epoch:          2
32 License:        BSD
33 Group:          Applications/Networking
34 Source0:        ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/%{name}-%{version}.tar.gz
35 # Source0-md5:  ada79c7328a8551bdf55c95e631e7dad
36 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
37 # Source1-md5:  66943d481cc422512b537bcc2c7400d1
38 Source2:        %{name}d.init
39 Source3:        %{name}d.pamd
40 Source4:        %{name}.sysconfig
41 Source5:        ssh-agent.sh
42 Source6:        ssh-agent.conf
43 Patch0:         %{name}-no_libnsl.patch
44 Patch2:         %{name}-pam_misc.patch
45 Patch3:         %{name}-sigpipe.patch
46 # http://www.opendarwin.org/projects/openssh-lpk/
47 Patch4:         %{name}-lpk-4.3p1-0.3.7.patch
48 Patch5:         %{name}-config.patch
49 Patch7:         %{name}-selinux.patch
50 # High Performance SSH/SCP - HPN-SSH - http://www.psc.edu/networking/projects/hpn-ssh/
51 # http://www.psc.edu/networking/projects/hpn-ssh/openssh-4.9p1-hpn13v2.diff.gz
52 Patch9:         %{name}-5.0p1-hpn13v4.diff
53 Patch10:        %{name}-include.patch
54 Patch11:        %{name}-chroot.patch
55 Patch12:        http://people.debian.org/~cjwatson/%{name}-blacklist.diff
56 URL:            http://www.openssh.com/
57 BuildRequires:  %{__perl}
58 BuildRequires:  autoconf
59 BuildRequires:  automake
60 %{?with_gnome:BuildRequires:    gnome-libs-devel}
61 %{?with_gtk:BuildRequires:      gtk+2-devel}
62 %{?with_kerberos5:BuildRequires:        krb5-devel}
63 %{?with_libedit:BuildRequires:  libedit-devel}
64 %{?with_selinux:BuildRequires:  libselinux-devel}
65 BuildRequires:  libwrap-devel
66 %{?with_ldap:BuildRequires:     openldap-devel >= 2.4.6}
67 BuildRequires:  openssl-devel >= 0.9.7d
68 BuildRequires:  pam-devel
69 %{?with_gtk:BuildRequires:      pkgconfig}
70 BuildRequires:  rpmbuild(macros) >= 1.318
71 BuildRequires:  zlib-devel
72 Requires:       filesystem >= 3.0-11
73 Requires:       pam >= 0.99.7.1
74 Suggests:       openssh-blacklist
75 Suggests:       xorg-app-xauth
76 Obsoletes:      ssh
77 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
78
79 %define         _sysconfdir     /etc/ssh
80 %define         _libexecdir     %{_libdir}/%{name}
81 %define         _privsepdir     /usr/share/empty
82
83 %description
84 Ssh (Secure Shell) a program for logging into a remote machine and for
85 executing commands in a remote machine. It is intended to replace
86 rlogin and rsh, and provide secure encrypted communications between
87 two untrusted hosts over an insecure network. X11 connections and
88 arbitrary TCP/IP ports can also be forwarded over the secure channel.
89
90 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
91 it up to date in terms of security and features, as well as removing
92 all patented algorithms to seperate libraries (OpenSSL).
93
94 This package includes the core files necessary for both the OpenSSH
95 client and server. To make this package useful, you should also
96 install openssh-clients, openssh-server, or both.
97 %if %{with hpn} || %{with hpn_none}
98 This release includes High Performance SSH/SCP patches from
99 http://www.psc.edu/networking/projects/hpn-ssh/ which are supposed
100 to increase throughput on fast connections with high RTT (20-150 msec).
101 See the website for '-w' values for your connection and /proc/sys TCP
102 values. BTW. in a LAN you have got generally RTT < 1 msec.
103 %endif
104 %if %{with hpn_none}
105 It also includes an undocumented '-z' option which switches
106 the cipher to none after authentication is completed. Data is
107 still secured from tampering and corruption in transit through
108 the use of the Message Authentication Code (MAC).
109 This option will significantly reduce the number of cpu cycles used
110 by the SSH/SCP process. This may allow some users to see significant
111 improvement in (sniffable) data tranfer rates.
112 %endif
113
114 %description -l de.UTF-8
115 OpenSSH (Secure Shell) stellt den Zugang zu anderen Rechnern her. Es
116 ersetzt telnet, rlogin, rexec und rsh und stellt eine sichere,
117 verschlüsselte Verbindung zwischen zwei nicht vertrauenswürdigen Hosts
118 über eine unsicheres Netzwerk her. X11 Verbindungen und beliebige
119 andere TCP/IP Ports können ebenso über den sicheren Channel
120 weitergeleitet werden.
121
122 %description -l es.UTF-8
123 SSH es un programa para accesar y ejecutar órdenes en computadores
124 remotos. Sustituye rlogin y rsh, y suministra un canal de comunicación
125 seguro entre dos servidores en una red insegura. Conexiones X11 y
126 puertas TCP/IP arbitrárias también pueden ser usadas por el canal
127 seguro.
128
129 OpenSSH es el resultado del trabajo del equipo de OpenBSD para
130 continuar la última versión gratuita de SSH, actualizándolo en
131 términos de seguridad y recursos,así también eliminando todos los
132 algoritmos patentados y colocándolos en bibliotecas separadas
133 (OpenSSL).
134
135 Este paquete contiene "port" para Linux de OpenSSH. Se debe instalar
136 también el paquete openssh-clients u openssh-server o ambos.
137
138 %description -l fr.UTF-8
139 OpenSSH (Secure Shell) fournit un accès à un système distant. Il
140 remplace telnet, rlogin, rexec et rsh, tout en assurant des
141 communications cryptées securisées entre deux hôtes non fiabilisés sur
142 un réseau non sécurisé. Des connexions X11 et des ports TCP/IP
143 arbitraires peuvent également être transmis sur le canal sécurisé.
144
145 %description -l it.UTF-8
146 OpenSSH (Secure Shell) fornisce l'accesso ad un sistema remoto.
147 Sostituisce telnet, rlogin, rexec, e rsh, e fornisce comunicazioni
148 sicure e crittate tra due host non fidati su una rete non sicura. Le
149 connessioni X11 ad una porta TCP/IP arbitraria possono essere
150 inoltrate attraverso un canale sicuro.
151
152 %description -l pl.UTF-8
153 Ssh (Secure Shell) to program służący do logowania się na zdalną
154 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
155 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
156 pomiędzy dwoma hostami.
157
158 Ten pakiet zawiera podstawowe pliki potrzebne zarówno po stronie
159 klienta jak i serwera OpenSSH. Aby był użyteczny, trzeba zainstalować
160 co najmniej jeden z pakietów: openssh-clients lub openssh-server.
161 %if %{with hpn} || %{with hpn_none}
162 Ta wersja zawiera łaty z projektu High Performance SSH/SCP
163 http://www.psc.edu/networking/projects/hpn-ssh/, które mają na celu
164 zwiększenie przepustowości transmisji dla szybkich połączeń
165 z dużym RTT (20-150 msec). Na stronie projektu znaleźć można
166 odpowednie dla danego połączenia wartości parametru '-w' oraz
167 opcje /proc/sys dla TCP. Nawiasem mówiąc w sieciach LAN RTT < 1 msec.
168 %endif
169 %if %{with hpn_none}
170 Obsługiwana jest również nieudokumentowana opcja '-z' odpowiedzialna
171 za wyłączenie szyfrowania danych po zakończeniu procesu uwierzytelniania.
172 Dane są zabezpieczone przed modyfikacją lub uszkodzeniem przez
173 stosowanie Message Authentication Code (MAC).
174 Opcja ta znacznie redukuje liczbę cykli procesora zużywanych przez
175 procesy SSH/SCP. W wybranych zastosowaniach może ona wpłynąć
176 na wyraźne przyspieszenie (podsłuchiwalnej) transmisji danych.
177 %endif
178
179 %description -l pt.UTF-8
180 OpenSSH (Secure Shell) fornece acesso a um sistema remoto. Substitui o
181 telnet, rlogin, rexec, e o rsh e fornece comunicações seguras e
182 cifradas entre duas máquinas sem confiança mútua sobre uma rede
183 insegura. Ligações X11 e portos TCP/IP arbitrários também poder ser
184 reenviados pelo canal seguro.
185
186 %description -l pt_BR.UTF-8
187 SSH é um programa para acessar e executar comandos em máquinas
188 remotas. Ele substitui rlogin e rsh, e provem um canal de comunicação
189 seguro entre dois hosts em uma rede insegura. Conexões X11 e portas
190 TCP/IP arbitrárias também podem ser usadas pelo canal seguro.
191
192 OpenSSH é o resultado do trabalho da equipe do OpenBSD em continuar a
193 última versão gratuita do SSH, atualizando-o em termos de segurança e
194 recursos, assim como removendo todos os algoritmos patenteados e
195 colocando-os em bibliotecas separadas (OpenSSL).
196
197 Esse pacote contém o "port" pra Linux do OpenSSH. Você deve instalar
198 também ou o pacote openssh-clients, ou o openssh-server, ou ambos.
199
200 %description -l ru.UTF-8
201 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
202 машину и для выполнения команд на удаленной машине. Она предназначена
203 для замены rlogin и rsh и обеспечивает безопасную шифрованную
204 коммуникацию между двумя хостами в сети, являющейся небезопасной.
205 Соединения X11 и любые порты TCP/IP могут также быть проведены через
206 безопасный канал.
207
208 OpenSSH - это переделка командой разработчиков OpenBSD последней
209 свободной версии SSH, доведенная до современного состояния в терминах
210 уровня безопасности и поддерживаемых возможностей. Все патентованные
211 алгоритмы вынесены в отдельные библиотеки (OpenSSL).
212
213 Этот пакет содержит файлы, необходимые как для клиента, так и для
214 сервера OpenSSH. Вам нужно будет установить еще openssh-clients,
215 openssh-server, или оба пакета.
216
217 %description -l uk.UTF-8
218 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
219 машини та для виконання команд на віддаленій машині. Вона призначена
220 для заміни rlogin та rsh і забезпечує безпечну шифровану комунікацію
221 між двома хостами в мережі, яка не є безпечною. З'єднання X11 та
222 довільні порти TCP/IP можуть також бути проведені через безпечний
223 канал.
224
225 OpenSSH - це переробка командою розробників OpenBSD останньої вільної
226 версії SSH, доведена до сучасного стану в термінах рівня безпеки та
227 підтримуваних можливостей. Всі патентовані алгоритми винесені до
228 окремих бібліотек (OpenSSL).
229
230 Цей пакет містить файли, необхідні як для клієнта, так і для сервера
231 OpenSSH. Вам потрібно буде ще встановити openssh-clients,
232 openssh-server, чи обидва пакети.
233
234 %package clients
235 Summary:        OpenSSH Secure Shell protocol clients
236 Summary(es.UTF-8):      Clientes de OpenSSH
237 Summary(pl.UTF-8):      Klienci protokołu Secure Shell
238 Summary(pt_BR.UTF-8):   Clientes do OpenSSH
239 Summary(ru.UTF-8):      OpenSSH - клиенты протокола Secure Shell
240 Summary(uk.UTF-8):      OpenSSH - клієнти протоколу Secure Shell
241 Group:          Applications/Networking
242 Requires:       %{name} = %{epoch}:%{version}-%{release}
243 Provides:       ssh-clients
244 Obsoletes:      ssh-clients
245
246 %description clients
247 Ssh (Secure Shell) a program for logging into a remote machine and for
248 executing commands in a remote machine. It is intended to replace
249 rlogin and rsh, and provide secure encrypted communications between
250 two untrusted hosts over an insecure network. X11 connections and
251 arbitrary TCP/IP ports can also be forwarded over the secure channel.
252
253 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
254 it up to date in terms of security and features, as well as removing
255 all patented algorithms to seperate libraries (OpenSSL).
256
257 This package includes the clients necessary to make encrypted
258 connections to SSH servers.
259
260 %description clients -l es.UTF-8
261 Este paquete incluye los clientes que se necesitan para hacer
262 conexiones codificadas con servidores SSH.
263
264 %description clients -l pl.UTF-8
265 Ssh (Secure Shell) to program służący do logowania się na zdalną
266 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
267 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
268 pomiędzy dwoma hostami.
269
270 Ten pakiet zawiera klientów służących do łączenia się z serwerami SSH.
271
272 %description clients -l pt_BR.UTF-8
273 Esse pacote inclui os clientes necessários para fazer conexões
274 encriptadas com servidores SSH.
275
276 %description clients -l ru.UTF-8
277 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
278 машину и для выполнения команд на удаленной машине.
279
280 Этот пакет содержит программы-клиенты, необходимые для установления
281 зашифрованных соединений с серверами SSH.
282
283 %description clients -l uk.UTF-8
284 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
285 машини та для виконання команд на віддаленій машині.
286
287 Цей пакет містить програми-клієнти, необхідні для встановлення
288 зашифрованих з'єднань з серверами SSH.
289
290 %package clients-agent-profile_d
291 Summary:        OpenSSH Secure Shell agent init script
292 Summary(pl.UTF-8):      Skrypt startowy agenta OpenSSH
293 Group:          Applications/Networking
294 Requires:       %{name}-clients = %{epoch}:%{version}-%{release}
295
296 %description clients-agent-profile_d
297 profile.d scripts for starting SSH agent.
298
299 %description clients-agent-profile_d -l pl.UTF-8
300 Skrypty profile.d do uruchamiania agenta SSH.
301
302 %package clients-agent-xinitrc
303 Summary:        OpenSSH Secure Shell agent init script
304 Summary(pl.UTF-8):      Skrypt inicjujący agenta ssh przez xinitrc
305 Group:          Applications/Networking
306 Requires:       %{name}-clients-agent-profile_d = %{epoch}:%{version}-%{release}
307 Requires:       xinitrc
308
309 %description clients-agent-xinitrc
310 xinitrc scripts for starting SSH agent.
311
312 %description clients-agent-xinitrc -l pl.UTF-8
313 Skrypty xinitrc do uruchamiania agenta SSH.
314
315 %package server
316 Summary:        OpenSSH Secure Shell protocol server (sshd)
317 Summary(de.UTF-8):      OpenSSH Secure Shell Protocol-Server (sshd)
318 Summary(es.UTF-8):      Servidor OpenSSH para comunicaciones codificadas
319 Summary(fr.UTF-8):      Serveur de protocole du shell sécurisé OpenSSH (sshd)
320 Summary(it.UTF-8):      Server OpenSSH per il protocollo Secure Shell (sshd)
321 Summary(pl.UTF-8):      Serwer protokołu Secure Shell (sshd)
322 Summary(pt.UTF-8):      Servidor do protocolo 'Secure Shell' OpenSSH (sshd)
323 Summary(pt_BR.UTF-8):   Servidor OpenSSH para comunicações encriptadas
324 Summary(ru.UTF-8):      OpenSSH - сервер протокола Secure Shell (sshd)
325 Summary(uk.UTF-8):      OpenSSH - сервер протоколу Secure Shell (sshd)
326 Group:          Networking/Daemons
327 Requires(post): chkconfig >= 0.9
328 Requires(post): grep
329 Requires(post,preun):   /sbin/chkconfig
330 Requires(postun):       /usr/sbin/userdel
331 Requires(pre):  /bin/id
332 Requires(pre):  /usr/sbin/useradd
333 Requires:       %{name} = %{epoch}:%{version}-%{release}
334 Requires:       /bin/login
335 Requires:       pam >= 0.99.7.1
336 Requires:       rc-scripts >= 0.4.1.23
337 Requires:       util-linux
338 Provides:       ssh-server
339 Provides:       user(sshd)
340
341 %description server
342 Ssh (Secure Shell) a program for logging into a remote machine and for
343 executing commands in a remote machine. It is intended to replace
344 rlogin and rsh, and provide secure encrypted communications between
345 two untrusted hosts over an insecure network. X11 connections and
346 arbitrary TCP/IP ports can also be forwarded over the secure channel.
347
348 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
349 it up to date in terms of security and features, as well as removing
350 all patented algorithms to seperate libraries (OpenSSL).
351
352 This package contains the secure shell daemon. The sshd is the server
353 part of the secure shell protocol and allows ssh clients to connect to
354 your host.
355
356 %description server -l de.UTF-8
357 Dieses Paket installiert den sshd, den Server-Teil der OpenSSH.
358
359 %description server -l es.UTF-8
360 Este paquete contiene el servidor SSH. sshd es la parte servidor del
361 protocolo secure shell y permite que clientes ssh se conecten a su
362 servidor.
363
364 %description server -l fr.UTF-8
365 Ce paquetage installe le 'sshd', partie serveur de OpenSSH.
366
367 %description server -l it.UTF-8
368 Questo pacchetto installa sshd, il server di OpenSSH.
369
370 %description server -l pl.UTF-8
371 Ssh (Secure Shell) to program służący do logowania się na zdalną
372 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
373 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
374 pomiędzy dwoma hostami.
375
376 Ten pakiet zawiera serwer sshd (do którego mogą łączyć się klienci
377 ssh).
378
379 %description server -l pt.UTF-8
380 Este pacote intala o sshd, o servidor do OpenSSH.
381
382 %description server -l pt_BR.UTF-8
383 Esse pacote contém o servidor SSH. O sshd é a parte servidor do
384 protocolo secure shell e permite que clientes ssh se conectem ao seu
385 host.
386
387 %description server -l ru.UTF-8
388 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
389 машину и для выполнения команд на удаленной машине.
390
391 Этот пакет содержит sshd - "демон" Secure Shell. sshd - это серверная
392 часть протокола Secure Shell, позволяющая клиентам ssh соединяться с
393 вашим хостом.
394
395 %description server -l uk.UTF-8
396 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
397 машини та для виконання команд на віддаленій машині.
398
399 Цей пакет містить sshd - "демон" Secure Shell. sshd - це серверна
400 частина протоколу Secure Shell, яка дозволяє клієнтам ssh зв'язуватись
401 з вашим хостом.
402
403 %package gnome-askpass
404 Summary:        OpenSSH GNOME passphrase dialog
405 Summary(de.UTF-8):      OpenSSH GNOME Passwort-Dialog
406 Summary(es.UTF-8):      Diálogo para introducción de passphrase para GNOME
407 Summary(fr.UTF-8):      Dialogue pass-phrase GNOME d'OpenSSH
408 Summary(it.UTF-8):      Finestra di dialogo GNOME per la frase segreta di OpenSSH
409 Summary(pl.UTF-8):      Odpytywacz hasła OpenSSH dla GNOME
410 Summary(pt.UTF-8):      Diálogo de pedido de senha para GNOME do OpenSSH
411 Summary(pt_BR.UTF-8):   Diálogo para entrada de passphrase para GNOME
412 Summary(ru.UTF-8):      OpenSSH - диалог ввода ключевой фразы (passphrase) для GNOME
413 Summary(uk.UTF-8):      OpenSSH - діалог вводу ключової фрази (passphrase) для GNOME
414 Group:          Applications/Networking
415 Requires:       %{name} = %{epoch}:%{version}-%{release}
416 Obsoletes:      openssh-askpass
417 Obsoletes:      ssh-askpass
418 Obsoletes:      ssh-extras
419
420 %description gnome-askpass
421 Ssh (Secure Shell) a program for logging into a remote machine and for
422 executing commands in a remote machine. It is intended to replace
423 rlogin and rsh, and provide secure encrypted communications between
424 two untrusted hosts over an insecure network. X11 connections and
425 arbitrary TCP/IP ports can also be forwarded over the secure channel.
426
427 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
428 it up to date in terms of security and features, as well as removing
429 all patented algorithms to seperate libraries (OpenSSL).
430
431 This package contains the GNOME passphrase dialog.
432
433 %description gnome-askpass -l es.UTF-8
434 Este paquete contiene un programa que abre una caja de diálogo para
435 entrada de passphrase en GNOME.
436
437 %description gnome-askpass -l pl.UTF-8
438 Ssh (Secure Shell) to program służący do logowania się na zdalną
439 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
440 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
441 pomiędzy dwoma hostami.
442
443 Ten pakiet zawiera ,,odpytywacz hasła'' dla GNOME.
444
445 %description gnome-askpass -l pt_BR.UTF-8
446 Esse pacote contém um programa que abre uma caixa de diálogo para
447 entrada de passphrase no GNOME.
448
449 %description gnome-askpass -l ru.UTF-8
450 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
451 машину и для выполнения команд на удаленной машине.
452
453 Этот пакет содержит диалог ввода ключевой фразы для использования под
454 GNOME.
455
456 %description gnome-askpass -l uk.UTF-8
457 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
458 машини та для виконання команд на віддаленій машині.
459
460 Цей пакет містить діалог вводу ключової фрази для використання під
461 GNOME.
462
463 %prep
464 %setup -q
465 %patch0 -p1
466 %patch2 -p1
467 %patch3 -p1
468 %{?with_ldap:%patch4 -p1}
469 %patch5 -p1
470 %patch7 -p1
471 %{?with_hpn:%patch9 -p1}
472 %patch10 -p1
473 %patch11 -p1
474 %patch12 -p1
475
476 %build
477 cp /usr/share/automake/config.sub .
478 %{__aclocal}
479 %{__autoconf}
480 CPPFLAGS="-DCHROOT"
481 %configure \
482         PERL=%{__perl} \
483         --with-dns \
484         --with-pam \
485         --with-mantype=man \
486         --with-md5-passwords \
487         --with-ipaddr-display \
488         %{?with_libedit:--with-libedit} \
489         --with-4in6 \
490         --disable-suid-ssh \
491         --with-tcp-wrappers \
492         %{?with_ldap:--with-libs="-lldap -llber"} \
493         %{?with_ldap:--with-cppflags="-DWITH_LDAP_PUBKEY"} \
494         %{?with_kerberos5:--with-kerberos5=/usr} \
495         --with-privsep-path=%{_privsepdir} \
496         --with-pid-dir=%{_localstatedir}/run \
497         --with-xauth=/usr/bin/xauth \
498         --enable-utmpx \
499         --enable-wtmpx
500
501 echo '#define LOGIN_PROGRAM                "/bin/login"' >>config.h
502
503 %{__make}
504
505 cd contrib
506 %if %{with gnome}
507 %{__make} gnome-ssh-askpass1 \
508         CC="%{__cc} %{rpmldflags} %{rpmcflags}"
509 %endif
510 %if %{with gtk}
511 %{__make} gnome-ssh-askpass2 \
512         CC="%{__cc} %{rpmldflags} %{rpmcflags}"
513 %endif
514
515 %install
516 rm -rf $RPM_BUILD_ROOT
517 install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/{pam.d,rc.d/init.d,sysconfig,security,env.d}} \
518         $RPM_BUILD_ROOT%{_libexecdir}/ssh
519 install -d $RPM_BUILD_ROOT/etc/{profile.d,X11/xinit/xinitrc.d}
520
521 %{__make} install \
522         DESTDIR=$RPM_BUILD_ROOT
523
524 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
525
526 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
527 install %{SOURCE3} $RPM_BUILD_ROOT/etc/pam.d/sshd
528 install %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/sshd
529 install %{SOURCE5} $RPM_BUILD_ROOT/etc/profile.d
530 ln -sf  /etc/profile.d/ssh-agent.sh $RPM_BUILD_ROOT/etc/X11/xinit/xinitrc.d/ssh-agent.sh
531 install %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}
532
533 %if %{with gnome}
534 install contrib/gnome-ssh-askpass1 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
535 %endif
536 %if %{with gtk}
537 install contrib/gnome-ssh-askpass2 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
538 %endif
539 %if %{with gnome} || %{with gtk}
540 cat << 'EOF' >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_SERVER
541 #GNOME_SSH_ASKPASS_GRAB_SERVER="true"
542 EOF
543 cat << 'EOF' >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_POINTER
544 #GNOME_SSH_ASKPASS_GRAB_POINTER="true"
545 EOF
546 ln -s %{_libexecdir}/ssh/ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/ssh-askpass
547 %endif
548
549 install contrib/ssh-copy-id $RPM_BUILD_ROOT%{_bindir}
550 install contrib/ssh-copy-id.1 $RPM_BUILD_ROOT%{_mandir}/man1
551
552 rm -f   $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
553 echo ".so ssh.1" > $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
554
555 touch $RPM_BUILD_ROOT/etc/security/blacklist.sshd
556
557 cat << 'EOF' > $RPM_BUILD_ROOT/etc/env.d/SSH_ASKPASS
558 #SSH_ASKPASS="%{_libexecdir}/ssh-askpass"
559 EOF
560
561 rm -f $RPM_BUILD_ROOT%{_datadir}/Ssh.bin # ???
562 rm -f $RPM_BUILD_ROOT%{_mandir}/README.openssh-non-english-man-pages
563
564 %clean
565 rm -rf $RPM_BUILD_ROOT
566
567 %post clients
568 %env_update
569
570 %postun clients
571 %env_update
572
573 %post gnome-askpass
574 %env_update
575
576 %postun gnome-askpass
577 %env_update
578
579 %pre server
580 %useradd -P %{name}-server -u 40 -d %{_privsepdir} -s /bin/false -c "OpenSSH PrivSep User" -g nobody sshd
581
582 %post server
583 /sbin/chkconfig --add sshd
584 %service sshd reload "openssh daemon"
585 if ! grep -qs ssh /etc/security/passwd.conf ; then
586         umask 022
587         echo "ssh" >> /etc/security/passwd.conf
588 fi
589
590 %preun server
591 if [ "$1" = "0" ]; then
592         %service sshd stop
593         /sbin/chkconfig --del sshd
594 fi
595
596 %postun server
597 if [ "$1" = "0" ]; then
598         %userremove sshd
599 fi
600
601 %files
602 %defattr(644,root,root,755)
603 %doc *.RNG TODO README OVERVIEW CREDITS Change*
604 %attr(755,root,root) %{_bindir}/ssh-key*
605 %attr(755,root,root) %{_bindir}/ssh-vulnkey*
606 %{_mandir}/man1/ssh-key*.1*
607 %{_mandir}/man1/ssh-vulnkey*.1*
608 %dir %{_sysconfdir}
609 %dir %{_libexecdir}
610
611 %files clients
612 %defattr(644,root,root,755)
613 %attr(755,root,root) %{_bindir}/ssh
614 %attr(755,root,root) %{_bindir}/slogin
615 %attr(755,root,root) %{_bindir}/sftp
616 %attr(755,root,root) %{_bindir}/ssh-agent
617 %attr(755,root,root) %{_bindir}/ssh-add
618 %attr(755,root,root) %{_bindir}/ssh-copy-id
619 %attr(755,root,root) %{_bindir}/scp
620 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh_config
621 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/SSH_ASKPASS
622 %{_mandir}/man1/scp.1*
623 %{_mandir}/man1/ssh.1*
624 %{_mandir}/man1/slogin.1*
625 %{_mandir}/man1/sftp.1*
626 %{_mandir}/man1/ssh-agent.1*
627 %{_mandir}/man1/ssh-add.1*
628 %{_mandir}/man1/ssh-copy-id.1*
629 %{_mandir}/man5/ssh_config.5*
630 %lang(it) %{_mandir}/it/man1/ssh.1*
631 %lang(it) %{_mandir}/it/man5/ssh_config.5*
632 %lang(pl) %{_mandir}/pl/man1/scp.1*
633 %lang(zh_CN) %{_mandir}/zh_CN/man1/scp.1*
634
635 # for host-based auth (suid required for accessing private host key)
636 #%attr(4755,root,root) %{_libexecdir}/ssh-keysign
637 #%{_mandir}/man8/ssh-keysign.8*
638
639 %files clients-agent-profile_d
640 %defattr(644,root,root,755)
641 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh-agent.conf
642 %attr(755,root,root) /etc/profile.d/ssh-agent.sh
643
644 %files clients-agent-xinitrc
645 %defattr(644,root,root,755)
646 %attr(755,root,root) /etc/X11/xinit/xinitrc.d/ssh-agent.sh
647
648 %files server
649 %defattr(644,root,root,755)
650 %attr(755,root,root) %{_sbindir}/sshd
651 %attr(755,root,root) %{_libexecdir}/sftp-server
652 %attr(755,root,root) %{_libexecdir}/ssh-keysign
653 %{_mandir}/man8/sshd.8*
654 %{_mandir}/man8/sftp-server.8*
655 %{_mandir}/man8/ssh-keysign.8*
656 %{_mandir}/man5/sshd_config.5*
657 %{_mandir}/man5/moduli.5*
658 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sshd_config
659 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/sshd
660 %attr(640,root,root) %{_sysconfdir}/moduli
661 %attr(754,root,root) /etc/rc.d/init.d/sshd
662 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/sshd
663 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.sshd
664
665 %if %{with gnome} || %{with gtk}
666 %files gnome-askpass
667 %defattr(644,root,root,755)
668 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/GNOME_SSH_ASKPASS*
669 %dir %{_libexecdir}/ssh
670 %attr(755,root,root) %{_libexecdir}/ssh/ssh-askpass
671 %attr(755,root,root) %{_libexecdir}/ssh-askpass
672 %endif
This page took 0.079507 seconds and 4 git commands to generate.