]> git.pld-linux.org Git - packages/openssh.git/blob - openssh.spec
- adapter(ized)
[packages/openssh.git] / openssh.spec
1 Summary:        OpenSSH free Secure Shell (SSH) implementation
2 Name:           openssh
3 Version:        1.2pre15
4 Release:        2
5 Source0:        openssh-%{version}.tar.gz
6 Source1:        opensshd.conf
7 Source2:        openssh.conf
8 Source3:        opensshd.init
9 Source4:        opensshd.pamd
10 Source5:        openssh.sysconfig
11 Patch0:         openssh-ssl.patch
12 Patch1:         openssh-DESTDIR.patch
13 License:        BSD
14 Group:          Applications/Networking
15 Group(pl):      Aplikacje/Sieciowe
16 BuildRequires:  openssl-devel
17 BuildRequires:  zlib-devel
18 BuildRequires:  pam-devel
19 BuildRequires:  XFree86-devel
20 BuildRequires:  gnome-libs-devel
21 BuildRoot:      /tmp/%{name}-%{version}-root
22 Obsoletes:      ssh
23
24 %define         _syscondir      /etc/ssh
25
26 %description
27 Ssh (Secure Shell) a program for logging into a remote machine and for
28 executing commands in a remote machine.  It is intended to replace
29 rlogin and rsh, and provide secure encrypted communications between
30 two untrusted hosts over an insecure network.  X11 connections and
31 arbitrary TCP/IP ports can also be forwarded over the secure channel.
32
33 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing it
34 up to date in terms of security and features, as well as removing all 
35 patented algorithms to seperate libraries (OpenSSL).
36
37 This package includes the core files necessary for both the OpenSSH
38 client and server.  To make this package useful, you should also
39 install openssh-clients, openssh-server, or both.
40
41 %package clients
42 Summary:        OpenSSH Secure Shell protocol clients
43 Requires:       openssh
44 Group:          Applications/Networking
45 Group(pl):      Aplikacje/Sieciowe
46 Obsoletes:      ssh-clients
47 Requires:       %{name} = %{version}
48
49 %description clients
50 Ssh (Secure Shell) a program for logging into a remote machine and for
51 executing commands in a remote machine.  It is intended to replace
52 rlogin and rsh, and provide secure encrypted communications between
53 two untrusted hosts over an insecure network.  X11 connections and
54 arbitrary TCP/IP ports can also be forwarded over the secure channel.
55
56 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing it
57 up to date in terms of security and features, as well as removing all 
58 patented algorithms to seperate libraries (OpenSSL).
59
60 This package includes the clients necessary to make encrypted connections
61 to SSH servers.
62
63 %package server
64 Summary:        OpenSSH Secure Shell protocol server (sshd)
65 Requires:       openssh chkconfig >= 0.9
66 Group:          Networking/Daemons
67 Group(pl):      Sieciowe/Serwery
68 Obsoletes:      ssh-server
69 Requires:       rc-scripts
70 Prereq:         %{name} = %{version}
71
72 %description server
73 Ssh (Secure Shell) a program for logging into a remote machine and for
74 executing commands in a remote machine.  It is intended to replace
75 rlogin and rsh, and provide secure encrypted communications between
76 two untrusted hosts over an insecure network.  X11 connections and
77 arbitrary TCP/IP ports can also be forwarded over the secure channel.
78
79 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing it
80 up to date in terms of security and features, as well as removing all 
81 patented algorithms to seperate libraries (OpenSSL).
82
83 This package contains the secure shell daemon. The sshd is the server 
84 part of the secure shell protocol and allows ssh clients to connect to 
85 your host.
86
87 %package askpass
88 Summary:        OpenSSH GNOME passphrase dialog
89 Group:          Applications/Networking
90 Group(pl):      Aplikacje/Sieciowe
91 Requires:       %{name} = %{version}
92 Obsoletes:      ssh-extras
93 Obsoletes:      ssh-askpass
94
95 %description askpass
96 Ssh (Secure Shell) a program for logging into a remote machine and for
97 executing commands in a remote machine.  It is intended to replace
98 rlogin and rsh, and provide secure encrypted communications between
99 two untrusted hosts over an insecure network.  X11 connections and
100 arbitrary TCP/IP ports can also be forwarded over the secure channel.
101
102 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing it
103 up to date in terms of security and features, as well as removing all 
104 patented algorithms to seperate libraries (OpenSSL).
105
106 This package contains the GNOME passphrase dialog.
107
108
109 %prep
110 %setup  -q
111 %patch0 -p1
112 %patch1 -p1
113
114 %build
115 autoconf
116 %configure \
117         --with-gnome-askpass
118 make
119
120 %install
121 rm -rf $RPM_BUILD_ROOT
122
123 install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/{pam.d,rc.d/init.d,sysconfig}}
124
125 make install \
126         DESTDIR="$RPM_BUILD_ROOT"
127
128 install %{SOURCE4} $RPM_BUILD_ROOT/etc/pam.d/sshd
129 install %{SOURCE5} $RPM_BUILD_ROOT/etc/sysconfig/sshd
130 install -m755 %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
131 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/ssh_config
132 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/sshd_config
133
134 gzip -9fn ChangeLog OVERVIEW COPYING.Ylonen README README.Ylonen UPGRADING \
135         $RPM_BUILD_ROOT/%{_mandir}/man*/*
136         
137 %clean
138 rm -rf $RPM_BUILD_ROOT
139
140 %post server
141 /sbin/chkconfig --add sshd
142 if [ ! -f /etc/ssh/ssh_host_key -o ! -s /etc/ssh/ssh_host_key ]; then
143         /usr/bin/ssh-keygen -b 1024 -f /etc/ssh/ssh_host_key -N '' >&2
144 fi
145 if test -r /var/run/sshd.pid
146 then
147         /etc/rc.d/init.d/sshd restart >&2
148 fi
149
150 %preun server
151 if [ "$1" = 0 ]
152 then
153         /etc/rc.d/init.d/sshd stop >&2
154         /sbin/chkconfig --del sshd
155 fi
156
157 %files
158 %defattr(644,root,root,755)
159 %doc {ChangeLog,OVERVIEW,COPYING.Ylonen,README,README.Ylonen,UPGRADING}.gz
160 %attr(755,root,root) %{_bindir}/ssh-keygen
161 %{_mandir}/man1/ssh-keygen.1*
162 %dir %{_sysconfdir}
163
164 %files clients
165 %defattr(644,root,root,755)
166 # suid root ?
167 #%attr(4755,root,root) %{_bindir}/ssh
168 %attr(0755,root,root) %{_bindir}/ssh
169 %attr(0755,root,root) %{_bindir}/ssh-agent
170 %attr(0755,root,root) %{_bindir}/ssh-add
171 #%attr(0755,root,root) %{_bindir}/slogin
172 %attr(755,root,root) %{_bindir}/scp
173 %{_mandir}/man1/scp.1*
174 %{_mandir}/man1/ssh.1*
175 %{_mandir}/man1/ssh-agent.1*
176 %{_mandir}/man1/ssh-add.1*
177 #%{_mandir}/man1/slogin.1
178 %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/ssh_config
179
180 %files server
181 %defattr(644,root,root,755)
182 %attr(755,root,root) %{_sbindir}/sshd
183 %{_mandir}/man8/sshd.8*
184 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/sshd_config
185 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/pam.d/sshd
186 %attr(754,root,root) /etc/rc.d/init.d/sshd
187 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/sysconfig/sshd
188
189 %files askpass
190 %defattr(644,root,root,755)
191 %dir %{_libexecdir}/ssh
192 %attr(755,root,root) %{_libexecdir}/ssh/ssh-askpass
This page took 0.041892 seconds and 4 git commands to generate.