]> git.pld-linux.org Git - packages/openssh.git/blob - openssh.spec
- rel 5
[packages/openssh.git] / openssh.spec
1 #
2 # Conditional build:
3 %bcond_without  chroot          # without chrooted user environment support
4 %bcond_with     gnome           # with gnome-askpass (GNOME 1.x) utility
5 %bcond_without  gtk             # without GTK+ (2.x)
6 %bcond_with     ldap            # with ldap support
7 %bcond_without  libedit         # without libedit (editline/history support in sftp client)
8 %bcond_without  kerberos5       # without kerberos5 support
9 %bcond_without  selinux         # build without SELinux support
10 %bcond_with     hpn             # with High Performance SSH/SCP - HPN-SSH (see patch comment)
11 %bcond_with     hpn_none        # with hpn (above) and '-z' none cipher option
12 #
13 %if %{with hpn_none}
14 %undefine       with_hpn
15 %endif
16 # gtk2-based gnome-askpass means no gnome1-based
17 %{?with_gtk:%undefine with_gnome}
18 Summary:        OpenSSH free Secure Shell (SSH) implementation
19 Summary(de.UTF-8):      OpenSSH - freie Implementation der Secure Shell (SSH)
20 Summary(es.UTF-8):      Implementación libre de SSH
21 Summary(fr.UTF-8):      Implémentation libre du shell sécurisé OpenSSH (SSH)
22 Summary(it.UTF-8):      Implementazione gratuita OpenSSH della Secure Shell
23 Summary(pl.UTF-8):      Publicznie dostępna implementacja bezpiecznego shella (SSH)
24 Summary(pt.UTF-8):      Implementação livre OpenSSH do protocolo 'Secure Shell' (SSH)
25 Summary(pt_BR.UTF-8):   Implementação livre do SSH
26 Summary(ru.UTF-8):      OpenSSH - свободная реализация протокола Secure Shell (SSH)
27 Summary(uk.UTF-8):      OpenSSH - вільна реалізація протоколу Secure Shell (SSH)
28 Name:           openssh
29 Version:        4.6p1
30 Release:        5%{?with_hpn:hpn}%{?with_hpn_none:hpn_none}
31 Epoch:          2
32 License:        BSD
33 Group:          Applications/Networking
34 Source0:        ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/%{name}-%{version}.tar.gz
35 # Source0-md5:  6a7fa99f44d9e1b5b04d15256e1405bb
36 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
37 # Source1-md5:  66943d481cc422512b537bcc2c7400d1
38 Source2:        %{name}d.init
39 Source3:        %{name}d.pamd
40 Source4:        %{name}.sysconfig
41 Source5:        ssh-agent.sh
42 Source6:        ssh-agent.conf
43 Patch0:         %{name}-no_libnsl.patch
44 Patch1:         %{name}-sshv1-openssl.patch
45 Patch2:         %{name}-linux-ipv6.patch
46 Patch3:         %{name}-pam_misc.patch
47 Patch4:         %{name}-sigpipe.patch
48 # http://www.opendarwin.org/projects/openssh-lpk/
49 Patch5:         %{name}-lpk-4.3p1-0.3.7.patch
50 Patch6:         %{name}-config.patch
51 Patch7:         %{name}-pam-conv.patch
52 # http://chrootssh.sourceforge.net/download/osshChroot-3.7.1p2.diff
53 Patch8:         %{name}-chroot.patch
54 Patch9:         %{name}-selinux.patch
55 # HPN patches rediffed due sigpipe patch.
56 # High Performance SSH/SCP - HPN-SSH - http://www.psc.edu/networking/projects/hpn-ssh/
57 # http://www.psc.edu/networking/projects/hpn-ssh/openssh-4.2p1-hpn11.diff
58 Patch10:        %{name}-4.3p1-hpn11.patch
59 # Adds HPN (see p11) and an undocumented -z none cipher flag
60 # http://www.psc.edu/networking/projects/hpn-ssh/openssh-4.2p1-hpn11-none.diff
61 Patch11:        %{name}-4.3p1-hpn11-none.patch
62 Patch12:        %{name}-include.patch
63 URL:            http://www.openssh.com/
64 BuildRequires:  %{__perl}
65 BuildRequires:  autoconf
66 BuildRequires:  automake
67 %{?with_gnome:BuildRequires:    gnome-libs-devel}
68 %{?with_gtk:BuildRequires:      gtk+2-devel}
69 %{?with_kerberos5:BuildRequires:        krb5-devel}
70 %{?with_libedit:BuildRequires:  libedit-devel}
71 %{?with_selinux:BuildRequires:  libselinux-devel}
72 BuildRequires:  libwrap-devel
73 %{?with_ldap:BuildRequires:     openldap-devel}
74 BuildRequires:  openssl-devel >= 0.9.7d
75 BuildRequires:  pam-devel
76 %{?with_gtk:BuildRequires:      pkgconfig}
77 BuildRequires:  rpmbuild(macros) >= 1.318
78 BuildRequires:  zlib-devel
79 Requires:       filesystem >= 3.0-11
80 Requires:       pam >= 0.99.7.1
81 Obsoletes:      ssh
82 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
83
84 %define         _sysconfdir     /etc/ssh
85 %define         _libexecdir     %{_libdir}/%{name}
86 %define         _privsepdir     /usr/share/empty
87
88 %description
89 Ssh (Secure Shell) a program for logging into a remote machine and for
90 executing commands in a remote machine. It is intended to replace
91 rlogin and rsh, and provide secure encrypted communications between
92 two untrusted hosts over an insecure network. X11 connections and
93 arbitrary TCP/IP ports can also be forwarded over the secure channel.
94
95 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
96 it up to date in terms of security and features, as well as removing
97 all patented algorithms to seperate libraries (OpenSSL).
98
99 This package includes the core files necessary for both the OpenSSH
100 client and server. To make this package useful, you should also
101 install openssh-clients, openssh-server, or both.
102 %if %{with hpn} || %{with hpn_none}
103 This release includes High Performance SSH/SCP patches from
104 http://www.psc.edu/networking/projects/hpn-ssh/ which are supposed
105 to increase throughput on fast connections with high RTT (20-150 msec).
106 See the website for '-w' values for your connection and /proc/sys TCP
107 values. BTW. in a LAN you have got generally RTT < 1 msec.
108 %endif
109 %if %{with hpn_none}
110 It also includes an undocumented '-z' option which switches
111 the cipher to none after authentication is completed. Data is
112 still secured from tampering and corruption in transit through
113 the use of the Message Authentication Code (MAC).
114 This option will significantly reduce the number of cpu cycles used
115 by the SSH/SCP process. This may allow some users to see significant
116 improvement in (sniffable) data tranfer rates.
117 %endif
118
119 %description -l de.UTF-8
120 OpenSSH (Secure Shell) stellt den Zugang zu anderen Rechnern her. Es
121 ersetzt telnet, rlogin, rexec und rsh und stellt eine sichere,
122 verschlüsselte Verbindung zwischen zwei nicht vertrauenswürdigen Hosts
123 über eine unsicheres Netzwerk her. X11 Verbindungen und beliebige
124 andere TCP/IP Ports können ebenso über den sicheren Channel
125 weitergeleitet werden.
126
127 %description -l es.UTF-8
128 SSH es un programa para accesar y ejecutar órdenes en computadores
129 remotos. Sustituye rlogin y rsh, y suministra un canal de comunicación
130 seguro entre dos servidores en una red insegura. Conexiones X11 y
131 puertas TCP/IP arbitrárias también pueden ser usadas por el canal
132 seguro.
133
134 OpenSSH es el resultado del trabajo del equipo de OpenBSD para
135 continuar la última versión gratuita de SSH, actualizándolo en
136 términos de seguridad y recursos,así también eliminando todos los
137 algoritmos patentados y colocándolos en bibliotecas separadas
138 (OpenSSL).
139
140 Este paquete contiene "port" para Linux de OpenSSH. Se debe instalar
141 también el paquete openssh-clients u openssh-server o ambos.
142
143 %description -l fr.UTF-8
144 OpenSSH (Secure Shell) fournit un accès à un système distant. Il
145 remplace telnet, rlogin, rexec et rsh, tout en assurant des
146 communications cryptées securisées entre deux hôtes non fiabilisés sur
147 un réseau non sécurisé. Des connexions X11 et des ports TCP/IP
148 arbitraires peuvent également être transmis sur le canal sécurisé.
149
150 %description -l it.UTF-8
151 OpenSSH (Secure Shell) fornisce l'accesso ad un sistema remoto.
152 Sostituisce telnet, rlogin, rexec, e rsh, e fornisce comunicazioni
153 sicure e crittate tra due host non fidati su una rete non sicura. Le
154 connessioni X11 ad una porta TCP/IP arbitraria possono essere
155 inoltrate attraverso un canale sicuro.
156
157 %description -l pl.UTF-8
158 Ssh (Secure Shell) to program służący do logowania się na zdalną
159 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
160 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
161 pomiędzy dwoma hostami.
162
163 Ten pakiet zawiera podstawowe pliki potrzebne zarówno po stronie
164 klienta jak i serwera OpenSSH. Aby był użyteczny, trzeba zainstalować
165 co najmniej jeden z pakietów: openssh-clients lub openssh-server.
166 %if %{with hpn} || %{with hpn_none}
167 Ta wersja zawiera łaty z projektu High Performance SSH/SCP
168 http://www.psc.edu/networking/projects/hpn-ssh/, które mają na celu
169 zwiększenie przepustowości transmisji dla szybkich połączeń
170 z dużym RTT (20-150 msec). Na stronie projektu znaleźć można
171 odpowednie dla danego połączenia wartości parametru '-w' oraz
172 opcje /proc/sys dla TCP. Nawiasem mówiąc w sieciach LAN RTT < 1 msec.
173 %endif
174 %if %{with hpn_none}
175 Obsługiwana jest również nieudokumentowana opcja '-z' odpowiedzialna
176 za wyłączenie szyfrowania danych po zakończeniu procesu uwierzytelniania.
177 Dane są zabezpieczone przed modyfikacją lub uszkodzeniem przez
178 stosowanie Message Authentication Code (MAC).
179 Opcja ta znacznie redukuje liczbę cykli procesora zużywanych przez
180 procesy SSH/SCP. W wybranych zastosowaniach może ona wpłynąć
181 na wyraźne przyspieszenie (podsłuchiwalnej) transmisji danych.
182 %endif
183
184 %description -l pt.UTF-8
185 OpenSSH (Secure Shell) fornece acesso a um sistema remoto. Substitui o
186 telnet, rlogin, rexec, e o rsh e fornece comunicações seguras e
187 cifradas entre duas máquinas sem confiança mútua sobre uma rede
188 insegura. Ligações X11 e portos TCP/IP arbitrários também poder ser
189 reenviados pelo canal seguro.
190
191 %description -l pt_BR.UTF-8
192 SSH é um programa para acessar e executar comandos em máquinas
193 remotas. Ele substitui rlogin e rsh, e provem um canal de comunicação
194 seguro entre dois hosts em uma rede insegura. Conexões X11 e portas
195 TCP/IP arbitrárias também podem ser usadas pelo canal seguro.
196
197 OpenSSH é o resultado do trabalho da equipe do OpenBSD em continuar a
198 última versão gratuita do SSH, atualizando-o em termos de segurança e
199 recursos, assim como removendo todos os algoritmos patenteados e
200 colocando-os em bibliotecas separadas (OpenSSL).
201
202 Esse pacote contém o "port" pra Linux do OpenSSH. Você deve instalar
203 também ou o pacote openssh-clients, ou o openssh-server, ou ambos.
204
205 %description -l ru.UTF-8
206 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
207 машину и для выполнения команд на удаленной машине. Она предназначена
208 для замены rlogin и rsh и обеспечивает безопасную шифрованную
209 коммуникацию между двумя хостами в сети, являющейся небезопасной.
210 Соединения X11 и любые порты TCP/IP могут также быть проведены через
211 безопасный канал.
212
213 OpenSSH - это переделка командой разработчиков OpenBSD последней
214 свободной версии SSH, доведенная до современного состояния в терминах
215 уровня безопасности и поддерживаемых возможностей. Все патентованные
216 алгоритмы вынесены в отдельные библиотеки (OpenSSL).
217
218 Этот пакет содержит файлы, необходимые как для клиента, так и для
219 сервера OpenSSH. Вам нужно будет установить еще openssh-clients,
220 openssh-server, или оба пакета.
221
222 %description -l uk.UTF-8
223 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
224 машини та для виконання команд на віддаленій машині. Вона призначена
225 для заміни rlogin та rsh і забезпечує безпечну шифровану комунікацію
226 між двома хостами в мережі, яка не є безпечною. З'єднання X11 та
227 довільні порти TCP/IP можуть також бути проведені через безпечний
228 канал.
229
230 OpenSSH - це переробка командою розробників OpenBSD останньої вільної
231 версії SSH, доведена до сучасного стану в термінах рівня безпеки та
232 підтримуваних можливостей. Всі патентовані алгоритми винесені до
233 окремих бібліотек (OpenSSL).
234
235 Цей пакет містить файли, необхідні як для клієнта, так і для сервера
236 OpenSSH. Вам потрібно буде ще встановити openssh-clients,
237 openssh-server, чи обидва пакети.
238
239 %package clients
240 Summary:        OpenSSH Secure Shell protocol clients
241 Summary(es.UTF-8):      Clientes de OpenSSH
242 Summary(pl.UTF-8):      Klienci protokołu Secure Shell
243 Summary(pt_BR.UTF-8):   Clientes do OpenSSH
244 Summary(ru.UTF-8):      OpenSSH - клиенты протокола Secure Shell
245 Summary(uk.UTF-8):      OpenSSH - клієнти протоколу Secure Shell
246 Group:          Applications/Networking
247 Requires:       %{name} = %{epoch}:%{version}-%{release}
248 Provides:       ssh-clients
249 Obsoletes:      ssh-clients
250
251 %description clients
252 Ssh (Secure Shell) a program for logging into a remote machine and for
253 executing commands in a remote machine. It is intended to replace
254 rlogin and rsh, and provide secure encrypted communications between
255 two untrusted hosts over an insecure network. X11 connections and
256 arbitrary TCP/IP ports can also be forwarded over the secure channel.
257
258 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
259 it up to date in terms of security and features, as well as removing
260 all patented algorithms to seperate libraries (OpenSSL).
261
262 This package includes the clients necessary to make encrypted
263 connections to SSH servers.
264
265 %description clients -l es.UTF-8
266 Este paquete incluye los clientes que se necesitan para hacer
267 conexiones codificadas con servidores SSH.
268
269 %description clients -l pl.UTF-8
270 Ssh (Secure Shell) to program służący do logowania się na zdalną
271 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
272 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
273 pomiędzy dwoma hostami.
274
275 Ten pakiet zawiera klientów służących do łączenia się z serwerami SSH.
276
277 %description clients -l pt_BR.UTF-8
278 Esse pacote inclui os clientes necessários para fazer conexões
279 encriptadas com servidores SSH.
280
281 %description clients -l ru.UTF-8
282 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
283 машину и для выполнения команд на удаленной машине.
284
285 Этот пакет содержит программы-клиенты, необходимые для установления
286 зашифрованных соединений с серверами SSH.
287
288 %description clients -l uk.UTF-8
289 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
290 машини та для виконання команд на віддаленій машині.
291
292 Цей пакет містить програми-клієнти, необхідні для встановлення
293 зашифрованих з'єднань з серверами SSH.
294
295 %package clients-agent-profile_d
296 Summary:        OpenSSH Secure Shell agent init script
297 Summary(pl.UTF-8):      Skrypt startowy agenta OpenSSH
298 Group:          Applications/Networking
299 Requires:       %{name}-clients = %{epoch}:%{version}-%{release}
300
301 %description clients-agent-profile_d
302 profile.d scripts for starting SSH agent.
303
304 %description clients-agent-profile_d -l pl.UTF-8
305 Skrypty profile.d do uruchamiania agenta SSH.
306
307 %package clients-agent-xinitrc
308 Summary:        OpenSSH Secure Shell agent init script
309 Summary(pl.UTF-8):      Skrypt inicjujący agenta ssh przez xinitrc
310 Group:          Applications/Networking
311 Requires:       %{name}-clients-agent-profile_d = %{epoch}:%{version}-%{release}
312 Requires:       xinitrc
313
314 %description clients-agent-xinitrc
315 xinitrc scripts for starting SSH agent.
316
317 %description clients-agent-xinitrc -l pl.UTF-8
318 Skrypty xinitrc do uruchamiania agenta SSH.
319
320 %package server
321 Summary:        OpenSSH Secure Shell protocol server (sshd)
322 Summary(de.UTF-8):      OpenSSH Secure Shell Protocol-Server (sshd)
323 Summary(es.UTF-8):      Servidor OpenSSH para comunicaciones codificadas
324 Summary(fr.UTF-8):      Serveur de protocole du shell sécurisé OpenSSH (sshd)
325 Summary(it.UTF-8):      Server OpenSSH per il protocollo Secure Shell (sshd)
326 Summary(pl.UTF-8):      Serwer protokołu Secure Shell (sshd)
327 Summary(pt.UTF-8):      Servidor do protocolo 'Secure Shell' OpenSSH (sshd)
328 Summary(pt_BR.UTF-8):   Servidor OpenSSH para comunicações encriptadas
329 Summary(ru.UTF-8):      OpenSSH - сервер протокола Secure Shell (sshd)
330 Summary(uk.UTF-8):      OpenSSH - сервер протоколу Secure Shell (sshd)
331 Group:          Networking/Daemons
332 Requires(post): chkconfig >= 0.9
333 Requires(post): grep
334 Requires(post,preun):   /sbin/chkconfig
335 Requires(postun):       /usr/sbin/userdel
336 Requires(pre):  /bin/id
337 Requires(pre):  /usr/sbin/useradd
338 Requires:       %{name} = %{epoch}:%{version}-%{release}
339 Requires:       /bin/login
340 Requires:       pam >= 0.99.7.1
341 Requires:       rc-scripts >= 0.4.0.18
342 Requires:       util-linux
343 Provides:       ssh-server
344 Provides:       user(sshd)
345
346 %description server
347 Ssh (Secure Shell) a program for logging into a remote machine and for
348 executing commands in a remote machine. It is intended to replace
349 rlogin and rsh, and provide secure encrypted communications between
350 two untrusted hosts over an insecure network. X11 connections and
351 arbitrary TCP/IP ports can also be forwarded over the secure channel.
352
353 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
354 it up to date in terms of security and features, as well as removing
355 all patented algorithms to seperate libraries (OpenSSL).
356
357 This package contains the secure shell daemon. The sshd is the server
358 part of the secure shell protocol and allows ssh clients to connect to
359 your host.
360
361 %description server -l de.UTF-8
362 Dieses Paket installiert den sshd, den Server-Teil der OpenSSH.
363
364 %description server -l es.UTF-8
365 Este paquete contiene el servidor SSH. sshd es la parte servidor del
366 protocolo secure shell y permite que clientes ssh se conecten a su
367 servidor.
368
369 %description server -l fr.UTF-8
370 Ce paquetage installe le 'sshd', partie serveur de OpenSSH.
371
372 %description server -l it.UTF-8
373 Questo pacchetto installa sshd, il server di OpenSSH.
374
375 %description server -l pl.UTF-8
376 Ssh (Secure Shell) to program służący do logowania się na zdalną
377 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
378 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
379 pomiędzy dwoma hostami.
380
381 Ten pakiet zawiera serwer sshd (do którego mogą łączyć się klienci
382 ssh).
383
384 %description server -l pt.UTF-8
385 Este pacote intala o sshd, o servidor do OpenSSH.
386
387 %description server -l pt_BR.UTF-8
388 Esse pacote contém o servidor SSH. O sshd é a parte servidor do
389 protocolo secure shell e permite que clientes ssh se conectem ao seu
390 host.
391
392 %description server -l ru.UTF-8
393 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
394 машину и для выполнения команд на удаленной машине.
395
396 Этот пакет содержит sshd - "демон" Secure Shell. sshd - это серверная
397 часть протокола Secure Shell, позволяющая клиентам ssh соединяться с
398 вашим хостом.
399
400 %description server -l uk.UTF-8
401 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
402 машини та для виконання команд на віддаленій машині.
403
404 Цей пакет містить sshd - "демон" Secure Shell. sshd - це серверна
405 частина протоколу Secure Shell, яка дозволяє клієнтам ssh зв'язуватись
406 з вашим хостом.
407
408 %package gnome-askpass
409 Summary:        OpenSSH GNOME passphrase dialog
410 Summary(de.UTF-8):      OpenSSH GNOME Passwort-Dialog
411 Summary(es.UTF-8):      Diálogo para introducción de passphrase para GNOME
412 Summary(fr.UTF-8):      Dialogue pass-phrase GNOME d'OpenSSH
413 Summary(it.UTF-8):      Finestra di dialogo GNOME per la frase segreta di OpenSSH
414 Summary(pl.UTF-8):      Odpytywacz hasła OpenSSH dla GNOME
415 Summary(pt.UTF-8):      Diálogo de pedido de senha para GNOME do OpenSSH
416 Summary(pt_BR.UTF-8):   Diálogo para entrada de passphrase para GNOME
417 Summary(ru.UTF-8):      OpenSSH - диалог ввода ключевой фразы (passphrase) для GNOME
418 Summary(uk.UTF-8):      OpenSSH - діалог вводу ключової фрази (passphrase) для GNOME
419 Group:          Applications/Networking
420 Requires:       %{name} = %{epoch}:%{version}-%{release}
421 Obsoletes:      openssh-askpass
422 Obsoletes:      ssh-askpass
423 Obsoletes:      ssh-extras
424
425 %description gnome-askpass
426 Ssh (Secure Shell) a program for logging into a remote machine and for
427 executing commands in a remote machine. It is intended to replace
428 rlogin and rsh, and provide secure encrypted communications between
429 two untrusted hosts over an insecure network. X11 connections and
430 arbitrary TCP/IP ports can also be forwarded over the secure channel.
431
432 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
433 it up to date in terms of security and features, as well as removing
434 all patented algorithms to seperate libraries (OpenSSL).
435
436 This package contains the GNOME passphrase dialog.
437
438 %description gnome-askpass -l es.UTF-8
439 Este paquete contiene un programa que abre una caja de diálogo para
440 entrada de passphrase en GNOME.
441
442 %description gnome-askpass -l pl.UTF-8
443 Ssh (Secure Shell) to program służący do logowania się na zdalną
444 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
445 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
446 pomiędzy dwoma hostami.
447
448 Ten pakiet zawiera ,,odpytywacz hasła'' dla GNOME.
449
450 %description gnome-askpass -l pt_BR.UTF-8
451 Esse pacote contém um programa que abre uma caixa de diálogo para
452 entrada de passphrase no GNOME.
453
454 %description gnome-askpass -l ru.UTF-8
455 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
456 машину и для выполнения команд на удаленной машине.
457
458 Этот пакет содержит диалог ввода ключевой фразы для использования под
459 GNOME.
460
461 %description gnome-askpass -l uk.UTF-8
462 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
463 машини та для виконання команд на віддаленій машині.
464
465 Цей пакет містить діалог вводу ключової фрази для використання під
466 GNOME.
467
468 %prep
469 %setup -q
470 %patch0 -p1
471 %patch1 -p1
472 %patch2 -p1
473 %patch3 -p1
474 %patch4 -p1
475 %{?with_ldap:%patch5 -p1}
476 %patch6 -p1
477 #%patch7 -p1
478 %patch8 -p1
479 %patch9 -p1
480 %{?with_hpn:%patch10 -p1}
481 %{?with_hpn_none:%patch11 -p1}
482 %patch12 -p1
483
484 %build
485 cp /usr/share/automake/config.sub .
486 %{__aclocal}
487 %{__autoconf}
488 %{?with_chroot:CPPFLAGS="-DCHROOT"}
489 %configure \
490         PERL=%{__perl} \
491         --with-dns \
492         --with-pam \
493         --with-mantype=man \
494         --with-md5-passwords \
495         --with-ipaddr-display \
496         %{?with_libedit:--with-libedit} \
497         --with-4in6 \
498         --disable-suid-ssh \
499         --with-tcp-wrappers \
500         %{?with_ldap:--with-libs="-lldap -llber"} \
501         %{?with_ldap:--with-cppflags="-DWITH_LDAP_PUBKEY"} \
502         %{?with_kerberos5:--with-kerberos5=/usr} \
503         --with-privsep-path=%{_privsepdir} \
504         --with-pid-dir=%{_localstatedir}/run \
505         --with-xauth=/usr/bin/xauth \
506         --enable-utmpx \
507         --enable-wtmpx
508
509 echo '#define LOGIN_PROGRAM                "/bin/login"' >>config.h
510
511 %{__make}
512
513 cd contrib
514 %if %{with gnome}
515 %{__make} gnome-ssh-askpass1 \
516         CC="%{__cc} %{rpmldflags} %{rpmcflags}"
517 %endif
518 %if %{with gtk}
519 %{__make} gnome-ssh-askpass2 \
520         CC="%{__cc} %{rpmldflags} %{rpmcflags}"
521 %endif
522
523 %install
524 rm -rf $RPM_BUILD_ROOT
525 install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/{pam.d,rc.d/init.d,sysconfig,security,env.d}} \
526         $RPM_BUILD_ROOT%{_libexecdir}/ssh
527 install -d $RPM_BUILD_ROOT/etc/{profile.d,X11/xinit/xinitrc.d}
528
529 %{__make} install \
530         DESTDIR=$RPM_BUILD_ROOT
531
532 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
533
534 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
535 install %{SOURCE3} $RPM_BUILD_ROOT/etc/pam.d/sshd
536 install %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/sshd
537 install %{SOURCE5} $RPM_BUILD_ROOT/etc/profile.d
538 ln -sf  /etc/profile.d/ssh-agent.sh $RPM_BUILD_ROOT/etc/X11/xinit/xinitrc.d/ssh-agent.sh
539 install %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}
540
541 %if %{with gnome}
542 install contrib/gnome-ssh-askpass1 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
543 %endif
544 %if %{with gtk}
545 install contrib/gnome-ssh-askpass2 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
546 %endif
547 %if %{with gnome} || %{with gtk}
548 cat << EOF >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_SERVER
549 #GNOME_SSH_ASKPASS_GRAB_SERVER="true"
550 EOF
551 cat << EOF >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_POINTER
552 #GNOME_SSH_ASKPASS_GRAB_POINTER="true"
553 EOF
554 ln -s %{_libexecdir}/ssh/ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/ssh-askpass
555 %endif
556
557 rm -f   $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
558 echo ".so ssh.1" > $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
559
560 touch $RPM_BUILD_ROOT/etc/security/blacklist.sshd
561
562 %if "%{_lib}" != "lib"
563 find $RPM_BUILD_ROOT%{_sysconfdir} -type f -print0 | xargs -0 sed -i -e 's#%{_prefix}/lib#%{_libdir}#'
564 %endif
565
566 cat << 'EOF' > $RPM_BUILD_ROOT/etc/env.d/SSH_ASKPASS
567 #SSH_ASKPASS="%{_libexecdir}/ssh-askpass"
568 EOF
569
570 %clean
571 rm -rf $RPM_BUILD_ROOT
572
573 %post clients
574 %env_update
575
576 %postun clients
577 %env_update
578
579 %post gnome-askpass
580 %env_update
581
582 %postun gnome-askpass
583 %env_update
584
585 %pre server
586 %useradd -P %{name}-server -u 40 -d %{_privsepdir} -s /bin/false -c "OpenSSH PrivSep User" -g nobody sshd
587
588 %post server
589 /sbin/chkconfig --add sshd
590 %service sshd reload "openssh daemon"
591 if ! grep -qs ssh /etc/security/passwd.conf ; then
592         umask 022
593         echo "ssh" >> /etc/security/passwd.conf
594 fi
595
596 %preun server
597 if [ "$1" = "0" ]; then
598         %service sshd stop
599         /sbin/chkconfig --del sshd
600 fi
601
602 %postun server
603 if [ "$1" = "0" ]; then
604         %userremove sshd
605 fi
606
607 %files
608 %defattr(644,root,root,755)
609 %doc *.RNG TODO README OVERVIEW CREDITS Change*
610 %attr(755,root,root) %{_bindir}/ssh-key*
611 %{_mandir}/man1/ssh-key*.1*
612 %dir %{_sysconfdir}
613 %dir %{_libexecdir}
614
615 %files clients
616 %defattr(644,root,root,755)
617 %attr(755,root,root) %{_bindir}/ssh
618 %attr(755,root,root) %{_bindir}/slogin
619 %attr(755,root,root) %{_bindir}/sftp
620 %attr(755,root,root) %{_bindir}/ssh-agent
621 %attr(755,root,root) %{_bindir}/ssh-add
622 %attr(755,root,root) %{_bindir}/scp
623 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh_config
624 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/SSH_ASKPASS
625 %{_mandir}/man1/scp.1*
626 %{_mandir}/man1/ssh.1*
627 %{_mandir}/man1/slogin.1*
628 %{_mandir}/man1/sftp.1*
629 %{_mandir}/man1/ssh-agent.1*
630 %{_mandir}/man1/ssh-add.1*
631 %{_mandir}/man5/ssh_config.5*
632 %lang(it) %{_mandir}/it/man1/ssh.1*
633 %lang(it) %{_mandir}/it/man5/ssh_config.5*
634 %lang(pl) %{_mandir}/pl/man1/scp.1*
635 %lang(zh_CN) %{_mandir}/zh_CN/man1/scp.1*
636
637 # for host-based auth (suid required for accessing private host key)
638 #%attr(4755,root,root) %{_libexecdir}/ssh-keysign
639 #%{_mandir}/man8/ssh-keysign.8*
640
641 %files clients-agent-profile_d
642 %defattr(644,root,root,755)
643 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh-agent.conf
644 %attr(755,root,root) /etc/profile.d/ssh-agent.sh
645
646 %files clients-agent-xinitrc
647 %defattr(644,root,root,755)
648 %attr(755,root,root) /etc/X11/xinit/xinitrc.d/ssh-agent.sh
649
650 %files server
651 %defattr(644,root,root,755)
652 %attr(755,root,root) %{_sbindir}/sshd
653 %attr(755,root,root) %{_libexecdir}/sftp-server
654 %attr(755,root,root) %{_libexecdir}/ssh-keysign
655 %{_mandir}/man8/sshd.8*
656 %{_mandir}/man8/sftp-server.8*
657 %{_mandir}/man8/ssh-keysign.8*
658 %{_mandir}/man5/sshd_config.5*
659 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sshd_config
660 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/sshd
661 %attr(640,root,root) %{_sysconfdir}/moduli
662 %attr(754,root,root) /etc/rc.d/init.d/sshd
663 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/sshd
664 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.sshd
665
666 %if %{with gnome} || %{with gtk}
667 %files gnome-askpass
668 %defattr(644,root,root,755)
669 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/GNOME_SSH_ASKPASS*
670 %dir %{_libexecdir}/ssh
671 %attr(755,root,root) %{_libexecdir}/ssh/ssh-askpass
672 %attr(755,root,root) %{_libexecdir}/ssh-askpass
673 %endif
This page took 0.080881 seconds and 4 git commands to generate.