]> git.pld-linux.org Git - packages/openssh.git/blob - openssh.spec
- added checkconfig to service sshd reload; rel 4
[packages/openssh.git] / openssh.spec
1 #
2 # Conditional build:
3 %bcond_without  chroot          # without chrooted user environment support
4 %bcond_with     gnome           # with gnome-askpass (GNOME 1.x) utility
5 %bcond_without  gtk             # without GTK+ (2.x)
6 %bcond_with     ldap            # with ldap support
7 %bcond_without  libedit         # without libedit (editline/history support in sftp client)
8 %bcond_without  kerberos5       # without kerberos5 support
9 %bcond_without  selinux         # build without SELinux support
10 %bcond_with     sshagentsh      # with system-wide script for starting ssh-agent
11 %bcond_with     hpn             # with High Performance SSH/SCP - HPN-SSH (see patch comment)
12 %bcond_with     hpn_none        # with hpn (above) and '-z' none cipher option
13 #
14 %if %{with hpn_none}
15 %undefine       with_hpn
16 %endif
17 # gtk2-based gnome-askpass means no gnome1-based
18 %{?with_gtk:%undefine with_gnome}
19 %define         _rel    4
20 Summary:        OpenSSH free Secure Shell (SSH) implementation
21 Summary(de):    OpenSSH - freie Implementation der Secure Shell (SSH)
22 Summary(es):    Implementación libre de SSH
23 Summary(fr):    Implémentation libre du shell sécurisé OpenSSH (SSH)
24 Summary(it):    Implementazione gratuita OpenSSH della Secure Shell
25 Summary(pl):    Publicznie dostêpna implementacja bezpiecznego shella (SSH)
26 Summary(pt):    Implementação livre OpenSSH do protocolo 'Secure Shell' (SSH)
27 Summary(pt_BR): Implementação livre do SSH
28 Summary(ru):    OpenSSH - Ó×ÏÂÏÄÎÁÑ ÒÅÁÌÉÚÁÃÉÑ ÐÒÏÔÏËÏÌÁ Secure Shell (SSH)
29 Summary(uk):    OpenSSH - ×¦ÌØÎÁ ÒÅÁ̦ÚÁæѠÐÒÏÔÏËÏÌÕ Secure Shell (SSH)
30 Name:           openssh
31 Version:        4.5p1
32 Release:        %{_rel}%{?with_hpn:hpn}%{?with_hpn_none:hpn_none}
33 Epoch:          2
34 License:        BSD
35 Group:          Applications/Networking
36 Source0:        ftp://ftp.ca.openbsd.org/pub/OpenBSD/OpenSSH/portable/%{name}-%{version}.tar.gz
37 # Source0-md5:  6468c339886f78e8a149b88f695839dd
38 Source1:        %{name}d.conf
39 Source2:        %{name}.conf
40 Source3:        %{name}d.init
41 Source4:        %{name}d.pamd
42 Source5:        %{name}.sysconfig
43 Source6:        passwd.pamd
44 Source7:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
45 # Source7-md5:  66943d481cc422512b537bcc2c7400d1
46 Source11:       ssh-agent.sh
47 Source12:       ssh-agent.conf
48 Patch0:         %{name}-no_libnsl.patch
49 Patch2:         %{name}-linux-ipv6.patch
50 Patch3:         %{name}-pam_misc.patch
51 Patch4:         %{name}-sigpipe.patch
52 # http://www.opendarwin.org/projects/openssh-lpk/
53 Patch5:         %{name}-lpk-4.3p1-0.3.7.patch
54 Patch6:         %{name}-heimdal.patch
55 Patch7:         %{name}-pam-conv.patch
56 # http://chrootssh.sourceforge.net/download/osshChroot-3.7.1p2.diff
57 Patch8:         %{name}-chroot.patch
58 Patch9:         %{name}-selinux.patch
59 # HPN patches rediffed due sigpipe patch.
60 # High Performance SSH/SCP - HPN-SSH - http://www.psc.edu/networking/projects/hpn-ssh/
61 # http://www.psc.edu/networking/projects/hpn-ssh/openssh-4.2p1-hpn11.diff
62 Patch10:        %{name}-4.3p1-hpn11.patch
63 # Adds HPN (see p11) and an undocumented -z none cipher flag
64 # http://www.psc.edu/networking/projects/hpn-ssh/openssh-4.2p1-hpn11-none.diff
65 Patch11:        %{name}-4.3p1-hpn11-none.patch
66 Patch12:        %{name}-include.patch
67 URL:            http://www.openssh.com/
68 BuildRequires:  %{__perl}
69 BuildRequires:  autoconf
70 BuildRequires:  automake
71 %{?with_gnome:BuildRequires:    gnome-libs-devel}
72 %{?with_gtk:BuildRequires:      gtk+2-devel}
73 %{?with_kerberos5:BuildRequires:        heimdal-devel >= 0.7}
74 %{?with_libedit:BuildRequires:  libedit-devel}
75 %{?with_selinux:BuildRequires:  libselinux-devel}
76 BuildRequires:  libwrap-devel
77 %{?with_ldap:BuildRequires:     openldap-devel}
78 BuildRequires:  openssl-devel >= 0.9.7d
79 BuildRequires:  pam-devel
80 %{?with_gtk:BuildRequires:      pkgconfig}
81 BuildRequires:  rpmbuild(macros) >= 1.318
82 BuildRequires:  zlib-devel
83 Requires:       filesystem >= 2.0-1
84 Requires:       pam >= 0.79.0
85 Obsoletes:      ssh
86 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
87
88 %define         _sysconfdir     /etc/ssh
89 %define         _libexecdir     %{_libdir}/%{name}
90 %define         _privsepdir     /usr/share/empty
91
92 %description
93 Ssh (Secure Shell) a program for logging into a remote machine and for
94 executing commands in a remote machine. It is intended to replace
95 rlogin and rsh, and provide secure encrypted communications between
96 two untrusted hosts over an insecure network. X11 connections and
97 arbitrary TCP/IP ports can also be forwarded over the secure channel.
98
99 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
100 it up to date in terms of security and features, as well as removing
101 all patented algorithms to seperate libraries (OpenSSL).
102
103 This package includes the core files necessary for both the OpenSSH
104 client and server. To make this package useful, you should also
105 install openssh-clients, openssh-server, or both.
106 %if %{with hpn} || %{with hpn_none}
107 This release includes High Performance SSH/SCP patches from
108 http://www.psc.edu/networking/projects/hpn-ssh/ which are supposed
109 to increase throughput on fast connections with high RTT (20-150 msec).
110 See the website for '-w' values for your connection and /proc/sys TCP
111 values. BTW. in a LAN you have got generally RTT < 1 msec.
112 %endif
113 %if %{with hpn_none}
114 It also includes an undocumented '-z' option which switches
115 the cipher to none after authentication is completed. Data is
116 still secured from tampering and corruption in transit through
117 the use of the Message Authentication Code (MAC).
118 This option will significantly reduce the number of cpu cycles used
119 by the SSH/SCP process. This may allow some users to see significant
120 improvement in (sniffable) data tranfer rates.
121 %endif
122
123 %description -l de
124 OpenSSH (Secure Shell) stellt den Zugang zu anderen Rechnern her. Es
125 ersetzt telnet, rlogin, rexec und rsh und stellt eine sichere,
126 verschlüsselte Verbindung zwischen zwei nicht vertrauenswürdigen Hosts
127 über eine unsicheres Netzwerk her. X11 Verbindungen und beliebige
128 andere TCP/IP Ports können ebenso über den sicheren Channel
129 weitergeleitet werden.
130
131 %description -l es
132 SSH es un programa para accesar y ejecutar órdenes en computadores
133 remotos. Sustituye rlogin y rsh, y suministra un canal de comunicación
134 seguro entre dos servidores en una red insegura. Conexiones X11 y
135 puertas TCP/IP arbitrárias también pueden ser usadas por el canal
136 seguro.
137
138 OpenSSH es el resultado del trabajo del equipo de OpenBSD para
139 continuar la última versión gratuita de SSH, actualizándolo en
140 términos de seguridad y recursos,así también eliminando todos los
141 algoritmos patentados y colocándolos en bibliotecas separadas
142 (OpenSSL).
143
144 Este paquete contiene "port" para Linux de OpenSSH. Se debe instalar
145 también el paquete openssh-clients u openssh-server o ambos.
146
147 %description -l fr
148 OpenSSH (Secure Shell) fournit un accès à un système distant. Il
149 remplace telnet, rlogin, rexec et rsh, tout en assurant des
150 communications cryptées securisées entre deux hôtes non fiabilisés sur
151 un réseau non sécurisé. Des connexions X11 et des ports TCP/IP
152 arbitraires peuvent également être transmis sur le canal sécurisé.
153
154 %description -l it
155 OpenSSH (Secure Shell) fornisce l'accesso ad un sistema remoto.
156 Sostituisce telnet, rlogin, rexec, e rsh, e fornisce comunicazioni
157 sicure e crittate tra due host non fidati su una rete non sicura. Le
158 connessioni X11 ad una porta TCP/IP arbitraria possono essere
159 inoltrate attraverso un canale sicuro.
160
161 %description -l pl
162 Ssh (Secure Shell) to program s³u¿±cy do logowania siê na zdaln±
163 maszynê i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
164 zast±piæ rlogin, rsh i dostarczyæ bezpieczne, szyfrowane po³±czenie
165 pomiêdzy dwoma hostami.
166
167 Ten pakiet zawiera podstawowe pliki potrzebne zarówno po stronie
168 klienta jak i serwera OpenSSH. Aby by³ u¿yteczny, trzeba zainstalowaæ
169 co najmniej jeden z pakietów: openssh-clients lub openssh-server.
170 %if %{with hpn} || %{with hpn_none}
171 Ta wersja zawiera ³aty z projektu High Performance SSH/SCP
172 http://www.psc.edu/networking/projects/hpn-ssh/, które maj± na celu
173 zwiêkszenie przepustowo¶ci transmisji dla szybkich po³±czeñ
174 z du¿ym RTT (20-150 msec). Na stronie projektu znale¼æ mo¿na
175 odpowednie dla danego po³±czenia warto¶ci parametru '-w' oraz
176 opcje /proc/sys dla TCP. Nawiasem mówi±c w sieciach LAN RTT < 1 msec.
177 %endif
178 %if %{with hpn_none}
179 Obs³ugiwana jest równie¿ nieudokumentowana opcja '-z' odpowiedzialna
180 za wy³±czenie szyfrowania danych po zakoñczeniu procesu uwierzytelniania.
181 Dane s± zabezpieczone przed modyfikacj± lub uszkodzeniem przez
182 stosowanie Message Authentication Code (MAC).
183 Opcja ta znacznie redukuje liczbê cykli procesora zu¿ywanych przez
184 procesy SSH/SCP. W wybranych zastosowaniach mo¿e ona wp³yn±æ
185 na wyra¼ne przyspieszenie (pods³uchiwalnej) transmisji danych.
186 %endif
187
188 %description -l pt
189 OpenSSH (Secure Shell) fornece acesso a um sistema remoto. Substitui o
190 telnet, rlogin, rexec, e o rsh e fornece comunicações seguras e
191 cifradas entre duas máquinas sem confiança mútua sobre uma rede
192 insegura. Ligações X11 e portos TCP/IP arbitrários também poder ser
193 reenviados pelo canal seguro.
194
195 %description -l pt_BR
196 SSH é um programa para acessar e executar comandos em máquinas
197 remotas. Ele substitui rlogin e rsh, e provem um canal de comunicação
198 seguro entre dois hosts em uma rede insegura. Conexões X11 e portas
199 TCP/IP arbitrárias também podem ser usadas pelo canal seguro.
200
201 OpenSSH é o resultado do trabalho da equipe do OpenBSD em continuar a
202 última versão gratuita do SSH, atualizando-o em termos de segurança e
203 recursos, assim como removendo todos os algoritmos patenteados e
204 colocando-os em bibliotecas separadas (OpenSSL).
205
206 Esse pacote contém o "port" pra Linux do OpenSSH. Você deve instalar
207 também ou o pacote openssh-clients, ou o openssh-server, ou ambos.
208
209 %description -l ru
210 Ssh (Secure Shell) - ÜÔÏ ÐÒÏÇÒÁÍÍÁ ÄÌÑ "ÚÁÈÏÄÁ" (login) ÎÁ ÕÄÁÌÅÎÎÕÀ
211 ÍÁÛÉÎÕ É ÄÌÑ ×ÙÐÏÌÎÅÎÉÑ ËÏÍÁÎÄ ÎÁ ÕÄÁÌÅÎÎÏÊ ÍÁÛÉÎÅ. ïÎÁ ÐÒÅÄÎÁÚÎÁÞÅÎÁ
212 ÄÌÑ ÚÁÍÅÎÙ rlogin É rsh É ÏÂÅÓÐÅÞÉ×ÁÅÔ ÂÅÚÏÐÁÓÎÕÀ ÛÉÆÒÏ×ÁÎÎÕÀ
213 ËÏÍÍÕÎÉËÁÃÉÀ ÍÅÖÄÕ Ä×ÕÍÑ ÈÏÓÔÁÍÉ × ÓÅÔÉ, Ñ×ÌÑÀÝÅÊÓÑ ÎÅÂÅÚÏÐÁÓÎÏÊ.
214 óÏÅÄÉÎÅÎÉÑ X11 É ÌÀÂÙÅ ÐÏÒÔÙ TCP/IP ÍÏÇÕÔ ÔÁËÖÅ ÂÙÔØ ÐÒÏ×ÅÄÅÎÙ ÞÅÒÅÚ
215 ÂÅÚÏÐÁÓÎÙÊ ËÁÎÁÌ.
216
217 OpenSSH - ÜÔÏ ÐÅÒÅÄÅÌËÁ ËÏÍÁÎÄÏÊ ÒÁÚÒÁÂÏÔÞÉËÏ× OpenBSD ÐÏÓÌÅÄÎÅÊ
218 Ó×ÏÂÏÄÎÏÊ ×ÅÒÓÉÉ SSH, ÄÏ×ÅÄÅÎÎÁÑ ÄÏ ÓÏ×ÒÅÍÅÎÎÏÇÏ ÓÏÓÔÏÑÎÉÑ × ÔÅÒÍÉÎÁÈ
219 ÕÒÏ×ÎÑ ÂÅÚÏÐÁÓÎÏÓÔÉ É ÐÏÄÄÅÒÖÉ×ÁÅÍÙÈ ×ÏÚÍÏÖÎÏÓÔÅÊ. ÷ÓÅ ÐÁÔÅÎÔÏ×ÁÎÎÙÅ
220 ÁÌÇÏÒÉÔÍÙ ×ÙÎÅÓÅÎÙ × ÏÔÄÅÌØÎÙÅ ÂÉÂÌÉÏÔÅËÉ (OpenSSL).
221
222 üÔÏÔ ÐÁËÅÔ ÓÏÄÅÒÖÉÔ ÆÁÊÌÙ, ÎÅÏÂÈÏÄÉÍÙÅ ËÁË ÄÌÑ ËÌÉÅÎÔÁ, ÔÁË É ÄÌÑ
223 ÓÅÒ×ÅÒÁ OpenSSH. ÷ÁÍ ÎÕÖÎÏ ÂÕÄÅÔ ÕÓÔÁÎÏ×ÉÔØ ÅÝÅ openssh-clients,
224 openssh-server, ÉÌÉ ÏÂÁ ÐÁËÅÔÁ.
225
226 %description -l uk
227 Ssh (Secure Shell) - ÃÅ ÐÒÏÇÒÁÍÁ ÄÌÑ "ÚÁÈÏÄÕ" (login) ÄϠצÄÄÁÌÅÎϧ
228 ÍÁÛÉÎÉ ÔÁ ÄÌÑ ×ÉËÏÎÁÎÎÑ ËÏÍÁÎÄ ÎÁ ×¦ÄÄÁÌÅΦʠÍÁÛÉΦ. ÷ÏÎÁ ÐÒÉÚÎÁÞÅÎÁ
229 ÄÌÑ ÚÁͦÎÉ rlogin ÔÁ rsh ¦ ÚÁÂÅÚÐÅÞÕ¤ ÂÅÚÐÅÞÎÕ ÛÉÆÒÏ×ÁÎÕ ËÏÍÕΦËÁæÀ
230 ͦ֠Ä×ÏÍÁ ÈÏÓÔÁÍÉ × ÍÅÒÅÖ¦, ÑËÁ ÎÅ ¤ ÂÅÚÐÅÞÎÏÀ. ú'¤ÄÎÁÎÎÑ X11 ÔÁ
231 ÄÏצÌØΦ ÐÏÒÔÉ TCP/IP ÍÏÖÕÔØ ÔÁËÏÖ ÂÕÔÉ ÐÒÏ×ÅÄÅΦ ÞÅÒÅÚ ÂÅÚÐÅÞÎÉÊ
232 ËÁÎÁÌ.
233
234 OpenSSH - ÃÅ ÐÅÒÅÒÏÂËÁ ËÏÍÁÎÄÏÀ ÒÏÚÒÏÂÎÉ˦נOpenBSD ÏÓÔÁÎÎØϧ ×¦ÌØÎϧ
235 ×ÅÒÓ¦§ SSH, ÄÏ×ÅÄÅÎÁ ÄÏ ÓÕÞÁÓÎÏÇÏ ÓÔÁÎÕ × ÔÅÒͦÎÁÈ Ò¦×ÎÑ ÂÅÚÐÅËÉ ÔÁ
236 ЦÄÔÒÉÍÕ×ÁÎÉÈ ÍÏÖÌÉ×ÏÓÔÅÊ. ÷Ó¦ ÐÁÔÅÎÔÏ×ÁΦ ÁÌÇÏÒÉÔÍÉ ×ÉÎÅÓÅΦ ÄÏ
237 ÏËÒÅÍÉȠ¦Â̦ÏÔÅË (OpenSSL).
238
239 ãÅÊ ÐÁËÅԠͦÓÔÉÔØ ÆÁÊÌÉ, ÎÅÏÂȦÄΦ ÑË ÄÌÑ Ë̦¤ÎÔÁ, ÔÁË ¦ ÄÌÑ ÓÅÒ×ÅÒÁ
240 OpenSSH. ÷ÁÍ ÐÏÔÒ¦ÂÎÏ ÂÕÄÅ ÝÅ ×ÓÔÁÎÏ×ÉÔÉ openssh-clients,
241 openssh-server, ÞÉ ÏÂÉÄ×Á ÐÁËÅÔÉ.
242
243 %package clients
244 Summary:        OpenSSH Secure Shell protocol clients
245 Summary(es):    Clientes de OpenSSH
246 Summary(pl):    Klienci protoko³u Secure Shell
247 Summary(pt_BR): Clientes do OpenSSH
248 Summary(ru):    OpenSSH - ËÌÉÅÎÔÙ ÐÒÏÔÏËÏÌÁ Secure Shell
249 Summary(uk):    OpenSSH - Ë̦¤ÎÔÉ ÐÒÏÔÏËÏÌÕ Secure Shell
250 Group:          Applications/Networking
251 Requires:       %{name} = %{epoch}:%{version}-%{release}
252 %{?with_sshagentsh:Requires:    xinitrc}
253 Provides:       ssh-clients
254 Obsoletes:      ssh-clients
255
256 %description clients
257 Ssh (Secure Shell) a program for logging into a remote machine and for
258 executing commands in a remote machine. It is intended to replace
259 rlogin and rsh, and provide secure encrypted communications between
260 two untrusted hosts over an insecure network. X11 connections and
261 arbitrary TCP/IP ports can also be forwarded over the secure channel.
262
263 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
264 it up to date in terms of security and features, as well as removing
265 all patented algorithms to seperate libraries (OpenSSL).
266
267 This package includes the clients necessary to make encrypted
268 connections to SSH servers.
269
270 %description clients -l es
271 Este paquete incluye los clientes que se necesitan para hacer
272 conexiones codificadas con servidores SSH.
273
274 %description clients -l pl
275 Ssh (Secure Shell) to program s³u¿±cy do logowania siê na zdaln±
276 maszynê i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
277 zast±piæ rlogin, rsh i dostarczyæ bezpieczne, szyfrowane po³±czenie
278 pomiêdzy dwoma hostami.
279
280 Ten pakiet zawiera klientów s³u¿±cych do ³±czenia siê z serwerami SSH.
281
282 %description clients -l pt_BR
283 Esse pacote inclui os clientes necessários para fazer conexões
284 encriptadas com servidores SSH.
285
286 %description clients -l ru
287 Ssh (Secure Shell) - ÜÔÏ ÐÒÏÇÒÁÍÍÁ ÄÌÑ "ÚÁÈÏÄÁ" (login) ÎÁ ÕÄÁÌÅÎÎÕÀ
288 ÍÁÛÉÎÕ É ÄÌÑ ×ÙÐÏÌÎÅÎÉÑ ËÏÍÁÎÄ ÎÁ ÕÄÁÌÅÎÎÏÊ ÍÁÛÉÎÅ.
289
290 üÔÏÔ ÐÁËÅÔ ÓÏÄÅÒÖÉÔ ÐÒÏÇÒÁÍÍÙ-ËÌÉÅÎÔÙ, ÎÅÏÂÈÏÄÉÍÙÅ ÄÌÑ ÕÓÔÁÎÏ×ÌÅÎÉÑ
291 ÚÁÛÉÆÒÏ×ÁÎÎÙÈ ÓÏÅÄÉÎÅÎÉÊ Ó ÓÅÒ×ÅÒÁÍÉ SSH.
292
293 %description clients -l uk
294 Ssh (Secure Shell) - ÃÅ ÐÒÏÇÒÁÍÁ ÄÌÑ "ÚÁÈÏÄÕ" (login) ÄϠצÄÄÁÌÅÎϧ
295 ÍÁÛÉÎÉ ÔÁ ÄÌÑ ×ÉËÏÎÁÎÎÑ ËÏÍÁÎÄ ÎÁ ×¦ÄÄÁÌÅΦʠÍÁÛÉΦ.
296
297 ãÅÊ ÐÁËÅԠͦÓÔÉÔØ ÐÒÏÇÒÁÍÉ-Ë̦¤ÎÔÉ, ÎÅÏÂȦÄΦ ÄÌÑ ×ÓÔÁÎÏ×ÌÅÎÎÑ
298 ÚÁÛÉÆÒÏ×ÁÎÉÈ Ú'¤ÄÎÁÎØ Ú ÓÅÒ×ÅÒÁÍÉ SSH.
299
300 %package server
301 Summary:        OpenSSH Secure Shell protocol server (sshd)
302 Summary(de):    OpenSSH Secure Shell Protocol-Server (sshd)
303 Summary(es):    Servidor OpenSSH para comunicaciones codificadas
304 Summary(fr):    Serveur de protocole du shell sécurisé OpenSSH (sshd)
305 Summary(it):    Server OpenSSH per il protocollo Secure Shell (sshd)
306 Summary(pl):    Serwer protoko³u Secure Shell (sshd)
307 Summary(pt):    Servidor do protocolo 'Secure Shell' OpenSSH (sshd)
308 Summary(pt_BR): Servidor OpenSSH para comunicações encriptadas
309 Summary(ru):    OpenSSH - ÓÅÒ×ÅÒ ÐÒÏÔÏËÏÌÁ Secure Shell (sshd)
310 Summary(uk):    OpenSSH - ÓÅÒ×ÅÒ ÐÒÏÔÏËÏÌÕ Secure Shell (sshd)
311 Group:          Networking/Daemons
312 Requires(post): chkconfig >= 0.9
313 Requires(post): grep
314 Requires(post,preun):   /sbin/chkconfig
315 Requires(postun):       /usr/sbin/userdel
316 Requires(pre):  /bin/id
317 Requires(pre):  /usr/sbin/useradd
318 Requires:       %{name} = %{epoch}:%{version}-%{release}
319 Requires:       /bin/login
320 Requires:       pam >= 0.77.3
321 Requires:       rc-scripts >= 0.4.0.18
322 Requires:       util-linux
323 Provides:       ssh-server
324 Provides:       user(sshd)
325
326 %description server
327 Ssh (Secure Shell) a program for logging into a remote machine and for
328 executing commands in a remote machine. It is intended to replace
329 rlogin and rsh, and provide secure encrypted communications between
330 two untrusted hosts over an insecure network. X11 connections and
331 arbitrary TCP/IP ports can also be forwarded over the secure channel.
332
333 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
334 it up to date in terms of security and features, as well as removing
335 all patented algorithms to seperate libraries (OpenSSL).
336
337 This package contains the secure shell daemon. The sshd is the server
338 part of the secure shell protocol and allows ssh clients to connect to
339 your host.
340
341 %description server -l de
342 Dieses Paket installiert den sshd, den Server-Teil der OpenSSH.
343
344 %description server -l es
345 Este paquete contiene el servidor SSH. sshd es la parte servidor del
346 protocolo secure shell y permite que clientes ssh se conecten a su
347 servidor.
348
349 %description server -l fr
350 Ce paquetage installe le 'sshd', partie serveur de OpenSSH.
351
352 %description server -l it
353 Questo pacchetto installa sshd, il server di OpenSSH.
354
355 %description server -l pl
356 Ssh (Secure Shell) to program s³u¿±cy do logowania siê na zdaln±
357 maszynê i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
358 zast±piæ rlogin, rsh i dostarczyæ bezpieczne, szyfrowane po³±czenie
359 pomiêdzy dwoma hostami.
360
361 Ten pakiet zawiera serwer sshd (do którego mog± ³±czyæ siê klienci
362 ssh).
363
364 %description server -l pt
365 Este pacote intala o sshd, o servidor do OpenSSH.
366
367 %description server -l pt_BR
368 Esse pacote contém o servidor SSH. O sshd é a parte servidor do
369 protocolo secure shell e permite que clientes ssh se conectem ao seu
370 host.
371
372 %description server -l ru
373 Ssh (Secure Shell) - ÜÔÏ ÐÒÏÇÒÁÍÍÁ ÄÌÑ "ÚÁÈÏÄÁ" (login) ÎÁ ÕÄÁÌÅÎÎÕÀ
374 ÍÁÛÉÎÕ É ÄÌÑ ×ÙÐÏÌÎÅÎÉÑ ËÏÍÁÎÄ ÎÁ ÕÄÁÌÅÎÎÏÊ ÍÁÛÉÎÅ.
375
376 üÔÏÔ ÐÁËÅÔ ÓÏÄÅÒÖÉÔ sshd - "ÄÅÍÏÎ" Secure Shell. sshd - ÜÔÏ ÓÅÒ×ÅÒÎÁÑ
377 ÞÁÓÔØ ÐÒÏÔÏËÏÌÁ Secure Shell, ÐÏÚ×ÏÌÑÀÝÁÑ ËÌÉÅÎÔÁÍ ssh ÓÏÅÄÉÎÑÔØÓÑ Ó
378 ×ÁÛÉÍ ÈÏÓÔÏÍ.
379
380 %description server -l uk
381 Ssh (Secure Shell) - ÃÅ ÐÒÏÇÒÁÍÁ ÄÌÑ "ÚÁÈÏÄÕ" (login) ÄϠצÄÄÁÌÅÎϧ
382 ÍÁÛÉÎÉ ÔÁ ÄÌÑ ×ÉËÏÎÁÎÎÑ ËÏÍÁÎÄ ÎÁ ×¦ÄÄÁÌÅΦʠÍÁÛÉΦ.
383
384 ãÅÊ ÐÁËÅԠͦÓÔÉÔØ sshd - "ÄÅÍÏÎ" Secure Shell. sshd - ÃÅ ÓÅÒ×ÅÒÎÁ
385 ÞÁÓÔÉÎÁ ÐÒÏÔÏËÏÌÕ Secure Shell, ÑËÁ ÄÏÚ×ÏÌѤ Ë̦¤ÎÔÁÍ ssh Ú×'ÑÚÕ×ÁÔÉÓØ
386 Ú ×ÁÛÉÍ ÈÏÓÔÏÍ.
387
388 %package gnome-askpass
389 Summary:        OpenSSH GNOME passphrase dialog
390 Summary(de):    OpenSSH GNOME Passwort-Dialog
391 Summary(es):    Diálogo para introducción de passphrase para GNOME
392 Summary(fr):    Dialogue pass-phrase GNOME d'OpenSSH
393 Summary(it):    Finestra di dialogo GNOME per la frase segreta di OpenSSH
394 Summary(pl):    Odpytywacz has³a OpenSSH dla GNOME
395 Summary(pt):    Diálogo de pedido de senha para GNOME do OpenSSH
396 Summary(pt_BR): Diálogo para entrada de passphrase para GNOME
397 Summary(ru):    OpenSSH - ÄÉÁÌÏÇ ××ÏÄÁ ËÌÀÞÅ×ÏÊ ÆÒÁÚÙ (passphrase) ÄÌÑ GNOME
398 Summary(uk):    OpenSSH - Ä¦ÁÌÏÇ ××ÏÄÕ ËÌÀÞÏ×ϧ ÆÒÁÚÉ (passphrase) ÄÌÑ GNOME
399 Group:          Applications/Networking
400 Requires:       %{name} = %{epoch}:%{version}-%{release}
401 Obsoletes:      openssh-askpass
402 Obsoletes:      ssh-askpass
403 Obsoletes:      ssh-extras
404
405 %description gnome-askpass
406 Ssh (Secure Shell) a program for logging into a remote machine and for
407 executing commands in a remote machine. It is intended to replace
408 rlogin and rsh, and provide secure encrypted communications between
409 two untrusted hosts over an insecure network. X11 connections and
410 arbitrary TCP/IP ports can also be forwarded over the secure channel.
411
412 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
413 it up to date in terms of security and features, as well as removing
414 all patented algorithms to seperate libraries (OpenSSL).
415
416 This package contains the GNOME passphrase dialog.
417
418 %description gnome-askpass -l es
419 Este paquete contiene un programa que abre una caja de diálogo para
420 entrada de passphrase en GNOME.
421
422 %description gnome-askpass -l pl
423 Ssh (Secure Shell) to program s³u¿±cy do logowania siê na zdaln±
424 maszynê i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
425 zast±piæ rlogin, rsh i dostarczyæ bezpieczne, szyfrowane po³±czenie
426 pomiêdzy dwoma hostami.
427
428 Ten pakiet zawiera ,,odpytywacz has³a'' dla GNOME.
429
430 %description gnome-askpass -l pt_BR
431 Esse pacote contém um programa que abre uma caixa de diálogo para
432 entrada de passphrase no GNOME.
433
434 %description gnome-askpass -l ru
435 Ssh (Secure Shell) - ÜÔÏ ÐÒÏÇÒÁÍÍÁ ÄÌÑ "ÚÁÈÏÄÁ" (login) ÎÁ ÕÄÁÌÅÎÎÕÀ
436 ÍÁÛÉÎÕ É ÄÌÑ ×ÙÐÏÌÎÅÎÉÑ ËÏÍÁÎÄ ÎÁ ÕÄÁÌÅÎÎÏÊ ÍÁÛÉÎÅ.
437
438 üÔÏÔ ÐÁËÅÔ ÓÏÄÅÒÖÉÔ ÄÉÁÌÏÇ ××ÏÄÁ ËÌÀÞÅ×ÏÊ ÆÒÁÚÙ ÄÌÑ ÉÓÐÏÌØÚÏ×ÁÎÉÑ ÐÏÄ
439 GNOME.
440
441 %description gnome-askpass -l uk
442 Ssh (Secure Shell) - ÃÅ ÐÒÏÇÒÁÍÁ ÄÌÑ "ÚÁÈÏÄÕ" (login) ÄϠצÄÄÁÌÅÎϧ
443 ÍÁÛÉÎÉ ÔÁ ÄÌÑ ×ÉËÏÎÁÎÎÑ ËÏÍÁÎÄ ÎÁ ×¦ÄÄÁÌÅΦʠÍÁÛÉΦ.
444
445 ãÅÊ ÐÁËÅԠͦÓÔÉÔؠĦÁÌÏÇ ××ÏÄÕ ËÌÀÞÏ×ϧ ÆÒÁÚÉ ÄÌÑ ×ÉËÏÒÉÓÔÁÎÎѠЦÄ
446 GNOME.
447
448 %prep
449 %setup -q
450 %patch0 -p1
451 %patch2 -p1
452 %patch3 -p1
453 %patch4 -p1
454 %{?with_ldap:%patch5 -p1}
455 %{?with_kerberos5:%patch6 -p1}
456 #%patch7 -p1
457 %patch8 -p1
458 %patch9 -p1
459 %{?with_hpn:%patch10 -p1}
460 %{?with_hpn_none:%patch11 -p1}
461 %patch12 -p1
462
463 %build
464 cp /usr/share/automake/config.sub .
465 %{__aclocal}
466 %{__autoconf}
467 %{?with_chroot:CPPFLAGS="-DCHROOT"}
468 %configure \
469         PERL=%{__perl} \
470         --with-dns \
471         --with-pam \
472         --with-mantype=man \
473         --with-md5-passwords \
474         --with-ipaddr-display \
475         %{?with_libedit:--with-libedit} \
476         --with-4in6 \
477         --disable-suid-ssh \
478         --with-tcp-wrappers \
479         %{?with_ldap:--with-libs="-lldap -llber"} \
480         %{?with_ldap:--with-cppflags="-DWITH_LDAP_PUBKEY"} \
481         %{?with_kerberos5:--with-kerberos5} \
482         --with-privsep-path=%{_privsepdir} \
483         --with-pid-dir=%{_localstatedir}/run \
484         --with-xauth=/usr/X11R6/bin/xauth \
485         --enable-utmpx \
486         --enable-wtmpx
487
488 echo '#define LOGIN_PROGRAM                "/bin/login"' >>config.h
489
490 %{__make}
491
492 cd contrib
493 %if %{with gnome}
494 %{__make} gnome-ssh-askpass1 \
495         CC="%{__cc} %{rpmldflags} %{rpmcflags}"
496 %endif
497 %if %{with gtk}
498 %{__make} gnome-ssh-askpass2 \
499         CC="%{__cc} %{rpmldflags} %{rpmcflags}"
500 %endif
501
502 %install
503 rm -rf $RPM_BUILD_ROOT
504 install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/{pam.d,rc.d/init.d,sysconfig,security,env.d}} \
505         $RPM_BUILD_ROOT%{_libexecdir}/ssh
506 %{?with_sshagentsh:install -d $RPM_BUILD_ROOT/etc/{profile.d,X11/xinit/xinitrc.d}}
507
508 %{__make} install \
509         DESTDIR=$RPM_BUILD_ROOT
510
511 install %{SOURCE4} $RPM_BUILD_ROOT/etc/pam.d/sshd
512 install %{SOURCE6} $RPM_BUILD_ROOT/etc/pam.d/passwdssh
513 install %{SOURCE5} $RPM_BUILD_ROOT/etc/sysconfig/sshd
514 install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
515 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/ssh_config
516 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/sshd_config
517 %if %{with sshagentsh}
518 install %{SOURCE11} $RPM_BUILD_ROOT/etc/profile.d
519 ln -sf  /etc/profile.d/ssh-agent.sh $RPM_BUILD_ROOT/etc/X11/xinit/xinitrc.d/ssh-agent.sh
520 install %{SOURCE12} $RPM_BUILD_ROOT%{_sysconfdir}
521 %endif
522
523 bzip2 -dc %{SOURCE7} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
524
525 %if %{with gnome}
526 install contrib/gnome-ssh-askpass1 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
527 %endif
528 %if %{with gtk}
529 install contrib/gnome-ssh-askpass2 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
530 %endif
531 %if %{with gnome} || %{with gtk}
532 cat << EOF >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_SERVER
533 #GNOME_SSH_ASKPASS_GRAB_SERVER="true"
534 EOF
535 cat << EOF >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_POINTER
536 #GNOME_SSH_ASKPASS_GRAB_POINTER="true"
537 EOF
538 ln -s %{_libexecdir}/ssh/ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/ssh-askpass
539 %endif
540
541 rm -f   $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
542 echo ".so ssh.1" > $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
543
544 touch $RPM_BUILD_ROOT/etc/security/blacklist.sshd
545
546 %if "%{_lib}" != "lib"
547 find $RPM_BUILD_ROOT%{_sysconfdir} -type f -print0 | xargs -0 sed -i -e 's#%{_prefix}/lib#%{_libdir}#'
548 %endif
549
550 cat << 'EOF' > $RPM_BUILD_ROOT/etc/env.d/SSH_ASKPASS
551 #SSH_ASKPASS="%{_libexecdir}/ssh-askpass"
552 EOF
553
554 %clean
555 rm -rf $RPM_BUILD_ROOT
556
557 %post clients
558 %env_update
559
560 %postun clients
561 %env_update
562
563 %post gnome-askpass
564 %env_update
565
566 %postun gnome-askpass
567 %env_update
568
569 %pre server
570 %useradd -P %{name}-server -u 40 -d %{_privsepdir} -s /bin/false -c "OpenSSH PrivSep User" -g nobody sshd
571
572 %post server
573 /sbin/chkconfig --add sshd
574 %service sshd reload "openssh daemon"
575 if ! grep -qs ssh /etc/security/passwd.conf ; then
576         umask 022
577         echo "ssh" >> /etc/security/passwd.conf
578 fi
579
580 %preun server
581 if [ "$1" = "0" ]; then
582         %service sshd stop
583         /sbin/chkconfig --del sshd
584 fi
585
586 %postun server
587 if [ "$1" = "0" ]; then
588         %userremove sshd
589 fi
590
591 %files
592 %defattr(644,root,root,755)
593 %doc *.RNG TODO README OVERVIEW CREDITS Change*
594 %attr(755,root,root) %{_bindir}/ssh-key*
595 %{_mandir}/man1/ssh-key*.1*
596 %dir %{_sysconfdir}
597 %dir %{_libexecdir}
598
599 %files clients
600 %defattr(644,root,root,755)
601 %attr(755,root,root) %{_bindir}/ssh
602 %attr(755,root,root) %{_bindir}/slogin
603 %attr(755,root,root) %{_bindir}/sftp
604 %attr(755,root,root) %{_bindir}/ssh-agent
605 %attr(755,root,root) %{_bindir}/ssh-add
606 %attr(755,root,root) %{_bindir}/scp
607 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh_config
608 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/SSH_ASKPASS
609 %if %{with sshagentsh}
610 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh-agent.conf
611 %attr(755,root,root) /etc/profile.d/ssh-agent.sh
612 %attr(755,root,root) /etc/X11/xinit/xinitrc.d/ssh-agent.sh
613 %endif
614 %{_mandir}/man1/scp.1*
615 %{_mandir}/man1/ssh.1*
616 %{_mandir}/man1/slogin.1*
617 %{_mandir}/man1/sftp.1*
618 %{_mandir}/man1/ssh-agent.1*
619 %{_mandir}/man1/ssh-add.1*
620 %{_mandir}/man5/ssh_config.5*
621 %lang(it) %{_mandir}/it/man1/ssh.1*
622 %lang(it) %{_mandir}/it/man5/ssh_config.5*
623 %lang(pl) %{_mandir}/pl/man1/scp.1*
624 %lang(zh_CN) %{_mandir}/zh_CN/man1/scp.1*
625
626 # for host-based auth (suid required for accessing private host key)
627 #%attr(4755,root,root) %{_libexecdir}/ssh-keysign
628 #%{_mandir}/man8/ssh-keysign.8*
629
630 %files server
631 %defattr(644,root,root,755)
632 %attr(755,root,root) %{_sbindir}/sshd
633 %attr(755,root,root) %{_libexecdir}/sftp-server
634 %attr(755,root,root) %{_libexecdir}/ssh-keysign
635 %{_mandir}/man8/sshd.8*
636 %{_mandir}/man8/sftp-server.8*
637 %{_mandir}/man8/ssh-keysign.8*
638 %{_mandir}/man5/sshd_config.5*
639 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sshd_config
640 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/sshd
641 %attr(640,root,root) %{_sysconfdir}/moduli
642 %attr(754,root,root) /etc/rc.d/init.d/sshd
643 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/sshd
644 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.sshd
645
646 %if %{with gnome} || %{with gtk}
647 %files gnome-askpass
648 %defattr(644,root,root,755)
649 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/GNOME_SSH_ASKPASS*
650 %dir %{_libexecdir}/ssh
651 %attr(755,root,root) %{_libexecdir}/ssh/ssh-askpass
652 %attr(755,root,root) %{_libexecdir}/ssh-askpass
653 %endif
This page took 0.143795 seconds and 3 git commands to generate.