]> git.pld-linux.org Git - packages/openssh.git/blob - openssh.spec
- R(post) and R(postun) env-update
[packages/openssh.git] / openssh.spec
1 #
2 # Conditional build:
3 %bcond_without  chroot          # without chrooted user environment support
4 %bcond_with     gnome           # with gnome-askpass (GNOME 1.x) utility
5 %bcond_without  gtk             # without GTK+ (2.x)
6 %bcond_with     ldap            # with ldap support
7 %bcond_without  libedit         # without libedit (editline/history support in sftp client)
8 %bcond_without  kerberos5       # without kerberos5 support
9 %bcond_without  selinux         # build without SELinux support
10 %bcond_with     sshagentsh      # with system-wide script for starting ssh-agent
11 %bcond_with     hpn             # with High Performance SSH/SCP - HPN-SSH (see patch comment)
12 %bcond_with     hpn_none        # with hpn (above) and '-z' none cipher option
13 #
14 %if %{with hpn_none}
15 %undefine       with_hpn
16 %endif
17 # gtk2-based gnome-askpass means no gnome1-based
18 %{?with_gtk:%undefine with_gnome}
19 %define         _rel    5
20 Summary:        OpenSSH free Secure Shell (SSH) implementation
21 Summary(de):    OpenSSH - freie Implementation der Secure Shell (SSH)
22 Summary(es):    Implementación libre de SSH
23 Summary(fr):    Implémentation libre du shell sécurisé OpenSSH (SSH)
24 Summary(it):    Implementazione gratuita OpenSSH della Secure Shell
25 Summary(pl):    Publicznie dostêpna implementacja bezpiecznego shella (SSH)
26 Summary(pt):    Implementação livre OpenSSH do protocolo 'Secure Shell' (SSH)
27 Summary(pt_BR): Implementação livre do SSH
28 Summary(ru):    OpenSSH - Ó×ÏÂÏÄÎÁÑ ÒÅÁÌÉÚÁÃÉÑ ÐÒÏÔÏËÏÌÁ Secure Shell (SSH)
29 Summary(uk):    OpenSSH - ×¦ÌØÎÁ ÒÅÁ̦ÚÁæѠÐÒÏÔÏËÏÌÕ Secure Shell (SSH)
30 Name:           openssh
31 Version:        4.3p2
32 Release:        %{_rel}%{?with_hpn:hpn}%{?with_hpn_none:hpn_none}
33 Epoch:          2
34 License:        BSD
35 Group:          Applications/Networking
36 Source0:        ftp://ftp.ca.openbsd.org/pub/OpenBSD/OpenSSH/portable/%{name}-%{version}.tar.gz
37 # Source0-md5:  7e9880ac20a9b9db0d3fea30a9ff3d46
38 Source1:        %{name}d.conf
39 Source2:        %{name}.conf
40 Source3:        %{name}d.init
41 Source4:        %{name}d.pamd
42 Source5:        %{name}.sysconfig
43 Source6:        passwd.pamd
44 Source7:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
45 # Source7-md5:  66943d481cc422512b537bcc2c7400d1
46 Source9:        http://www.taiyo.co.jp/~gotoh/ssh/connect.c
47 # Source9-md5:  b856937f1cdfca7a3ccfb2fac36ef726
48 Source10:       http://www.taiyo.co.jp/~gotoh/ssh/connect.html
49 # Source10-md5: bb972b3a9d435c62023b355960d78f78
50 Source11:       ssh-agent.sh
51 Source12:       ssh-agent.conf
52 Patch0:         %{name}-no_libnsl.patch
53 Patch1:         %{name}-ac_fix.patch
54 Patch2:         %{name}-linux-ipv6.patch
55 Patch3:         %{name}-pam_misc.patch
56 Patch4:         %{name}-sigpipe.patch
57 # http://www.opendarwin.org/projects/openssh-lpk/
58 Patch5:         %{name}-lpk-4.3p1-0.3.7.patch
59 Patch6:         %{name}-heimdal.patch
60 Patch7:         %{name}-pam-conv.patch
61 # http://chrootssh.sourceforge.net/download/osshChroot-3.7.1p2.diff
62 Patch8:         %{name}-chroot.patch
63 Patch9:         %{name}-selinux.patch
64 Patch10:        %{name}-selinux-pld.patch
65 # HPN patches rediffed due sigpipe patch.
66 # High Performance SSH/SCP - HPN-SSH - http://www.psc.edu/networking/projects/hpn-ssh/
67 # http://www.psc.edu/networking/projects/hpn-ssh/openssh-4.2p1-hpn11.diff
68 Patch11:        %{name}-4.3p1-hpn11.patch
69 # Adds HPN (see p11) and an undocumented -z none cipher flag
70 # http://www.psc.edu/networking/projects/hpn-ssh/openssh-4.2p1-hpn11-none.diff
71 Patch12:        %{name}-4.3p1-hpn11-none.patch
72 Patch13:        %{name}-include.patch
73 URL:            http://www.openssh.com/
74 BuildRequires:  %{__perl}
75 BuildRequires:  autoconf
76 BuildRequires:  automake
77 %{?with_gnome:BuildRequires:    gnome-libs-devel}
78 %{?with_gtk:BuildRequires:      gtk+2-devel}
79 %{?with_kerberos5:BuildRequires:        heimdal-devel >= 0.7}
80 %{?with_libedit:BuildRequires:  libedit-devel}
81 %{?with_selinux:BuildRequires:  libselinux-devel}
82 BuildRequires:  libwrap-devel
83 %{?with_ldap:BuildRequires:     openldap-devel}
84 BuildRequires:  openssl-devel >= 0.9.7d
85 BuildRequires:  pam-devel
86 %{?with_gtk:BuildRequires:      pkgconfig}
87 BuildRequires:  rpmbuild(macros) >= 1.318
88 BuildRequires:  zlib-devel
89 Requires:       FHS >= 2.1-24
90 Requires:       pam >= 0.79.0
91 Obsoletes:      ssh
92 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
93
94 %define         _sysconfdir     /etc/ssh
95 %define         _libexecdir     %{_libdir}/%{name}
96 %define         _privsepdir     /usr/share/empty
97
98 %description
99 Ssh (Secure Shell) a program for logging into a remote machine and for
100 executing commands in a remote machine. It is intended to replace
101 rlogin and rsh, and provide secure encrypted communications between
102 two untrusted hosts over an insecure network. X11 connections and
103 arbitrary TCP/IP ports can also be forwarded over the secure channel.
104
105 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
106 it up to date in terms of security and features, as well as removing
107 all patented algorithms to seperate libraries (OpenSSL).
108
109 This package includes the core files necessary for both the OpenSSH
110 client and server. To make this package useful, you should also
111 install openssh-clients, openssh-server, or both.
112 %if %{with hpn} || %{with hpn_none}
113 This release includes High Performance SSH/SCP patches from
114 http://www.psc.edu/networking/projects/hpn-ssh/ which are supposed
115 to increase throughput on fast connections with high RTT (20-150 msec).
116 See the website for '-w' values for your connection and /proc/sys TCP
117 values. BTW. in a LAN you have got generally RTT < 1 msec.
118 %endif
119 %if %{with hpn_none}
120 It also includes an undocumented '-z' option which switches
121 the cipher to none after authentication is completed. Data is
122 still secured from tampering and corruption in transit through
123 the use of the Message Authentication Code (MAC).
124 This option will significantly reduce the number of cpu cycles used
125 by the SSH/SCP process. This may allow some users to see significant
126 improvement in (sniffable) data tranfer rates.
127 %endif
128
129 %description -l de
130 OpenSSH (Secure Shell) stellt den Zugang zu anderen Rechnern her. Es
131 ersetzt telnet, rlogin, rexec und rsh und stellt eine sichere,
132 verschlüsselte Verbindung zwischen zwei nicht vertrauenswürdigen Hosts
133 über eine unsicheres Netzwerk her. X11 Verbindungen und beliebige
134 andere TCP/IP Ports können ebenso über den sicheren Channel
135 weitergeleitet werden.
136
137 %description -l es
138 SSH es un programa para accesar y ejecutar órdenes en computadores
139 remotos. Sustituye rlogin y rsh, y suministra un canal de comunicación
140 seguro entre dos servidores en una red insegura. Conexiones X11 y
141 puertas TCP/IP arbitrárias también pueden ser usadas por el canal
142 seguro.
143
144 OpenSSH es el resultado del trabajo del equipo de OpenBSD para
145 continuar la última versión gratuita de SSH, actualizándolo en
146 términos de seguridad y recursos,así también eliminando todos los
147 algoritmos patentados y colocándolos en bibliotecas separadas
148 (OpenSSL).
149
150 Este paquete contiene "port" para Linux de OpenSSH. Se debe instalar
151 también el paquete openssh-clients u openssh-server o ambos.
152
153 %description -l fr
154 OpenSSH (Secure Shell) fournit un accès à un système distant. Il
155 remplace telnet, rlogin, rexec et rsh, tout en assurant des
156 communications cryptées securisées entre deux hôtes non fiabilisés sur
157 un réseau non sécurisé. Des connexions X11 et des ports TCP/IP
158 arbitraires peuvent également être transmis sur le canal sécurisé.
159
160 %description -l it
161 OpenSSH (Secure Shell) fornisce l'accesso ad un sistema remoto.
162 Sostituisce telnet, rlogin, rexec, e rsh, e fornisce comunicazioni
163 sicure e crittate tra due host non fidati su una rete non sicura. Le
164 connessioni X11 ad una porta TCP/IP arbitraria possono essere
165 inoltrate attraverso un canale sicuro.
166
167 %description -l pl
168 Ssh (Secure Shell) to program s³u¿±cy do logowania siê na zdaln±
169 maszynê i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
170 zast±piæ rlogin, rsh i dostarczyæ bezpieczne, szyfrowane po³±czenie
171 pomiêdzy dwoma hostami.
172
173 Ten pakiet zawiera podstawowe pliki potrzebne zarówno po stronie
174 klienta jak i serwera OpenSSH. Aby by³ u¿yteczny, trzeba zainstalowaæ
175 co najmniej jeden z pakietów: openssh-clients lub openssh-server.
176 %if %{with hpn} || %{with hpn_none}
177 Ta wersja zawiera ³aty z projektu High Performance SSH/SCP
178 http://www.psc.edu/networking/projects/hpn-ssh/, które maj± na celu
179 zwiêkszenie przepustowo¶ci transmisji dla szybkich po³±czeñ
180 z du¿ym RTT (20-150 msec). Na stronie projektu znale¼æ mo¿na
181 odpowednie dla danego po³±czenia warto¶ci parametru '-w' oraz
182 opcje /proc/sys dla TCP. Nawiasem mówi±c w sieciach LAN RTT < 1 msec.
183 %endif
184 %if %{with hpn_none}
185 Obs³ugiwana jest równie¿ nieudokumentowana opcja '-z' odpowiedzialna
186 za wy³±czenie szyfrowania danych po zakoñczeniu procesu uwierzytelniania.
187 Dane s± zabezpieczone przed modyfikacj± lub uszkodzeniem przez
188 stosowanie Message Authentication Code (MAC).
189 Opcja ta znacznie redukuje liczbê cykli procesora zu¿ywanych przez
190 procesy SSH/SCP. W wybranych zastosowaniach mo¿e ona wp³yn±æ
191 na wyra¼ne przyspieszenie (pods³uchiwalnej) transmisji danych.
192 %endif
193
194 %description -l pt
195 OpenSSH (Secure Shell) fornece acesso a um sistema remoto. Substitui o
196 telnet, rlogin, rexec, e o rsh e fornece comunicações seguras e
197 cifradas entre duas máquinas sem confiança mútua sobre uma rede
198 insegura. Ligações X11 e portos TCP/IP arbitrários também poder ser
199 reenviados pelo canal seguro.
200
201 %description -l pt_BR
202 SSH é um programa para acessar e executar comandos em máquinas
203 remotas. Ele substitui rlogin e rsh, e provem um canal de comunicação
204 seguro entre dois hosts em uma rede insegura. Conexões X11 e portas
205 TCP/IP arbitrárias também podem ser usadas pelo canal seguro.
206
207 OpenSSH é o resultado do trabalho da equipe do OpenBSD em continuar a
208 última versão gratuita do SSH, atualizando-o em termos de segurança e
209 recursos, assim como removendo todos os algoritmos patenteados e
210 colocando-os em bibliotecas separadas (OpenSSL).
211
212 Esse pacote contém o "port" pra Linux do OpenSSH. Você deve instalar
213 também ou o pacote openssh-clients, ou o openssh-server, ou ambos.
214
215 %description -l ru
216 Ssh (Secure Shell) - ÜÔÏ ÐÒÏÇÒÁÍÍÁ ÄÌÑ "ÚÁÈÏÄÁ" (login) ÎÁ ÕÄÁÌÅÎÎÕÀ
217 ÍÁÛÉÎÕ É ÄÌÑ ×ÙÐÏÌÎÅÎÉÑ ËÏÍÁÎÄ ÎÁ ÕÄÁÌÅÎÎÏÊ ÍÁÛÉÎÅ. ïÎÁ ÐÒÅÄÎÁÚÎÁÞÅÎÁ
218 ÄÌÑ ÚÁÍÅÎÙ rlogin É rsh É ÏÂÅÓÐÅÞÉ×ÁÅÔ ÂÅÚÏÐÁÓÎÕÀ ÛÉÆÒÏ×ÁÎÎÕÀ
219 ËÏÍÍÕÎÉËÁÃÉÀ ÍÅÖÄÕ Ä×ÕÍÑ ÈÏÓÔÁÍÉ × ÓÅÔÉ, Ñ×ÌÑÀÝÅÊÓÑ ÎÅÂÅÚÏÐÁÓÎÏÊ.
220 óÏÅÄÉÎÅÎÉÑ X11 É ÌÀÂÙÅ ÐÏÒÔÙ TCP/IP ÍÏÇÕÔ ÔÁËÖÅ ÂÙÔØ ÐÒÏ×ÅÄÅÎÙ ÞÅÒÅÚ
221 ÂÅÚÏÐÁÓÎÙÊ ËÁÎÁÌ.
222
223 OpenSSH - ÜÔÏ ÐÅÒÅÄÅÌËÁ ËÏÍÁÎÄÏÊ ÒÁÚÒÁÂÏÔÞÉËÏ× OpenBSD ÐÏÓÌÅÄÎÅÊ
224 Ó×ÏÂÏÄÎÏÊ ×ÅÒÓÉÉ SSH, ÄÏ×ÅÄÅÎÎÁÑ ÄÏ ÓÏ×ÒÅÍÅÎÎÏÇÏ ÓÏÓÔÏÑÎÉÑ × ÔÅÒÍÉÎÁÈ
225 ÕÒÏ×ÎÑ ÂÅÚÏÐÁÓÎÏÓÔÉ É ÐÏÄÄÅÒÖÉ×ÁÅÍÙÈ ×ÏÚÍÏÖÎÏÓÔÅÊ. ÷ÓÅ ÐÁÔÅÎÔÏ×ÁÎÎÙÅ
226 ÁÌÇÏÒÉÔÍÙ ×ÙÎÅÓÅÎÙ × ÏÔÄÅÌØÎÙÅ ÂÉÂÌÉÏÔÅËÉ (OpenSSL).
227
228 üÔÏÔ ÐÁËÅÔ ÓÏÄÅÒÖÉÔ ÆÁÊÌÙ, ÎÅÏÂÈÏÄÉÍÙÅ ËÁË ÄÌÑ ËÌÉÅÎÔÁ, ÔÁË É ÄÌÑ
229 ÓÅÒ×ÅÒÁ OpenSSH. ÷ÁÍ ÎÕÖÎÏ ÂÕÄÅÔ ÕÓÔÁÎÏ×ÉÔØ ÅÝÅ openssh-clients,
230 openssh-server, ÉÌÉ ÏÂÁ ÐÁËÅÔÁ.
231
232 %description -l uk
233 Ssh (Secure Shell) - ÃÅ ÐÒÏÇÒÁÍÁ ÄÌÑ "ÚÁÈÏÄÕ" (login) ÄϠצÄÄÁÌÅÎϧ
234 ÍÁÛÉÎÉ ÔÁ ÄÌÑ ×ÉËÏÎÁÎÎÑ ËÏÍÁÎÄ ÎÁ ×¦ÄÄÁÌÅΦʠÍÁÛÉΦ. ÷ÏÎÁ ÐÒÉÚÎÁÞÅÎÁ
235 ÄÌÑ ÚÁͦÎÉ rlogin ÔÁ rsh ¦ ÚÁÂÅÚÐÅÞÕ¤ ÂÅÚÐÅÞÎÕ ÛÉÆÒÏ×ÁÎÕ ËÏÍÕΦËÁæÀ
236 ͦ֠Ä×ÏÍÁ ÈÏÓÔÁÍÉ × ÍÅÒÅÖ¦, ÑËÁ ÎÅ ¤ ÂÅÚÐÅÞÎÏÀ. ú'¤ÄÎÁÎÎÑ X11 ÔÁ
237 ÄÏצÌØΦ ÐÏÒÔÉ TCP/IP ÍÏÖÕÔØ ÔÁËÏÖ ÂÕÔÉ ÐÒÏ×ÅÄÅΦ ÞÅÒÅÚ ÂÅÚÐÅÞÎÉÊ
238 ËÁÎÁÌ.
239
240 OpenSSH - ÃÅ ÐÅÒÅÒÏÂËÁ ËÏÍÁÎÄÏÀ ÒÏÚÒÏÂÎÉ˦נOpenBSD ÏÓÔÁÎÎØϧ ×¦ÌØÎϧ
241 ×ÅÒÓ¦§ SSH, ÄÏ×ÅÄÅÎÁ ÄÏ ÓÕÞÁÓÎÏÇÏ ÓÔÁÎÕ × ÔÅÒͦÎÁÈ Ò¦×ÎÑ ÂÅÚÐÅËÉ ÔÁ
242 ЦÄÔÒÉÍÕ×ÁÎÉÈ ÍÏÖÌÉ×ÏÓÔÅÊ. ÷Ó¦ ÐÁÔÅÎÔÏ×ÁΦ ÁÌÇÏÒÉÔÍÉ ×ÉÎÅÓÅΦ ÄÏ
243 ÏËÒÅÍÉȠ¦Â̦ÏÔÅË (OpenSSL).
244
245 ãÅÊ ÐÁËÅԠͦÓÔÉÔØ ÆÁÊÌÉ, ÎÅÏÂȦÄΦ ÑË ÄÌÑ Ë̦¤ÎÔÁ, ÔÁË ¦ ÄÌÑ ÓÅÒ×ÅÒÁ
246 OpenSSH. ÷ÁÍ ÐÏÔÒ¦ÂÎÏ ÂÕÄÅ ÝÅ ×ÓÔÁÎÏ×ÉÔÉ openssh-clients,
247 openssh-server, ÞÉ ÏÂÉÄ×Á ÐÁËÅÔÉ.
248
249 %package clients
250 Summary:        OpenSSH Secure Shell protocol clients
251 Summary(es):    Clientes de OpenSSH
252 Summary(pl):    Klienci protoko³u Secure Shell
253 Summary(pt_BR): Clientes do OpenSSH
254 Summary(ru):    OpenSSH - ËÌÉÅÎÔÙ ÐÒÏÔÏËÏÌÁ Secure Shell
255 Summary(uk):    OpenSSH - Ë̦¤ÎÔÉ ÐÒÏÔÏËÏÌÕ Secure Shell
256 Group:          Applications/Networking
257 Requires:       %{name} = %{epoch}:%{version}-%{release}
258 Requires(post): env-update
259 Requires(postun):       env-update
260 %{?with_sshagentsh:Requires:    xinitrc}
261 Provides:       ssh-clients
262 Obsoletes:      ssh-clients
263
264 %description clients
265 Ssh (Secure Shell) a program for logging into a remote machine and for
266 executing commands in a remote machine. It is intended to replace
267 rlogin and rsh, and provide secure encrypted communications between
268 two untrusted hosts over an insecure network. X11 connections and
269 arbitrary TCP/IP ports can also be forwarded over the secure channel.
270
271 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
272 it up to date in terms of security and features, as well as removing
273 all patented algorithms to seperate libraries (OpenSSL).
274
275 This package includes the clients necessary to make encrypted
276 connections to SSH servers.
277
278 %description clients -l es
279 Este paquete incluye los clientes que se necesitan para hacer
280 conexiones codificadas con servidores SSH.
281
282 %description clients -l pl
283 Ssh (Secure Shell) to program s³u¿±cy do logowania siê na zdaln±
284 maszynê i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
285 zast±piæ rlogin, rsh i dostarczyæ bezpieczne, szyfrowane po³±czenie
286 pomiêdzy dwoma hostami.
287
288 Ten pakiet zawiera klientów s³u¿±cych do ³±czenia siê z serwerami SSH.
289
290 %description clients -l pt_BR
291 Esse pacote inclui os clientes necessários para fazer conexões
292 encriptadas com servidores SSH.
293
294 %description clients -l ru
295 Ssh (Secure Shell) - ÜÔÏ ÐÒÏÇÒÁÍÍÁ ÄÌÑ "ÚÁÈÏÄÁ" (login) ÎÁ ÕÄÁÌÅÎÎÕÀ
296 ÍÁÛÉÎÕ É ÄÌÑ ×ÙÐÏÌÎÅÎÉÑ ËÏÍÁÎÄ ÎÁ ÕÄÁÌÅÎÎÏÊ ÍÁÛÉÎÅ.
297
298 üÔÏÔ ÐÁËÅÔ ÓÏÄÅÒÖÉÔ ÐÒÏÇÒÁÍÍÙ-ËÌÉÅÎÔÙ, ÎÅÏÂÈÏÄÉÍÙÅ ÄÌÑ ÕÓÔÁÎÏ×ÌÅÎÉÑ
299 ÚÁÛÉÆÒÏ×ÁÎÎÙÈ ÓÏÅÄÉÎÅÎÉÊ Ó ÓÅÒ×ÅÒÁÍÉ SSH.
300
301 %description clients -l uk
302 Ssh (Secure Shell) - ÃÅ ÐÒÏÇÒÁÍÁ ÄÌÑ "ÚÁÈÏÄÕ" (login) ÄϠצÄÄÁÌÅÎϧ
303 ÍÁÛÉÎÉ ÔÁ ÄÌÑ ×ÉËÏÎÁÎÎÑ ËÏÍÁÎÄ ÎÁ ×¦ÄÄÁÌÅΦʠÍÁÛÉΦ.
304
305 ãÅÊ ÐÁËÅԠͦÓÔÉÔØ ÐÒÏÇÒÁÍÉ-Ë̦¤ÎÔÉ, ÎÅÏÂȦÄΦ ÄÌÑ ×ÓÔÁÎÏ×ÌÅÎÎÑ
306 ÚÁÛÉÆÒÏ×ÁÎÉÈ Ú'¤ÄÎÁÎØ Ú ÓÅÒ×ÅÒÁÍÉ SSH.
307
308 %package server
309 Summary:        OpenSSH Secure Shell protocol server (sshd)
310 Summary(de):    OpenSSH Secure Shell Protocol-Server (sshd)
311 Summary(es):    Servidor OpenSSH para comunicaciones codificadas
312 Summary(fr):    Serveur de protocole du shell sécurisé OpenSSH (sshd)
313 Summary(it):    Server OpenSSH per il protocollo Secure Shell (sshd)
314 Summary(pl):    Serwer protoko³u Secure Shell (sshd)
315 Summary(pt):    Servidor do protocolo 'Secure Shell' OpenSSH (sshd)
316 Summary(pt_BR): Servidor OpenSSH para comunicações encriptadas
317 Summary(ru):    OpenSSH - ÓÅÒ×ÅÒ ÐÒÏÔÏËÏÌÁ Secure Shell (sshd)
318 Summary(uk):    OpenSSH - ÓÅÒ×ÅÒ ÐÒÏÔÏËÏÌÕ Secure Shell (sshd)
319 Group:          Networking/Daemons
320 Requires(post): chkconfig >= 0.9
321 Requires(post): grep
322 Requires(post,preun):   /sbin/chkconfig
323 Requires(postun):       /usr/sbin/userdel
324 Requires(pre):  /bin/id
325 Requires(pre):  /usr/sbin/useradd
326 Requires:       %{name} = %{epoch}:%{version}-%{release}
327 Requires:       /bin/login
328 Requires:       pam >= 0.77.3
329 Requires:       rc-scripts >= 0.4.0.18
330 Requires:       util-linux
331 Provides:       ssh-server
332 Provides:       user(sshd)
333
334 %description server
335 Ssh (Secure Shell) a program for logging into a remote machine and for
336 executing commands in a remote machine. It is intended to replace
337 rlogin and rsh, and provide secure encrypted communications between
338 two untrusted hosts over an insecure network. X11 connections and
339 arbitrary TCP/IP ports can also be forwarded over the secure channel.
340
341 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
342 it up to date in terms of security and features, as well as removing
343 all patented algorithms to seperate libraries (OpenSSL).
344
345 This package contains the secure shell daemon. The sshd is the server
346 part of the secure shell protocol and allows ssh clients to connect to
347 your host.
348
349 %description server -l de
350 Dieses Paket installiert den sshd, den Server-Teil der OpenSSH.
351
352 %description server -l es
353 Este paquete contiene el servidor SSH. sshd es la parte servidor del
354 protocolo secure shell y permite que clientes ssh se conecten a su
355 servidor.
356
357 %description server -l fr
358 Ce paquetage installe le 'sshd', partie serveur de OpenSSH.
359
360 %description server -l it
361 Questo pacchetto installa sshd, il server di OpenSSH.
362
363 %description server -l pl
364 Ssh (Secure Shell) to program s³u¿±cy do logowania siê na zdaln±
365 maszynê i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
366 zast±piæ rlogin, rsh i dostarczyæ bezpieczne, szyfrowane po³±czenie
367 pomiêdzy dwoma hostami.
368
369 Ten pakiet zawiera serwer sshd (do którego mog± ³±czyæ siê klienci
370 ssh).
371
372 %description server -l pt
373 Este pacote intala o sshd, o servidor do OpenSSH.
374
375 %description server -l pt_BR
376 Esse pacote contém o servidor SSH. O sshd é a parte servidor do
377 protocolo secure shell e permite que clientes ssh se conectem ao seu
378 host.
379
380 %description server -l ru
381 Ssh (Secure Shell) - ÜÔÏ ÐÒÏÇÒÁÍÍÁ ÄÌÑ "ÚÁÈÏÄÁ" (login) ÎÁ ÕÄÁÌÅÎÎÕÀ
382 ÍÁÛÉÎÕ É ÄÌÑ ×ÙÐÏÌÎÅÎÉÑ ËÏÍÁÎÄ ÎÁ ÕÄÁÌÅÎÎÏÊ ÍÁÛÉÎÅ.
383
384 üÔÏÔ ÐÁËÅÔ ÓÏÄÅÒÖÉÔ sshd - "ÄÅÍÏÎ" Secure Shell. sshd - ÜÔÏ ÓÅÒ×ÅÒÎÁÑ
385 ÞÁÓÔØ ÐÒÏÔÏËÏÌÁ Secure Shell, ÐÏÚ×ÏÌÑÀÝÁÑ ËÌÉÅÎÔÁÍ ssh ÓÏÅÄÉÎÑÔØÓÑ Ó
386 ×ÁÛÉÍ ÈÏÓÔÏÍ.
387
388 %description server -l uk
389 Ssh (Secure Shell) - ÃÅ ÐÒÏÇÒÁÍÁ ÄÌÑ "ÚÁÈÏÄÕ" (login) ÄϠצÄÄÁÌÅÎϧ
390 ÍÁÛÉÎÉ ÔÁ ÄÌÑ ×ÉËÏÎÁÎÎÑ ËÏÍÁÎÄ ÎÁ ×¦ÄÄÁÌÅΦʠÍÁÛÉΦ.
391
392 ãÅÊ ÐÁËÅԠͦÓÔÉÔØ sshd - "ÄÅÍÏÎ" Secure Shell. sshd - ÃÅ ÓÅÒ×ÅÒÎÁ
393 ÞÁÓÔÉÎÁ ÐÒÏÔÏËÏÌÕ Secure Shell, ÑËÁ ÄÏÚ×ÏÌѤ Ë̦¤ÎÔÁÍ ssh Ú×'ÑÚÕ×ÁÔÉÓØ
394 Ú ×ÁÛÉÍ ÈÏÓÔÏÍ.
395
396 %package gnome-askpass
397 Summary:        OpenSSH GNOME passphrase dialog
398 Summary(de):    OpenSSH GNOME Passwort-Dialog
399 Summary(es):    Diálogo para introducción de passphrase para GNOME
400 Summary(fr):    Dialogue pass-phrase GNOME d'OpenSSH
401 Summary(it):    Finestra di dialogo GNOME per la frase segreta di OpenSSH
402 Summary(pl):    Odpytywacz has³a OpenSSH dla GNOME
403 Summary(pt):    Diálogo de pedido de senha para GNOME do OpenSSH
404 Summary(pt_BR): Diálogo para entrada de passphrase para GNOME
405 Summary(ru):    OpenSSH - ÄÉÁÌÏÇ ××ÏÄÁ ËÌÀÞÅ×ÏÊ ÆÒÁÚÙ (passphrase) ÄÌÑ GNOME
406 Summary(uk):    OpenSSH - Ä¦ÁÌÏÇ ××ÏÄÕ ËÌÀÞÏ×ϧ ÆÒÁÚÉ (passphrase) ÄÌÑ GNOME
407 Group:          Applications/Networking
408 Requires:       %{name} = %{epoch}:%{version}-%{release}
409 Obsoletes:      openssh-askpass
410 Obsoletes:      ssh-askpass
411 Obsoletes:      ssh-extras
412
413 %description gnome-askpass
414 Ssh (Secure Shell) a program for logging into a remote machine and for
415 executing commands in a remote machine. It is intended to replace
416 rlogin and rsh, and provide secure encrypted communications between
417 two untrusted hosts over an insecure network. X11 connections and
418 arbitrary TCP/IP ports can also be forwarded over the secure channel.
419
420 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
421 it up to date in terms of security and features, as well as removing
422 all patented algorithms to seperate libraries (OpenSSL).
423
424 This package contains the GNOME passphrase dialog.
425
426 %description gnome-askpass -l es
427 Este paquete contiene un programa que abre una caja de diálogo para
428 entrada de passphrase en GNOME.
429
430 %description gnome-askpass -l pl
431 Ssh (Secure Shell) to program s³u¿±cy do logowania siê na zdaln±
432 maszynê i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
433 zast±piæ rlogin, rsh i dostarczyæ bezpieczne, szyfrowane po³±czenie
434 pomiêdzy dwoma hostami.
435
436 Ten pakiet zawiera ,,odpytywacz has³a'' dla GNOME.
437
438 %description gnome-askpass -l pt_BR
439 Esse pacote contém um programa que abre uma caixa de diálogo para
440 entrada de passphrase no GNOME.
441
442 %description gnome-askpass -l ru
443 Ssh (Secure Shell) - ÜÔÏ ÐÒÏÇÒÁÍÍÁ ÄÌÑ "ÚÁÈÏÄÁ" (login) ÎÁ ÕÄÁÌÅÎÎÕÀ
444 ÍÁÛÉÎÕ É ÄÌÑ ×ÙÐÏÌÎÅÎÉÑ ËÏÍÁÎÄ ÎÁ ÕÄÁÌÅÎÎÏÊ ÍÁÛÉÎÅ.
445
446 üÔÏÔ ÐÁËÅÔ ÓÏÄÅÒÖÉÔ ÄÉÁÌÏÇ ××ÏÄÁ ËÌÀÞÅ×ÏÊ ÆÒÁÚÙ ÄÌÑ ÉÓÐÏÌØÚÏ×ÁÎÉÑ ÐÏÄ
447 GNOME.
448
449 %description gnome-askpass -l uk
450 Ssh (Secure Shell) - ÃÅ ÐÒÏÇÒÁÍÁ ÄÌÑ "ÚÁÈÏÄÕ" (login) ÄϠצÄÄÁÌÅÎϧ
451 ÍÁÛÉÎÉ ÔÁ ÄÌÑ ×ÉËÏÎÁÎÎÑ ËÏÍÁÎÄ ÎÁ ×¦ÄÄÁÌÅΦʠÍÁÛÉΦ.
452
453 ãÅÊ ÐÁËÅԠͦÓÔÉÔؠĦÁÌÏÇ ××ÏÄÕ ËÌÀÞÏ×ϧ ÆÒÁÚÉ ÄÌÑ ×ÉËÏÒÉÓÔÁÎÎѠЦÄ
454 GNOME.
455
456 %prep
457 %setup -q
458 %patch0 -p1
459 %patch1 -p1
460 %patch2 -p1
461 %patch3 -p1
462 %patch4 -p1
463 %{?with_ldap:%patch5 -p1}
464 %{?with_kerberos5:%patch6 -p1}
465 #%patch7 -p1
466 %patch8 -p1
467 %{?with_selinux:%patch9 -p1}
468 %{?with_selinux:%patch10 -p1}
469 %{?with_hpn:%patch11 -p1}
470 %{?with_hpn_none:%patch12 -p1}
471 %patch13 -p1
472
473 %build
474 cp %{_datadir}/automake/config.sub .
475 %{__aclocal}
476 %{__autoconf}
477 %{?with_chroot:CPPFLAGS="-DCHROOT"}
478 %configure \
479         PERL=%{__perl} \
480         --with-dns \
481         --with-pam \
482         --with-mantype=man \
483         --with-md5-passwords \
484         --with-ipaddr-display \
485         %{?with_libedit:--with-libedit} \
486         --with-4in6 \
487         --disable-suid-ssh \
488         --with-tcp-wrappers \
489         %{?with_ldap:--with-libs="-lldap -llber"} \
490         %{?with_ldap:--with-cppflags="-DWITH_LDAP_PUBKEY"} \
491         %{?with_kerberos5:--with-kerberos5} \
492         --with-privsep-path=%{_privsepdir} \
493         --with-pid-dir=%{_localstatedir}/run \
494         --with-xauth=/usr/X11R6/bin/xauth \
495         --enable-utmpx \
496         --enable-wtmpx
497
498 echo '#define LOGIN_PROGRAM           "/bin/login"' >>config.h
499
500 %{__make}
501
502 cp -f %{SOURCE9} .
503 cp -f %{SOURCE10} .
504 %{__cc} %{rpmcflags} %{rpmldflags} connect.c -o connect
505
506 cd contrib
507 %if %{with gnome}
508 %{__make} gnome-ssh-askpass1 \
509         CC="%{__cc} %{rpmldflags} %{rpmcflags}"
510 %endif
511 %if %{with gtk}
512 %{__make} gnome-ssh-askpass2 \
513         CC="%{__cc} %{rpmldflags} %{rpmcflags}"
514 %endif
515
516 %install
517 rm -rf $RPM_BUILD_ROOT
518 install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/{pam.d,rc.d/init.d,sysconfig,security,env.d}} \
519         $RPM_BUILD_ROOT%{_libexecdir}/ssh
520 %{?with_sshagentsh:install -d $RPM_BUILD_ROOT/etc/{profile.d,X11/xinit/xinitrc.d}}
521
522 %{__make} install \
523         DESTDIR=$RPM_BUILD_ROOT
524
525 install connect $RPM_BUILD_ROOT%{_bindir}
526 install %{SOURCE4} $RPM_BUILD_ROOT/etc/pam.d/sshd
527 install %{SOURCE6} $RPM_BUILD_ROOT/etc/pam.d/passwdssh
528 install %{SOURCE5} $RPM_BUILD_ROOT/etc/sysconfig/sshd
529 install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
530 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/ssh_config
531 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/sshd_config
532 %if %{with sshagentsh}
533 install %{SOURCE11} $RPM_BUILD_ROOT/etc/profile.d
534 ln -sf  /etc/profile.d/ssh-agent.sh $RPM_BUILD_ROOT/etc/X11/xinit/xinitrc.d/ssh-agent.sh
535 install %{SOURCE12} $RPM_BUILD_ROOT%{_sysconfdir}
536 %endif
537
538 bzip2 -dc %{SOURCE7} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
539
540 %if %{with gnome}
541 install contrib/gnome-ssh-askpass1 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
542 %endif
543 %if %{with gtk}
544 install contrib/gnome-ssh-askpass2 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
545 %endif
546 %if %{with gnome} || %{with gtk}
547 cat << EOF >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_SERVER
548 #GNOME_SSH_ASKPASS_GRAB_SERVER="true"
549 EOF
550 cat << EOF >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_POINTER
551 #GNOME_SSH_ASKPASS_GRAB_POINTER="true"
552 EOF
553 ln -s %{_libexecdir}/ssh/ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/ssh-askpass
554 %endif
555
556 rm -f   $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
557 echo ".so ssh.1" > $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
558
559 touch $RPM_BUILD_ROOT/etc/security/blacklist.sshd
560
561 %if "%{_lib}" != "lib"
562 find $RPM_BUILD_ROOT%{_sysconfdir} -type f -print0 | xargs -0 perl -pi -e "s#/usr/lib#/usr/%{_lib}#"
563 %endif
564
565 cat << EOF >$RPM_BUILD_ROOT/etc/env.d/SSH_ASKPASS
566 #SSH_ASKPASS="%{_libexecdir}/ssh-askpass"
567 EOF
568
569 %clean
570 rm -rf $RPM_BUILD_ROOT
571
572 %post clients
573 %env_update
574
575 %postun clients
576 %env_update
577
578 %post gnome-askpass
579 %env_update
580
581 %postun gnome-askpass
582 %env_update
583
584 %pre server
585 %useradd -P %{name}-server -u 40 -d %{_privsepdir} -s /bin/false -c "OpenSSH PrivSep User" -g nobody sshd
586
587 %post server
588 /sbin/chkconfig --add sshd
589 %service sshd reload "openssh daemon"
590 if ! grep -qs ssh /etc/security/passwd.conf ; then
591         umask 022
592         echo "ssh" >> /etc/security/passwd.conf
593 fi
594
595 %preun server
596 if [ "$1" = "0" ]; then
597         %service sshd stop
598         /sbin/chkconfig --del sshd
599 fi
600
601 %postun server
602 if [ "$1" = "0" ]; then
603         %userremove sshd
604 fi
605
606 %files
607 %defattr(644,root,root,755)
608 %doc *.RNG TODO README OVERVIEW CREDITS Change*
609 %attr(755,root,root) %{_bindir}/ssh-key*
610 %{_mandir}/man1/ssh-key*.1*
611 %dir %{_sysconfdir}
612 %dir %{_libexecdir}
613
614 %files clients
615 %defattr(644,root,root,755)
616 %doc connect.html
617 %attr(755,root,root) %{_bindir}/connect
618 %attr(755,root,root) %{_bindir}/ssh
619 %attr(755,root,root) %{_bindir}/slogin
620 %attr(755,root,root) %{_bindir}/sftp
621 %attr(755,root,root) %{_bindir}/ssh-agent
622 %attr(755,root,root) %{_bindir}/ssh-add
623 %attr(755,root,root) %{_bindir}/scp
624 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh_config
625 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/SSH_ASKPASS
626 %if %{with sshagentsh}
627 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh-agent.conf
628 %attr(755,root,root) /etc/profile.d/ssh-agent.sh
629 %attr(755,root,root) /etc/X11/xinit/xinitrc.d/ssh-agent.sh
630 %endif
631 %{_mandir}/man1/scp.1*
632 %{_mandir}/man1/ssh.1*
633 %{_mandir}/man1/slogin.1*
634 %{_mandir}/man1/sftp.1*
635 %{_mandir}/man1/ssh-agent.1*
636 %{_mandir}/man1/ssh-add.1*
637 %{_mandir}/man5/ssh_config.5*
638 %lang(it) %{_mandir}/it/man1/ssh.1*
639 %lang(it) %{_mandir}/it/man5/ssh_config.5*
640 %lang(pl) %{_mandir}/pl/man1/scp.1*
641 %lang(zh_CN) %{_mandir}/zh_CN/man1/scp.1*
642
643 # for host-based auth (suid required for accessing private host key)
644 #%attr(4755,root,root) %{_libexecdir}/ssh-keysign
645 #%{_mandir}/man8/ssh-keysign.8*
646
647 %files server
648 %defattr(644,root,root,755)
649 %attr(755,root,root) %{_sbindir}/sshd
650 %attr(755,root,root) %{_libexecdir}/sftp-server
651 %attr(755,root,root) %{_libexecdir}/ssh-keysign
652 %{_mandir}/man8/sshd.8*
653 %{_mandir}/man8/sftp-server.8*
654 %{_mandir}/man8/ssh-keysign.8*
655 %{_mandir}/man5/sshd_config.5*
656 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sshd_config
657 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/sshd
658 %attr(640,root,root) %{_sysconfdir}/moduli
659 %attr(754,root,root) /etc/rc.d/init.d/sshd
660 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/sshd
661 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.sshd
662
663 %if %{with gnome} || %{with gtk}
664 %files gnome-askpass
665 %defattr(644,root,root,755)
666 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/GNOME_SSH_ASKPASS*
667 %dir %{_libexecdir}/ssh
668 %attr(755,root,root) %{_libexecdir}/ssh/ssh-askpass
669 %attr(755,root,root) %{_libexecdir}/ssh-askpass
670 %endif
This page took 0.070056 seconds and 3 git commands to generate.