]> git.pld-linux.org Git - packages/openssh.git/blob - openssh.spec
- use %service, rel 3
[packages/openssh.git] / openssh.spec
1 #
2 # Conditional build:
3 %bcond_without  chroot          # without chrooted user environment support
4 %bcond_with     gnome           # with gnome-askpass (GNOME 1.x) utility
5 %bcond_without  gtk             # without GTK+ (2.x)
6 %bcond_with     ldap            # with ldap support
7 %bcond_without  libedit         # without libedit (editline/history support in sftp client)
8 %bcond_without  kerberos5       # without kerberos5 support
9 %bcond_without  selinux         # build without SELinux support
10 %bcond_with     sshagentsh      # with system-wide script for starting ssh-agent
11 %bcond_with     hpn             # with High Performance SSH/SCP - HPN-SSH (see patch comment)
12 %bcond_with     hpn_none        # with hpn (above) and '-z' none cipher option
13 #
14 %if %{with hpn_none}
15 %undefine       with_hpn
16 %endif
17 # gtk2-based gnome-askpass means no gnome1-based
18 %{?with_gtk:%undefine with_gnome}
19 %define         _rel 3
20 Summary:        OpenSSH free Secure Shell (SSH) implementation
21 Summary(de):    OpenSSH - freie Implementation der Secure Shell (SSH)
22 Summary(es):    Implementación libre de SSH
23 Summary(fr):    Implémentation libre du shell sécurisé OpenSSH (SSH)
24 Summary(it):    Implementazione gratuita OpenSSH della Secure Shell
25 Summary(pl):    Publicznie dostêpna implementacja bezpiecznego shella (SSH)
26 Summary(pt):    Implementação livre OpenSSH do protocolo 'Secure Shell' (SSH)
27 Summary(pt_BR): Implementação livre do SSH
28 Summary(ru):    OpenSSH - Ó×ÏÂÏÄÎÁÑ ÒÅÁÌÉÚÁÃÉÑ ÐÒÏÔÏËÏÌÁ Secure Shell (SSH)
29 Summary(uk):    OpenSSH - ×¦ÌØÎÁ ÒÅÁ̦ÚÁæѠÐÒÏÔÏËÏÌÕ Secure Shell (SSH)
30 Name:           openssh
31 Version:        4.3p2
32 Release:        %{_rel}%{?with_hpn:hpn}%{?with_hpn_none:hpn_none}
33 Epoch:          2
34 License:        BSD
35 Group:          Applications/Networking
36 Source0:        ftp://ftp.ca.openbsd.org/pub/OpenBSD/OpenSSH/portable/%{name}-%{version}.tar.gz
37 # Source0-md5:  7e9880ac20a9b9db0d3fea30a9ff3d46
38 Source1:        %{name}d.conf
39 Source2:        %{name}.conf
40 Source3:        %{name}d.init
41 Source4:        %{name}d.pamd
42 Source5:        %{name}.sysconfig
43 Source6:        passwd.pamd
44 Source7:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
45 # Source7-md5:  66943d481cc422512b537bcc2c7400d1
46 Source9:        http://www.taiyo.co.jp/~gotoh/ssh/connect.c
47 # NoSource9-md5:        e1c3cbed88f08ea778d90813d48cd428
48 Source10:       http://www.taiyo.co.jp/~gotoh/ssh/connect.html
49 # NoSource10-md5:       ec74f3e3b2ea3a7dc84c7988235b6fcf
50 Source11:       ssh-agent.sh
51 Source12:       ssh-agent.conf
52 Patch0:         %{name}-no_libnsl.patch
53 Patch2:         %{name}-linux-ipv6.patch
54 Patch3:         %{name}-pam_misc.patch
55 Patch4:         %{name}-sigpipe.patch
56 # http://www.opendarwin.org/projects/openssh-lpk/
57 Patch5:         %{name}-lpk-4.1p1-0.3.6.patch
58 Patch6:         %{name}-heimdal.patch
59 Patch7:         %{name}-pam-conv.patch
60 # http://chrootssh.sourceforge.net/download/osshChroot-3.7.1p2.diff
61 Patch8:         %{name}-chroot.patch
62 Patch9:         %{name}-selinux.patch
63 Patch10:        %{name}-selinux-pld.patch
64 # HPN patches rediffed due sigpipe patch.
65 # High Performance SSH/SCP - HPN-SSH - http://www.psc.edu/networking/projects/hpn-ssh/
66 # http://www.psc.edu/networking/projects/hpn-ssh/openssh-4.2p1-hpn11.diff
67 Patch11:        %{name}-4.3p1-hpn11.patch
68 # Adds HPN (see p11) and an undocumented -z none cipher flag
69 # http://www.psc.edu/networking/projects/hpn-ssh/openssh-4.2p1-hpn11-none.diff
70 Patch12:        %{name}-4.3p1-hpn11-none.patch
71 Patch13:        %{name}-include.patch
72 URL:            http://www.openssh.com/
73 BuildRequires:  %{__perl}
74 BuildRequires:  autoconf
75 BuildRequires:  automake
76 %{?with_gnome:BuildRequires:    gnome-libs-devel}
77 %{?with_gtk:BuildRequires:      gtk+2-devel}
78 %{?with_kerberos5:BuildRequires:        heimdal-devel >= 0.7}
79 %{?with_libedit:BuildRequires:  libedit-devel}
80 %{?with_selinux:BuildRequires:  libselinux-devel}
81 BuildRequires:  libwrap-devel
82 %{?with_ldap:BuildRequires:     openldap-devel}
83 BuildRequires:  openssl-devel >= 0.9.7d
84 BuildRequires:  pam-devel
85 %{?with_gtk:BuildRequires:      pkgconfig}
86 BuildRequires:  rpmbuild(macros) >= 1.268
87 BuildRequires:  zlib-devel
88 Requires:       FHS >= 2.1-24
89 Requires:       pam >= 0.79.0
90 Obsoletes:      ssh
91 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
92
93 %define         _sysconfdir     /etc/ssh
94 %define         _libexecdir     %{_libdir}/%{name}
95 %define         _privsepdir     /usr/share/empty
96
97 %description
98 Ssh (Secure Shell) a program for logging into a remote machine and for
99 executing commands in a remote machine. It is intended to replace
100 rlogin and rsh, and provide secure encrypted communications between
101 two untrusted hosts over an insecure network. X11 connections and
102 arbitrary TCP/IP ports can also be forwarded over the secure channel.
103
104 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
105 it up to date in terms of security and features, as well as removing
106 all patented algorithms to seperate libraries (OpenSSL).
107
108 This package includes the core files necessary for both the OpenSSH
109 client and server. To make this package useful, you should also
110 install openssh-clients, openssh-server, or both.
111 %if %{with hpn} || %{with hpn_none}
112 This release includes High Performance SSH/SCP patches from
113 http://www.psc.edu/networking/projects/hpn-ssh/ which are supposed
114 to increase throughput on fast connections with high RTT (20-150 msec).
115 See the website for '-w' values for your connection and /proc/sys TCP
116 values. BTW. in a LAN you have got generally RTT < 1 msec.
117 %endif
118 %if %{with hpn_none}
119 It also includes an undocumented '-z' option which switches
120 the cipher to none after authentication is completed. Data is
121 still secured from tampering and corruption in transit through
122 the use of the Message Authentication Code (MAC).
123 This option will significantly reduce the number of cpu cycles used
124 by the SSH/SCP process. This may allow some users to see significant
125 improvement in (sniffable) data tranfer rates.
126 %endif
127
128 %description -l de
129 OpenSSH (Secure Shell) stellt den Zugang zu anderen Rechnern her. Es
130 ersetzt telnet, rlogin, rexec und rsh und stellt eine sichere,
131 verschlüsselte Verbindung zwischen zwei nicht vertrauenswürdigen Hosts
132 über eine unsicheres Netzwerk her. X11 Verbindungen und beliebige
133 andere TCP/IP Ports können ebenso über den sicheren Channel
134 weitergeleitet werden.
135
136 %description -l es
137 SSH es un programa para accesar y ejecutar órdenes en computadores
138 remotos. Sustituye rlogin y rsh, y suministra un canal de comunicación
139 seguro entre dos servidores en una red insegura. Conexiones X11 y
140 puertas TCP/IP arbitrárias también pueden ser usadas por el canal
141 seguro.
142
143 OpenSSH es el resultado del trabajo del equipo de OpenBSD para
144 continuar la última versión gratuita de SSH, actualizándolo en
145 términos de seguridad y recursos,así también eliminando todos los
146 algoritmos patentados y colocándolos en bibliotecas separadas
147 (OpenSSL).
148
149 Este paquete contiene "port" para Linux de OpenSSH. Se debe instalar
150 también el paquete openssh-clients u openssh-server o ambos.
151
152 %description -l fr
153 OpenSSH (Secure Shell) fournit un accès à un système distant. Il
154 remplace telnet, rlogin, rexec et rsh, tout en assurant des
155 communications cryptées securisées entre deux hôtes non fiabilisés sur
156 un réseau non sécurisé. Des connexions X11 et des ports TCP/IP
157 arbitraires peuvent également être transmis sur le canal sécurisé.
158
159 %description -l it
160 OpenSSH (Secure Shell) fornisce l'accesso ad un sistema remoto.
161 Sostituisce telnet, rlogin, rexec, e rsh, e fornisce comunicazioni
162 sicure e crittate tra due host non fidati su una rete non sicura. Le
163 connessioni X11 ad una porta TCP/IP arbitraria possono essere
164 inoltrate attraverso un canale sicuro.
165
166 %description -l pl
167 Ssh (Secure Shell) to program s³u¿±cy do logowania siê na zdaln±
168 maszynê i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
169 zast±piæ rlogin, rsh i dostarczyæ bezpieczne, szyfrowane po³±czenie
170 pomiêdzy dwoma hostami.
171
172 Ten pakiet zawiera podstawowe pliki potrzebne zarówno po stronie
173 klienta jak i serwera OpenSSH. Aby by³ u¿yteczny, trzeba zainstalowaæ
174 co najmniej jeden z pakietów: openssh-clients lub openssh-server.
175 %if %{with hpn} || %{with hpn_none}
176 Ta wersja zawiera ³aty z projektu High Performance SSH/SCP
177 http://www.psc.edu/networking/projects/hpn-ssh/, które maj± na celu
178 zwiêkszenie przepustowo¶ci transmisji dla szybkich po³±czeñ
179 z du¿ym RTT (20-150 msec). Na stronie projektu znale¼æ mo¿na
180 odpowednie dla danego po³±czenia warto¶ci parametru '-w' oraz
181 opcje /proc/sys dla TCP. Nawiasem mówi±c w sieciach LAN RTT < 1 msec.
182 %endif
183 %if %{with hpn_none}
184 Obs³ugiwana jest równie¿ nieudokumentowana opcja '-z' odpowiedzialna
185 za wy³±czenie szyfrowania danych po zakoñczeniu procesu uwierzytelniania.
186 Dane s± zabezpieczone przed modyfikacj± lub uszkodzeniem przez
187 stosowanie Message Authentication Code (MAC).
188 Opcja ta znacznie redukuje liczbê cykli procesora zu¿ywanych przez
189 procesy SSH/SCP. W wybranych zastosowaniach mo¿e ona wp³yn±æ
190 na wyra¼ne przyspieszenie (pods³uchiwalnej) transmisji danych.
191 %endif
192
193 %description -l pt
194 OpenSSH (Secure Shell) fornece acesso a um sistema remoto. Substitui o
195 telnet, rlogin, rexec, e o rsh e fornece comunicações seguras e
196 cifradas entre duas máquinas sem confiança mútua sobre uma rede
197 insegura. Ligações X11 e portos TCP/IP arbitrários também poder ser
198 reenviados pelo canal seguro.
199
200 %description -l pt_BR
201 SSH é um programa para acessar e executar comandos em máquinas
202 remotas. Ele substitui rlogin e rsh, e provem um canal de comunicação
203 seguro entre dois hosts em uma rede insegura. Conexões X11 e portas
204 TCP/IP arbitrárias também podem ser usadas pelo canal seguro.
205
206 OpenSSH é o resultado do trabalho da equipe do OpenBSD em continuar a
207 última versão gratuita do SSH, atualizando-o em termos de segurança e
208 recursos, assim como removendo todos os algoritmos patenteados e
209 colocando-os em bibliotecas separadas (OpenSSL).
210
211 Esse pacote contém o "port" pra Linux do OpenSSH. Você deve instalar
212 também ou o pacote openssh-clients, ou o openssh-server, ou ambos.
213
214 %description -l ru
215 Ssh (Secure Shell) - ÜÔÏ ÐÒÏÇÒÁÍÍÁ ÄÌÑ "ÚÁÈÏÄÁ" (login) ÎÁ ÕÄÁÌÅÎÎÕÀ
216 ÍÁÛÉÎÕ É ÄÌÑ ×ÙÐÏÌÎÅÎÉÑ ËÏÍÁÎÄ ÎÁ ÕÄÁÌÅÎÎÏÊ ÍÁÛÉÎÅ. ïÎÁ ÐÒÅÄÎÁÚÎÁÞÅÎÁ
217 ÄÌÑ ÚÁÍÅÎÙ rlogin É rsh É ÏÂÅÓÐÅÞÉ×ÁÅÔ ÂÅÚÏÐÁÓÎÕÀ ÛÉÆÒÏ×ÁÎÎÕÀ
218 ËÏÍÍÕÎÉËÁÃÉÀ ÍÅÖÄÕ Ä×ÕÍÑ ÈÏÓÔÁÍÉ × ÓÅÔÉ, Ñ×ÌÑÀÝÅÊÓÑ ÎÅÂÅÚÏÐÁÓÎÏÊ.
219 óÏÅÄÉÎÅÎÉÑ X11 É ÌÀÂÙÅ ÐÏÒÔÙ TCP/IP ÍÏÇÕÔ ÔÁËÖÅ ÂÙÔØ ÐÒÏ×ÅÄÅÎÙ ÞÅÒÅÚ
220 ÂÅÚÏÐÁÓÎÙÊ ËÁÎÁÌ.
221
222 OpenSSH - ÜÔÏ ÐÅÒÅÄÅÌËÁ ËÏÍÁÎÄÏÊ ÒÁÚÒÁÂÏÔÞÉËÏ× OpenBSD ÐÏÓÌÅÄÎÅÊ
223 Ó×ÏÂÏÄÎÏÊ ×ÅÒÓÉÉ SSH, ÄÏ×ÅÄÅÎÎÁÑ ÄÏ ÓÏ×ÒÅÍÅÎÎÏÇÏ ÓÏÓÔÏÑÎÉÑ × ÔÅÒÍÉÎÁÈ
224 ÕÒÏ×ÎÑ ÂÅÚÏÐÁÓÎÏÓÔÉ É ÐÏÄÄÅÒÖÉ×ÁÅÍÙÈ ×ÏÚÍÏÖÎÏÓÔÅÊ. ÷ÓÅ ÐÁÔÅÎÔÏ×ÁÎÎÙÅ
225 ÁÌÇÏÒÉÔÍÙ ×ÙÎÅÓÅÎÙ × ÏÔÄÅÌØÎÙÅ ÂÉÂÌÉÏÔÅËÉ (OpenSSL).
226
227 üÔÏÔ ÐÁËÅÔ ÓÏÄÅÒÖÉÔ ÆÁÊÌÙ, ÎÅÏÂÈÏÄÉÍÙÅ ËÁË ÄÌÑ ËÌÉÅÎÔÁ, ÔÁË É ÄÌÑ
228 ÓÅÒ×ÅÒÁ OpenSSH. ÷ÁÍ ÎÕÖÎÏ ÂÕÄÅÔ ÕÓÔÁÎÏ×ÉÔØ ÅÝÅ openssh-clients,
229 openssh-server, ÉÌÉ ÏÂÁ ÐÁËÅÔÁ.
230
231 %description -l uk
232 Ssh (Secure Shell) - ÃÅ ÐÒÏÇÒÁÍÁ ÄÌÑ "ÚÁÈÏÄÕ" (login) ÄϠצÄÄÁÌÅÎϧ
233 ÍÁÛÉÎÉ ÔÁ ÄÌÑ ×ÉËÏÎÁÎÎÑ ËÏÍÁÎÄ ÎÁ ×¦ÄÄÁÌÅΦʠÍÁÛÉΦ. ÷ÏÎÁ ÐÒÉÚÎÁÞÅÎÁ
234 ÄÌÑ ÚÁͦÎÉ rlogin ÔÁ rsh ¦ ÚÁÂÅÚÐÅÞÕ¤ ÂÅÚÐÅÞÎÕ ÛÉÆÒÏ×ÁÎÕ ËÏÍÕΦËÁæÀ
235 ͦ֠Ä×ÏÍÁ ÈÏÓÔÁÍÉ × ÍÅÒÅÖ¦, ÑËÁ ÎÅ ¤ ÂÅÚÐÅÞÎÏÀ. ú'¤ÄÎÁÎÎÑ X11 ÔÁ
236 ÄÏצÌØΦ ÐÏÒÔÉ TCP/IP ÍÏÖÕÔØ ÔÁËÏÖ ÂÕÔÉ ÐÒÏ×ÅÄÅΦ ÞÅÒÅÚ ÂÅÚÐÅÞÎÉÊ
237 ËÁÎÁÌ.
238
239 OpenSSH - ÃÅ ÐÅÒÅÒÏÂËÁ ËÏÍÁÎÄÏÀ ÒÏÚÒÏÂÎÉ˦נOpenBSD ÏÓÔÁÎÎØϧ ×¦ÌØÎϧ
240 ×ÅÒÓ¦§ SSH, ÄÏ×ÅÄÅÎÁ ÄÏ ÓÕÞÁÓÎÏÇÏ ÓÔÁÎÕ × ÔÅÒͦÎÁÈ Ò¦×ÎÑ ÂÅÚÐÅËÉ ÔÁ
241 ЦÄÔÒÉÍÕ×ÁÎÉÈ ÍÏÖÌÉ×ÏÓÔÅÊ. ÷Ó¦ ÐÁÔÅÎÔÏ×ÁΦ ÁÌÇÏÒÉÔÍÉ ×ÉÎÅÓÅΦ ÄÏ
242 ÏËÒÅÍÉȠ¦Â̦ÏÔÅË (OpenSSL).
243
244 ãÅÊ ÐÁËÅԠͦÓÔÉÔØ ÆÁÊÌÉ, ÎÅÏÂȦÄΦ ÑË ÄÌÑ Ë̦¤ÎÔÁ, ÔÁË ¦ ÄÌÑ ÓÅÒ×ÅÒÁ
245 OpenSSH. ÷ÁÍ ÐÏÔÒ¦ÂÎÏ ÂÕÄÅ ÝÅ ×ÓÔÁÎÏ×ÉÔÉ openssh-clients,
246 openssh-server, ÞÉ ÏÂÉÄ×Á ÐÁËÅÔÉ.
247
248 %package clients
249 Summary:        OpenSSH Secure Shell protocol clients
250 Summary(es):    Clientes de OpenSSH
251 Summary(pl):    Klienci protoko³u Secure Shell
252 Summary(pt_BR): Clientes do OpenSSH
253 Summary(ru):    OpenSSH - ËÌÉÅÎÔÙ ÐÒÏÔÏËÏÌÁ Secure Shell
254 Summary(uk):    OpenSSH - Ë̦¤ÎÔÉ ÐÒÏÔÏËÏÌÕ Secure Shell
255 Group:          Applications/Networking
256 Requires:       %{name} = %{epoch}:%{version}-%{release}
257 %{?with_sshagentsh:Requires:    xinitrc}
258 Provides:       ssh-clients
259 Obsoletes:      ssh-clients
260
261 %description clients
262 Ssh (Secure Shell) a program for logging into a remote machine and for
263 executing commands in a remote machine. It is intended to replace
264 rlogin and rsh, and provide secure encrypted communications between
265 two untrusted hosts over an insecure network. X11 connections and
266 arbitrary TCP/IP ports can also be forwarded over the secure channel.
267
268 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
269 it up to date in terms of security and features, as well as removing
270 all patented algorithms to seperate libraries (OpenSSL).
271
272 This package includes the clients necessary to make encrypted
273 connections to SSH servers.
274
275 %description clients -l es
276 Este paquete incluye los clientes que se necesitan para hacer
277 conexiones codificadas con servidores SSH.
278
279 %description clients -l pl
280 Ssh (Secure Shell) to program s³u¿±cy do logowania siê na zdaln±
281 maszynê i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
282 zast±piæ rlogin, rsh i dostarczyæ bezpieczne, szyfrowane po³±czenie
283 pomiêdzy dwoma hostami.
284
285 Ten pakiet zawiera klientów s³u¿±cych do ³±czenia siê z serwerami SSH.
286
287 %description clients -l pt_BR
288 Esse pacote inclui os clientes necessários para fazer conexões
289 encriptadas com servidores SSH.
290
291 %description clients -l ru
292 Ssh (Secure Shell) - ÜÔÏ ÐÒÏÇÒÁÍÍÁ ÄÌÑ "ÚÁÈÏÄÁ" (login) ÎÁ ÕÄÁÌÅÎÎÕÀ
293 ÍÁÛÉÎÕ É ÄÌÑ ×ÙÐÏÌÎÅÎÉÑ ËÏÍÁÎÄ ÎÁ ÕÄÁÌÅÎÎÏÊ ÍÁÛÉÎÅ.
294
295 üÔÏÔ ÐÁËÅÔ ÓÏÄÅÒÖÉÔ ÐÒÏÇÒÁÍÍÙ-ËÌÉÅÎÔÙ, ÎÅÏÂÈÏÄÉÍÙÅ ÄÌÑ ÕÓÔÁÎÏ×ÌÅÎÉÑ
296 ÚÁÛÉÆÒÏ×ÁÎÎÙÈ ÓÏÅÄÉÎÅÎÉÊ Ó ÓÅÒ×ÅÒÁÍÉ SSH.
297
298 %description clients -l uk
299 Ssh (Secure Shell) - ÃÅ ÐÒÏÇÒÁÍÁ ÄÌÑ "ÚÁÈÏÄÕ" (login) ÄϠצÄÄÁÌÅÎϧ
300 ÍÁÛÉÎÉ ÔÁ ÄÌÑ ×ÉËÏÎÁÎÎÑ ËÏÍÁÎÄ ÎÁ ×¦ÄÄÁÌÅΦʠÍÁÛÉΦ.
301
302 ãÅÊ ÐÁËÅԠͦÓÔÉÔØ ÐÒÏÇÒÁÍÉ-Ë̦¤ÎÔÉ, ÎÅÏÂȦÄΦ ÄÌÑ ×ÓÔÁÎÏ×ÌÅÎÎÑ
303 ÚÁÛÉÆÒÏ×ÁÎÉÈ Ú'¤ÄÎÁÎØ Ú ÓÅÒ×ÅÒÁÍÉ SSH.
304
305 %package server
306 Summary:        OpenSSH Secure Shell protocol server (sshd)
307 Summary(de):    OpenSSH Secure Shell Protocol-Server (sshd)
308 Summary(es):    Servidor OpenSSH para comunicaciones codificadas
309 Summary(fr):    Serveur de protocole du shell sécurisé OpenSSH (sshd)
310 Summary(it):    Server OpenSSH per il protocollo Secure Shell (sshd)
311 Summary(pl):    Serwer protoko³u Secure Shell (sshd)
312 Summary(pt):    Servidor do protocolo 'Secure Shell' OpenSSH (sshd)
313 Summary(pt_BR): Servidor OpenSSH para comunicações encriptadas
314 Summary(ru):    OpenSSH - ÓÅÒ×ÅÒ ÐÒÏÔÏËÏÌÁ Secure Shell (sshd)
315 Summary(uk):    OpenSSH - ÓÅÒ×ÅÒ ÐÒÏÔÏËÏÌÕ Secure Shell (sshd)
316 Group:          Networking/Daemons
317 Requires(post): chkconfig >= 0.9
318 Requires(post): grep
319 Requires(post,preun):   /sbin/chkconfig
320 Requires(postun):       /usr/sbin/userdel
321 Requires(pre):  /bin/id
322 Requires(pre):  /usr/sbin/useradd
323 Requires:       %{name} = %{epoch}:%{version}-%{release}
324 Requires:       /bin/login
325 Requires:       pam >= 0.77.3
326 Requires:       rc-scripts >= 0.4.0.18
327 Requires:       util-linux
328 Provides:       ssh-server
329 Provides:       user(sshd)
330
331 %description server
332 Ssh (Secure Shell) a program for logging into a remote machine and for
333 executing commands in a remote machine. It is intended to replace
334 rlogin and rsh, and provide secure encrypted communications between
335 two untrusted hosts over an insecure network. X11 connections and
336 arbitrary TCP/IP ports can also be forwarded over the secure channel.
337
338 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
339 it up to date in terms of security and features, as well as removing
340 all patented algorithms to seperate libraries (OpenSSL).
341
342 This package contains the secure shell daemon. The sshd is the server
343 part of the secure shell protocol and allows ssh clients to connect to
344 your host.
345
346 %description server -l de
347 Dieses Paket installiert den sshd, den Server-Teil der OpenSSH.
348
349 %description server -l es
350 Este paquete contiene el servidor SSH. sshd es la parte servidor del
351 protocolo secure shell y permite que clientes ssh se conecten a su
352 servidor.
353
354 %description server -l fr
355 Ce paquetage installe le 'sshd', partie serveur de OpenSSH.
356
357 %description server -l it
358 Questo pacchetto installa sshd, il server di OpenSSH.
359
360 %description server -l pl
361 Ssh (Secure Shell) to program s³u¿±cy do logowania siê na zdaln±
362 maszynê i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
363 zast±piæ rlogin, rsh i dostarczyæ bezpieczne, szyfrowane po³±czenie
364 pomiêdzy dwoma hostami.
365
366 Ten pakiet zawiera serwer sshd (do którego mog± ³±czyæ siê klienci
367 ssh).
368
369 %description server -l pt
370 Este pacote intala o sshd, o servidor do OpenSSH.
371
372 %description server -l pt_BR
373 Esse pacote contém o servidor SSH. O sshd é a parte servidor do
374 protocolo secure shell e permite que clientes ssh se conectem ao seu
375 host.
376
377 %description server -l ru
378 Ssh (Secure Shell) - ÜÔÏ ÐÒÏÇÒÁÍÍÁ ÄÌÑ "ÚÁÈÏÄÁ" (login) ÎÁ ÕÄÁÌÅÎÎÕÀ
379 ÍÁÛÉÎÕ É ÄÌÑ ×ÙÐÏÌÎÅÎÉÑ ËÏÍÁÎÄ ÎÁ ÕÄÁÌÅÎÎÏÊ ÍÁÛÉÎÅ.
380
381 üÔÏÔ ÐÁËÅÔ ÓÏÄÅÒÖÉÔ sshd - "ÄÅÍÏÎ" Secure Shell. sshd - ÜÔÏ ÓÅÒ×ÅÒÎÁÑ
382 ÞÁÓÔØ ÐÒÏÔÏËÏÌÁ Secure Shell, ÐÏÚ×ÏÌÑÀÝÁÑ ËÌÉÅÎÔÁÍ ssh ÓÏÅÄÉÎÑÔØÓÑ Ó
383 ×ÁÛÉÍ ÈÏÓÔÏÍ.
384
385 %description server -l uk
386 Ssh (Secure Shell) - ÃÅ ÐÒÏÇÒÁÍÁ ÄÌÑ "ÚÁÈÏÄÕ" (login) ÄϠצÄÄÁÌÅÎϧ
387 ÍÁÛÉÎÉ ÔÁ ÄÌÑ ×ÉËÏÎÁÎÎÑ ËÏÍÁÎÄ ÎÁ ×¦ÄÄÁÌÅΦʠÍÁÛÉΦ.
388
389 ãÅÊ ÐÁËÅԠͦÓÔÉÔØ sshd - "ÄÅÍÏÎ" Secure Shell. sshd - ÃÅ ÓÅÒ×ÅÒÎÁ
390 ÞÁÓÔÉÎÁ ÐÒÏÔÏËÏÌÕ Secure Shell, ÑËÁ ÄÏÚ×ÏÌѤ Ë̦¤ÎÔÁÍ ssh Ú×'ÑÚÕ×ÁÔÉÓØ
391 Ú ×ÁÛÉÍ ÈÏÓÔÏÍ.
392
393 %package gnome-askpass
394 Summary:        OpenSSH GNOME passphrase dialog
395 Summary(de):    OpenSSH GNOME Passwort-Dialog
396 Summary(es):    Diálogo para introducción de passphrase para GNOME
397 Summary(fr):    Dialogue pass-phrase GNOME d'OpenSSH
398 Summary(it):    Finestra di dialogo GNOME per la frase segreta di OpenSSH
399 Summary(pl):    Odpytywacz has³a OpenSSH dla GNOME
400 Summary(pt):    Diálogo de pedido de senha para GNOME do OpenSSH
401 Summary(pt_BR): Diálogo para entrada de passphrase para GNOME
402 Summary(ru):    OpenSSH - ÄÉÁÌÏÇ ××ÏÄÁ ËÌÀÞÅ×ÏÊ ÆÒÁÚÙ (passphrase) ÄÌÑ GNOME
403 Summary(uk):    OpenSSH - Ä¦ÁÌÏÇ ××ÏÄÕ ËÌÀÞÏ×ϧ ÆÒÁÚÉ (passphrase) ÄÌÑ GNOME
404 Group:          Applications/Networking
405 Requires:       %{name} = %{epoch}:%{version}-%{release}
406 Obsoletes:      openssh-askpass
407 Obsoletes:      ssh-askpass
408 Obsoletes:      ssh-extras
409
410 %description gnome-askpass
411 Ssh (Secure Shell) a program for logging into a remote machine and for
412 executing commands in a remote machine. It is intended to replace
413 rlogin and rsh, and provide secure encrypted communications between
414 two untrusted hosts over an insecure network. X11 connections and
415 arbitrary TCP/IP ports can also be forwarded over the secure channel.
416
417 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
418 it up to date in terms of security and features, as well as removing
419 all patented algorithms to seperate libraries (OpenSSL).
420
421 This package contains the GNOME passphrase dialog.
422
423 %description gnome-askpass -l es
424 Este paquete contiene un programa que abre una caja de diálogo para
425 entrada de passphrase en GNOME.
426
427 %description gnome-askpass -l pl
428 Ssh (Secure Shell) to program s³u¿±cy do logowania siê na zdaln±
429 maszynê i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
430 zast±piæ rlogin, rsh i dostarczyæ bezpieczne, szyfrowane po³±czenie
431 pomiêdzy dwoma hostami.
432
433 Ten pakiet zawiera ,,odpytywacz has³a'' dla GNOME.
434
435 %description gnome-askpass -l pt_BR
436 Esse pacote contém um programa que abre uma caixa de diálogo para
437 entrada de passphrase no GNOME.
438
439 %description gnome-askpass -l ru
440 Ssh (Secure Shell) - ÜÔÏ ÐÒÏÇÒÁÍÍÁ ÄÌÑ "ÚÁÈÏÄÁ" (login) ÎÁ ÕÄÁÌÅÎÎÕÀ
441 ÍÁÛÉÎÕ É ÄÌÑ ×ÙÐÏÌÎÅÎÉÑ ËÏÍÁÎÄ ÎÁ ÕÄÁÌÅÎÎÏÊ ÍÁÛÉÎÅ.
442
443 üÔÏÔ ÐÁËÅÔ ÓÏÄÅÒÖÉÔ ÄÉÁÌÏÇ ××ÏÄÁ ËÌÀÞÅ×ÏÊ ÆÒÁÚÙ ÄÌÑ ÉÓÐÏÌØÚÏ×ÁÎÉÑ ÐÏÄ
444 GNOME.
445
446 %description gnome-askpass -l uk
447 Ssh (Secure Shell) - ÃÅ ÐÒÏÇÒÁÍÁ ÄÌÑ "ÚÁÈÏÄÕ" (login) ÄϠצÄÄÁÌÅÎϧ
448 ÍÁÛÉÎÉ ÔÁ ÄÌÑ ×ÉËÏÎÁÎÎÑ ËÏÍÁÎÄ ÎÁ ×¦ÄÄÁÌÅΦʠÍÁÛÉΦ.
449
450 ãÅÊ ÐÁËÅԠͦÓÔÉÔؠĦÁÌÏÇ ××ÏÄÕ ËÌÀÞÏ×ϧ ÆÒÁÚÉ ÄÌÑ ×ÉËÏÒÉÓÔÁÎÎѠЦÄ
451 GNOME.
452
453 %prep
454 %setup -q
455 %patch0 -p1
456 %patch2 -p1
457 %patch3 -p1
458 %patch4 -p1
459 %{?with_ldap:%patch5 -p1}
460 %{?with_kerberos5:%patch6 -p1}
461 #%patch7 -p1
462 %patch8 -p1
463 %{?with_selinux:%patch9 -p1}
464 %{?with_selinux:%patch10 -p1}
465 %{?with_hpn:%patch11 -p1}
466 %{?with_hpn_none:%patch12 -p1}
467 %patch13 -p1
468
469 %build
470 cp %{_datadir}/automake/config.sub .
471 %{__aclocal}
472 %{__autoconf}
473 %{?with_chroot:CPPFLAGS="-DCHROOT"}
474 %configure \
475         PERL=%{__perl} \
476         --with-dns \
477         --with-pam \
478         --with-mantype=man \
479         --with-md5-passwords \
480         --with-ipaddr-display \
481         %{?with_libedit:--with-libedit} \
482         --with-4in6 \
483         --disable-suid-ssh \
484         --with-tcp-wrappers \
485         %{?with_ldap:--with-libs="-lldap -llber"} \
486         %{?with_ldap:--with-cppflags="-DWITH_LDAP_PUBKEY"} \
487         %{?with_kerberos5:--with-kerberos5} \
488         --with-privsep-path=%{_privsepdir} \
489         --with-pid-dir=%{_localstatedir}/run \
490         --with-xauth=/usr/X11R6/bin/xauth \
491         --enable-utmpx \
492         --enable-wtmpx
493
494 echo '#define LOGIN_PROGRAM           "/bin/login"' >>config.h
495
496 %{__make}
497
498 cp -f %{SOURCE9} .
499 cp -f %{SOURCE10} .
500 %{__cc} %{rpmcflags} %{rpmldflags} connect.c -o connect
501
502 cd contrib
503 %if %{with gnome}
504 %{__make} gnome-ssh-askpass1 \
505         CC="%{__cc} %{rpmldflags} %{rpmcflags}"
506 %endif
507 %if %{with gtk}
508 %{__make} gnome-ssh-askpass2 \
509         CC="%{__cc} %{rpmldflags} %{rpmcflags}"
510 %endif
511
512 %install
513 rm -rf $RPM_BUILD_ROOT
514 install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/{pam.d,rc.d/init.d,sysconfig,security,env.d}} \
515         $RPM_BUILD_ROOT%{_libexecdir}/ssh
516 %{?with_sshagentsh:install -d $RPM_BUILD_ROOT/etc/{profile.d,X11/xinit/xinitrc.d}}
517
518 %{__make} install \
519         DESTDIR=$RPM_BUILD_ROOT
520
521 install connect    $RPM_BUILD_ROOT%{_bindir}
522 install %{SOURCE4} $RPM_BUILD_ROOT/etc/pam.d/sshd
523 install %{SOURCE6} $RPM_BUILD_ROOT/etc/pam.d/passwdssh
524 install %{SOURCE5} $RPM_BUILD_ROOT/etc/sysconfig/sshd
525 install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
526 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/ssh_config
527 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/sshd_config
528 %if %{with sshagentsh}
529 install %{SOURCE11} $RPM_BUILD_ROOT/etc/profile.d
530 ln -sf  /etc/profile.d/ssh-agent.sh $RPM_BUILD_ROOT/etc/X11/xinit/xinitrc.d/ssh-agent.sh
531 install %{SOURCE12} $RPM_BUILD_ROOT%{_sysconfdir}
532 %endif
533
534 bzip2 -dc %{SOURCE7} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
535
536 %if %{with gnome}
537 install contrib/gnome-ssh-askpass1 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
538 %endif
539 %if %{with gtk}
540 install contrib/gnome-ssh-askpass2 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
541 %endif
542 %if %{with gnome} || %{with gtk}
543 cat << EOF >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_SERVER
544 #GNOME_SSH_ASKPASS_GRAB_SERVER="true"
545 EOF
546 cat << EOF >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_POINTER
547 #GNOME_SSH_ASKPASS_GRAB_POINTER="true"
548 EOF
549 ln -s %{_libexecdir}/ssh/ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/ssh-askpass
550 %endif
551
552 rm -f   $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
553 echo ".so ssh.1" > $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
554
555 touch $RPM_BUILD_ROOT/etc/security/blacklist.sshd
556
557 %if "%{_lib}" != "lib"
558 find $RPM_BUILD_ROOT%{_sysconfdir} -type f -print0 | xargs -0 perl -pi -e "s#/usr/lib#/usr/%{_lib}#"
559 %endif
560
561 cat << EOF >$RPM_BUILD_ROOT/etc/env.d/SSH_ASKPASS
562 #SSH_ASKPASS="%{_libexecdir}/ssh-askpass"
563 EOF
564
565 %clean
566 rm -rf $RPM_BUILD_ROOT
567
568 %pre server
569 %useradd -P %{name}-server -u 40 -d %{_privsepdir} -s /bin/false -c "OpenSSH PrivSep User" -g nobody sshd
570
571 %post server
572 /sbin/chkconfig --add sshd
573 %service sshd restart "openssh daemon"
574 if ! grep -qs ssh /etc/security/passwd.conf ; then
575         umask 022
576         echo "ssh" >> /etc/security/passwd.conf
577 fi
578
579 %preun server
580 if [ "$1" = "0" ]; then
581         %service sshd stop
582         /sbin/chkconfig --del sshd
583 fi
584
585 %postun server
586 if [ "$1" = "0" ]; then
587         %userremove sshd
588 fi
589
590 %files
591 %defattr(644,root,root,755)
592 %doc *.RNG TODO README OVERVIEW CREDITS Change*
593 %attr(755,root,root) %{_bindir}/ssh-key*
594 %{_mandir}/man1/ssh-key*.1*
595 %dir %{_sysconfdir}
596 %dir %{_libexecdir}
597
598 %files clients
599 %defattr(644,root,root,755)
600 %doc connect.html
601 %attr(755,root,root) %{_bindir}/connect
602 %attr(755,root,root) %{_bindir}/ssh
603 %attr(755,root,root) %{_bindir}/slogin
604 %attr(755,root,root) %{_bindir}/sftp
605 %attr(755,root,root) %{_bindir}/ssh-agent
606 %attr(755,root,root) %{_bindir}/ssh-add
607 %attr(755,root,root) %{_bindir}/scp
608 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh_config
609 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/SSH_ASKPASS
610 %if %{with sshagentsh}
611 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh-agent.conf
612 %attr(755,root,root) /etc/profile.d/ssh-agent.sh
613 %attr(755,root,root) /etc/X11/xinit/xinitrc.d/ssh-agent.sh
614 %endif
615 %{_mandir}/man1/scp.1*
616 %{_mandir}/man1/ssh.1*
617 %{_mandir}/man1/slogin.1*
618 %{_mandir}/man1/sftp.1*
619 %{_mandir}/man1/ssh-agent.1*
620 %{_mandir}/man1/ssh-add.1*
621 %{_mandir}/man5/ssh_config.5*
622 %lang(it) %{_mandir}/it/man1/ssh.1*
623 %lang(it) %{_mandir}/it/man5/ssh_config.5*
624 %lang(pl) %{_mandir}/pl/man1/scp.1*
625 %lang(zh_CN) %{_mandir}/zh_CN/man1/scp.1*
626
627 # for host-based auth (suid required for accessing private host key)
628 #%attr(4755,root,root) %{_libexecdir}/ssh-keysign
629 #%{_mandir}/man8/ssh-keysign.8*
630
631 %files server
632 %defattr(644,root,root,755)
633 %attr(755,root,root) %{_sbindir}/sshd
634 %attr(755,root,root) %{_libexecdir}/sftp-server
635 %attr(755,root,root) %{_libexecdir}/ssh-keysign
636 %{_mandir}/man8/sshd.8*
637 %{_mandir}/man8/sftp-server.8*
638 %{_mandir}/man8/ssh-keysign.8*
639 %{_mandir}/man5/sshd_config.5*
640 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sshd_config
641 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/sshd
642 %attr(640,root,root) %{_sysconfdir}/moduli
643 %attr(754,root,root) /etc/rc.d/init.d/sshd
644 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/sshd
645 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.sshd
646
647 %if %{with gnome} || %{with gtk}
648 %files gnome-askpass
649 %defattr(644,root,root,755)
650 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/GNOME_SSH_ASKPASS*
651 %dir %{_libexecdir}/ssh
652 %attr(755,root,root) %{_libexecdir}/ssh/ssh-askpass
653 %attr(755,root,root) %{_libexecdir}/ssh-askpass
654 %endif
This page took 1.045182 seconds and 3 git commands to generate.