]> git.pld-linux.org Git - packages/openssh.git/blob - openssh.spec
3ebf144502f00d783645e8c165ae73e78f98696f
[packages/openssh.git] / openssh.spec
1 #
2 # Conditional build:
3 %bcond_with     audit           # sshd audit support
4 %bcond_with     gnome           # with gnome-askpass (GNOME 1.x) utility
5 %bcond_without  gtk             # without GTK+ (2.x)
6 %bcond_without  ldap            # with ldap support
7 %bcond_without  libedit         # without libedit (editline/history support in sftp client)
8 %bcond_without  kerberos5       # without kerberos5 support
9 %bcond_without  selinux         # build without SELinux support
10 %bcond_with     hpn             # High Performance SSH/SCP - HPN-SSH including Cipher NONE (broken too often)
11
12 # gtk2-based gnome-askpass means no gnome1-based
13 %{?with_gtk:%undefine with_gnome}
14
15 %if "%{pld_release}" == "ac"
16 %define         pam_ver 0.79.0
17 %else
18 %define         pam_ver 0.99.7.1
19 %endif
20
21 Summary:        OpenSSH free Secure Shell (SSH) implementation
22 Summary(de.UTF-8):      OpenSSH - freie Implementation der Secure Shell (SSH)
23 Summary(es.UTF-8):      Implementación libre de SSH
24 Summary(fr.UTF-8):      Implémentation libre du shell sécurisé OpenSSH (SSH)
25 Summary(it.UTF-8):      Implementazione gratuita OpenSSH della Secure Shell
26 Summary(pl.UTF-8):      Publicznie dostępna implementacja bezpiecznego shella (SSH)
27 Summary(pt.UTF-8):      Implementação livre OpenSSH do protocolo 'Secure Shell' (SSH)
28 Summary(pt_BR.UTF-8):   Implementação livre do SSH
29 Summary(ru.UTF-8):      OpenSSH - свободная реализация протокола Secure Shell (SSH)
30 Summary(uk.UTF-8):      OpenSSH - вільна реалізація протоколу Secure Shell (SSH)
31 Name:           openssh
32 Version:        5.9p1
33 Release:        5
34 Epoch:          2
35 License:        BSD
36 Group:          Applications/Networking
37 Source0:        ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/%{name}-%{version}.tar.gz
38 # Source0-md5:  b50a499fa02616a47984b1920848b565
39 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
40 # Source1-md5:  66943d481cc422512b537bcc2c7400d1
41 Source2:        %{name}d.init
42 Source3:        %{name}d.pamd
43 Source4:        %{name}.sysconfig
44 Source5:        ssh-agent.sh
45 Source6:        ssh-agent.conf
46 Source7:        %{name}-lpk.schema
47 Source8:        %{name}d.upstart
48 Patch100:       %{name}-heimdal.patch
49 Patch0:         %{name}-no_libnsl.patch
50 Patch2:         %{name}-pam_misc.patch
51 Patch3:         %{name}-sigpipe.patch
52 # http://pkgs.fedoraproject.org/gitweb/?p=openssh.git;a=tree
53 Patch4:         %{name}-5.9p1-ldap.patch
54 Patch5:         %{name}-5.9p1-ldap-fixes.patch
55 Patch8:         ldap.conf.patch
56 Patch6:         %{name}-config.patch
57 # https://bugzilla.mindrot.org/show_bug.cgi?id=1663
58 Patch7:         authorized-keys-command.patch
59 # High Performance SSH/SCP - HPN-SSH - http://www.psc.edu/networking/projects/hpn-ssh/
60 # http://www.psc.edu/networking/projects/hpn-ssh/openssh-5.2p1-hpn13v6.diff.gz
61 Patch9:         %{name}-5.2p1-hpn13v6.diff
62 Patch10:        %{name}-include.patch
63 Patch11:        %{name}-chroot.patch
64 # http://people.debian.org/~cjwatson/%{name}-blacklist.diff
65 Patch12:        %{name}-blacklist.diff
66 Patch13:        %{name}-kuserok.patch
67 URL:            http://www.openssh.com/portable.html
68 BuildRequires:  %{__perl}
69 %{?with_audit:BuildRequires:    audit-libs-devel}
70 BuildRequires:  autoconf >= 2.50
71 BuildRequires:  automake
72 %{?with_gnome:BuildRequires:    gnome-libs-devel}
73 %{?with_gtk:BuildRequires:      gtk+2-devel}
74 %{?with_kerberos5:BuildRequires:        heimdal-devel >= 0.7}
75 %{?with_libedit:BuildRequires:  libedit-devel}
76 %{?with_selinux:BuildRequires:  libselinux-devel}
77 BuildRequires:  libwrap-devel
78 %{?with_ldap:BuildRequires:     openldap-devel}
79 BuildRequires:  openssl-devel >= 0.9.7d
80 BuildRequires:  pam-devel
81 %{?with_gtk:BuildRequires:      pkgconfig}
82 BuildRequires:  rpm >= 4.4.9-56
83 BuildRequires:  rpmbuild(macros) >= 1.318
84 BuildRequires:  sed >= 4.0
85 BuildRequires:  zlib-devel
86 %if "%{pld_release}" == "ac"
87 Requires:       filesystem >= 2.0-1
88 Requires:       pam >= 0.79.0
89 %else
90 Requires:       filesystem >= 3.0-11
91 Requires:       pam >= %{pam_ver}
92 Suggests:       openssh-blacklist
93 Suggests:       xorg-app-xauth
94 %endif
95 Obsoletes:      ssh
96 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
97
98 %define         _sysconfdir     /etc/ssh
99 %define         _libexecdir     %{_libdir}/%{name}
100 %define         _privsepdir     /usr/share/empty
101 %define         schemadir       /usr/share/openldap/schema
102
103 %description
104 Ssh (Secure Shell) a program for logging into a remote machine and for
105 executing commands in a remote machine. It is intended to replace
106 rlogin and rsh, and provide secure encrypted communications between
107 two untrusted hosts over an insecure network. X11 connections and
108 arbitrary TCP/IP ports can also be forwarded over the secure channel.
109
110 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
111 it up to date in terms of security and features, as well as removing
112 all patented algorithms to seperate libraries (OpenSSL).
113
114 This package includes the core files necessary for both the OpenSSH
115 client and server. To make this package useful, you should also
116 install openssh-clients, openssh-server, or both.
117
118 %if %{with hpn}
119 This release includes High Performance SSH/SCP patches from
120 http://www.psc.edu/networking/projects/hpn-ssh/ which are supposed to
121 increase throughput on fast connections with high RTT (20-150 msec).
122 See the website for '-w' values for your connection and /proc/sys TCP
123 values. BTW. in a LAN you have got generally RTT < 1 msec.
124 %endif
125
126 %description -l de.UTF-8
127 OpenSSH (Secure Shell) stellt den Zugang zu anderen Rechnern her. Es
128 ersetzt telnet, rlogin, rexec und rsh und stellt eine sichere,
129 verschlüsselte Verbindung zwischen zwei nicht vertrauenswürdigen Hosts
130 über eine unsicheres Netzwerk her. X11 Verbindungen und beliebige
131 andere TCP/IP Ports können ebenso über den sicheren Channel
132 weitergeleitet werden.
133
134 %description -l es.UTF-8
135 SSH es un programa para accesar y ejecutar órdenes en computadores
136 remotos. Sustituye rlogin y rsh, y suministra un canal de comunicación
137 seguro entre dos servidores en una red insegura. Conexiones X11 y
138 puertas TCP/IP arbitrárias también pueden ser usadas por el canal
139 seguro.
140
141 OpenSSH es el resultado del trabajo del equipo de OpenBSD para
142 continuar la última versión gratuita de SSH, actualizándolo en
143 términos de seguridad y recursos,así también eliminando todos los
144 algoritmos patentados y colocándolos en bibliotecas separadas
145 (OpenSSL).
146
147 Este paquete contiene "port" para Linux de OpenSSH. Se debe instalar
148 también el paquete openssh-clients u openssh-server o ambos.
149
150 %description -l fr.UTF-8
151 OpenSSH (Secure Shell) fournit un accès à un système distant. Il
152 remplace telnet, rlogin, rexec et rsh, tout en assurant des
153 communications cryptées securisées entre deux hôtes non fiabilisés sur
154 un réseau non sécurisé. Des connexions X11 et des ports TCP/IP
155 arbitraires peuvent également être transmis sur le canal sécurisé.
156
157 %description -l it.UTF-8
158 OpenSSH (Secure Shell) fornisce l'accesso ad un sistema remoto.
159 Sostituisce telnet, rlogin, rexec, e rsh, e fornisce comunicazioni
160 sicure e crittate tra due host non fidati su una rete non sicura. Le
161 connessioni X11 ad una porta TCP/IP arbitraria possono essere
162 inoltrate attraverso un canale sicuro.
163
164 %description -l pl.UTF-8
165 Ssh (Secure Shell) to program służący do logowania się na zdalną
166 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
167 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
168 pomiędzy dwoma hostami.
169
170 Ten pakiet zawiera podstawowe pliki potrzebne zarówno po stronie
171 klienta jak i serwera OpenSSH. Aby był użyteczny, trzeba zainstalować
172 co najmniej jeden z pakietów: openssh-clients lub openssh-server.
173
174 %if %{with hpn}
175 Ta wersja zawiera łaty z projektu High Performance SSH/SCP
176 http://www.psc.edu/networking/projects/hpn-ssh/, które mają na celu
177 zwiększenie przepustowości transmisji dla szybkich połączeń z dużym
178 RTT (20-150 msec). Na stronie projektu znaleźć można odpowednie dla
179 danego połączenia wartości parametru '-w' oraz opcje /proc/sys dla
180 TCP. Nawiasem mówiąc w sieciach LAN RTT < 1 msec.
181 %endif
182
183 %description -l pt.UTF-8
184 OpenSSH (Secure Shell) fornece acesso a um sistema remoto. Substitui o
185 telnet, rlogin, rexec, e o rsh e fornece comunicações seguras e
186 cifradas entre duas máquinas sem confiança mútua sobre uma rede
187 insegura. Ligações X11 e portos TCP/IP arbitrários também poder ser
188 reenviados pelo canal seguro.
189
190 %description -l pt_BR.UTF-8
191 SSH é um programa para acessar e executar comandos em máquinas
192 remotas. Ele substitui rlogin e rsh, e provem um canal de comunicação
193 seguro entre dois hosts em uma rede insegura. Conexões X11 e portas
194 TCP/IP arbitrárias também podem ser usadas pelo canal seguro.
195
196 OpenSSH é o resultado do trabalho da equipe do OpenBSD em continuar a
197 última versão gratuita do SSH, atualizando-o em termos de segurança e
198 recursos, assim como removendo todos os algoritmos patenteados e
199 colocando-os em bibliotecas separadas (OpenSSL).
200
201 Esse pacote contém o "port" pra Linux do OpenSSH. Você deve instalar
202 também ou o pacote openssh-clients, ou o openssh-server, ou ambos.
203
204 %description -l ru.UTF-8
205 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
206 машину и для выполнения команд на удаленной машине. Она предназначена
207 для замены rlogin и rsh и обеспечивает безопасную шифрованную
208 коммуникацию между двумя хостами в сети, являющейся небезопасной.
209 Соединения X11 и любые порты TCP/IP могут также быть проведены через
210 безопасный канал.
211
212 OpenSSH - это переделка командой разработчиков OpenBSD последней
213 свободной версии SSH, доведенная до современного состояния в терминах
214 уровня безопасности и поддерживаемых возможностей. Все патентованные
215 алгоритмы вынесены в отдельные библиотеки (OpenSSL).
216
217 Этот пакет содержит файлы, необходимые как для клиента, так и для
218 сервера OpenSSH. Вам нужно будет установить еще openssh-clients,
219 openssh-server, или оба пакета.
220
221 %description -l uk.UTF-8
222 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
223 машини та для виконання команд на віддаленій машині. Вона призначена
224 для заміни rlogin та rsh і забезпечує безпечну шифровану комунікацію
225 між двома хостами в мережі, яка не є безпечною. З'єднання X11 та
226 довільні порти TCP/IP можуть також бути проведені через безпечний
227 канал.
228
229 OpenSSH - це переробка командою розробників OpenBSD останньої вільної
230 версії SSH, доведена до сучасного стану в термінах рівня безпеки та
231 підтримуваних можливостей. Всі патентовані алгоритми винесені до
232 окремих бібліотек (OpenSSL).
233
234 Цей пакет містить файли, необхідні як для клієнта, так і для сервера
235 OpenSSH. Вам потрібно буде ще встановити openssh-clients,
236 openssh-server, чи обидва пакети.
237
238 %package clients
239 Summary:        OpenSSH Secure Shell protocol clients
240 Summary(es.UTF-8):      Clientes de OpenSSH
241 Summary(pl.UTF-8):      Klienci protokołu Secure Shell
242 Summary(pt_BR.UTF-8):   Clientes do OpenSSH
243 Summary(ru.UTF-8):      OpenSSH - клиенты протокола Secure Shell
244 Summary(uk.UTF-8):      OpenSSH - клієнти протоколу Secure Shell
245 Group:          Applications/Networking
246 Requires:       %{name}
247 Provides:       ssh-clients
248 Obsoletes:      ssh-clients
249
250 %description clients
251 Ssh (Secure Shell) a program for logging into a remote machine and for
252 executing commands in a remote machine. It is intended to replace
253 rlogin and rsh, and provide secure encrypted communications between
254 two untrusted hosts over an insecure network. X11 connections and
255 arbitrary TCP/IP ports can also be forwarded over the secure channel.
256
257 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
258 it up to date in terms of security and features, as well as removing
259 all patented algorithms to seperate libraries (OpenSSL).
260
261 This package includes the clients necessary to make encrypted
262 connections to SSH servers.
263
264 %description clients -l es.UTF-8
265 Este paquete incluye los clientes que se necesitan para hacer
266 conexiones codificadas con servidores SSH.
267
268 %description clients -l pl.UTF-8
269 Ssh (Secure Shell) to program służący do logowania się na zdalną
270 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
271 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
272 pomiędzy dwoma hostami.
273
274 Ten pakiet zawiera klientów służących do łączenia się z serwerami SSH.
275
276 %description clients -l pt_BR.UTF-8
277 Esse pacote inclui os clientes necessários para fazer conexões
278 encriptadas com servidores SSH.
279
280 %description clients -l ru.UTF-8
281 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
282 машину и для выполнения команд на удаленной машине.
283
284 Этот пакет содержит программы-клиенты, необходимые для установления
285 зашифрованных соединений с серверами SSH.
286
287 %description clients -l uk.UTF-8
288 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
289 машини та для виконання команд на віддаленій машині.
290
291 Цей пакет містить програми-клієнти, необхідні для встановлення
292 зашифрованих з'єднань з серверами SSH.
293
294 %package clients-agent-profile_d
295 Summary:        OpenSSH Secure Shell agent init script
296 Summary(pl.UTF-8):      Skrypt startowy agenta OpenSSH
297 Group:          Applications/Networking
298 Requires:       %{name}-clients = %{epoch}:%{version}-%{release}
299
300 %description clients-agent-profile_d
301 profile.d scripts for starting SSH agent.
302
303 %description clients-agent-profile_d -l pl.UTF-8
304 Skrypty profile.d do uruchamiania agenta SSH.
305
306 %package clients-agent-xinitrc
307 Summary:        OpenSSH Secure Shell agent init script
308 Summary(pl.UTF-8):      Skrypt inicjujący agenta ssh przez xinitrc
309 Group:          Applications/Networking
310 Requires:       %{name}-clients-agent-profile_d = %{epoch}:%{version}-%{release}
311 Requires:       xinitrc
312
313 %description clients-agent-xinitrc
314 xinitrc scripts for starting SSH agent.
315
316 %description clients-agent-xinitrc -l pl.UTF-8
317 Skrypty xinitrc do uruchamiania agenta SSH.
318
319 %package server
320 Summary:        OpenSSH Secure Shell protocol server (sshd)
321 Summary(de.UTF-8):      OpenSSH Secure Shell Protocol-Server (sshd)
322 Summary(es.UTF-8):      Servidor OpenSSH para comunicaciones codificadas
323 Summary(fr.UTF-8):      Serveur de protocole du shell sécurisé OpenSSH (sshd)
324 Summary(it.UTF-8):      Server OpenSSH per il protocollo Secure Shell (sshd)
325 Summary(pl.UTF-8):      Serwer protokołu Secure Shell (sshd)
326 Summary(pt.UTF-8):      Servidor do protocolo 'Secure Shell' OpenSSH (sshd)
327 Summary(pt_BR.UTF-8):   Servidor OpenSSH para comunicações encriptadas
328 Summary(ru.UTF-8):      OpenSSH - сервер протокола Secure Shell (sshd)
329 Summary(uk.UTF-8):      OpenSSH - сервер протоколу Secure Shell (sshd)
330 Group:          Networking/Daemons
331 Requires(post): /sbin/chkconfig
332 Requires(post): grep
333 Requires(post,preun):   /sbin/chkconfig
334 Requires(postun):       /usr/sbin/userdel
335 Requires(pre):  /bin/id
336 Requires(pre):  /usr/sbin/useradd
337 Requires:       %{name} = %{epoch}:%{version}-%{release}
338 # remove in 6.0, kept for flawless upgrade
339 Requires:       %{name}-server-ldap = %{epoch}:%{version}-%{release}
340 Requires:       pam >= %{pam_ver}
341 Requires:       rc-scripts >= 0.4.3.0
342 Requires:       util-linux
343 Suggests:       /bin/login
344 Provides:       ssh-server
345 Provides:       user(sshd)
346
347 %description server
348 Ssh (Secure Shell) a program for logging into a remote machine and for
349 executing commands in a remote machine. It is intended to replace
350 rlogin and rsh, and provide secure encrypted communications between
351 two untrusted hosts over an insecure network. X11 connections and
352 arbitrary TCP/IP ports can also be forwarded over the secure channel.
353
354 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
355 it up to date in terms of security and features, as well as removing
356 all patented algorithms to seperate libraries (OpenSSL).
357
358 This package contains the secure shell daemon. The sshd is the server
359 part of the secure shell protocol and allows ssh clients to connect to
360 your host.
361
362 %description server -l de.UTF-8
363 Dieses Paket installiert den sshd, den Server-Teil der OpenSSH.
364
365 %description server -l es.UTF-8
366 Este paquete contiene el servidor SSH. sshd es la parte servidor del
367 protocolo secure shell y permite que clientes ssh se conecten a su
368 servidor.
369
370 %description server -l fr.UTF-8
371 Ce paquetage installe le 'sshd', partie serveur de OpenSSH.
372
373 %description server -l it.UTF-8
374 Questo pacchetto installa sshd, il server di OpenSSH.
375
376 %description server -l pl.UTF-8
377 Ssh (Secure Shell) to program służący do logowania się na zdalną
378 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
379 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
380 pomiędzy dwoma hostami.
381
382 Ten pakiet zawiera serwer sshd (do którego mogą łączyć się klienci
383 ssh).
384
385 %description server -l pt.UTF-8
386 Este pacote intala o sshd, o servidor do OpenSSH.
387
388 %description server -l pt_BR.UTF-8
389 Esse pacote contém o servidor SSH. O sshd é a parte servidor do
390 protocolo secure shell e permite que clientes ssh se conectem ao seu
391 host.
392
393 %description server -l ru.UTF-8
394 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
395 машину и для выполнения команд на удаленной машине.
396
397 Этот пакет содержит sshd - "демон" Secure Shell. sshd - это серверная
398 часть протокола Secure Shell, позволяющая клиентам ssh соединяться с
399 вашим хостом.
400
401 %description server -l uk.UTF-8
402 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
403 машини та для виконання команд на віддаленій машині.
404
405 Цей пакет містить sshd - "демон" Secure Shell. sshd - це серверна
406 частина протоколу Secure Shell, яка дозволяє клієнтам ssh зв'язуватись
407 з вашим хостом.
408
409 %package server-ldap
410 Summary:        A LDAP support for open source SSH server daemon
411 Group:          Daemons
412 Requires:       %{name} = %{epoch}:%{version}-%{release}
413
414 %description server-ldap
415 OpenSSH LDAP backend is a way how to distribute the authorized tokens
416 among the servers in the network.
417
418 %package server-upstart
419 Summary:        Upstart job description for OpenSSH server
420 Summary(pl.UTF-8):      Opis zadania Upstart dla serwera OpenSSH
421 Group:          Daemons
422 Requires:       %{name}-server = %{epoch}:%{version}-%{release}
423 Requires:       upstart >= 0.6
424 Conflicts:      syslog-ng < 3.2.4-1
425
426 %description server-upstart
427 Upstart job description for OpenSSH.
428
429 %description server-upstart -l pl.UTF-8
430 Opis zadania Upstart dla OpenSSH.
431
432 %package gnome-askpass
433 Summary:        OpenSSH GNOME passphrase dialog
434 Summary(de.UTF-8):      OpenSSH GNOME Passwort-Dialog
435 Summary(es.UTF-8):      Diálogo para introducción de passphrase para GNOME
436 Summary(fr.UTF-8):      Dialogue pass-phrase GNOME d'OpenSSH
437 Summary(it.UTF-8):      Finestra di dialogo GNOME per la frase segreta di OpenSSH
438 Summary(pl.UTF-8):      Odpytywacz hasła OpenSSH dla GNOME
439 Summary(pt.UTF-8):      Diálogo de pedido de senha para GNOME do OpenSSH
440 Summary(pt_BR.UTF-8):   Diálogo para entrada de passphrase para GNOME
441 Summary(ru.UTF-8):      OpenSSH - диалог ввода ключевой фразы (passphrase) для GNOME
442 Summary(uk.UTF-8):      OpenSSH - діалог вводу ключової фрази (passphrase) для GNOME
443 Group:          Applications/Networking
444 Requires:       %{name} = %{epoch}:%{version}-%{release}
445 Obsoletes:      openssh-askpass
446 Obsoletes:      ssh-askpass
447 Obsoletes:      ssh-extras
448
449 %description gnome-askpass
450 Ssh (Secure Shell) a program for logging into a remote machine and for
451 executing commands in a remote machine. It is intended to replace
452 rlogin and rsh, and provide secure encrypted communications between
453 two untrusted hosts over an insecure network. X11 connections and
454 arbitrary TCP/IP ports can also be forwarded over the secure channel.
455
456 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
457 it up to date in terms of security and features, as well as removing
458 all patented algorithms to seperate libraries (OpenSSL).
459
460 This package contains the GNOME passphrase dialog.
461
462 %description gnome-askpass -l es.UTF-8
463 Este paquete contiene un programa que abre una caja de diálogo para
464 entrada de passphrase en GNOME.
465
466 %description gnome-askpass -l pl.UTF-8
467 Ssh (Secure Shell) to program służący do logowania się na zdalną
468 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
469 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
470 pomiędzy dwoma hostami.
471
472 Ten pakiet zawiera ,,odpytywacz hasła'' dla GNOME.
473
474 %description gnome-askpass -l pt_BR.UTF-8
475 Esse pacote contém um programa que abre uma caixa de diálogo para
476 entrada de passphrase no GNOME.
477
478 %description gnome-askpass -l ru.UTF-8
479 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
480 машину и для выполнения команд на удаленной машине.
481
482 Этот пакет содержит диалог ввода ключевой фразы для использования под
483 GNOME.
484
485 %description gnome-askpass -l uk.UTF-8
486 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
487 машини та для виконання команд на віддаленій машині.
488
489 Цей пакет містить діалог вводу ключової фрази для використання під
490 GNOME.
491
492 %package -n openldap-schema-openssh-lpk
493 Summary:        OpenSSH LDAP Public Key schema
494 Summary(pl.UTF-8):      Schemat klucza publicznego LDAP dla OpenSSH
495 Group:          Networking/Daemons
496 Requires(post,postun):  sed >= 4.0
497 Requires:       openldap-servers
498
499 %description -n openldap-schema-openssh-lpk
500 This package contains OpenSSH LDAP Public Key schema for openldap.
501
502 %description -n openldap-schema-openssh-lpk -l pl.UTF-8
503 Ten pakiet zawiera schemat klucza publicznego LDAP dla OpenSSH dla
504 openldap-a.
505
506 %prep
507 %setup -q
508 %{?with_kerberos5:%patch100 -p1}
509 %patch0 -p1
510 %patch2 -p1
511 %patch3 -p1
512 %patch4 -p1
513 %patch5 -p1
514 %patch8 -p1
515 %patch6 -p1
516 %patch7 -p1
517 %{?with_hpn:%patch9 -p1}
518 %patch10 -p1
519 %patch11 -p1
520 %patch12 -p1
521 %patch13 -p1
522
523 cp -p %{SOURCE3} sshd.pam
524 install -p %{SOURCE2} sshd.init
525
526 %if "%{pld_release}" == "ac"
527 # fix for missing x11.pc
528 %{__sed} -i -e '/pkg-config/s/ x11//' contrib/Makefile
529 # not present in ac, no point searching it
530 %{__sed} -i -e '/pam_keyinit.so/d' sshd.pam
531
532 # openssl on ac does not have OPENSSL_HAS_ECC
533 %{__sed} -i -e '/ecdsa/d' sshd.init
534 %endif
535
536 # hack since arc4random from openbsd-compat needs symbols from libssh and vice versa
537 sed -i -e 's#-lssh -lopenbsd-compat#-lssh -lopenbsd-compat -lssh#g' Makefile*
538
539 grep -rl /usr/libexec/openssh/ssh-ldap-helper . | xargs \
540 %{__sed} -i -e 's,/usr/libexec/openssh/ssh-ldap-helper,%{_libexecdir}/ssh-ldap-helper,'
541
542 %build
543 cp /usr/share/automake/config.sub .
544 %{__aclocal}
545 %{__autoconf}
546 %{__autoheader}
547 CPPFLAGS="-DCHROOT"
548 %configure \
549         PERL=%{__perl} \
550         --disable-strip \
551         --enable-utmpx \
552         --enable-wtmpx \
553         --with-4in6 \
554         %{?with_audit:--with-audit=linux} \
555         --with-ipaddr-display \
556         %{?with_kerberos5:--with-kerberos5=/usr} \
557         --with-ldap%{!?with_ldap:=no} \
558         %{?with_libedit:--with-libedit} \
559         --with-mantype=man \
560         --with-md5-passwords \
561         --with-pam \
562         --with-authorized-keys-command \
563         --with-pid-dir=%{_localstatedir}/run \
564         --with-privsep-path=%{_privsepdir} \
565         %{?with_selinux:--with-selinux} \
566         --with-tcp-wrappers \
567 %if "%{pld_release}" == "ac"
568         --with-xauth=/usr/X11R6/bin/xauth
569 %else
570         --with-xauth=%{_bindir}/xauth
571 %endif
572
573 echo '#define LOGIN_PROGRAM                "/bin/login"' >>config.h
574
575 %{__make}
576
577 cd contrib
578 %if %{with gnome}
579 %{__make} gnome-ssh-askpass1 \
580         CC="%{__cc} %{rpmldflags} %{rpmcflags}"
581 %endif
582 %if %{with gtk}
583 %{__make} gnome-ssh-askpass2 \
584         CC="%{__cc} %{rpmldflags} %{rpmcflags}"
585 %endif
586
587 %install
588 rm -rf $RPM_BUILD_ROOT
589 install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/{init,pam.d,rc.d/init.d,sysconfig,security,env.d}} \
590         $RPM_BUILD_ROOT{%{_libexecdir}/ssh,%{schemadir}}
591 install -d $RPM_BUILD_ROOT/etc/{profile.d,X11/xinit/xinitrc.d}
592
593 %{__make} install \
594         DESTDIR=$RPM_BUILD_ROOT
595
596 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
597
598 install -p sshd.init $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
599 cp -p sshd.pam $RPM_BUILD_ROOT/etc/pam.d/sshd
600 cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/sshd
601 cp -p %{SOURCE5} $RPM_BUILD_ROOT/etc/profile.d
602 ln -sf  /etc/profile.d/ssh-agent.sh $RPM_BUILD_ROOT/etc/X11/xinit/xinitrc.d/ssh-agent.sh
603 cp -p %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}
604 cp -p %{SOURCE7} $RPM_BUILD_ROOT%{schemadir}
605 cp -p %{SOURCE8} $RPM_BUILD_ROOT/etc/init/sshd.conf
606
607 %if %{with gnome}
608 install -p contrib/gnome-ssh-askpass1 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
609 %endif
610 %if %{with gtk}
611 install -p contrib/gnome-ssh-askpass2 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
612 %endif
613 %if %{with gnome} || %{with gtk}
614 cat << 'EOF' >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_SERVER
615 #GNOME_SSH_ASKPASS_GRAB_SERVER="true"
616 EOF
617 cat << 'EOF' >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_POINTER
618 #GNOME_SSH_ASKPASS_GRAB_POINTER="true"
619 EOF
620 ln -s %{_libexecdir}/ssh/ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/ssh-askpass
621 %endif
622
623 install -p contrib/ssh-copy-id $RPM_BUILD_ROOT%{_bindir}
624 cp -p contrib/ssh-copy-id.1 $RPM_BUILD_ROOT%{_mandir}/man1
625
626 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
627 echo ".so ssh.1" > $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
628
629 touch $RPM_BUILD_ROOT/etc/security/blacklist.sshd
630
631 cat << 'EOF' > $RPM_BUILD_ROOT/etc/env.d/SSH_ASKPASS
632 #SSH_ASKPASS="%{_libexecdir}/ssh-askpass"
633 EOF
634
635 %{__rm} $RPM_BUILD_ROOT%{_mandir}/README.openssh-non-english-man-pages
636 %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/ldap.conf
637
638 %clean
639 rm -rf $RPM_BUILD_ROOT
640
641 %post clients
642 %env_update
643
644 %postun clients
645 %env_update
646
647 %post gnome-askpass
648 %env_update
649
650 %postun gnome-askpass
651 %env_update
652
653 %pre server
654 %useradd -P %{name}-server -u 40 -d %{_privsepdir} -s /bin/false -c "OpenSSH PrivSep User" -g nobody sshd
655
656 %post server
657 /sbin/chkconfig --add sshd
658 %service sshd reload "OpenSSH Daemon"
659 if ! grep -qs ssh /etc/security/passwd.conf ; then
660         umask 022
661         echo "ssh" >> /etc/security/passwd.conf
662 fi
663
664 %preun server
665 if [ "$1" = "0" ]; then
666         %service sshd stop
667         /sbin/chkconfig --del sshd
668 fi
669
670 %postun server
671 if [ "$1" = "0" ]; then
672         %userremove sshd
673 fi
674
675 %triggerpostun server -- %{name}-server < 2:5.9p1-1
676 # lpk.patch to ldap.patch
677 if grep -qE '^(UseLPK|Lpk)' %{_sysconfdir}/sshd_config; then
678         echo >&2 "Migrating LPK patch to LDAP patch"
679         cp -f %{_sysconfdir}/sshd_config{,.rpmorig}
680         %{__sed} -i -e '
681                 # disable old configs
682                 # just UseLPK/LkpLdapConf supported for now
683                 s/^UseLPK/## Obsolete &/
684                 s/^Lpk/## Obsolete &/
685                 # Enable new ones, assumes /etc/ldap.conf defaults, see HOWTO.ldap-keys
686                 /UseLPK/iAuthorizedKeysCommand %{_libexecdir}/ssh-ldap-wrapper
687         ' %{_sysconfdir}/sshd_config
688         %service -q sshd reload
689 fi
690
691 %post server-upstart
692 %upstart_post sshd
693
694 %postun server-upstart
695 %upstart_postun sshd
696
697 %post -n openldap-schema-openssh-lpk
698 %openldap_schema_register %{schemadir}/openssh-lpk.schema
699 %service -q ldap restart
700
701 %postun -n openldap-schema-openssh-lpk
702 if [ "$1" = "0" ]; then
703         %openldap_schema_unregister %{schemadir}/openssh-lpk.schema
704         %service -q ldap restart
705 fi
706
707 %files
708 %defattr(644,root,root,755)
709 %doc TODO README OVERVIEW CREDITS Change*
710 %attr(755,root,root) %{_bindir}/ssh-key*
711 %attr(755,root,root) %{_bindir}/ssh-vulnkey*
712 %{_mandir}/man1/ssh-key*.1*
713 %{_mandir}/man1/ssh-vulnkey*.1*
714 %dir %{_sysconfdir}
715 %dir %{_libexecdir}
716
717 %files clients
718 %defattr(644,root,root,755)
719 %attr(755,root,root) %{_bindir}/ssh
720 %attr(755,root,root) %{_bindir}/slogin
721 %attr(755,root,root) %{_bindir}/sftp
722 %attr(755,root,root) %{_bindir}/ssh-agent
723 %attr(755,root,root) %{_bindir}/ssh-add
724 %attr(755,root,root) %{_bindir}/ssh-copy-id
725 %attr(755,root,root) %{_bindir}/scp
726 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh_config
727 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/SSH_ASKPASS
728 %{_mandir}/man1/scp.1*
729 %{_mandir}/man1/ssh.1*
730 %{_mandir}/man1/slogin.1*
731 %{_mandir}/man1/sftp.1*
732 %{_mandir}/man1/ssh-agent.1*
733 %{_mandir}/man1/ssh-add.1*
734 %{_mandir}/man1/ssh-copy-id.1*
735 %{_mandir}/man5/ssh_config.5*
736 %lang(it) %{_mandir}/it/man1/ssh.1*
737 %lang(it) %{_mandir}/it/man5/ssh_config.5*
738 %lang(pl) %{_mandir}/pl/man1/scp.1*
739 %lang(zh_CN) %{_mandir}/zh_CN/man1/scp.1*
740
741 # for host-based auth (suid required for accessing private host key)
742 #%attr(4755,root,root) %{_libexecdir}/ssh-keysign
743 #%{_mandir}/man8/ssh-keysign.8*
744
745 %files clients-agent-profile_d
746 %defattr(644,root,root,755)
747 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh-agent.conf
748 %attr(755,root,root) /etc/profile.d/ssh-agent.sh
749
750 %files clients-agent-xinitrc
751 %defattr(644,root,root,755)
752 %attr(755,root,root) /etc/X11/xinit/xinitrc.d/ssh-agent.sh
753
754 %files server
755 %defattr(644,root,root,755)
756 %attr(755,root,root) %{_sbindir}/sshd
757 %attr(755,root,root) %{_libexecdir}/sftp-server
758 %attr(755,root,root) %{_libexecdir}/ssh-keysign
759 %attr(755,root,root) %{_libexecdir}/ssh-pkcs11-helper
760 %{_mandir}/man8/sshd.8*
761 %{_mandir}/man8/sftp-server.8*
762 %{_mandir}/man8/ssh-keysign.8*
763 %{_mandir}/man8/ssh-pkcs11-helper.8*
764 %{_mandir}/man5/sshd_config.5*
765 %{_mandir}/man5/moduli.5*
766 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sshd_config
767 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/sshd
768 %attr(640,root,root) %{_sysconfdir}/moduli
769 %attr(754,root,root) /etc/rc.d/init.d/sshd
770 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/sshd
771 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.sshd
772
773 %if %{with ldap}
774 %files server-ldap
775 %defattr(644,root,root,755)
776 %doc HOWTO.ldap-keys ldap.conf
777 %attr(755,root,root) %{_libexecdir}/ssh-ldap-helper
778 %attr(755,root,root) %{_libexecdir}/ssh-ldap-wrapper
779 %{_mandir}/man5/ssh-ldap.conf.5*
780 %{_mandir}/man8/ssh-ldap-helper.8*
781 %endif
782
783 %if %{with gnome} || %{with gtk}
784 %files gnome-askpass
785 %defattr(644,root,root,755)
786 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/GNOME_SSH_ASKPASS*
787 %dir %{_libexecdir}/ssh
788 %attr(755,root,root) %{_libexecdir}/ssh/ssh-askpass
789 %attr(755,root,root) %{_libexecdir}/ssh-askpass
790 %endif
791
792 %if %{with ldap}
793 %files -n openldap-schema-openssh-lpk
794 %defattr(644,root,root,755)
795 %{schemadir}/openssh-lpk.schema
796 %endif
797
798 %if "%{pld_release}" != "ti"
799 %files server-upstart
800 %defattr(644,root,root,755)
801 %config(noreplace) %verify(not md5 mtime size) /etc/init/sshd.conf
802 %endif
This page took 0.075008 seconds and 3 git commands to generate.