]> git.pld-linux.org Git - packages/openssh.git/blob - openssh.spec
291cda9f00953d4174a058585e6f67cc72c48220
[packages/openssh.git] / openssh.spec
1 #
2 # Conditional build:
3 %bcond_without  chroot          # without chrooted user environment support
4 %bcond_with     gnome           # with gnome-askpass (GNOME 1.x) utility
5 %bcond_without  gtk             # without GTK+ (2.x)
6 %bcond_with     ldap            # with ldap support
7 %bcond_without  libedit         # without libedit (editline/history support in sftp client)
8 %bcond_without  kerberos5       # without kerberos5 support
9 %bcond_without  selinux         # build without SELinux support
10 %bcond_with     hpn             # with High Performance SSH/SCP - HPN-SSH (see patch comment)
11 %bcond_with     hpn_none        # with hpn (above) and '-z' none cipher option
12 #
13 %if %{with hpn_none}
14 %undefine       with_hpn
15 %endif
16 # gtk2-based gnome-askpass means no gnome1-based
17 %{?with_gtk:%undefine with_gnome}
18 Summary:        OpenSSH free Secure Shell (SSH) implementation
19 Summary(de.UTF-8):      OpenSSH - freie Implementation der Secure Shell (SSH)
20 Summary(es.UTF-8):      Implementación libre de SSH
21 Summary(fr.UTF-8):      Implémentation libre du shell sécurisé OpenSSH (SSH)
22 Summary(it.UTF-8):      Implementazione gratuita OpenSSH della Secure Shell
23 Summary(pl.UTF-8):      Publicznie dostępna implementacja bezpiecznego shella (SSH)
24 Summary(pt.UTF-8):      Implementação livre OpenSSH do protocolo 'Secure Shell' (SSH)
25 Summary(pt_BR.UTF-8):   Implementação livre do SSH
26 Summary(ru.UTF-8):      OpenSSH - свободная реализация протокола Secure Shell (SSH)
27 Summary(uk.UTF-8):      OpenSSH - вільна реалізація протоколу Secure Shell (SSH)
28 Name:           openssh
29 Version:        4.6p1
30 Release:        2%{?with_hpn:hpn}%{?with_hpn_none:hpn_none}
31 Epoch:          2
32 License:        BSD
33 Group:          Applications/Networking
34 Source0:        ftp://ftp.ca.openbsd.org/pub/OpenBSD/OpenSSH/portable/%{name}-%{version}.tar.gz
35 # Source0-md5:  6a7fa99f44d9e1b5b04d15256e1405bb
36 Source1:        %{name}d.conf
37 Source2:        %{name}.conf
38 Source3:        %{name}d.init
39 Source4:        %{name}d.pamd
40 Source5:        %{name}.sysconfig
41 Source6:        passwd.pamd
42 Source7:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
43 # Source7-md5:  66943d481cc422512b537bcc2c7400d1
44 Source11:       ssh-agent.sh
45 Source12:       ssh-agent.conf
46 Patch0:         %{name}-no_libnsl.patch
47 Patch2:         %{name}-linux-ipv6.patch
48 Patch3:         %{name}-pam_misc.patch
49 Patch4:         %{name}-sigpipe.patch
50 # http://www.opendarwin.org/projects/openssh-lpk/
51 Patch5:         %{name}-lpk-4.3p1-0.3.7.patch
52 Patch6:         %{name}-heimdal.patch
53 Patch7:         %{name}-pam-conv.patch
54 # http://chrootssh.sourceforge.net/download/osshChroot-3.7.1p2.diff
55 Patch8:         %{name}-chroot.patch
56 Patch9:         %{name}-selinux.patch
57 # HPN patches rediffed due sigpipe patch.
58 # High Performance SSH/SCP - HPN-SSH - http://www.psc.edu/networking/projects/hpn-ssh/
59 # http://www.psc.edu/networking/projects/hpn-ssh/openssh-4.2p1-hpn11.diff
60 Patch10:        %{name}-4.3p1-hpn11.patch
61 # Adds HPN (see p11) and an undocumented -z none cipher flag
62 # http://www.psc.edu/networking/projects/hpn-ssh/openssh-4.2p1-hpn11-none.diff
63 Patch11:        %{name}-4.3p1-hpn11-none.patch
64 Patch12:        %{name}-include.patch
65 URL:            http://www.openssh.com/
66 BuildRequires:  %{__perl}
67 BuildRequires:  autoconf
68 BuildRequires:  automake
69 %{?with_gnome:BuildRequires:    gnome-libs-devel}
70 %{?with_gtk:BuildRequires:      gtk+2-devel}
71 %{?with_kerberos5:BuildRequires:        heimdal-devel >= 0.7}
72 %{?with_libedit:BuildRequires:  libedit-devel}
73 %{?with_selinux:BuildRequires:  libselinux-devel}
74 BuildRequires:  libwrap-devel
75 %{?with_ldap:BuildRequires:     openldap-devel}
76 BuildRequires:  openssl-devel >= 0.9.7d
77 BuildRequires:  pam-devel
78 %{?with_gtk:BuildRequires:      pkgconfig}
79 BuildRequires:  rpmbuild(macros) >= 1.318
80 BuildRequires:  zlib-devel
81 Requires:       filesystem >= 3.0-11
82 Requires:       pam >= 0.99.7.1
83 Obsoletes:      ssh
84 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
85
86 %define         _sysconfdir     /etc/ssh
87 %define         _libexecdir     %{_libdir}/%{name}
88 %define         _privsepdir     /usr/share/empty
89
90 %description
91 Ssh (Secure Shell) a program for logging into a remote machine and for
92 executing commands in a remote machine. It is intended to replace
93 rlogin and rsh, and provide secure encrypted communications between
94 two untrusted hosts over an insecure network. X11 connections and
95 arbitrary TCP/IP ports can also be forwarded over the secure channel.
96
97 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
98 it up to date in terms of security and features, as well as removing
99 all patented algorithms to seperate libraries (OpenSSL).
100
101 This package includes the core files necessary for both the OpenSSH
102 client and server. To make this package useful, you should also
103 install openssh-clients, openssh-server, or both.
104 %if %{with hpn} || %{with hpn_none}
105 This release includes High Performance SSH/SCP patches from
106 http://www.psc.edu/networking/projects/hpn-ssh/ which are supposed
107 to increase throughput on fast connections with high RTT (20-150 msec).
108 See the website for '-w' values for your connection and /proc/sys TCP
109 values. BTW. in a LAN you have got generally RTT < 1 msec.
110 %endif
111 %if %{with hpn_none}
112 It also includes an undocumented '-z' option which switches
113 the cipher to none after authentication is completed. Data is
114 still secured from tampering and corruption in transit through
115 the use of the Message Authentication Code (MAC).
116 This option will significantly reduce the number of cpu cycles used
117 by the SSH/SCP process. This may allow some users to see significant
118 improvement in (sniffable) data tranfer rates.
119 %endif
120
121 %description -l de.UTF-8
122 OpenSSH (Secure Shell) stellt den Zugang zu anderen Rechnern her. Es
123 ersetzt telnet, rlogin, rexec und rsh und stellt eine sichere,
124 verschlüsselte Verbindung zwischen zwei nicht vertrauenswürdigen Hosts
125 über eine unsicheres Netzwerk her. X11 Verbindungen und beliebige
126 andere TCP/IP Ports können ebenso über den sicheren Channel
127 weitergeleitet werden.
128
129 %description -l es.UTF-8
130 SSH es un programa para accesar y ejecutar órdenes en computadores
131 remotos. Sustituye rlogin y rsh, y suministra un canal de comunicación
132 seguro entre dos servidores en una red insegura. Conexiones X11 y
133 puertas TCP/IP arbitrárias también pueden ser usadas por el canal
134 seguro.
135
136 OpenSSH es el resultado del trabajo del equipo de OpenBSD para
137 continuar la última versión gratuita de SSH, actualizándolo en
138 términos de seguridad y recursos,así también eliminando todos los
139 algoritmos patentados y colocándolos en bibliotecas separadas
140 (OpenSSL).
141
142 Este paquete contiene "port" para Linux de OpenSSH. Se debe instalar
143 también el paquete openssh-clients u openssh-server o ambos.
144
145 %description -l fr.UTF-8
146 OpenSSH (Secure Shell) fournit un accès à un système distant. Il
147 remplace telnet, rlogin, rexec et rsh, tout en assurant des
148 communications cryptées securisées entre deux hôtes non fiabilisés sur
149 un réseau non sécurisé. Des connexions X11 et des ports TCP/IP
150 arbitraires peuvent également être transmis sur le canal sécurisé.
151
152 %description -l it.UTF-8
153 OpenSSH (Secure Shell) fornisce l'accesso ad un sistema remoto.
154 Sostituisce telnet, rlogin, rexec, e rsh, e fornisce comunicazioni
155 sicure e crittate tra due host non fidati su una rete non sicura. Le
156 connessioni X11 ad una porta TCP/IP arbitraria possono essere
157 inoltrate attraverso un canale sicuro.
158
159 %description -l pl.UTF-8
160 Ssh (Secure Shell) to program służący do logowania się na zdalną
161 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
162 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
163 pomiędzy dwoma hostami.
164
165 Ten pakiet zawiera podstawowe pliki potrzebne zarówno po stronie
166 klienta jak i serwera OpenSSH. Aby był użyteczny, trzeba zainstalować
167 co najmniej jeden z pakietów: openssh-clients lub openssh-server.
168 %if %{with hpn} || %{with hpn_none}
169 Ta wersja zawiera łaty z projektu High Performance SSH/SCP
170 http://www.psc.edu/networking/projects/hpn-ssh/, które mają na celu
171 zwiększenie przepustowości transmisji dla szybkich połączeń
172 z dużym RTT (20-150 msec). Na stronie projektu znaleźć można
173 odpowednie dla danego połączenia wartości parametru '-w' oraz
174 opcje /proc/sys dla TCP. Nawiasem mówiąc w sieciach LAN RTT < 1 msec.
175 %endif
176 %if %{with hpn_none}
177 Obsługiwana jest również nieudokumentowana opcja '-z' odpowiedzialna
178 za wyłączenie szyfrowania danych po zakończeniu procesu uwierzytelniania.
179 Dane są zabezpieczone przed modyfikacją lub uszkodzeniem przez
180 stosowanie Message Authentication Code (MAC).
181 Opcja ta znacznie redukuje liczbę cykli procesora zużywanych przez
182 procesy SSH/SCP. W wybranych zastosowaniach może ona wpłynąć
183 na wyraźne przyspieszenie (podsłuchiwalnej) transmisji danych.
184 %endif
185
186 %description -l pt.UTF-8
187 OpenSSH (Secure Shell) fornece acesso a um sistema remoto. Substitui o
188 telnet, rlogin, rexec, e o rsh e fornece comunicações seguras e
189 cifradas entre duas máquinas sem confiança mútua sobre uma rede
190 insegura. Ligações X11 e portos TCP/IP arbitrários também poder ser
191 reenviados pelo canal seguro.
192
193 %description -l pt_BR.UTF-8
194 SSH é um programa para acessar e executar comandos em máquinas
195 remotas. Ele substitui rlogin e rsh, e provem um canal de comunicação
196 seguro entre dois hosts em uma rede insegura. Conexões X11 e portas
197 TCP/IP arbitrárias também podem ser usadas pelo canal seguro.
198
199 OpenSSH é o resultado do trabalho da equipe do OpenBSD em continuar a
200 última versão gratuita do SSH, atualizando-o em termos de segurança e
201 recursos, assim como removendo todos os algoritmos patenteados e
202 colocando-os em bibliotecas separadas (OpenSSL).
203
204 Esse pacote contém o "port" pra Linux do OpenSSH. Você deve instalar
205 também ou o pacote openssh-clients, ou o openssh-server, ou ambos.
206
207 %description -l ru.UTF-8
208 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
209 машину и для выполнения команд на удаленной машине. Она предназначена
210 для замены rlogin и rsh и обеспечивает безопасную шифрованную
211 коммуникацию между двумя хостами в сети, являющейся небезопасной.
212 Соединения X11 и любые порты TCP/IP могут также быть проведены через
213 безопасный канал.
214
215 OpenSSH - это переделка командой разработчиков OpenBSD последней
216 свободной версии SSH, доведенная до современного состояния в терминах
217 уровня безопасности и поддерживаемых возможностей. Все патентованные
218 алгоритмы вынесены в отдельные библиотеки (OpenSSL).
219
220 Этот пакет содержит файлы, необходимые как для клиента, так и для
221 сервера OpenSSH. Вам нужно будет установить еще openssh-clients,
222 openssh-server, или оба пакета.
223
224 %description -l uk.UTF-8
225 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
226 машини та для виконання команд на віддаленій машині. Вона призначена
227 для заміни rlogin та rsh і забезпечує безпечну шифровану комунікацію
228 між двома хостами в мережі, яка не є безпечною. З'єднання X11 та
229 довільні порти TCP/IP можуть також бути проведені через безпечний
230 канал.
231
232 OpenSSH - це переробка командою розробників OpenBSD останньої вільної
233 версії SSH, доведена до сучасного стану в термінах рівня безпеки та
234 підтримуваних можливостей. Всі патентовані алгоритми винесені до
235 окремих бібліотек (OpenSSL).
236
237 Цей пакет містить файли, необхідні як для клієнта, так і для сервера
238 OpenSSH. Вам потрібно буде ще встановити openssh-clients,
239 openssh-server, чи обидва пакети.
240
241 %package clients
242 Summary:        OpenSSH Secure Shell protocol clients
243 Summary(es.UTF-8):      Clientes de OpenSSH
244 Summary(pl.UTF-8):      Klienci protokołu Secure Shell
245 Summary(pt_BR.UTF-8):   Clientes do OpenSSH
246 Summary(ru.UTF-8):      OpenSSH - клиенты протокола Secure Shell
247 Summary(uk.UTF-8):      OpenSSH - клієнти протоколу Secure Shell
248 Group:          Applications/Networking
249 Requires:       %{name} = %{epoch}:%{version}-%{release}
250 Provides:       ssh-clients
251 Obsoletes:      ssh-clients
252
253 %description clients
254 Ssh (Secure Shell) a program for logging into a remote machine and for
255 executing commands in a remote machine. It is intended to replace
256 rlogin and rsh, and provide secure encrypted communications between
257 two untrusted hosts over an insecure network. X11 connections and
258 arbitrary TCP/IP ports can also be forwarded over the secure channel.
259
260 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
261 it up to date in terms of security and features, as well as removing
262 all patented algorithms to seperate libraries (OpenSSL).
263
264 This package includes the clients necessary to make encrypted
265 connections to SSH servers.
266
267 %description clients -l es.UTF-8
268 Este paquete incluye los clientes que se necesitan para hacer
269 conexiones codificadas con servidores SSH.
270
271 %description clients -l pl.UTF-8
272 Ssh (Secure Shell) to program służący do logowania się na zdalną
273 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
274 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
275 pomiędzy dwoma hostami.
276
277 Ten pakiet zawiera klientów służących do łączenia się z serwerami SSH.
278
279 %description clients -l pt_BR.UTF-8
280 Esse pacote inclui os clientes necessários para fazer conexões
281 encriptadas com servidores SSH.
282
283 %description clients -l ru.UTF-8
284 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
285 машину и для выполнения команд на удаленной машине.
286
287 Этот пакет содержит программы-клиенты, необходимые для установления
288 зашифрованных соединений с серверами SSH.
289
290 %description clients -l uk.UTF-8
291 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
292 машини та для виконання команд на віддаленій машині.
293
294 Цей пакет містить програми-клієнти, необхідні для встановлення
295 зашифрованих з'єднань з серверами SSH.
296
297 %package clients-agent-profile_d
298 Summary:        OpenSSH Secure Shell agent init script
299 Summary(pl.UTF-8):      Skrypt
300 Summary(pt_BR.UTF-8):   Clientes do OpenSSH
301 Summary(ru.UTF-8):      OpenSSH - клиенты протокола Secure Shell
302 Summary(uk.UTF-8):      OpenSSH - клієнти протоколу Secure Shell
303 Group:          Applications/Networking
304 Requires:       %{name}-clients = %{epoch}:%{version}-%{release}
305
306 %description clients-agent-profile_d
307 profile.d scripts for starting SSH agent.
308
309 %package clients-agent-xinitrc
310 Summary:        OpenSSH Secure Shell agent init script
311 Summary(pl.UTF-8):      Skrypt inicjujący agenta ssh przez xinitrc
312 Group:          Applications/Networking
313 Requires:       %{name}-clients-agent-profile_d = %{epoch}:%{version}-%{release}
314 Requires:       xinitrc
315
316 %description clients-agent-xinitrc
317 xinitrc scripts for starting SSH agent.
318
319
320 %package server
321 Summary:        OpenSSH Secure Shell protocol server (sshd)
322 Summary(de.UTF-8):      OpenSSH Secure Shell Protocol-Server (sshd)
323 Summary(es.UTF-8):      Servidor OpenSSH para comunicaciones codificadas
324 Summary(fr.UTF-8):      Serveur de protocole du shell sécurisé OpenSSH (sshd)
325 Summary(it.UTF-8):      Server OpenSSH per il protocollo Secure Shell (sshd)
326 Summary(pl.UTF-8):      Serwer protokołu Secure Shell (sshd)
327 Summary(pt.UTF-8):      Servidor do protocolo 'Secure Shell' OpenSSH (sshd)
328 Summary(pt_BR.UTF-8):   Servidor OpenSSH para comunicações encriptadas
329 Summary(ru.UTF-8):      OpenSSH - сервер протокола Secure Shell (sshd)
330 Summary(uk.UTF-8):      OpenSSH - сервер протоколу Secure Shell (sshd)
331 Group:          Networking/Daemons
332 Requires(post): chkconfig >= 0.9
333 Requires(post): grep
334 Requires(post,preun):   /sbin/chkconfig
335 Requires(postun):       /usr/sbin/userdel
336 Requires(pre):  /bin/id
337 Requires(pre):  /usr/sbin/useradd
338 Requires:       %{name} = %{epoch}:%{version}-%{release}
339 Requires:       /bin/login
340 Requires:       pam >= 0.99.7.1
341 Requires:       rc-scripts >= 0.4.0.18
342 Requires:       util-linux
343 Provides:       ssh-server
344 Provides:       user(sshd)
345
346 %description server
347 Ssh (Secure Shell) a program for logging into a remote machine and for
348 executing commands in a remote machine. It is intended to replace
349 rlogin and rsh, and provide secure encrypted communications between
350 two untrusted hosts over an insecure network. X11 connections and
351 arbitrary TCP/IP ports can also be forwarded over the secure channel.
352
353 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
354 it up to date in terms of security and features, as well as removing
355 all patented algorithms to seperate libraries (OpenSSL).
356
357 This package contains the secure shell daemon. The sshd is the server
358 part of the secure shell protocol and allows ssh clients to connect to
359 your host.
360
361 %description server -l de.UTF-8
362 Dieses Paket installiert den sshd, den Server-Teil der OpenSSH.
363
364 %description server -l es.UTF-8
365 Este paquete contiene el servidor SSH. sshd es la parte servidor del
366 protocolo secure shell y permite que clientes ssh se conecten a su
367 servidor.
368
369 %description server -l fr.UTF-8
370 Ce paquetage installe le 'sshd', partie serveur de OpenSSH.
371
372 %description server -l it.UTF-8
373 Questo pacchetto installa sshd, il server di OpenSSH.
374
375 %description server -l pl.UTF-8
376 Ssh (Secure Shell) to program służący do logowania się na zdalną
377 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
378 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
379 pomiędzy dwoma hostami.
380
381 Ten pakiet zawiera serwer sshd (do którego mogą łączyć się klienci
382 ssh).
383
384 %description server -l pt.UTF-8
385 Este pacote intala o sshd, o servidor do OpenSSH.
386
387 %description server -l pt_BR.UTF-8
388 Esse pacote contém o servidor SSH. O sshd é a parte servidor do
389 protocolo secure shell e permite que clientes ssh se conectem ao seu
390 host.
391
392 %description server -l ru.UTF-8
393 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
394 машину и для выполнения команд на удаленной машине.
395
396 Этот пакет содержит sshd - "демон" Secure Shell. sshd - это серверная
397 часть протокола Secure Shell, позволяющая клиентам ssh соединяться с
398 вашим хостом.
399
400 %description server -l uk.UTF-8
401 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
402 машини та для виконання команд на віддаленій машині.
403
404 Цей пакет містить sshd - "демон" Secure Shell. sshd - це серверна
405 частина протоколу Secure Shell, яка дозволяє клієнтам ssh зв'язуватись
406 з вашим хостом.
407
408 %package gnome-askpass
409 Summary:        OpenSSH GNOME passphrase dialog
410 Summary(de.UTF-8):      OpenSSH GNOME Passwort-Dialog
411 Summary(es.UTF-8):      Diálogo para introducción de passphrase para GNOME
412 Summary(fr.UTF-8):      Dialogue pass-phrase GNOME d'OpenSSH
413 Summary(it.UTF-8):      Finestra di dialogo GNOME per la frase segreta di OpenSSH
414 Summary(pl.UTF-8):      Odpytywacz hasła OpenSSH dla GNOME
415 Summary(pt.UTF-8):      Diálogo de pedido de senha para GNOME do OpenSSH
416 Summary(pt_BR.UTF-8):   Diálogo para entrada de passphrase para GNOME
417 Summary(ru.UTF-8):      OpenSSH - диалог ввода ключевой фразы (passphrase) для GNOME
418 Summary(uk.UTF-8):      OpenSSH - діалог вводу ключової фрази (passphrase) для GNOME
419 Group:          Applications/Networking
420 Requires:       %{name} = %{epoch}:%{version}-%{release}
421 Obsoletes:      openssh-askpass
422 Obsoletes:      ssh-askpass
423 Obsoletes:      ssh-extras
424
425 %description gnome-askpass
426 Ssh (Secure Shell) a program for logging into a remote machine and for
427 executing commands in a remote machine. It is intended to replace
428 rlogin and rsh, and provide secure encrypted communications between
429 two untrusted hosts over an insecure network. X11 connections and
430 arbitrary TCP/IP ports can also be forwarded over the secure channel.
431
432 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
433 it up to date in terms of security and features, as well as removing
434 all patented algorithms to seperate libraries (OpenSSL).
435
436 This package contains the GNOME passphrase dialog.
437
438 %description gnome-askpass -l es.UTF-8
439 Este paquete contiene un programa que abre una caja de diálogo para
440 entrada de passphrase en GNOME.
441
442 %description gnome-askpass -l pl.UTF-8
443 Ssh (Secure Shell) to program służący do logowania się na zdalną
444 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
445 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
446 pomiędzy dwoma hostami.
447
448 Ten pakiet zawiera ,,odpytywacz hasła'' dla GNOME.
449
450 %description gnome-askpass -l pt_BR.UTF-8
451 Esse pacote contém um programa que abre uma caixa de diálogo para
452 entrada de passphrase no GNOME.
453
454 %description gnome-askpass -l ru.UTF-8
455 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
456 машину и для выполнения команд на удаленной машине.
457
458 Этот пакет содержит диалог ввода ключевой фразы для использования под
459 GNOME.
460
461 %description gnome-askpass -l uk.UTF-8
462 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
463 машини та для виконання команд на віддаленій машині.
464
465 Цей пакет містить діалог вводу ключової фрази для використання під
466 GNOME.
467
468 %prep
469 %setup -q
470 %patch0 -p1
471 %patch2 -p1
472 %patch3 -p1
473 %patch4 -p1
474 %{?with_ldap:%patch5 -p1}
475 %{?with_kerberos5:%patch6 -p1}
476 #%patch7 -p1
477 %patch8 -p1
478 %patch9 -p1
479 %{?with_hpn:%patch10 -p1}
480 %{?with_hpn_none:%patch11 -p1}
481 %patch12 -p1
482
483 %build
484 cp /usr/share/automake/config.sub .
485 %{__aclocal}
486 %{__autoconf}
487 %{?with_chroot:CPPFLAGS="-DCHROOT"}
488 %configure \
489         PERL=%{__perl} \
490         --with-dns \
491         --with-pam \
492         --with-mantype=man \
493         --with-md5-passwords \
494         --with-ipaddr-display \
495         %{?with_libedit:--with-libedit} \
496         --with-4in6 \
497         --disable-suid-ssh \
498         --with-tcp-wrappers \
499         %{?with_ldap:--with-libs="-lldap -llber"} \
500         %{?with_ldap:--with-cppflags="-DWITH_LDAP_PUBKEY"} \
501         %{?with_kerberos5:--with-kerberos5} \
502         --with-privsep-path=%{_privsepdir} \
503         --with-pid-dir=%{_localstatedir}/run \
504         --with-xauth=/usr/bin/xauth \
505         --enable-utmpx \
506         --enable-wtmpx
507
508 echo '#define LOGIN_PROGRAM                "/bin/login"' >>config.h
509
510 %{__make}
511
512 cd contrib
513 %if %{with gnome}
514 %{__make} gnome-ssh-askpass1 \
515         CC="%{__cc} %{rpmldflags} %{rpmcflags}"
516 %endif
517 %if %{with gtk}
518 %{__make} gnome-ssh-askpass2 \
519         CC="%{__cc} %{rpmldflags} %{rpmcflags}"
520 %endif
521
522 %install
523 rm -rf $RPM_BUILD_ROOT
524 install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/{pam.d,rc.d/init.d,sysconfig,security,env.d}} \
525         $RPM_BUILD_ROOT%{_libexecdir}/ssh
526 install -d $RPM_BUILD_ROOT/etc/{profile.d,X11/xinit/xinitrc.d}
527
528 %{__make} install \
529         DESTDIR=$RPM_BUILD_ROOT
530
531 install %{SOURCE4} $RPM_BUILD_ROOT/etc/pam.d/sshd
532 install %{SOURCE6} $RPM_BUILD_ROOT/etc/pam.d/passwdssh
533 install %{SOURCE5} $RPM_BUILD_ROOT/etc/sysconfig/sshd
534 install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
535 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/ssh_config
536 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/sshd_config
537 install %{SOURCE11} $RPM_BUILD_ROOT/etc/profile.d
538 ln -sf  /etc/profile.d/ssh-agent.sh $RPM_BUILD_ROOT/etc/X11/xinit/xinitrc.d/ssh-agent.sh
539 install %{SOURCE12} $RPM_BUILD_ROOT%{_sysconfdir}
540
541 bzip2 -dc %{SOURCE7} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
542
543 %if %{with gnome}
544 install contrib/gnome-ssh-askpass1 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
545 %endif
546 %if %{with gtk}
547 install contrib/gnome-ssh-askpass2 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
548 %endif
549 %if %{with gnome} || %{with gtk}
550 cat << EOF >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_SERVER
551 #GNOME_SSH_ASKPASS_GRAB_SERVER="true"
552 EOF
553 cat << EOF >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_POINTER
554 #GNOME_SSH_ASKPASS_GRAB_POINTER="true"
555 EOF
556 ln -s %{_libexecdir}/ssh/ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/ssh-askpass
557 %endif
558
559 rm -f   $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
560 echo ".so ssh.1" > $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
561
562 touch $RPM_BUILD_ROOT/etc/security/blacklist.sshd
563
564 %if "%{_lib}" != "lib"
565 find $RPM_BUILD_ROOT%{_sysconfdir} -type f -print0 | xargs -0 sed -i -e 's#%{_prefix}/lib#%{_libdir}#'
566 %endif
567
568 cat << 'EOF' > $RPM_BUILD_ROOT/etc/env.d/SSH_ASKPASS
569 #SSH_ASKPASS="%{_libexecdir}/ssh-askpass"
570 EOF
571
572 %clean
573 rm -rf $RPM_BUILD_ROOT
574
575 %post clients
576 %env_update
577
578 %postun clients
579 %env_update
580
581 %post gnome-askpass
582 %env_update
583
584 %postun gnome-askpass
585 %env_update
586
587 %pre server
588 %useradd -P %{name}-server -u 40 -d %{_privsepdir} -s /bin/false -c "OpenSSH PrivSep User" -g nobody sshd
589
590 %post server
591 /sbin/chkconfig --add sshd
592 %service sshd reload "openssh daemon"
593 if ! grep -qs ssh /etc/security/passwd.conf ; then
594         umask 022
595         echo "ssh" >> /etc/security/passwd.conf
596 fi
597
598 %preun server
599 if [ "$1" = "0" ]; then
600         %service sshd stop
601         /sbin/chkconfig --del sshd
602 fi
603
604 %postun server
605 if [ "$1" = "0" ]; then
606         %userremove sshd
607 fi
608
609 %files
610 %defattr(644,root,root,755)
611 %doc *.RNG TODO README OVERVIEW CREDITS Change*
612 %attr(755,root,root) %{_bindir}/ssh-key*
613 %{_mandir}/man1/ssh-key*.1*
614 %dir %{_sysconfdir}
615 %dir %{_libexecdir}
616
617 %files clients
618 %defattr(644,root,root,755)
619 %attr(755,root,root) %{_bindir}/ssh
620 %attr(755,root,root) %{_bindir}/slogin
621 %attr(755,root,root) %{_bindir}/sftp
622 %attr(755,root,root) %{_bindir}/ssh-agent
623 %attr(755,root,root) %{_bindir}/ssh-add
624 %attr(755,root,root) %{_bindir}/scp
625 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh_config
626 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/SSH_ASKPASS
627 %{_mandir}/man1/scp.1*
628 %{_mandir}/man1/ssh.1*
629 %{_mandir}/man1/slogin.1*
630 %{_mandir}/man1/sftp.1*
631 %{_mandir}/man1/ssh-agent.1*
632 %{_mandir}/man1/ssh-add.1*
633 %{_mandir}/man5/ssh_config.5*
634 %lang(it) %{_mandir}/it/man1/ssh.1*
635 %lang(it) %{_mandir}/it/man5/ssh_config.5*
636 %lang(pl) %{_mandir}/pl/man1/scp.1*
637 %lang(zh_CN) %{_mandir}/zh_CN/man1/scp.1*
638
639 # for host-based auth (suid required for accessing private host key)
640 #%attr(4755,root,root) %{_libexecdir}/ssh-keysign
641 #%{_mandir}/man8/ssh-keysign.8*
642
643 %files clients-agent-profile_d
644 %defattr(644,root,root,755)
645 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh-agent.conf
646 %attr(755,root,root) /etc/profile.d/ssh-agent.sh
647
648 %files clients-agent-xinitrc
649 %defattr(644,root,root,755)
650 %attr(755,root,root) /etc/X11/xinit/xinitrc.d/ssh-agent.sh
651
652 %files server
653 %defattr(644,root,root,755)
654 %attr(755,root,root) %{_sbindir}/sshd
655 %attr(755,root,root) %{_libexecdir}/sftp-server
656 %attr(755,root,root) %{_libexecdir}/ssh-keysign
657 %{_mandir}/man8/sshd.8*
658 %{_mandir}/man8/sftp-server.8*
659 %{_mandir}/man8/ssh-keysign.8*
660 %{_mandir}/man5/sshd_config.5*
661 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sshd_config
662 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/sshd
663 %attr(640,root,root) %{_sysconfdir}/moduli
664 %attr(754,root,root) /etc/rc.d/init.d/sshd
665 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/sshd
666 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.sshd
667
668 %if %{with gnome} || %{with gtk}
669 %files gnome-askpass
670 %defattr(644,root,root,755)
671 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/GNOME_SSH_ASKPASS*
672 %dir %{_libexecdir}/ssh
673 %attr(755,root,root) %{_libexecdir}/ssh/ssh-askpass
674 %attr(755,root,root) %{_libexecdir}/ssh-askpass
675 %endif
This page took 0.243164 seconds and 3 git commands to generate.