]> git.pld-linux.org Git - packages/openslp.git/blob - openslp.spec
- raw version.
[packages/openslp.git] / openslp.spec
1 %define ver 0.8.1
2 %define rel 1
3 %define name openslp
4 %define libver 0.0.2
5
6 Name            : openslp
7 Version         : %ver
8 Release         : %rel
9 Group           : Server/Network
10 Provides        : openslp libslp.so slpd
11 Summary         : OpenSLP implementation of Service Location Protocol V2 
12 Copyright       : Caldera Systems (LGPL)
13 Packager        : Matthew Peterson <mpeterson@calderasystems.com>
14 URL             : http://www.openslp.org/
15 BuildRoot       : /tmp/%{name}-%{ver}
16 Source0         : ftp://openslp.org/pub/openslp/%{name}-%{ver}/%{name}-%{ver}.tar.gz
17
18
19 %Description
20 Service Location Protocol is an IETF standards track protocol that
21 provides a framework to allow networking applications to discover the
22 existence, location, and configuration of networked services in
23 enterprise networks.
24
25 OpenSLP is an open source implementation of the SLPv2 protocol as defined 
26 by RFC 2608 and RFC 2614.  This package include the daemon, libraries, header 
27 files and documentation
28
29 %Prep
30 %setup
31
32 %Build
33 #./configure --with-RPM-prefix=$RPM_BUILD_ROOT
34 ./autogen.sh
35 ./configure --prefix=$RPM_BUILD_ROOT
36 ./configure
37 make
38
39 %Install
40 %{mkDESTDIR}
41 make install 
42 mkdir -p $DESTDIR/etc/rc.d/init.d
43 install -m 755 etc/slpd.all_init $DESTDIR/etc/rc.d/init.d/slpd
44
45 %Clean
46 rm -rf $RPM_BUILD_ROOT
47
48 %Post
49 rm -f /usr/lib/libslp.so
50 ln -s /usr/lib/libslp.so.%{libver} /usr/lib/libslp.so
51 /sbin/ldconfig
52
53 if [ -d '/usr/lib/OpenLinux' ]; then 
54 cat <<EOD  > /etc/sysconfig/daemons/slpd
55 IDENT=slp
56 DESCRIPTIVE="SLP Service Agent"
57 ONBOOT="yes"
58 EOD
59 fi
60
61 if [ -x /sbin/chkconfig ]; then
62   chkconfig --add slpd
63 else 
64   for i in 2 3 4 5; do
65     ln -sf /etc/rc.d/init.d/slpd /etc/rc.d/rc$i.d/S13slpd
66   done
67   for i in 0 1 6; do
68     ln -sf /etc/rc.d/init.d/slpd /etc/rc.d/rc$i.d/K87slpd
69   done
70 fi
71
72 %PreUn
73 rm -f /etc/sysconfig/daemons/slpd
74 if [ "$1" = "0" ]; then
75   if [ -x /sbin/chkconfig ]; then
76     /sbin/chkconfig --del slpd
77   else
78     for i in 2 3 4 5; do
79       rm -f /etc/rc.d/rc$i.d/S13slpd
80     done
81     for i in 0 1 6; do
82       rm -f /etc/rc.d/rc$i.d/K87slpd
83     done
84   fi
85 fi
86
87 %PostUn 
88 if [ "$1" = "0" ]; then
89   rm -f /usr/lib/libslp.so
90 fi
91 /sbin/ldconfig
92
93
94 %Files
95 %defattr(-,root,root)
96 %doc AUTHORS COPYING INSTALL NEWS README doc/*
97 %config /etc/slp.conf
98 %config /etc/slp.reg
99 /etc/rc.d/init.d/slpd
100 /usr/lib/libslp*
101 /usr/include/slp.h
102 /usr/sbin/slpd
103
104
105 %ChangeLog
106 * Wed Jul 17 2000 mpeterson@calderasystems.com
107         Added lisa stuff
108         
109 * Thu Jul 7 2000 david.mccormack@ottawa.com
110         Made it work with the new autoconf/automake scripts.
111  
112 * Wed Apr 27 2000 mpeterson
113         started
This page took 0.09213 seconds and 4 git commands to generate.