]> git.pld-linux.org Git - packages/openslp.git/blob - openslp.spec
- updated 1.0.11
[packages/openslp.git] / openslp.spec
1 Summary:        OpenSLP implementation of Service Location Protocol V2
2 Summary(de):    Open source Implementierung des Service Location Protocols V2
3 Summary(es):    Implementación open source del Service Location Protocol V2
4 Summary(fr):    Implémentation Open Source du Service Location Protocol V2
5 Summary(it):    Implementazione open source del Service Location Protocol V2
6 Summary(pl):    Otwarta implementacja Service Location Protocol V2
7 Summary(pt):    Implementação 'open source' do protocolo Service Location Protocol V2
8 Name:           openslp
9 Version:        1.0.11
10 Release:        1
11 License:        LGPL
12 Group:          Networking/Daemons
13 Source0:        http://dl.sourceforge.net/openslp/%{name}-%{version}.tar.gz
14 Source1:        %{name}.init
15 URL:            http://www.openslp.org/
16 BuildRequires:  autoconf
17 BuildRequires:  automake
18 BuildRequires:  libtool
19 BuildRequires:  openssl-devel >= 0.9.7b
20 Prereq:         rc-scripts
21 Prereq:         /sbin/chkconfig
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %define         _sysconfdir             /etc/openslp
25
26 %description
27 Service Location Protocol is an IETF standards track protocol that
28 provides a framework to allow networking applications to discover the
29 existence, location, and configuration of networked services in
30 enterprise networks.
31
32 OpenSLP is an open source implementation of the SLPv2 protocol as
33 defined by RFC 2608 and RFC 2614. This package include the daemon and
34 libraries.
35
36 %description -l de
37 Das Service Location Protocol ist ein IETF standard Protokoll welches
38 ein Gerüst bereitstellt um es Netzwerk-fähigen Anwendungen zu
39 ermöglichen die Existenz, den Ort und die Konfiguration von
40 Netzwerkdiensten in Unternehmensnetzwerken zu entdecken.
41
42 %description -l es
43 El Protocolo de Localización de Servicios es un protocolo de
44 seguimiento acorde al estándar IETF que proporciona un entorno para
45 permitir a las aplicaciones de red descubrir la existencia,
46 localización y configuración de servicios de red en redes
47 empresariales.
48
49 %description -l fr
50 Service Location Protocol est un protocole de suivi des normes IETF
51 qui fournit un cadre permettant à des applications réseau de découvrir
52 l'existence, l'emplacement et la configuration de services de réseau
53 dans les réseaux d'entreprise.
54
55 %description -l it
56 Il Service Location Protocol (protocollo di localizzazione di servizi)
57 è un protocollo standard IETF che fornisce un'infrastruttura per
58 permettere alle applicazioni di rete di scoprire l'esistenza, la
59 localizzazione e la configurazione dei servizi nelle reti delle
60 aziende.
61
62 %description -l pl
63 Service Location Protocol jest zgodnym ze standardem IETF protoko³em
64 pozwalaj±cym aplikacjom sieciowym na badanie istnienia, po³o¿enia i
65 konfiguracji us³ug sieciowych.
66
67 OpenSLP jest otwart± implementacj± protoko³u SLPv2 zdefiniowanego w
68 RFC 2608 i RFC 2614. Ten pakiet zawiera demona i biblioteki.
69
70 %description -l pt
71 O Service Location Protocol é um protocolo normalizado pelo IETF que
72 oferece uma plataforma para permitir às aplicações de rede que
73 descubram a existência, localização e a configuração dos serviços de
74 rede nas redes duma empresa.
75
76 %package devel
77 Summary:        OpenSLP development files
78 Summary(pl):    Czê¶æ OpenSLP dla programistów
79 Group:          Development/Libraries
80 Requires:       %{name} = %{version}
81
82 %description devel
83 OpenSLP development files.
84
85 %description devel -l pl
86 Pliki nag³ówkowe OpenSLP.
87
88 %package static
89 Summary:        OpenSLP static libraries
90 Summary(pl):    Biblioteki statyczne OpenSLP
91 Group:          Development/Libraries
92 Requires:       %{name}-devel = %{version}
93
94 %description static
95 OpenSLP static libraries.
96
97 %description static -l pl
98 Biblioteki statyczne OpenSLP.
99
100 %prep
101 %setup -q
102
103 %build
104 rm -f missing
105 %{__libtoolize}
106 %{__aclocal}
107 %{__autoconf}
108 %{__automake}
109 %configure \
110         --enable-slpv1 \
111         --enable-slpv2-security \
112         --disable-predicates
113
114 %{__make}
115
116 %install
117 rm -rf $RPM_BUILD_ROOT
118 install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig}
119
120 %{__make} install \
121         DESTDIR=$RPM_BUILD_ROOT
122
123 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/slpd
124
125 %clean
126 rm -rf $RPM_BUILD_ROOT
127
128 %post
129 /sbin/ldconfig
130 /sbin/chkconfig --add slpd
131 if [ -r /var/lock/subsys/slpd ]; then
132         /etc/rc.d/init.d/slpd restart >&2
133 else
134         echo "Run \"/etc/rc.d/init.d/slpd start\" to start OpenSLP server."
135 fi
136
137
138 %preun
139 if [ "$1" = "0" ]; then
140         if [ -f /var/lock/subsys/slpd ]; then
141                 /etc/rc.d/init.d/slpd stop
142         fi
143         /sbin/chkconfig --del slpd
144 fi
145
146 %postun -p /sbin/ldconfig
147
148 %files
149 %defattr(644,root,root,755)
150 %dir %{_sysconfdir}
151 %config %{_sysconfdir}/slp.conf
152 %config %{_sysconfdir}/slp.reg
153 %config %{_sysconfdir}/slp.spi
154 %attr(754,root,root) /etc/rc.d/init.d/slpd
155 %attr(755,root,root) %{_sbindir}/slpd
156 %attr(755,root,root) %{_bindir}/*
157 %attr(755,root,root) %{_libdir}/lib*.so.*.*
158
159 %files devel
160 %defattr(644,root,root,755)
161 %doc AUTHORS NEWS README doc/*
162 %{_includedir}/*
163 %attr(755,root,root) %{_libdir}/lib*.so
164 %{_libdir}/lib*.la
165
166 %files static
167 %defattr(644,root,root,755)
168 %{_libdir}/lib*.a
This page took 0.111499 seconds and 4 git commands to generate.