]> git.pld-linux.org Git - packages/openslp.git/blob - openslp.spec
- massive attack: no need for 755 for *.la
[packages/openslp.git] / openslp.spec
1 Summary:        OpenSLP implementation of Service Location Protocol V2
2 Summary(de):    Open source Implementierung des Service Location Protocols V2
3 Summary(es):    Implementación open source del Service Location Protocol V2
4 Summary(fr):    Implémentation Open Source du Service Location Protocol V2
5 Summary(it):    Implementazione open source del Service Location Protocol V2
6 Summary(pl):    Otwarta implementacja Service Location Protocol V2
7 Summary(pt):    Implementação 'open source' do protocolo Service Location Protocol V2
8 Name:           openslp
9 Version:        1.0.9
10 Release:        1
11 License:        LGPL
12 Group:          Networking/Daemons
13 # Source0:      http://prdownloads.sourceforge.net/openslp/%{name}-%{version}.tar.gz
14 Source0:        ftp://ftp.sourceforge.net/pub/sourceforge/openslp/%{name}-%{version}.tar.gz
15 Source1:        %{name}.init
16 URL:            http://www.openslp.org/
17 BuildRequires:  autoconf
18 BuildRequires:  automake
19 BuildRequires:  libtool
20 BuildRequires:  openssl-devel >= 0.9.6b
21 Prereq:         rc-scripts
22 Prereq:         /sbin/chkconfig
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %define         _sysconfdir             /etc/openslp
26
27 %description
28 Service Location Protocol is an IETF standards track protocol that
29 provides a framework to allow networking applications to discover the
30 existence, location, and configuration of networked services in
31 enterprise networks.
32
33 OpenSLP is an open source implementation of the SLPv2 protocol as
34 defined by RFC 2608 and RFC 2614. This package include the daemon and
35 libraries.
36
37 %description -l de
38 Das Service Location Protocol ist ein IETF standard Protokoll welches
39 ein Gerüst bereitstellt um es Netzwerk-fähigen Anwendungen zu
40 ermöglichen die Existenz, den Ort und die Konfiguration von
41 Netzwerkdiensten in Unternehmensnetzwerken zu entdecken.
42
43 %description -l es
44 El Protocolo de Localización de Servicios es un protocolo de
45 seguimiento acorde al estándar IETF que proporciona un entorno para
46 permitir a las aplicaciones de red descubrir la existencia,
47 localización y configuración de servicios de red en redes
48 empresariales.
49
50 %description -l fr
51 Service Location Protocol est un protocole de suivi des normes IETF
52 qui fournit un cadre permettant à des applications réseau de découvrir
53 l'existence, l'emplacement et la configuration de services de réseau
54 dans les réseaux d'entreprise.
55
56 %description -l it
57 Il Service Location Protocol (protocollo di localizzazione di servizi)
58 è un protocollo standard IETF che fornisce un'infrastruttura per
59 permettere alle applicazioni di rete di scoprire l'esistenza, la
60 localizzazione e la configurazione dei servizi nelle reti delle
61 aziende.
62
63 %description -l pl
64 Service Location Protocol jest zgodnym ze standardem IETF protoko³em
65 pozwalaj±cym aplikacjom sieciowym na badanie istnienia, po³o¿enia i
66 konfiguracji us³ug sieciowych.
67
68 OpenSLP jest otwart± implementacj± protoko³u SLPv2 zdefiniowanego w
69 RFC 2608 i RFC 2614. Ten pakiet zawiera demona i biblioteki.
70
71 %description -l pt
72 O Service Location Protocol é um protocolo normalizado pelo IETF que
73 oferece uma plataforma para permitir às aplicações de rede que
74 descubram a existência, localização e a configuração dos serviços de
75 rede nas redes duma empresa.
76
77 %package devel
78 Summary:        OpenSLP development files
79 Summary(pl):    Czê¶æ OpenSLP dla programistów
80 Group:          Development/Libraries
81 Requires:       %{name} = %{version}
82
83 %description devel
84 OpenSLP development files.
85
86 %description devel -l pl
87 Pliki nag³ówkowe OpenSLP.
88
89 %package static
90 Summary:        OpenSLP static libraries
91 Summary(pl):    Biblioteki statyczne OpenSLP
92 Group:          Development/Libraries
93 Requires:       %{name}-devel = %{version}
94
95 %description static
96 OpenSLP static libraries.
97
98 %description static -l pl
99 Biblioteki statyczne OpenSLP.
100
101 %prep
102 %setup -q
103
104 %build
105 rm -f missing
106 %{__libtoolize}
107 %{__aclocal}
108 %{__autoconf}
109 %{__automake}
110 %configure \
111         --enable-slpv1 \
112         --enable-slpv2-security \
113         --disable-predicates
114
115 %{__make}
116
117 %install
118 rm -rf $RPM_BUILD_ROOT
119 install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig}
120
121 %{__make} install \
122         DESTDIR=$RPM_BUILD_ROOT
123
124 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/slpd
125
126 gzip -9nf AUTHORS NEWS README doc/rfc/*txt
127
128 %clean
129 rm -rf $RPM_BUILD_ROOT
130
131 %post
132 /sbin/ldconfig
133 /sbin/chkconfig --add slpd
134 if [ -r /var/lock/subsys/slpd ]; then
135         /etc/rc.d/init.d/slpd restart >&2
136 else
137         echo "Run \"/etc/rc.d/init.d/slpd start\" to start OpenSLP server."
138 fi
139
140
141 %preun
142 if [ "$1" = "0" ]; then
143         if [ -f /var/lock/subsys/slpd ]; then
144                 /etc/rc.d/init.d/slpd stop
145         fi
146         /sbin/chkconfig --del slpd
147 fi
148
149 %postun -p /sbin/ldconfig
150
151 %files
152 %defattr(644,root,root,755)
153 %dir %{_sysconfdir}
154 %config %{_sysconfdir}/slp.conf
155 %config %{_sysconfdir}/slp.reg
156 %config %{_sysconfdir}/slp.spi
157 %attr(754,root,root) /etc/rc.d/init.d/slpd
158 %attr(755,root,root) %{_sbindir}/slpd
159 %attr(755,root,root) %{_bindir}/*
160 %attr(755,root,root) %{_libdir}/lib*.so.*.*
161
162 %files devel
163 %defattr(644,root,root,755)
164 %doc *.gz doc/*
165 %{_includedir}/*
166 %attr(755,root,root) %{_libdir}/lib*.so
167 %{_libdir}/lib*.la
168
169 %files static
170 %defattr(644,root,root,755)
171 %{_libdir}/lib*.a
This page took 0.037795 seconds and 4 git commands to generate.