]> git.pld-linux.org Git - packages/opal.git/blob - opal.spec
b308df4b2068ba5d08995df34044dde5b64219f6
[packages/opal.git] / opal.spec
1 #
2 # Don't touch this! strip removes all symbols from library
3 %define         no_install_post_strip           1
4 #
5 Summary:        Open Phone Abstraction Library (aka OpenH323 v2)
6 Summary(pl.UTF-8):      Biblioteka Open Phone Abstraction Library (aka OpenH323 v2)
7 Name:           opal
8 Version:        2.2.11
9 Release:        2
10 License:        MPL
11 Group:          Libraries
12 Source0:        http://ftp.gnome.org/pub/gnome/sources/opal/2.2/%{name}-%{version}.tar.bz2
13 # Source0-md5:  b759033c85a1351e00ad1a29e4f50f26
14 #Source0:       http://www.ekiga.org/admin/downloads/latest/sources/sources/%{name}-%{version}.tar.gz
15 Patch0:         %{name}-libname.patch
16 Patch1:         %{name}-mak_files.patch
17 URL:            http://www.openh323.org/
18 BuildRequires:  libstdc++-devel
19 BuildRequires:  pwlib-devel >= 1.10.10
20 BuildRequires:  sed >= 4.0
21 BuildRequires:  speex-devel >= 1:1.1.5
22 %requires_eq    pwlib
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 The OPAL project aims to create a full featured, interoperable,
27 Open Source implementation of the ITU H.323 teleconferencing protocol
28 that can be used by personal developers and commercial users without
29 charge.
30
31 %description -l pl.UTF-8
32 Celem projektu OPAL jest stworzenie w pełni funkcjonalnej i
33 wyposażonej implementacji protokołu telekonferencyjnego ITU H.323,
34 który może być używany przez użytkowników prywatnych i komercyjnych
35 bez opłat.
36
37 %package devel
38 Summary:        Opal development files
39 Summary(pl.UTF-8):      Pliki dla developerów Opal
40 Group:          Development/Libraries
41 Requires:       %{name} = %{version}-%{release}
42 Requires:       libstdc++-devel
43 Requires:       pwlib-devel
44
45 %description devel
46 Header files and libraries for developing applications that use
47 OPAL.
48
49 %description devel -l pl.UTF-8
50 Pliki nagłówkowe i biblioteki konieczne do rozwoju aplikacji
51 używających OPAL.
52
53 %package static
54 Summary:        OPAL static libraries
55 Summary(pl.UTF-8):      Biblioteki statyczne OPAL
56 Group:          Development/Libraries
57 Requires:       %{name}-devel = %{version}-%{release}
58
59 %description static
60 OPAL static libraries.
61
62 %description static -l pl.UTF-8
63 Biblioteki statyczne OPAL.
64
65 %prep
66 %setup -q
67 %patch0 -p1
68 %patch1 -p1
69
70 %build
71 PWLIBDIR=%{_prefix}; export PWLIBDIR
72 OPALDIR=`pwd`; export OPALDIR
73 OPAL_BUILD="yes"; export OPAL_BUILD
74 %configure 
75
76 %{__make} %{?debug:debug}%{!?debug:opt} \
77         CC="%{__cc}" \
78         CPLUS="%{__cxx}" \
79         OPTCCFLAGS="%{rpmcflags} %{!?debug:-DNDEBUG}"
80
81 %{__make} -C samples/simple %{?debug:debug}%{!?debug:opt} \
82         CC="%{__cc}" \
83         CPLUS=%{__cxx} \
84         OPTCCFLAGS="%{rpmcflags} %{!?debug:-DNDEBUG}"
85
86 %install
87 rm -rf $RPM_BUILD_ROOT
88 install -d $RPM_BUILD_ROOT{%{_libdir},%{_includedir}/opal,%{_bindir},%{_datadir}/%{name}}
89
90 %{__make} install \
91         DESTDIR=$RPM_BUILD_ROOT
92
93 # using cp as install won't preserve links
94 cp -d lib/lib*.a $RPM_BUILD_ROOT%{_libdir}
95 install version.h $RPM_BUILD_ROOT%{_includedir}/opal
96 install samples/simple/obj_*/simpleopal $RPM_BUILD_ROOT%{_bindir}
97 sed -i -e 's@\$(OPALDIR)/include@&/opal@' \
98        -e 's@\$(OPALDIR)/lib@\$(OPALDIR)/%{_lib}@' $RPM_BUILD_ROOT%{_datadir}/opal/opal_inc.mak
99
100 %clean
101 rm -rf $RPM_BUILD_ROOT
102
103 %post   -p /sbin/ldconfig
104 %postun -p /sbin/ldconfig
105
106 %files
107 %defattr(644,root,root,755)
108 %attr(755,root,root) %{_bindir}/*
109 %attr(755,root,root) %{_libdir}/lib*.so.*.*
110
111 %files devel
112 %defattr(644,root,root,755)
113 %attr(755,root,root) %{_libdir}/*.so
114 %{_includedir}/*
115 %{_datadir}/%{name}
116
117 %files static
118 %defattr(644,root,root,755)
119 %{_libdir}/*.a
This page took 0.07051 seconds and 3 git commands to generate.