]> git.pld-linux.org Git - packages/ogdi.git/blob - ogdi.spec
- shellglob fix
[packages/ogdi.git] / ogdi.spec
1 # TODO: separate gltpd to -server package, add init script (requires portmap)
2 #
3 # Conditional build:
4 %bcond_without  tcl             # disable gui and nviz
5 %bcond_without  odbc    # disable unixODBC support
6 #
7 Summary:        Open Geographic Datastore Interface
8 Summary(pl):    OGDI - otwarty interfejs do danych geograficznych
9 Name:           ogdi
10 Version:        3.1.5
11 Release:        2
12 License:        BSD-like
13 Group:          Applications
14 Source0:        http://dl.sourceforge.net/ogdi/%{name}-%{version}.tar.gz
15 # Source0-md5:  9ccf8202b63875a68ded23588bd49544
16 Source1:        http://ogdi.sourceforge.net/ogdi.pdf
17 # Source1-md5:  029a8cdcd36bee73df92196ee769040e
18 Patch0:         %{name}-driversdir.patch
19 Patch1:         %{name}-pic.patch
20 URL:            http://ogdi.sourceforge.net/
21 BuildRequires:  autoconf
22 BuildRequires:  expat-devel
23 BuildRequires:  proj-devel
24 %{?with_tcl:BuildRequires:      tcl-devel}
25 %{?with_odbc:BuildRequires:     unixODBC-devel}
26 BuildRequires:  zlib-devel
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 OGDI is the Open Geographic Datastore Interface. OGDI is an
31 application programming interface (API) that uses a standardized
32 access methods to work in conjunction with GIS software packages (the
33 application) and various geospatial data products. OGDI uses a
34 client/server architecture to facilitate the dissemination of
35 geospatial data products over any TCP/IP network, and a
36 driver-oriented approach to facilitate access to several geospatial
37 data products/formats.
38
39 %description -l pl
40 OGDI (Open Geographic Datastore Interface) oznacza otwarty interfejs
41 do danych geograficznych. OGDI to API u¿ywaj±ce ustandaryzowanych
42 metod dostêpu do pracy z pakietami oprogramowania GIS i ró¿nymi danymi
43 geograficznymi. OGDI u¿ywa architektury klient-serwer aby udostêpniaæ
44 dane po dowolnej sieci TCP/IP oraz podej¶cia bazuj±cego na
45 sterownikach aby zapewniæ dostêp do ró¿nych produktów/formatów danych
46 geograficznych.
47
48 %package devel
49 Summary:        OGDI header files and documentation
50 Summary(pl):    Pliki nag³ówkowe i dokumentacja OGDI
51 Group:          Development/Libraries
52 Requires:       %{name} = %{version}-%{release}
53 Requires:       proj-devel
54
55 %description devel
56 OGDI header files and developer's documentation.
57
58 %description devel -l pl
59 Pliki nag³ówkowe i dokumentacja programisty do OGDI.
60
61 %package odbc
62 Summary:        ODBC driver for OGDI
63 Summary(pl):    Sterownik ODBC do OGDI
64 Group:          Libraries
65 Requires:       %{name} = %{version}-%{release}
66
67 %description odbc
68 ODBC driver for OGDI.
69
70 %description odbc -l pl
71 Sterownik ODBC do OGDI.
72
73 %package -n tcl-ogdi
74 Summary:        Tcl wrapper for OGDI
75 Summary(pl):    Interfejs Tcl do OGDI
76 Group:          Libraries
77 Requires:       %{name} = %{version}-%{release}
78
79 %description -n tcl-ogdi
80 Tcl wrapper for OGDI.
81
82 %description -n tcl-ogdi -l pl
83 Interfejs Tcl do OGDI.
84
85 %prep
86 %setup -q
87 %patch0 -p1
88 %patch1 -p1
89
90 cp -f %{SOURCE1} .
91
92 %build
93 %{__autoconf}
94 TOPDIR=`pwd`; TARGET=Linux; export TOPDIR TARGET
95 %configure \
96         --with-expat \
97         --with-proj \
98         --with-zlib
99
100 %{__make} \
101         OPTIMIZATION="%{rpmcflags}"
102
103 %if %{with tcl}
104 %{__make} -C ogdi/tcl_interface \
105         OPTIMIZATION="%{rpmcflags}" \
106         TCL_LINKLIB="-ltcl"
107 %endif
108 %{__make} -C contrib/gdal \
109         OPTIMIZATION="%{rpmcflags}"
110 %if %{with odbc}
111 %{__make} -C ogdi/attr_driver/odbc \
112         OPTIMIZATION="%{rpmcflags}" \
113         ODBC_LINKLIB="-lodbc"
114 %endif
115
116 %install
117 rm -rf $RPM_BUILD_ROOT
118
119 TOPDIR=`pwd`; TARGET=Linux; export TOPDIR TARGET
120
121 %{__make} install \
122         INST_INCLUDE=$RPM_BUILD_ROOT%{_includedir} \
123         INST_LIB=$RPM_BUILD_ROOT%{_libdir}/ogdi \
124         INST_BIN=$RPM_BUILD_ROOT%{_bindir}
125
126 %if %{with tcl}
127 %{__make} install -C ogdi/tcl_interface \
128         INST_LIB=$RPM_BUILD_ROOT%{_libdir}
129 %endif
130 %{__make} install -C contrib/gdal \
131         INST_LIB=$RPM_BUILD_ROOT%{_libdir}/ogdi
132 %if %{with odbc}
133 %{__make} install -C ogdi/attr_driver/odbc \
134         INST_LIB=$RPM_BUILD_ROOT%{_libdir}/ogdi
135 %endif
136
137 # only libogdi* is common library, the rest are dlopened drivers
138 mv -f $RPM_BUILD_ROOT%{_libdir}/ogdi/libogdi*.so $RPM_BUILD_ROOT%{_libdir}
139
140 %clean
141 rm -rf $RPM_BUILD_ROOT
142
143 %post   -p /sbin/ldconfig
144 %postun -p /sbin/ldconfig
145
146 %files
147 %defattr(644,root,root,755)
148 %doc LICENSE NEWS
149 %attr(755,root,root) %{_bindir}/gltpd
150 %attr(755,root,root) %{_bindir}/ogdi_*
151 %attr(755,root,root) %{_libdir}/libogdi*.so
152 %dir %{_libdir}/ogdi
153 %attr(755,root,root) %{_libdir}/ogdi/lib[!l]*.so
154
155 %files devel
156 %defattr(644,root,root,755)
157 %doc ogdi.pdf
158 %{_includedir}/*.h
159
160 %if %{with odbc}
161 %files odbc
162 %defattr(644,root,root,755)
163 %attr(755,root,root) %{_libdir}/ogdi/liblodbc.so
164 %endif
165
166 %if %{with tcl}
167 %files -n tcl-ogdi
168 %defattr(644,root,root,755)
169 %attr(755,root,root) %{_libdir}/libecs_tcl.so
170 %endif
This page took 0.098092 seconds and 4 git commands to generate.