]> git.pld-linux.org Git - packages/ocaml-net.git/blob - ocaml-net.spec
- rel 5
[packages/ocaml-net.git] / ocaml-net.spec
1 # TODO:
2 # - nethttpd needs to be packaged
3 # - apache stuff
4 # - lablgtk2 support
5 #
6 %define         ocaml_ver       1:3.09.2
7 Summary:        Modules for Internet programming in OCaml
8 Summary(pl.UTF-8):      Moduły ułatwiające pisanie programów internetowych w OCamlu
9 Name:           ocaml-net
10 Version:        2.2.9
11 Release:        5
12 License:        GPL v2+ (nethttpd), LGPL v2+ (mod_caml), BSD-like (the rest)
13 Group:          Libraries
14 Source0:        http://download.camlcity.org/download/ocamlnet-%{version}.tar.gz
15 # Source0-md5:  3655e3be3bb2806e0a1f48bb7ce16fb3
16 Patch0:         %{name}-buildfix.patch
17 URL:            http://projects.camlcity.org/projects/ocamlnet.html
18 BuildRequires:  ncurses-devel
19 BuildRequires:  ocaml >= %{ocaml_ver}
20 BuildRequires:  ocaml-findlib
21 BuildRequires:  ocaml-pcre-devel
22 #BuildRequires: ocaml-lablgtk2-devel
23 BuildRequires:  ocaml-ssl-devel
24 BuildRequires:  ocaml-labltk-devel
25 BuildRequires:  tcl-devel
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 Modules for Internet programming in OCaml.
30
31 %description -l pl.UTF-8
32 Moduły ułatwiające pisanie programów internetowych w OCamlu.
33
34 %package doc
35 Summary:        ocaml-net documentation
36 Summary(pl.UTF-8):      Dokumentacja dla pakietów ocaml-net
37 License:        BSD-like
38 Group:          Development/Libraries
39
40 %description doc
41 ocaml-net documentation.
42
43 %description doc -l pl.UTF-8
44 Dokumentacja dla pakietów ocaml-net.
45
46 %package cgi-devel
47 Summary:        Common Gateway Interface library
48 Summary(pl.UTF-8):      Biblioteka do tworzenia skryptów CGI
49 License:        LGPL v2+ (mod_caml), BSD-like (the rest)
50 Group:          Development/Libraries
51 Requires:       %{name}-netplex-devel = %{version}-%{release}
52 Requires:       %{name}-netstring-devel = %{version}-%{release}
53 Requires:       %{name}-netsys-devel = %{version}-%{release}
54 %requires_eq    ocaml
55
56 %description cgi-devel
57 Common Gateway Interface library, part of Ocamlnet. This package
58 contains files needed to develop OCaml programs using netcgi library.
59
60 %description cgi-devel -l pl.UTF-8
61 Biblioteka do tworzenia skryptów CGI, część pakietu Ocamlnet. Ten
62 pakiet zawiera pliki niezbędne do tworzenia programów używających
63 biblioteki netcgi.
64
65 %package equeue-devel
66 Summary:        Event queue library for OCaml
67 Summary(pl.UTF-8):      Biblioteka obsługująca kolejkę zdarzeń dla OCamla
68 License:        BSD-like
69 Group:          Development/Libraries
70 Requires:       %{name}-netsys-devel = %{version}-%{release}
71 %requires_eq    ocaml
72 Obsoletes:      ocaml-equeue-devel
73
74 %description equeue-devel
75 Equeue provides a generic event queue module, and a specific module
76 for file descriptor events.
77
78 This package contains files needed to develop OCaml programs using
79 equeue library.
80
81 %description equeue-devel -l pl.UTF-8
82 Equeue dostarcza ogólnego modułu obsługi kolejki zdarzeń jak również
83 modułu obsługi zdarzeń na deskryptorach plików.
84
85 Ten pakiet zawiera pliki niezbędne do tworzenia programów używających
86 biblioteki equeue.
87
88 %package equeue-ssl
89 Summary:        Event queue library for OCaml, SSL support
90 Summary(pl.UTF-8):      Biblioteka obsługująca kolejkę zdarzeń dla OCamla, wsparcie dla SSL
91 License:        BSD-like
92 Group:          Libraries
93 %requires_eq    ocaml-runtime
94
95 %description equeue-ssl
96 This package makes it possible to let Equeue cooperate with the event
97 queue implementation of SSL.
98
99 This package contains files needed to run bytecode executables using
100 equeue-ssl library.
101
102 %description equeue-ssl -l pl.UTF-8
103 Pakiet ten umożliwia współpracę Equeue z implementacją kolejki zdarzeń
104 w SSL.
105
106 Ten pakiet zawiera moduł potrzebny do uruchamiania programów
107 używających biblioteki equeue-ssl.
108
109 %package equeue-ssl-devel
110 Summary:        Equeue SSL support - development part
111 Summary(pl.UTF-8):      Wsparcie dla SSL-a w equeue - cześć programistyczna
112 License:        BSD-like
113 Group:          Development/Libraries
114 Requires:       %{name}-equeue-devel = %{version}-%{release}
115 Requires:       %{name}-equeue-ssl = %{version}-%{release}
116 %requires_eq    ocaml-ssl-devel
117 %requires_eq    ocaml
118
119 %description equeue-ssl-devel
120 This package makes it possible to let Equeue cooperate with the event
121 queue implementation of SSL.
122
123 This package contains files needed to develop OCaml programs using
124 equeue-ssl library.
125
126 %description equeue-ssl-devel -l pl.UTF-8
127 Pakiet ten umożliwia współpracę Equeue z implementacją kolejki zdarzeń
128 w SSL.
129
130 Ten pakiet zawiera pliki niezbędne do tworzenia programów używających
131 biblioteki equeue-ssl.
132
133 %package equeue-tcl
134 Summary:        Event queue library for OCaml, Tcl support
135 Summary(pl.UTF-8):      Biblioteka obsługująca kolejkę zdarzeń dla OCamla, wsparcie dla Tcl
136 License:        BSD-like
137 Group:          Libraries
138 %requires_eq    ocaml-runtime
139 %requires_eq    ocaml-labltk
140 Obsoletes:      ocaml-equeue-tcl
141
142 %description equeue-tcl
143 This package makes it possible to let Equeue cooperate with the event
144 queue implementation of Tcl.
145
146 This package contains files needed to run bytecode executables using
147 equeue-tcl library.
148
149 %description equeue-tcl -l pl.UTF-8
150 Pakiet ten umożliwia współpracę Equeue z implementacją kolejki zdarzeń
151 w Tcl.
152
153 Ten pakiet zawiera moduły potrzebne do uruchamiania programów
154 używających biblioteki equeue-tcl.
155
156 %package equeue-tcl-devel
157 Summary:        Equeue Tcl support - development part
158 Summary(pl.UTF-8):      Wsparcie dla Tcl-a w equeue - cześć programistyczna
159 License:        BSD-like
160 Group:          Development/Libraries
161 Requires:       %{name}-equeue-devel = %{version}-%{release}
162 Requires:       %{name}-equeue-tcl = %{version}-%{release}
163 %requires_eq    ocaml-labltk-devel
164 %requires_eq    ocaml
165 Obsoletes:      ocaml-equeue-tcl-devel
166
167 %description equeue-tcl-devel
168 This package makes it possible to let Equeue cooperate with the event
169 queue implementation of Tcl.
170
171 This package contains files needed to develop OCaml programs using
172 this library.
173
174 %description equeue-tcl-devel -l pl.UTF-8
175 Pakiet ten umożliwia współpracę Equeue z implementacją kolejki zdarzeń
176 w Tcl.
177
178 Ten pakiet zawiera pliki niezbędne do tworzenia programów używających
179 biblioteki equeue-tcl.
180
181 %package netclient-devel
182 Summary:        HTTP 1.1 client for OCaml
183 Summary(pl.UTF-8):      Klient HTTP 1.1 dla OCamla
184 License:        BSD-like
185 Group:          Development/Libraries
186 Requires:       %{name}-equeue-devel = %{version}-%{release}
187 Requires:       %{name}-netstring-devel = %{version}-%{release}
188 %requires_eq    ocaml
189 Obsoletes:      ocaml-netclient-devel
190
191 %description netclient-devel
192 Implements much of HTTP/1.1. Implements the following advanced
193 features: chunked messages; persistent connections; connections in
194 pipelining mode ("full duplex" connections); modular authentication
195 methods, currently Basic and Digest; event-driven implementation;
196 allows concurrent service for several network connections.
197
198 This package contains files needed to develop OCaml programs using
199 netclient library.
200
201 %description netclient-devel -l pl.UTF-8
202 Biblioteka netclient implementuje większość HTTP/1.1, a także
203 następujące zaawansowane właściwości: komunikaty w kawałkach;
204 połączenia stałe; połączenia w trybie "full duplex"; modularne metody
205 uwierzytelniania, obecnie Basic i Digest; implementacja oparta na
206 zdarzeniach; umożliwia jednoczesną obsługę kilku połączeń.
207
208 Ten pakiet zawiera pliki niezbędne do tworzenia programów używających
209 biblioteki netclient.
210
211 %package nethttpd-devel
212 Summary:        HTTPd library
213 Summary(pl.UTF-8):      Biblioteka do obsługi protokołu HTTP
214 License:        GPL v2+
215 Group:          Development/Libraries
216 Requires:       %{name}-cgi-devel = %{version}-%{release}
217 Requires:       %{name}-equeue-devel = %{version}-%{release}
218 Requires:       %{name}-netplex-devel = %{version}-%{release}
219 %requires_eq    ocaml-pcre-devel
220 %requires_eq    ocaml
221
222 %description nethttpd-devel
223 HTTPd library, part of Ocamlnet. This package contains the files
224 needed to develop OCaml programs using nethttpd library.
225
226 %description nethttpd-devel -l pl.UTF-8
227 Biblioteka do obsługi protokołu HTTP, część pakietu Ocamlnet. Ten
228 pakiet zawiera pliki niezbędne do tworzenia programów używających
229 biblioteki nethttpd.
230
231 %package netplex
232 Summary:        Server framework
233 Summary(pl.UTF-8):      Szkielet serwerowy
234 License:        BSD-like
235 Group:          Libraries
236 %requires_eq    ocaml-runtime
237 %requires_eq    ocaml-labltk
238
239 %description netplex
240 Server framework.
241
242 This package contains files needed to run bytecode executables using
243 netplex library.
244
245 %description netplex -l pl.UTF-8
246 Szkielet serwerowy.
247
248 Ten pakiet zawiera moduły potrzebne do uruchamiania programów
249 używających biblioteki netplex.
250
251 %package netplex-devel
252 Summary:        Server framework - development part
253 Summary(pl.UTF-8):      Szkielet serwerowy - cześć programistyczna
254 License:        BSD-like
255 Group:          Development/Libraries
256 Requires:       %{name}-netplex = %{version}-%{release}
257 Requires:       %{name}-equeue-devel = %{version}-%{release}
258 Requires:       %{name}-netstring-devel = %{version}-%{release}
259 Requires:       %{name}-rpc-devel = %{version}-%{release}
260 Requires:       %{name}-netsys-devel = %{version}-%{release}
261 %requires_eq    ocaml
262
263 %description netplex-devel
264 Server framework.
265
266 This package contains files needed to develop OCaml programs using
267 netplex library.
268
269 %description netplex-devel -l pl.UTF-8
270 Szkielet serwerowy.
271
272 Ten pakiet zawiera pliki niezbędne do tworzenia programów używających
273 biblioteki netplex.
274
275 %package netshm-devel
276 Summary:        Shared memory support - development package
277 Summary(pl.UTF-8):      Obsługa pamięci dzielonej - pakiet programistyczny
278 License:        BSD-like
279 Group:          Development/Libraries
280 Requires:       %{name}-netsys-devel = %{version}-%{release}
281 %requires_eq    ocaml
282
283 %description netshm-devel
284 Shared memory support.
285
286 This package contains files needed to develop OCaml programs using
287 netshm library.
288
289 %description netshm-devel -l pl.UTF-8
290 Obsługa pamięci dzielonej.
291
292 Ten pakiet zawiera pliki niezbędne do tworzenia programów używających
293 biblioteki netshm.
294
295 %package netstring-devel
296 Summary:        String processing library
297 Summary(pl.UTF-8):      Biblioteka do przetwarzania napisów
298 License:        BSD-like
299 Group:          Development/Libraries
300 Requires:       %{name}-netsys-devel = %{version}-%{release}
301 %requires_eq    ocaml-pcre-devel
302 %requires_eq    ocaml
303
304 %description netstring-devel
305 String processing library, part of Ocamlnet. This package contains
306 files needed to develop OCaml programs using netstring library.
307
308 %description netstring-devel -l pl.UTF-8
309 Biblioteka do przetwarzania napisów, część pakietu Ocamlnet. Ten
310 pakiet zawiera pliki niezbędne do tworzenia programów używających
311 biblioteki netstring.
312
313 %package netsys
314 Summary:        OS-specific functions
315 Summary(pl.UTF-8):      Funkcje specyficzne dla systemu operacyjnego
316 License:        BSD-like
317 Group:          Libraries
318 %requires_eq    ocaml-runtime
319
320 %description netsys
321 OS-specific functions.
322
323 This package contains files needed to run bytecode executables using
324 netsys library.
325
326 %description netsys -l pl.UTF-8
327 Funkcje specyficzne dla systemu operacyjnego.
328
329 Ten pakiet zawiera moduły potrzebne do uruchamiania programów
330 używających biblioteki netsys.
331
332 %package netsys-devel
333 Summary:        OS-specific functions - development part
334 Summary(pl.UTF-8):      Funkcje specyficzne dla systemu operacyjnego - cześć programistyczna
335 License:        BSD-like
336 Group:          Development/Libraries
337 Requires:       %{name}-netsys = %{version}-%{release}
338 %requires_eq    ocaml
339
340 %description netsys-devel
341 OS-specific functions.
342
343 This package contains files needed to develop OCaml programs using
344 netsys library.
345
346 %description netsys-devel -l pl.UTF-8
347 Funkcje specyficzne dla systemu operacyjnego.
348
349 Ten pakiet zawiera pliki niezbędne do tworzenia programów używających
350 biblioteki netsys.
351
352 %package pop3-devel
353 Summary:        Post Office Protocol (POP3) library
354 Summary(pl.UTF-8):      Biblioteka do obsługi POP3
355 License:        BSD-like
356 Group:          Development/Libraries
357 Requires:       %{name}-netstring-devel = %{version}-%{release}
358 %requires_eq    ocaml
359
360 %description pop3-devel
361 Post Office Protocol (POP3) library, part of Ocamlnet. This package
362 contains files needed to develop OCaml programs using pop library.
363
364 %description pop3-devel -l pl.UTF-8
365 Biblioteka do obsługi POP3, część pakietu Ocamlnet. Ten pakiet zawiera
366 pliki niezbędne do tworzenia programów używających biblioteki pop.
367
368 %package rpc
369 Summary:        Remote Procedure Call (RPC) libraries
370 Summary(pl.UTF-8):      Biblioteki do obsługi RPC
371 License:        BSD-like
372 Group:          Development/Libraries
373 Requires:       %{name}-equeue-ssl = %{version}-%{release}
374 %requires_eq    ocaml
375
376 %description rpc
377 Remote Procedure Call (RPC) libraries.
378
379 %description rpc -l pl.UTF-8
380 Biblioteki do obsługi RPC.
381
382 %package rpc-devel
383 Summary:        Remote Procedure Call (RPC) libraries - development part
384 Summary(pl.UTF-8):      Biblioteki do obsługi RPC - część programistyczna
385 License:        BSD-like
386 Group:          Development/Libraries
387 Requires:       %{name}-equeue-ssl-devel = %{version}-%{release}
388 Requires:       %{name}-rpc = %{version}-%{release}
389 %requires_eq    ocaml
390
391 %description rpc-devel
392 Remote Procedure Call (RPC) libraries - development part.
393
394 %description rpc-devel -l pl.UTF-8
395 Biblioteki do obsługi RPC - część programistyczna.
396
397 %package shell-devel
398 Summary:        Unix shell functions
399 Summary(pl.UTF-8):      Funkcje powłoki uniksowej
400 License:        BSD-like
401 Group:          Development/Libraries
402 Requires:       %{name}-netsys-devel = %{version}-%{release}
403 Requires:       %{name}-equeue-devel = %{version}-%{release}
404 %requires_eq    ocaml
405
406 %description shell-devel
407 Unix shell functions.
408
409 %description shell-devel -l pl.UTF-8
410 Funkcje powłoki uniksowej.
411
412 %package smtp-devel
413 Summary:        Simple Mail Transfer Protocol (SMTP) library
414 Summary(pl.UTF-8):      Biblioteka do obsługi SMTP
415 License:        BSD-like
416 Group:          Development/Libraries
417 Requires:       %{name}-netstring-devel = %{version}-%{release}
418 %requires_eq    ocaml
419
420 %description smtp-devel
421 Interface for the Simple Mail Tranfer Protocol (SMTP) as specified by
422 RFC 2821.
423
424 %description smtp-devel -l pl.UTF-8
425 Interfejs dla protokołu SMTP opisanego w RFC 2821.
426
427 %prep
428 %setup -q -n ocamlnet-%{version}
429 %patch0 -p1
430
431 %build
432 # no %%configure, please
433 ./configure \
434         -disable-gtk \
435         -disable-gtk2 \
436         -enable-ssl \
437         -enable-tcl \
438         -equeue-tcl-libs "-ltcl" \
439         -with-nethttpd
440
441 %{__make} -j1 all opt
442
443 %install
444 rm -rf $RPM_BUILD_ROOT
445
446 install -d $RPM_BUILD_ROOT%{_libdir}/ocaml
447
448 %{__make} -j1 install \
449         OCAMLFIND_DESTDIR=$RPM_BUILD_ROOT%{_libdir}/ocaml \
450         DESTDIR=$RPM_BUILD_ROOT
451
452 cd src
453 for f in e* n* p* r* shell smtp ; do
454         [ -d $RPM_BUILD_ROOT%{_libdir}/ocaml/$f ] || continue
455         install -d $RPM_BUILD_ROOT%{_libdir}/ocaml/site-lib/$f
456         mv $RPM_BUILD_ROOT%{_libdir}/ocaml/$f/META \
457                 $RPM_BUILD_ROOT%{_libdir}/ocaml/site-lib/$f/
458         echo "directory = \"+$f\"" \
459                 >> $RPM_BUILD_ROOT%{_libdir}/ocaml/site-lib/$f/META
460 done
461 # cgi is a special case
462 install -d $RPM_BUILD_ROOT%{_libdir}/ocaml/site-lib/cgi
463 mv $RPM_BUILD_ROOT%{_libdir}/ocaml/cgi/META $RPM_BUILD_ROOT%{_libdir}/ocaml/site-lib/cgi/
464 cd ..
465
466 # not sure about *.o
467 rm $RPM_BUILD_ROOT%{_libdir}/ocaml/*/*.mli
468
469 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-{cgi,equeue,netclient,nethttpd,pop3,rpc}-%{version}
470 cp -r examples/cgi/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-cgi-%{version}
471 cp -r examples/equeue/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-equeue-%{version}
472 cp -r examples/netclient/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-netclient-%{version}
473 cp -r examples/nethttpd/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-nethttpd-%{version}
474 cp -r examples/pop/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-pop3-%{version}
475 cp -r examples/rpc/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-rpc-%{version}
476
477 %clean
478 rm -rf $RPM_BUILD_ROOT
479
480 %files doc
481 %defattr(644,root,root,755)
482 %doc LICENSE* ChangeLog RELNOTES doc/html-main
483
484 %files cgi-devel
485 %defattr(644,root,root,755)
486 %dir %{_libdir}/ocaml/netcgi*
487 %{_libdir}/ocaml/netcgi*/*.cm[ixao]*
488 %{_libdir}/ocaml/netcgi*/*.a
489 %{_libdir}/ocaml/site-lib/*cgi*
490 %{_examplesdir}/%{name}-cgi-%{version}
491
492 %files equeue-devel
493 %defattr(644,root,root,755)
494 %dir %{_libdir}/ocaml/equeue
495 %{_libdir}/ocaml/equeue/*.cm[ixao]*
496 %{_libdir}/ocaml/equeue/*.a
497 %{_libdir}/ocaml/equeue/*.o
498 %{_libdir}/ocaml/site-lib/equeue
499 %{_examplesdir}/%{name}-equeue-%{version}
500
501 %files equeue-ssl
502 %defattr(644,root,root,755)
503 %dir %{_libdir}/ocaml/equeue-ssl
504 %attr(755,root,root) %{_libdir}/ocaml/equeue-ssl/*.so
505
506 %files equeue-ssl-devel
507 %defattr(644,root,root,755)
508 %{_libdir}/ocaml/equeue-ssl/*.cm[ixao]*
509 %{_libdir}/ocaml/equeue-ssl/*.a
510 %{_libdir}/ocaml/site-lib/equeue-ssl
511
512 %files equeue-tcl
513 %defattr(644,root,root,755)
514 %dir %{_libdir}/ocaml/equeue-tcl
515 %attr(755,root,root) %{_libdir}/ocaml/equeue-tcl/*.so
516
517 %files equeue-tcl-devel
518 %defattr(644,root,root,755)
519 %{_libdir}/ocaml/equeue-tcl/*.cm[ixao]*
520 %{_libdir}/ocaml/equeue-tcl/*.a
521 %{_libdir}/ocaml/site-lib/equeue-tcl
522
523 %files netclient-devel
524 %defattr(644,root,root,755)
525 %dir %{_libdir}/ocaml/netclient
526 %{_libdir}/ocaml/netclient/*.cm[ixao]*
527 %{_libdir}/ocaml/netclient/*.a
528 %{_libdir}/ocaml/netclient/*.o
529 %{_libdir}/ocaml/site-lib/netclient
530 %{_examplesdir}/%{name}-netclient-%{version}
531
532 %files nethttpd-devel
533 %defattr(644,root,root,755)
534 %dir %{_libdir}/ocaml/nethttpd-*
535 %{_libdir}/ocaml/nethttpd-*/*.cm[ixao]*
536 %{_libdir}/ocaml/nethttpd-*/*.a
537 %{_libdir}/ocaml/site-lib/nethttpd*
538 %{_examplesdir}/%{name}-nethttpd-%{version}
539
540 %files netplex
541 %defattr(644,root,root,755)
542 %attr(755,root,root) %{_bindir}/netplex-admin
543
544 %files netplex-devel
545 %defattr(644,root,root,755)
546 %dir %{_libdir}/ocaml/netplex
547 %{_libdir}/ocaml/netplex/netplex-packlist
548 %{_libdir}/ocaml/netplex/*.cm[ixao]*
549 %{_libdir}/ocaml/netplex/*.a
550 %{_libdir}/ocaml/netplex/*.o
551 %{_libdir}/ocaml/site-lib/netplex
552
553 %files netshm-devel
554 %defattr(644,root,root,755)
555 %dir %{_libdir}/ocaml/netshm
556 %{_libdir}/ocaml/netshm/*.cm[ixao]*
557 %{_libdir}/ocaml/netshm/*.a
558 %{_libdir}/ocaml/site-lib/netshm
559
560 %files netstring-devel
561 %defattr(644,root,root,755)
562 %dir %{_libdir}/ocaml/netstring
563 %{_libdir}/ocaml/netstring/netdb-packlist
564 %{_libdir}/ocaml/netstring/*.cm[ixao]*
565 %{_libdir}/ocaml/netstring/*.a
566 %{_libdir}/ocaml/netstring/*.o
567 %attr(755,root,root) %{_libdir}/ocaml/netstring/*.so
568 %{_libdir}/ocaml/site-lib/netstring
569
570 %files netsys
571 %defattr(644,root,root,755)
572 %dir %{_libdir}/ocaml/netsys
573 %attr(755,root,root) %{_libdir}/ocaml/netsys/*.so
574
575 %files netsys-devel
576 %defattr(644,root,root,755)
577 %{_libdir}/ocaml/netsys/*.cm[ixao]*
578 %{_libdir}/ocaml/netsys/*.a
579 %{_libdir}/ocaml/site-lib/netsys
580
581 %files pop3-devel
582 %defattr(644,root,root,755)
583 %dir %{_libdir}/ocaml/pop
584 %{_libdir}/ocaml/pop/*.cm[ixao]*
585 %{_libdir}/ocaml/pop/*.a
586 %{_libdir}/ocaml/site-lib/pop
587 %{_examplesdir}/%{name}-pop3-%{version}
588
589 %files rpc
590 %defattr(644,root,root,755)
591 %attr(755,root,root) %{_bindir}/ocamlrpcgen
592 %dir %{_libdir}/ocaml/rpc-auth-local
593 %dir %{_libdir}/ocaml/rpc-generator
594 %attr(755,root,root) %{_libdir}/ocaml/rpc-auth-local/dllrpc_auth_local.so
595
596 %files rpc-devel
597 %defattr(644,root,root,755)
598 %dir %{_libdir}/ocaml/rpc
599 %dir %{_libdir}/ocaml/rpc-ssl
600 %{_libdir}/ocaml/rpc-generator/rpcgen-packlist
601 %{_libdir}/ocaml/rpc*/*.cm[ixao]*
602 %{_libdir}/ocaml/rpc*/*.a
603 %{_libdir}/ocaml/site-lib/rpc*
604 %{_examplesdir}/%{name}-rpc-%{version}
605
606 %files shell-devel
607 %defattr(644,root,root,755)
608 %dir %{_libdir}/ocaml/shell
609 %{_libdir}/ocaml/shell/*.cm[ixao]*
610 %{_libdir}/ocaml/shell/*.a
611 %{_libdir}/ocaml/shell/*.o
612 %{_libdir}/ocaml/site-lib/shell
613
614 %files smtp-devel
615 %defattr(644,root,root,755)
616 %dir %{_libdir}/ocaml/smtp
617 %{_libdir}/ocaml/smtp/*.cm[ixao]*
618 %{_libdir}/ocaml/smtp/*.a
619 %{_libdir}/ocaml/site-lib/smtp
This page took 0.07359 seconds and 4 git commands to generate.