]> git.pld-linux.org Git - packages/ocaml-net.git/blob - ocaml-net.spec
- rel 3
[packages/ocaml-net.git] / ocaml-net.spec
1 # TODO:
2 # - nethttpd needs to be packaged
3 # - apache stuff
4 # - lablgtk2 support
5 #
6 %define         ocaml_ver       1:3.09.2
7 Summary:        Modules for Internet programming in OCaml
8 Summary(pl.UTF-8):      Moduły ułatwiające pisanie programów internetowych w OCamlu
9 Name:           ocaml-net
10 Version:        2.2.9
11 Release:        3
12 License:        GPL v2
13 Group:          Libraries
14 Source0:        http://dl.sourceforge.net/ocamlnet/ocamlnet-%{version}.tar.gz
15 # Source0-md5:  3655e3be3bb2806e0a1f48bb7ce16fb3
16 URL:            http://ocamlnet.sourceforge.net/
17 BuildRequires:  ncurses-devel
18 BuildRequires:  ocaml >= %{ocaml_ver}
19 BuildRequires:  ocaml-findlib
20 BuildRequires:  ocaml-pcre-devel
21 #BuildRequires: ocaml-lablgtk2-devel
22 BuildRequires:  ocaml-ssl-devel
23 BuildRequires:  ocaml-labltk-devel
24 BuildRequires:  tcl-devel
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 Modules for Internet programming in OCaml.
29
30 %description -l pl.UTF-8
31 Moduły ułatwiające pisanie programów internetowych w OCamlu.
32
33 %package doc
34 Summary:        ocaml-net documentation
35 Summary(pl.UTF-8):      Dokumentacja dla pakietów ocaml-net
36 Group:          Development/Libraries
37
38 %description doc
39 ocaml-net documentation.
40
41 %description doc -l pl.UTF-8
42 Dokumentacja dla pakietów ocaml-net.
43
44 %package cgi-devel
45 Summary:        Common Gateway Interface library
46 Summary(pl.UTF-8):      Biblioteka do tworzenia skryptów CGI
47 Group:          Development/Libraries
48 Requires:       %{name}-netplex-devel = %{version}-%{release}
49 Requires:       %{name}-netstring-devel = %{version}-%{release}
50 Requires:       %{name}-netsys-devel = %{version}-%{release}
51 %requires_eq    ocaml
52
53 %description cgi-devel
54 Common Gateway Interface library, part of Ocamlnet. This package
55 contains files needed to develop OCaml programs using this library.
56
57 %description cgi-devel -l pl.UTF-8
58 Biblioteka do tworzenia skryptów CGI, część pakietu Ocamlnet. Pakiet
59 ten zawiera pliki niezbędne do tworzenia programów używających tej
60 biblioteki.
61
62 %package equeue-devel
63 Summary:        Event queue library for OCaml
64 Summary(pl.UTF-8):      Biblioteka obsługująca kolejkę zdarzeń dla OCamla
65 Group:          Development/Libraries
66 Requires:       %{name}-netsys-devel = %{version}-%{release}
67 %requires_eq    ocaml
68 Obsoletes:      ocaml-equeue-devel
69 Obsoletes:      ocaml-equeue-tcl
70 Obsoletes:      ocaml-equeue-tcl-devel
71
72 %description equeue-devel
73 Equeue provides a generic event queue module, and a specific module
74 for file descriptor events.
75
76 This package contains files needed to develop OCaml programs using
77 this library.
78
79 %description equeue-devel -l pl.UTF-8
80 Equeue dostarcza ogólnego modułu obsługi kolejki zdarzeń jak również
81 modułu obsługi zdarzeń na deskryptorach plików.
82
83 Pakiet ten zawiera pliki niezbędne do tworzenia programów używających
84 tej biblioteki.
85
86 %package equeue-ssl
87 Summary:        Event queue library for OCaml, SSL support
88 Summary(pl.UTF-8):      Biblioteka obsługująca kolejkę zdarzeń dla OCamla, wsparcie dla SSL
89 Group:          Libraries
90 %requires_eq    ocaml-runtime
91
92 %description equeue-ssl
93 This package makes it possible to let Equeue cooperate with the event
94 queue implementation of SSL.
95
96 This package contains files needed to run bytecode executables using
97 this library.
98
99 %description equeue-ssl -l pl.UTF-8
100 Pakiet ten umożliwia współpracę Equeue z implementacją kolejki zdarzeń
101 w SSL.
102
103 Pakiet ten zawiera binaria potrzebne do uruchamiania programów
104 używających tej biblioteki.
105
106 %package equeue-ssl-devel
107 Summary:        Equeue SSL support - development part
108 Summary(pl.UTF-8):      Wsparcie dla SSL-a w equeue - cześć programistyczna
109 Group:          Development/Libraries
110 Requires:       %{name}-equeue-devel = %{version}-%{release}
111 Requires:       %{name}-equeue-ssl = %{version}-%{release}
112 %requires_eq    ocaml-ssl-devel
113 %requires_eq    ocaml
114
115 %description equeue-ssl-devel
116 This package makes it possible to let Equeue cooperate with the event
117 queue implementation of SSL.
118
119 This package contains files needed to develop OCaml programs using
120 this library.
121
122 %description equeue-ssl-devel -l pl.UTF-8
123 Pakiet ten umożliwia współpracę Equeue z implementacją kolejki zdarzeń
124 w SSL.
125
126 Pakiet ten zawiera pliki niezbędne do tworzenia programów używających
127 tej biblioteki.
128
129 %package equeue-tcl
130 Summary:        Event queue library for OCaml, Tcl support
131 Summary(pl.UTF-8):      Biblioteka obsługująca kolejkę zdarzeń dla OCamla, wsparcie dla Tcl
132 Group:          Libraries
133 %requires_eq    ocaml-runtime
134 %requires_eq    ocaml-labltk
135
136 %description equeue-tcl
137 This package makes it possible to let Equeue cooperate with the event
138 queue implementation of Tcl.
139
140 This package contains files needed to run bytecode executables using
141 this library.
142
143 %description equeue-tcl -l pl.UTF-8
144 Pakiet ten umożliwia współpracę Equeue z implementacją kolejki zdarzeń
145 w Tcl.
146
147 Pakiet ten zawiera binaria potrzebne do uruchamiania programów
148 używających tej biblioteki.
149
150 %package equeue-tcl-devel
151 Summary:        Equeue Tcl support - development part
152 Summary(pl.UTF-8):      Wsparcie dla Tcl-a w equeue - cześć programistyczna
153 Group:          Development/Libraries
154 Requires:       %{name}-equeue-devel = %{version}-%{release}
155 Requires:       %{name}-equeue-tcl = %{version}-%{release}
156 %requires_eq    ocaml-labltk-devel
157 %requires_eq    ocaml
158
159 %description equeue-tcl-devel
160 This package makes it possible to let Equeue cooperate with the event
161 queue implementation of Tcl.
162
163 This package contains files needed to develop OCaml programs using
164 this library.
165
166 %description equeue-tcl-devel -l pl.UTF-8
167 Pakiet ten umożliwia współpracę Equeue z implementacją kolejki zdarzeń
168 w Tcl.
169
170 Pakiet ten zawiera pliki niezbędne do tworzenia programów używających
171 tej biblioteki.
172
173 %package netclient-devel
174 Summary:        HTTP 1.1 client for OCaml
175 Summary(pl.UTF-8):      Klient HTTP 1.1 dla OCamla
176 Group:          Development/Libraries
177 Requires:       %{name}-equeue-devel = %{version}-%{release}
178 Requires:       %{name}-netstring-devel = %{version}-%{release}
179 %requires_eq    ocaml
180 Obsoletes:      ocaml-netclient-devel
181
182 %description netclient-devel
183 Implements much of HTTP/1.1. Implements the following advanced
184 features: chunked messages; persistent connections; connections in
185 pipelining mode ("full duplex" connections); modular authentication
186 methods, currently Basic and Digest; event-driven implementation;
187 allows concurrent service for several network connections.
188
189 This package contains files needed to develop OCaml programs using
190 this library.
191
192 %description netclient-devel -l pl.UTF-8
193 Implementuje większość HTTP/1.1. Implementuje również następujące
194 zaawansowane własności: komunikaty w kawałkach; połączenia stałe;
195 połączenia w trybie "full duplex"; modularne metody autentykacji,
196 obecnie Basic i Digest; bazowna na zdarzeniach implementacja;
197 umożliwia jednoczesną obsługę kilku połączeń.
198
199 Pakiet ten zawiera pliki niezbędne do tworzenia programów używających
200 tej biblioteki.
201
202 %package nethttpd-devel
203 Summary:        HTTPd library
204 Summary(pl.UTF-8):      Biblioteka do obsługi protokołu HTTP
205 Group:          Development/Libraries
206 Requires:       %{name}-cgi-devel = %{version}-%{release}
207 Requires:       %{name}-equeue-devel = %{version}-%{release}
208 Requires:       %{name}-netplex-devel = %{version}-%{release}
209 %requires_eq    ocaml-pcre-devel
210 %requires_eq    ocaml
211
212 %description nethttpd-devel
213 HTTPd library, part of Ocamlnet. This package contains the files
214 needed to develop OCaml programs using this library.
215
216 %description nethttpd-devel -l pl.UTF-8
217 Biblioteka do obsługi protokołu HTTP, część pakietu Ocamlnet. Pakiet
218 ten zawiera pliki niezbędne do tworzenia programów używających tej
219 biblioteki.
220
221 %package netplex
222 Summary:        Server framework
223 #Summary(pl.UTF-8):     
224 Group:          Libraries
225 %requires_eq    ocaml-runtime
226 %requires_eq    ocaml-labltk
227
228 %description netplex
229 Server framework.
230
231 This package contains files needed to run bytecode executables using
232 this library.
233
234 #%description netplex -l pl.UTF-8
235 #
236 #Pakiet ten zawiera binaria potrzebne do uruchamiania programów
237 #używających tej biblioteki.
238
239 %package netplex-devel
240 Summary:        Server framework - development part
241 #Summary(pl.UTF-8):      - cześć programistyczna
242 Group:          Development/Libraries
243 Requires:       %{name}-netplex = %{version}-%{release}
244 Requires:       %{name}-equeue-devel = %{version}-%{release}
245 Requires:       %{name}-netstring-devel = %{version}-%{release}
246 Requires:       %{name}-rpc-devel = %{version}-%{release}
247 Requires:       %{name}-netsys-devel = %{version}-%{release}
248 %requires_eq    ocaml
249
250 %description netplex-devel
251 Server framework.
252
253 This package contains files needed to develop OCaml programs using
254 this library.
255
256 #%description netplex-devel -l pl.UTF-8
257 #
258 #Pakiet ten zawiera pliki niezbędne do tworzenia programów używających
259 #tej biblioteki.
260
261 %package netshm-devel
262 Summary:        Shared memory support - development part
263 #Summary(pl.UTF-8):      - cześć programistyczna
264 Group:          Development/Libraries
265 Requires:       %{name}-netsys-devel = %{version}-%{release}
266 %requires_eq    ocaml
267
268 %description netshm-devel
269 Shared memory support.
270
271 This package contains files needed to develop OCaml programs using
272 this library.
273
274 #%description netshm-devel -l pl.UTF-8
275 #
276 #Pakiet ten zawiera pliki niezbędne do tworzenia programów używających
277 #tej biblioteki.
278
279 %package netstring-devel
280 Summary:        String processing library
281 Summary(pl.UTF-8):      Biblioteka do przetwarzania napisów
282 Group:          Development/Libraries
283 Requires:       %{name}-netsys-devel = %{version}-%{release}
284 %requires_eq    ocaml-pcre-devel
285 %requires_eq    ocaml
286
287 %description netstring-devel
288 String processing library, part of Ocamlnet. This package contains
289 files needed to develop OCaml programs using this library.
290
291 %description netstring-devel -l pl.UTF-8
292 Biblioteka do przetwarzania napisów, część pakietu Ocamlnet. Pakiet
293 ten zawiera pliki niezbędne do tworzenia programów używających tej
294 biblioteki.
295
296 %package netsys
297 Summary:        OS-specific functions
298 #Summary(pl.UTF-8):     
299 Group:          Libraries
300 %requires_eq    ocaml-runtime
301
302 %description netsys
303 OS-specific functions.
304
305 This package contains files needed to run bytecode executables using
306 this library.
307
308 #%description netsys -l pl.UTF-8
309 #
310 #Pakiet ten zawiera binaria potrzebne do uruchamiania programów
311 #używających tej biblioteki.
312
313 %package netsys-devel
314 Summary:        OS-specific functions - development part
315 #Summary(pl.UTF-8):      - cześć programistyczna
316 Group:          Development/Libraries
317 Requires:       %{name}-netsys = %{version}-%{release}
318 %requires_eq    ocaml
319
320 %description netsys-devel
321 OS-specific functions.
322
323 This package contains files needed to develop OCaml programs using
324 this library.
325
326 #%description netsys-devel -l pl.UTF-8
327 #
328 #Pakiet ten zawiera pliki niezbędne do tworzenia programów używających
329 #tej biblioteki.
330
331 %package pop3-devel
332 Summary:        Post Office Protocol (POP3) library
333 Summary(pl.UTF-8):      Biblioteka do obsługi POP3
334 Group:          Development/Libraries
335 Requires:       %{name}-netstring-devel = %{version}-%{release}
336 %requires_eq    ocaml
337
338 %description pop3-devel
339 Post Office Protocol (POP3) library, part of Ocamlnet. This package
340 contains files needed to develop OCaml programs using this library.
341
342 %description pop3-devel -l pl.UTF-8
343 Biblioteka do obsługi POP3, część pakietu Ocamlnet. Pakiet ten zawiera
344 pliki niezbędne do tworzenia programów używających tej biblioteki.
345
346 %package rpc
347 Summary:        Remote Procedure Call (RPC) library
348 Summary(pl.UTF-8):      Biblioteka do obsługi RPC
349 Group:          Development/Libraries
350 Requires:       %{name}-equeue-ssl = %{version}-%{release}
351 %requires_eq    ocaml
352
353 %description rpc
354 Remote Procedure Call (RPC) library.
355
356 %description rpc -l pl.UTF-8
357 Biblioteka do obsługi RPC.
358
359 %package rpc-devel
360 Summary:        Remote Procedure Call (RPC) library
361 Summary(pl.UTF-8):      Biblioteka do obsługi RPC
362 Group:          Development/Libraries
363 Requires:       %{name}-equeue-ssl-devel = %{version}-%{release}
364 Requires:       %{name}-rpc = %{version}-%{release}
365 %requires_eq    ocaml
366
367 %description rpc-devel
368 Remote Procedure Call (RPC) library.
369
370 %description rpc-devel -l pl.UTF-8
371 Biblioteka do obsługi RPC.
372
373 %package shell-devel
374 Summary:        Unix shell functions
375 #Summary(pl.UTF-8):     
376 Group:          Development/Libraries
377 Requires:       %{name}-netsys-devel = %{version}-%{release}
378 Requires:       %{name}-equeue-devel = %{version}-%{release}
379 %requires_eq    ocaml
380
381 %description shell-devel
382 Unix shell functions.
383
384 #%description shell-devel -l pl.UTF-8
385
386 %package smtp-devel
387 Summary:        Simple Mail Transfer Protocol (SMTP) library
388 Summary(pl.UTF-8):      Biblioteka do obsługi SMTP
389 Group:          Development/Libraries
390 Requires:       %{name}-netstring-devel = %{version}-%{release}
391 %requires_eq    ocaml
392
393 %description smtp-devel
394 Interface for the Simple Mail Tranfer Protocol (SMTP) as specified by
395 RFC 2821.
396
397 %description smtp-devel -l pl.UTF-8
398 Interfejs dla protokołu SMTP wyszczególniony w RFC 2821.
399
400 %prep
401 %setup -q -n ocamlnet-%{version}
402
403 %build
404 # no %%configure, please
405 ./configure \
406         -disable-gtk \
407         -disable-gtk2 \
408         -enable-ssl \
409         -enable-tcl \
410         -equeue-tcl-libs "-ltcl" \
411         -with-nethttpd
412
413 %{__make} -j1 all opt
414
415 %install
416 rm -rf $RPM_BUILD_ROOT
417
418 install -d $RPM_BUILD_ROOT%{_libdir}/ocaml
419
420 %{__make} -j1 install \
421         OCAMLFIND_DESTDIR=$RPM_BUILD_ROOT%{_libdir}/ocaml \
422         DESTDIR=$RPM_BUILD_ROOT
423
424 cd src
425 for f in e* n* p* r* shell smtp ; do
426         [ -d $RPM_BUILD_ROOT%{_libdir}/ocaml/$f ] || continue
427         install -d $RPM_BUILD_ROOT%{_libdir}/ocaml/site-lib/$f
428         mv $RPM_BUILD_ROOT%{_libdir}/ocaml/$f/META \
429                 $RPM_BUILD_ROOT%{_libdir}/ocaml/site-lib/$f/
430         echo "directory = \"+$f\"" \
431                 >> $RPM_BUILD_ROOT%{_libdir}/ocaml/site-lib/$f/META
432 done
433 # cgi is a special case
434 install -d $RPM_BUILD_ROOT%{_libdir}/ocaml/site-lib/cgi
435 mv $RPM_BUILD_ROOT%{_libdir}/ocaml/cgi/META $RPM_BUILD_ROOT%{_libdir}/ocaml/site-lib/cgi/
436 cd ..
437
438 # not sure about *.o
439 rm $RPM_BUILD_ROOT%{_libdir}/ocaml/*/*.mli
440
441 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-{cgi,equeue,netclient,nethttpd,pop3,rpc}-%{version}
442 cp -r examples/cgi/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-cgi-%{version}
443 cp -r examples/equeue/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-equeue-%{version}
444 cp -r examples/netclient/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-netclient-%{version}
445 cp -r examples/nethttpd/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-nethttpd-%{version}
446 cp -r examples/pop/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-pop3-%{version}
447 cp -r examples/rpc/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-rpc-%{version}
448
449 %clean
450 rm -rf $RPM_BUILD_ROOT
451
452 %files doc
453 %defattr(644,root,root,755)
454 %doc LICENSE* ChangeLog RELNOTES doc/html-main
455
456 %files cgi-devel
457 %defattr(644,root,root,755)
458 %dir %{_libdir}/ocaml/netcgi*
459 %{_libdir}/ocaml/netcgi*/*.cm[ixao]*
460 %{_libdir}/ocaml/netcgi*/*.a
461 %{_libdir}/ocaml/site-lib/*cgi*
462 %{_examplesdir}/%{name}-cgi-%{version}
463
464 %files equeue-devel
465 %defattr(644,root,root,755)
466 %dir %{_libdir}/ocaml/equeue
467 %{_libdir}/ocaml/equeue/*.cm[ixao]*
468 %{_libdir}/ocaml/equeue/*.a
469 %{_libdir}/ocaml/equeue/*.o
470 %{_libdir}/ocaml/site-lib/equeue
471 %{_examplesdir}/%{name}-equeue-%{version}
472
473 %files equeue-ssl
474 %defattr(644,root,root,755)
475 %dir %{_libdir}/ocaml/equeue-ssl
476 %attr(755,root,root) %{_libdir}/ocaml/equeue-ssl/*.so
477
478 %files equeue-ssl-devel
479 %defattr(644,root,root,755)
480 %{_libdir}/ocaml/equeue-ssl/*.cm[ixao]*
481 %{_libdir}/ocaml/equeue-ssl/*.a
482 %{_libdir}/ocaml/site-lib/equeue-ssl
483
484 %files equeue-tcl
485 %defattr(644,root,root,755)
486 %dir %{_libdir}/ocaml/equeue-tcl
487 %attr(755,root,root) %{_libdir}/ocaml/equeue-tcl/*.so
488
489 %files equeue-tcl-devel
490 %defattr(644,root,root,755)
491 %{_libdir}/ocaml/equeue-tcl/*.cm[ixao]*
492 %{_libdir}/ocaml/equeue-tcl/*.a
493 %{_libdir}/ocaml/site-lib/equeue-tcl
494
495 %files netclient-devel
496 %defattr(644,root,root,755)
497 %dir %{_libdir}/ocaml/netclient
498 %{_libdir}/ocaml/netclient/*.cm[ixao]*
499 %{_libdir}/ocaml/netclient/*.a
500 %{_libdir}/ocaml/netclient/*.o
501 %{_libdir}/ocaml/site-lib/netclient
502 %{_examplesdir}/%{name}-netclient-%{version}
503
504 %files nethttpd-devel
505 %defattr(644,root,root,755)
506 %dir %{_libdir}/ocaml/nethttpd-*
507 %{_libdir}/ocaml/nethttpd-*/*.cm[ixao]*
508 %{_libdir}/ocaml/nethttpd-*/*.a
509 %{_libdir}/ocaml/site-lib/nethttpd*
510 %{_examplesdir}/%{name}-nethttpd-%{version}
511
512 %files netplex
513 %defattr(644,root,root,755)
514 %attr(755,root,root) %{_bindir}/netplex-admin
515
516 %files netplex-devel
517 %defattr(644,root,root,755)
518 %dir %{_libdir}/ocaml/netplex
519 %{_libdir}/ocaml/netplex/netplex-packlist
520 %{_libdir}/ocaml/netplex/*.cm[ixao]*
521 %{_libdir}/ocaml/netplex/*.a
522 %{_libdir}/ocaml/netplex/*.o
523 %{_libdir}/ocaml/site-lib/netplex
524
525 %files netshm-devel
526 %defattr(644,root,root,755)
527 %dir %{_libdir}/ocaml/netshm
528 %{_libdir}/ocaml/netshm/*.cm[ixao]*
529 %{_libdir}/ocaml/netshm/*.a
530 %{_libdir}/ocaml/site-lib/netshm
531
532 %files netstring-devel
533 %defattr(644,root,root,755)
534 %dir %{_libdir}/ocaml/netstring
535 %{_libdir}/ocaml/netstring/netdb-packlist
536 %{_libdir}/ocaml/netstring/*.cm[ixao]*
537 %{_libdir}/ocaml/netstring/*.a
538 %{_libdir}/ocaml/netstring/*.o
539 %attr(755,root,root) %{_libdir}/ocaml/netstring/*.so
540 %{_libdir}/ocaml/site-lib/netstring
541
542 %files netsys
543 %defattr(644,root,root,755)
544 %dir %{_libdir}/ocaml/netsys
545 %attr(755,root,root) %{_libdir}/ocaml/netsys/*.so
546
547 %files netsys-devel
548 %defattr(644,root,root,755)
549 %{_libdir}/ocaml/netsys/*.cm[ixao]*
550 %{_libdir}/ocaml/netsys/*.a
551 %{_libdir}/ocaml/site-lib/netsys
552
553 %files pop3-devel
554 %defattr(644,root,root,755)
555 %dir %{_libdir}/ocaml/pop
556 %{_libdir}/ocaml/pop/*.cm[ixao]*
557 %{_libdir}/ocaml/pop/*.a
558 %{_libdir}/ocaml/site-lib/pop
559 %{_examplesdir}/%{name}-pop3-%{version}
560
561 %files rpc
562 %defattr(644,root,root,755)
563 %attr(755,root,root) %{_bindir}/ocamlrpcgen
564 %dir %{_libdir}/ocaml/rpc-auth-local
565 %dir %{_libdir}/ocaml/rpc-generator
566 %attr(755,root,root) %{_libdir}/ocaml/rpc-auth-local/dllrpc_auth_local.so
567
568 %files rpc-devel
569 %defattr(644,root,root,755)
570 %dir %{_libdir}/ocaml/rpc
571 %dir %{_libdir}/ocaml/rpc-ssl
572 %{_libdir}/ocaml/rpc-generator/rpcgen-packlist
573 %{_libdir}/ocaml/rpc*/*.cm[ixao]*
574 %{_libdir}/ocaml/rpc*/*.a
575 %{_libdir}/ocaml/site-lib/rpc*
576 %{_examplesdir}/%{name}-rpc-%{version}
577
578 %files shell-devel
579 %defattr(644,root,root,755)
580 %dir %{_libdir}/ocaml/shell
581 %{_libdir}/ocaml/shell/*.cm[ixao]*
582 %{_libdir}/ocaml/shell/*.a
583 %{_libdir}/ocaml/shell/*.o
584 %{_libdir}/ocaml/site-lib/shell
585
586 %files smtp-devel
587 %defattr(644,root,root,755)
588 %dir %{_libdir}/ocaml/smtp
589 %{_libdir}/ocaml/smtp/*.cm[ixao]*
590 %{_libdir}/ocaml/smtp/*.a
591 %{_libdir}/ocaml/site-lib/smtp
This page took 0.060479 seconds and 3 git commands to generate.