]> git.pld-linux.org Git - packages/ocaml-gapi-ocaml.git/blob - ocaml-gapi-ocaml.spec
- up to 0.3.6
[packages/ocaml-gapi-ocaml.git] / ocaml-gapi-ocaml.spec
1 #
2 # Conditional build:
3 %bcond_without  ocaml_opt       # skip building native optimized binaries (bytecode is always built)
4
5 # not yet available on x32 (ocaml 4.02.1), remove when upstream will support it
6 %ifnarch %{ix86} %{x8664} arm aarch64 ppc sparc sparcv9
7 %undefine       with_ocaml_opt
8 %endif
9
10 %define         pkgname gapi-ocaml
11 %define         debug_package   %{nil}
12 Summary:        Google Data Protocol (GData) client library
13 Name:           ocaml-%{pkgname}
14 Version:        0.3.6
15 Release:        1
16 License:        MIT
17 Group:          Libraries
18 Source0:        https://github.com/astrada/gapi-ocaml/archive/v%{version}/%{name}-%{version}.tar.gz
19 # Source0-md5:  b8759b3a9010769db86786141ed374dd
20 Patch0:         jbuilder.patch
21 URL:            http://gapi-ocaml.forge.ocamlcore.org/
22 BuildRequires:  cppo >= 0.9.3
23 BuildRequires:  ocaml >= 4.02.3
24 BuildRequires:  ocaml-biniou-devel >= 1.0.6
25 BuildRequires:  ocaml-cryptokit-devel >= 1.9
26 BuildRequires:  ocaml-curl-devel >= 0.6.0
27 BuildRequires:  ocaml-easy-format-devel >= 1.0.1
28 BuildRequires:  ocaml-extlib-devel >= 1.5.4
29 BuildRequires:  ocaml-findlib >= 1.4
30 BuildRequires:  ocaml-net-netstring-devel >= 4.1.4
31 BuildRequires:  ocaml-xmlm-devel >= 1.1.1
32 BuildRequires:  ocaml-yojson-devel >= 1.1.6
33 %requires_eq    ocaml-runtime
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 gapi-ocaml is a simple, unofficial, OCaml client for Google Services.
38 The project is hosted on github, where you can find the latest
39 development version, and on the OCaml forge where you can find
40 releases. Reference documentation can be found here.
41
42 %description -l pl.UTF-8
43 Pakiet ten zawiera binaria potrzebne do uruchamiania programów
44 używających tej biblioteki.
45
46 %package devel
47 Summary:        Google Data Protocol (GData) client library - development part
48 Summary(pl.UTF-8):      Wiązania gapi dla OCamla - cześć programistyczna
49 Group:          Development/Libraries
50 %requires_eq    ocaml
51 Requires:       ocaml-biniou-devel >= 1.0.6
52 Requires:       ocaml-cryptokit-devel >= 1.9
53 Requires:       ocaml-curl-devel >= 0.6.0
54 Requires:       ocaml-easy-format-devel >= 1.0.1
55 Requires:       ocaml-extlib-devel >= 1.5.4
56 Requires:       ocaml-net-netstring-devel >= 3.6
57 #Requires:      ocaml-net-netstring-devel >= 3.7.3
58 Requires:       ocaml-xmlm-devel >= 1.1.1
59 Requires:       ocaml-yojson-devel >= 1.1.6
60
61 %description devel
62 This package contains files needed to develop OCaml programs using
63 this library.
64
65 %description devel -l pl.UTF-8
66 Pakiet ten zawiera pliki niezbędne do tworzenia programów używających
67 tej biblioteki.
68
69 %prep
70 %setup -q -n %{pkgname}-%{version}
71 %patch0 -p1 -R
72
73 %build
74 ocaml setup.ml -configure \
75         --destdir $RPM_BUILD_ROOT
76 ocaml setup.ml -build
77
78 %install
79 rm -rf $RPM_BUILD_ROOT
80 export OCAMLFIND_DESTDIR=$RPM_BUILD_ROOT%{_libdir}/ocaml
81 install -d $OCAMLFIND_DESTDIR
82 ocaml setup.ml -install
83
84 # move to dir pld ocamlfind looks
85 install -d $RPM_BUILD_ROOT%{_libdir}/ocaml/site-lib/%{pkgname}
86 mv $OCAMLFIND_DESTDIR/%{pkgname}/META \
87         $RPM_BUILD_ROOT%{_libdir}/ocaml/site-lib/%{pkgname}
88 cat <<EOF >> $RPM_BUILD_ROOT%{_libdir}/ocaml/site-lib/%{pkgname}/META
89 directory="+%{pkgname}"
90 EOF
91
92 # no standard way of packaging .mli docs in pld. just drop
93 %{__rm} $RPM_BUILD_ROOT%{_libdir}/ocaml/%{pkgname}/*.mli
94
95 %clean
96 rm -rf $RPM_BUILD_ROOT
97
98 %files devel
99 %defattr(644,root,root,755)
100 %doc LICENSE
101 %dir %{_libdir}/ocaml/%{pkgname}
102 %{_libdir}/ocaml/%{pkgname}/*.annot
103 %{_libdir}/ocaml/%{pkgname}/*.cma
104 %{_libdir}/ocaml/%{pkgname}/*.cmt*
105 %{_libdir}/ocaml/%{pkgname}/*.cm[ix]
106 %if %{with ocaml_opt}
107 %{_libdir}/ocaml/%{pkgname}/*.a
108 %{_libdir}/ocaml/%{pkgname}/*.cmx[as]
109 %endif
110 %dir %{_libdir}/ocaml/site-lib/%{pkgname}
111 %{_libdir}/ocaml/site-lib/%{pkgname}/META
This page took 0.165773 seconds and 4 git commands to generate.