]> git.pld-linux.org Git - packages/ocaml-gapi-ocaml.git/blob - ocaml-gapi-ocaml.spec
a228f9438e9af4497934edb5539ff7685b45831f
[packages/ocaml-gapi-ocaml.git] / ocaml-gapi-ocaml.spec
1 #
2 # Conditional build:
3 %bcond_without  ocaml_opt       # skip building native optimized binaries (bytecode is always built)
4
5 # not yet available on x32 (ocaml 4.02.1), remove when upstream will support it
6 %ifnarch %{ix86} %{x8664} arm aarch64 ppc sparc sparcv9
7 %undefine       with_ocaml_opt
8 %endif
9
10 %define         pkgname gapi-ocaml
11 %define         debug_package   %{nil}
12 Summary:        Google Data Protocol (GData) client library
13 Name:           ocaml-%{pkgname}
14 Version:        0.4.1
15 Release:        2
16 License:        MIT
17 Group:          Libraries
18 Source0:        https://github.com/astrada/gapi-ocaml/archive/v%{version}/%{name}-%{version}.tar.gz
19 # Source0-md5:  aeecae11fddf4511cea908808c73366a
20 URL:            http://gapi-ocaml.forge.ocamlcore.org/
21 BuildRequires:  cppo >= 0.9.3
22 BuildRequires:  ocaml >= 4.02.3
23 BuildRequires:  ocaml-biniou-devel >= 1.0.6
24 BuildRequires:  ocaml-cryptokit-devel >= 1.9
25 BuildRequires:  ocaml-curl-devel >= 0.6.0
26 BuildRequires:  ocaml-easy-format-devel >= 1.0.1
27 BuildRequires:  ocaml-findlib >= 1.4
28 BuildRequires:  ocaml-net-netstring-devel >= 4.1.4
29 BuildRequires:  ocaml-yojson-devel >= 1.1.6
30 %requires_eq    ocaml-runtime
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 gapi-ocaml is a simple, unofficial, OCaml client for Google Services.
35 The project is hosted on github, where you can find the latest
36 development version, and on the OCaml forge where you can find
37 releases. Reference documentation can be found here.
38
39 %description -l pl.UTF-8
40 Pakiet ten zawiera binaria potrzebne do uruchamiania programów
41 używających tej biblioteki.
42
43 %package devel
44 Summary:        Google Data Protocol (GData) client library - development part
45 Summary(pl.UTF-8):      Wiązania gapi dla OCamla - cześć programistyczna
46 Group:          Development/Libraries
47 %requires_eq ocaml
48 Requires:       ocaml-biniou-devel >= 1.0.6
49 Requires:       ocaml-cryptokit-devel >= 1.9
50 Requires:       ocaml-curl-devel >= 0.6.0
51 Requires:       ocaml-easy-format-devel >= 1.0.1
52 Requires:       ocaml-net-netstring-devel >= 3.7.3
53 Requires:       ocaml-yojson-devel >= 1.1.6
54
55 %description devel
56 This package contains files needed to develop OCaml programs using
57 this library.
58
59 %description devel -l pl.UTF-8
60 Pakiet ten zawiera pliki niezbędne do tworzenia programów używających
61 tej biblioteki.
62
63 %prep
64 %setup -q -n %{pkgname}-%{version}
65
66 %build
67 dune build
68
69 %install
70 rm -rf $RPM_BUILD_ROOT
71
72 dune install --destdir=$RPM_BUILD_ROOT
73
74 # no standard way of packaging .mli docs in pld. just drop
75 %{__rm} $RPM_BUILD_ROOT%{_libdir}/ocaml/%{pkgname}/*.mli
76
77 %clean
78 rm -rf $RPM_BUILD_ROOT
79
80 %files devel
81 %defattr(644,root,root,755)
82 %doc LICENSE
83 %dir %{_libdir}/ocaml/%{pkgname}
84 %{_libdir}/ocaml/gapi-ocaml/META
85 %{_libdir}/ocaml/gapi-ocaml/dune-package
86 %{_libdir}/ocaml/gapi-ocaml/opam
87 %{_libdir}/ocaml/%{pkgname}/*.cma
88 %{_libdir}/ocaml/%{pkgname}/*.cmt*
89 %{_libdir}/ocaml/%{pkgname}/*.cm[ix]
90 %if %{with ocaml_opt}
91 %{_libdir}/ocaml/%{pkgname}/*.a
92 %{_libdir}/ocaml/%{pkgname}/*.cmx[as]
93 %endif
This page took 0.081322 seconds and 3 git commands to generate.