]> git.pld-linux.org Git - packages/ocaml-gapi-ocaml.git/blob - ocaml-gapi-ocaml.spec
- up to 0.2.6
[packages/ocaml-gapi-ocaml.git] / ocaml-gapi-ocaml.spec
1 #
2 # Conditional build:
3 %bcond_without  opt             # build opt
4
5 %define         pkgname gapi-ocaml
6 %define         debug_package   %{nil}
7 Summary:        Google Data Protocol (GData) client library
8 Name:           ocaml-%{pkgname}
9 Version:        0.2.6
10 Release:        1
11 License:        MIT
12 Group:          Libraries
13 Source0:        https://forge.ocamlcore.org/frs/download.php/1448/%{pkgname}-%{version}.tar.gz
14 # Source0-md5:  6396613e70d8c768e81295ed677cc204
15 URL:            http://gapi-ocaml.forge.ocamlcore.org/
16 BuildRequires:  cppo >= 0.9.3
17 BuildRequires:  ocaml >= 3.04-7
18 BuildRequires:  ocaml-biniou-devel >= 1.0.6
19 BuildRequires:  ocaml-cryptokit-devel >= 1.9
20 BuildRequires:  ocaml-curl-devel >= 0.6.0
21 BuildRequires:  ocaml-easy-format-devel >= 1.0.1
22 BuildRequires:  ocaml-extlib-devel >= 1.5.4
23 BuildRequires:  ocaml-findlib >= 1.4
24 BuildRequires:  ocaml-net-netstring-devel >= 3.6
25 #BuildRequires: ocaml-net-netstring-devel >= 3.7.3
26 BuildRequires:  ocaml-xmlm-devel >= 1.1.1
27 BuildRequires:  ocaml-yojson-devel >= 1.1.6
28 %requires_eq    ocaml-runtime
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 gapi-ocaml is a simple, unofficial, OCaml client for Google Services.
33 The project is hosted on github, where you can find the latest
34 development version, and on the OCaml forge where you can find
35 releases. Reference documentation can be found here.
36
37 %description -l pl.UTF-8
38 Pakiet ten zawiera binaria potrzebne do uruchamiania programów
39 używających tej biblioteki.
40
41 %package devel
42 Summary:        Google Data Protocol (GData) client library - development part
43 Summary(pl.UTF-8):      Wiązania gapi dla OCamla - cześć programistyczna
44 Group:          Development/Libraries
45 %requires_eq    ocaml
46 Requires:       ocaml-biniou-devel >= 1.0.6
47 Requires:       ocaml-cryptokit-devel >= 1.9
48 Requires:       ocaml-curl-devel >= 0.6.0
49 Requires:       ocaml-easy-format-devel >= 1.0.1
50 Requires:       ocaml-extlib-devel >= 1.5.4
51 Requires:       ocaml-net-netstring-devel >= 3.6
52 #Requires:      ocaml-net-netstring-devel >= 3.7.3
53 Requires:       ocaml-xmlm-devel >= 1.1.1
54 Requires:       ocaml-yojson-devel >= 1.1.6
55
56 %description devel
57 This package contains files needed to develop OCaml programs using
58 this library.
59
60 %description devel -l pl.UTF-8
61 Pakiet ten zawiera pliki niezbędne do tworzenia programów używających
62 tej biblioteki.
63
64 %prep
65 %setup -q -n %{pkgname}-%{version}
66
67 %build
68 ocaml setup.ml -configure \
69         --destdir $RPM_BUILD_ROOT
70 ocaml setup.ml -build
71
72 %install
73 rm -rf $RPM_BUILD_ROOT
74 export OCAMLFIND_DESTDIR=$RPM_BUILD_ROOT%{_libdir}/ocaml
75 install -d $OCAMLFIND_DESTDIR
76 ocaml setup.ml -install
77
78 # move to dir pld ocamlfind looks
79 install -d $RPM_BUILD_ROOT%{_libdir}/ocaml/site-lib/%{pkgname}
80 mv $OCAMLFIND_DESTDIR/%{pkgname}/META \
81         $RPM_BUILD_ROOT%{_libdir}/ocaml/site-lib/%{pkgname}
82 cat <<EOF >> $RPM_BUILD_ROOT%{_libdir}/ocaml/site-lib/%{pkgname}/META
83 directory="+%{pkgname}"
84 EOF
85
86 # no standard way of packaging .mli docs in pld. just drop
87 %{__rm} $RPM_BUILD_ROOT%{_libdir}/ocaml/%{pkgname}/*.mli
88
89 %clean
90 rm -rf $RPM_BUILD_ROOT
91
92 %files devel
93 %defattr(644,root,root,755)
94 %doc LICENSE
95 %dir %{_libdir}/ocaml/%{pkgname}
96 %{_libdir}/ocaml/%{pkgname}/*.a
97 %{_libdir}/ocaml/%{pkgname}/*.cm[ixa]*
98 %dir %{_libdir}/ocaml/site-lib/%{pkgname}
99 %{_libdir}/ocaml/site-lib/%{pkgname}/META
This page took 0.069583 seconds and 3 git commands to generate.